Vytvoření nebo spuštění makra

V aplikaci Word můžete automatizovat často používané úkoly vytvořením a spuštěním maker. Makro je řada příkazů a pokynů, které seskupíte jako jeden příkaz, který automaticky provede daný úkol.

Pokud chcete ušetřit čas na úkolech, které děláte často, svažte jednotlivé kroky do makra. Nejdřív makro zaznamenejte. Pak ho můžete spustit kliknutím na tlačítko na panelu nástrojů Rychlý přístup nebo stiskem kombinace kláves. Záleží na tom, jak si ho nastavíte.

  1. Klikněte na Zobrazení > Makra > Zaznamenat makro.

    Příkaz Zaznamenat makro

  2. Zadejte název makra.

    Pole Název makra

  3. Abyste tohle makro mohli použít u všech nových dokumentů, které vytvoříte, nezapomeňte v poli Uložit makro v vybrat možnost Všechny dokumenty (Normal.dotm).

    Pole pro výběr místa uložení makra

  4. Pokud chcete makro spouštět kliknutím na tlačítko, klikněte na Tlačítko.

    Kliknutím přiřadíte makro k tlačítku

  5. Klikněte na nové makro (jeho název vypadá podobně jako Normal.NewMacros.<váš název makra>) a klikněte na Přidat.

    Makro a tlačítko Přidat

  6. Klikněte na Změnit.

    Tlačítko Změnit v okně Přizpůsobení panelu nástrojů Rychlý přístup

  7. Zvolte obrázek tlačítka, zadejte požadovaný název a dvakrát klikněte na OK.

    Možnosti tlačítka v okně Tlačítko Změnit

  8. Teď je čas pro záznam kroků. Pro každý krok úkolu klikněte na příkaz nebo stiskněte tlačítko. Word zaznamená vaše kliknutí a stisknutí kláves.

    Poznámka: Při záznamu makra vybírejte text pomocí klávesnice. Výběr provedený pomocí myši makro nezaznamená.

  9. Pro ukončení záznamu klikněte na Zobrazení > Makra > Zastavit záznam.

    Příkaz Zastavit záznam

Tlačítko vašeho makra se zobrazí na panelu nástrojů Rychlý přístup.

Tlačítko makra na panelu nástrojů Rychlý přístup

Kliknutím na tlačítko makro spustíte.

  1. Klikněte na Zobrazení > Makra > Zaznamenat makro.

    Příkaz Zaznamenat makro

  2. Zadejte název makra.

    Pole Název makra

  3. Abyste tohle makro mohli použít u všech nových dokumentů, které vytvoříte, nezapomeňte v poli Uložit makro v vybrat možnost Všechny dokumenty (Normal.dotm).

    Pole pro výběr místa uložení makra

  4. Pokud chcete makro spouštět stiskem klávesové zkratky, klikněte na Klávesnici.

    Kliknutím přiřadíte makro ke klávesové zkratce

  5. Do pole Stiskněte klávesovou zkratku zadejte kombinaci kláves.

  6. Zkontrolujte, jestli tato kombinace už není přiřazená k něčemu jinému. Pokud ano, zkuste jinou kombinaci.

  7. Abyste toto makro mohli použít u všech nových dokumentů, které vytvoříte, nezapomeňte v poli Změny uložit do vybrat možnost Normal.dotm.

  8. Klikněte na Přiřadit.

  9. Teď je čas pro záznam kroků. Pro každý krok úkolu klikněte na příkaz nebo stiskněte tlačítko. Word zaznamená vaše kliknutí a stisknutí kláves.

    Poznámka: Při záznamu makra vybírejte text pomocí klávesnice. Výběr provedený pomocí myši makro nezaznamená.

  10. Pro ukončení záznamu klikněte na Zobrazení > Makra > Zastavit záznam.

    Příkaz Zastavit záznam

Makro spustíte stiskem klávesové zkratky.

Když chcete spustit makro, klikněte na tlačítko na panelu nástrojů Rychlý přístup a stiskněte klávesovou zkratku. Nebo můžete makro spustit ze seznamu Makra.

  1. Klikněte na Zobrazení > Makra > Zobrazit makra.

    Příkaz Zobrazit makra

  2. V seznamu Název makra klikněte na makro, které chcete spustit.

  3. Klikněte na Spustit.

Aby mohlo být makro z jednoho dokumentu dostupné ve všech nových dokumentech, přidejte ho do šablony Normal.dotm.

  1. Otevřete dokument obsahující makro.

  2. Klikněte na Zobrazení > Makra > Zobrazit makra.

    Příkaz Zobrazit makra

  3. Klikněte na Organizátor.

    Tlačítko Organizátor v okně Zobrazit makra

  4. Klikněte na makro, které chcete přidat do šablony Normal.dotm a pak na Kopírovat.

  1. Klikněte na Soubor > Možnosti > Přizpůsobit pás karet.

  2. V rozevíracím seznamu Zvolit příkazy z klikněte na položku Makra.

  3. Klikněte na požadované makro.

  4. V části Přizpůsobit pás karet klikněte na kartu a vlastní skupinu, do které chcete makro přidat.

Pokud nemáte vlastní skupinu, klikněte na tlačítko Nová skupina. Potom klikněte na Přejmenovat a zadejte název vlastní skupiny.

  1. Klikněte na Přidat.

  2. Kliknutím na Přejmenovat zvolíte pro makro symbol a zadáte požadovaný název.

  3. Dvakrát klikněte na OK.

  1. Na kartě Vývojář klikněte ve skupině Kód na tlačítko Makra.

  2. Do pole Název makra napište název makra.

    Poznámka: Pokud přiřadíte nové makro stejným názvem jako integrované makro ve Wordu, nahradí nové makro akce makra předdefinované makro. Pokud chcete zobrazit seznam vestavěných maker, klikněte na příkazy Word v seznamu makra v seznamu.

  3. V seznamu makra v klikněte na šablonu nebo dokument, do kterého chcete makro uložit.

    Pokud chcete, aby bylo makro dostupné ve všech dokumentech, klikněte na Normal. dotm.

  4. Kliknutím na vytvořit otevřete Visual Basic Editor.

Po otevření editoru jazyka Visual Basic můžete získat další informace o práci s jazykem Visual Basic for Applications. Další informace získáte po kliknutí na příkaz Nápověda pro Microsoft Visual Basic v nabídce Nápověda nebo stisknutím klávesy F1.

Můžete zaznamenat posloupnost akcí nebo vytvořit nové makro, a to tak, že zadáte kód jazyka Visual Basic for Applications v Visual Basic Editor.

Poznámka: Pokud chcete pracovat s makry v Office Word 2007, musíte zobrazit kartu vývojář .

  1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka a potom klikněte na Možnosti aplikace Word.

  2. Klikněte na Oblíbené.

  3. V části Nejpoužívanější možnosti při práci s Wordemzaškrtněte políčko Zobrazit na pásu kartu Vývojář .

    Poznámka: Pás karet je součástí Fluent systému Microsoft Office.

  1. Na kartě Vývojář klikněte ve skupině Kód na Zaznamenat makro.

    Skupina Kód na kartě Vývojář
  2. Do pole Název makra napište název makra.

    Poznámka: Pokud přiřadíte nové makro stejným názvem jako integrované makro v Office Word 2007, nahradí makro nové makro předdefinované makro. Pokud chcete zobrazit seznam vestavěných maker, klikněte na kartě vývojář ve skupině kód na tlačítko makra. V seznamu makra v klikněte na příkazy Wordu.

  3. V poli Uložit makro do klikněte na Šablona nebo dokument, do kterého chcete makro uložit.

    Důležité informace: Pokud chcete, aby bylo makro dostupné ve všech dokumentech, klikněte na Normal. dotm.

  4. Do pole Popis napište krátký popis makra.

  5. Proveďte jednu z následujících akcí:

    • Začít nahrávat    Pokud chcete zahájit záznam makra, aniž byste ho přiřadili tlačítku na panelu nástrojů Rychlý přístup nebo k klávesové zkratce, klikněte na OK.

    • Vytvoření tlačítka    Pokud chcete makro přiřadit tlačítku na panelu nástrojů Rychlý přístup, postupujte takto:

      1. Klikněte na tlačítko.

      2. V části Přizpůsobit panel nástrojů Rychlý přístupvyberte dokument (nebo všechny dokumenty), pro který chcete přidat makro na panel nástrojů Rychlý přístup.

        Důležité informace: Pokud chcete, aby bylo makro dostupné ve všech dokumentech, klikněte na Normal. dotm.

      3. V části zvolit příkazy z dialogového okna klikněte na makro, které chcete nahrát, a potom klikněte na Přidat.

      4. Pokud chcete tlačítko přizpůsobit, klikněte na změnit.

      5. V části symbolklikněte na symbol, který chcete použít pro tlačítko.

      6. Do pole Zobrazovaný název zadejte název makra, které chcete zobrazit.

      7. Dvojím kliknutím na OK začněte nahrávat makro.

        Zvolený symbol se zobrazí na panelu nástrojů Rychlý přístup. Po umístění ukazatele na symbol se zobrazí název, který zadáte.

    • Přiřazení klávesové zkratky    Pokud chcete makro přiřadit klávesové zkratce, postupujte takto:

      1. Klikněte na Klávesnice.

      2. V seznamu příkazy klikněte na makro, které chcete nahrát.

      3. Do pole stiskněte klávesovou zkratku zadejte požadovanou klávesovou zkratku a klikněte na přiřadit.

      4. Kliknutím na Zavřít začněte nahrávat makro.

  6. Proveďte akce, které chcete do makra zahrnout.

    Poznámka: Když zaznamenáte makro, můžete pomocí myši kliknout na příkazy a možnosti, ale nechcete vybrat text. Text musíte vybrat pomocí klávesnice. Další informace o výběru textu pomocí klávesnice najdete v tématu Výběr textu.

  7. Pokud chcete nahrávání akcí ukončit, klikněte ve skupině kód na Zastavit záznam .

Změna klávesové zkratky pro makro

  1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka a potom klikněte na Možnosti aplikace Word.

  2. Klikněte na Přizpůsobit.

  3. Vedle klávesové zkratkyklikněte na přizpůsobit.

  4. V seznamu kategorie klikněte na makra.

  5. V seznamu makra klikněte na makro, které chcete změnit.

  6. Do pole stiskněte klávesovou zkratku zadejte kombinaci kláves, kterou chcete zvolit.

  7. Zaškrtněte políčko aktuální klíče , abyste měli jistotu, že nepřiřazujete kombinaci kláves, která už používáte k provádění jiného úkolu.

  8. V seznamu Uložit změny v klikněte na možnost, která odpovídá umístění, ve kterém chcete makro spustit.

    Důležité informace: Pokud chcete, aby bylo makro dostupné ve všech dokumentech, klikněte na Normal. dotm.

  9. Klikněte na tlačítko Zavřít.

  1. Na kartě Vývojář klikněte ve skupině Kód na tlačítko Makra.

    Skupina Kód na kartě Vývojář

  2. V seznamu název makraklikněte na makro, které chcete spustit.

  3. Klikněte na Spustit.

  1. Na kartě Vývojář klikněte ve skupině Kód na tlačítko Makra.

    Skupina Kód na kartě Vývojář

  2. Do pole Název makra napište název makra.

    Poznámka: Pokud přiřadíte nové makro stejným názvem jako integrované makro v Office Word 2007, nahradí makro nové makro předdefinované makro. Pokud chcete zobrazit seznam vestavěných maker, klikněte na příkazy Word v seznamu makra v seznamu.

  3. V seznamu makra v klikněte na Šablona nebo dokument, do kterého chcete makro uložit.

    Pokud chcete, aby bylo makro dostupné ve všech dokumentech, klikněte na Normal. dotm.

  4. Kliknutím na vytvořit otevřete Visual Basic Editor.

Po otevření editoru jazyka Visual Basic můžete získat další informace o práci s jazykem Visual Basic for Applications. Další informace získáte po kliknutí na příkaz Nápověda pro Microsoft Visual Basic v nabídce Nápověda nebo stisknutím klávesy F1.

Pokud chcete rychle pracovat s úkoly, které často používáte, můžete je v desktopové verzi Wordu seskupit do maker, která se spouští jediným kliknutím. V Word pro web musíte úkoly procházet ručně.

Pokud máte Word, otevřete dokument ve Wordu kliknutím na otevřít ve Wordu .

Obrázek příkazu Otevřít ve Wordu ve Wordu Online

Pak postupujte podle pokynů pro desktopovou verzi Wordu.

Když makro spustíte ve Wordu a dokument uložíte, uvidíte výsledky makra při opětovném otevření dokumentu v Word pro web.

Poznámka:  Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát vědět, jestli vám informace pomohly? Pokud chcete, můžete se podívat na anglickou verzi článku.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×