Office
Přihlásit se

Vytvoření návrhu formuláře tak, aby se měnil podle stavu pracovního postupu

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Můžete vytvářet formuláře aplikace Microsoft Office InfoPath k zobrazení konkrétních dat, která odpovídá aktuální stav pracovního postupu. Provedete návrhem šablony formuláře použít pravidla, která zahájit akce v jeho formuláře založené na stav pracovního postupu. To můžete zjednodušit procesy, které uživatelé používají vyplňovat formuláře.

Tento článek popisuje, jak navrhnout šabloně formulář vyúčtování výdajů automaticky zobrazíte různá zobrazení šablony formuláře v závislosti na stav přidružené pracovního postupu schválení. Například před spuštěním pracovního postupu formuláře se zobrazí výdaje zobrazení, která obsahuje tabulku s opakováním kterého uživatelé mohou zadat náklady. V průběhu po stav pracovního postupu formuláři zobrazí souhrn výdajů zobrazení, které zobrazuje celkové náklady v každé kategorii. Dokončeno po stav pracovního postupu formuláři zobrazí zobrazení dokončeno, které obsahuje podrobnosti o na odhadovaná náhradu časy.

Pokud chcete povolit, aby formuláře odpovědět na stav pracovního postupu, proveďte na webu Microsoft Office SharePoint Server 2007 nebo Windows SharePoint Services 3.0 webu, kde jsou umístěny formuláře a úkoly v aplikaci InfoPath. Na webu služby SharePoint je třeba vytvořit pracovní postup a webu Typ obsahu a v aplikaci InfoPath musíte přidat datové připojení k šabloně formuláře, vytvořit pravidlo a publikování šablony formuláře.

Poznámka: Tento článek používá scénáři příklad, ve kterém je publikován šablony formuláře jako typu obsahu webu. Můžete taky publikování šablony formuláře do sdílené síťové umístění nebo vytvořte novou knihovnu dokumentů po publikování šablony formuláře s webem služby SharePoint. Další informace o publikování šablon formulářů v části Viz také.

V tomto článku

Úvod k používání pracovních postupů pomocí formulářů aplikace InfoPath

Důležité informace o kompatibilitě

Než začnete

Krok 1: Přidání pracovního postupu schválení do knihovny

Krok 2: Přidání datového připojení do šablony formuláře

Krok 3: Přidání pravidla do šablony formuláře a zobrazit konkrétní zobrazení

Krok 4: Publikování šablony formuláře jako typu obsahu webu

Krok 5: Přidání typu obsahu do knihovny dokumentů

Úvod k používání pracovních postupů s formuláři aplikace InfoPath

Pracovní postupy pomoct ostatním lidem spolupráce na dokumentech a spravovat úkoly projektu implementací specifickým obchodním procesům na dokumenty a položky na webu Microsoft Office SharePoint Server 2007 nebo Windows SharePoint Services 3.0 webu. Pracovní postupy organizacím dodržovat konzistentní obchodní procesy a jejich také zvýšit efektivitu a produktivity spravovat úkoly a kroky při specifickým obchodním procesům. To umožňuje uživatelům, kteří provádět tyto úkoly koncentrát provádění práce než Správa pracovního postupu.

Formulář aplikace InfoPath k zobrazení konkrétních dat, která odpovídá aktuální stav pracovního postupu můžete povolit. Provedete návrhem šablony formuláře použít pravidla, která zahájit akce ve formuláři podle stavu pracovního postupu. To můžete zjednodušit procesy, které uživatelé používají vyplňovat formuláře. Můžete třeba povolit tak, aby zobrazení jen pro čtení když stav pracovního postupu je Dokončeno, tedy neměli změnit data ve formuláři.

Pracovní postupy je přidat do seznamu služby SharePoint, knihovnu nebo typ obsahu zpřístupnit pro použití na šablonách formulářů aplikace InfoPath. Dostupné pracovní postupy pro web se liší v závislosti na typu webu a zda byly vlastních pracovních postupů vytvořený s využitím Microsoft Office SharePoint Designer 2007.

Tento článek pomocí pracovního postupu schválení ke znázornění použití pracovní postupy s šablon formulářů aplikace InfoPath. Pracovní postup schválení směruje formuláře Infopathu, které se uloží do knihovny se skupinou lidí ke schválení. Ve výchozím nastavení pracovního postupu schválení je přidružený k typu obsahu dokument a je automaticky k dispozici v knihovnách dokumentů nebo formulářů.

Jednotlivé pracovní postupy je definován různých stavy s popisných názvů, například Probíhá. Názvy stavy se liší podle typu pracovního postupu. Příklad pracovního postupu schválení, která je dostupná na serverech musí běžet Microsoft Office SharePoint Server 2007 – patří stav Probíhá, zrušeno a Dokončeno. Stavy třístavového pracovního postupu, která je dostupná v Windows SharePoint Services 3.0 – to možné definovat osoba, která přidá pracovního postupu do knihovny nebo seznamu, zatímco ostatní pracovních postupů pomocí standardní stavy například stav Probíhá uvedeno dříve. Popisný název je viditelná pro uživatele, sice stavy pracovního postupu jsou představovány programově číselné hodnoty. Návrh šablony formuláře a měnil podle stavu konkrétní pracovní postup, musíte znát číselná hodnota pro stav pracovního postupu, který chcete použít. Je to proto aplikace InfoPath pomocí číselnou hodnotu pracovní postup spustit akci, například přepínání zobrazení.

Jak je uvedeno dříve, můžete povolit šablonu formuláře aplikace InfoPath k zobrazení konkrétních dat, která odpovídá aktuální stav pracovního postupu. I když tento článek popisuje, jak povolit šabloně formulář vyúčtování výdajů automaticky zobrazení konkrétních podle stavu pracovního postupu, můžete taky přizpůsobit pracovní postup přidáním další akce. Třeba místo povolení formuláře pro zobrazení specifické, můžete povolit, aby zobrazit zprávu dialogového okna zobrazující pokyny. A místo použití pracovního postupu schválení, můžete třístavový pracovní postup.

Poznámka: Pokud povolíte akce nejsou popisované v tomto článku, budete muset provést další kroky a pomáhají zajistit, že šablony formuláře spolupracuje pracovní postup, který používáte.

Začátek stránky

Důležité informace o kompatibilitě

Pokud budete chtít vytvořit Šablona formuláře kompatibilní s prohlížečem, mějte na paměti, které nejsou viditelné v šablon formulářů kompatibilních s prohlížečem, které uživatelé vyplňovat ve webovém prohlížeči panel akcí dokumentu, které se zobrazí při vyplňování formulářů v dokumentech Microsoft Office, včetně formulářů aplikace InfoPath . Prohlížečový formuláře však může použít s pracovními postupy. Pokud chcete změnit stav pracovního postupu u těchto formulářů, účastníci pracovního postupu můžete použít nastavení knihovny dokumentů. Další informace o změně nastavení pracovního postupu pomocí Sharepointových webů v části Viz také.

Začátek stránky

Než začnete

Zajištění následující před provedením úkoly v tomto článku:

  • Požádejte správce farmy k potvrzení, že pracovních postupech schválení nainstalované a povolené webu služby SharePoint, který chcete použít.

  • Ujistěte se, že máte alespoň návrh Úroveň oprávnění webu služby SharePoint. Této úrovni oprávnění je třeba publikování šablony formuláře a vytvořte pracovní postup.

  • Vytvoření šablony formuláře s dvěma nebo více zobrazení a přizpůsobení každé zobrazení se zobrazí typ dat, která je vhodné pro každý stav pracovního postupu. Pro zobrazení, které chcete zobrazit při dokončení pracovního postupu, je třeba nastavit ovládací prvky v tomto zobrazení jen pro čtení.

  • Vytvoření knihovny dokumentů nebo formulářů a ujistěte se, že knihovně nastavená možnost použití více typů obsahu.

Začátek stránky

Krok 1: Přidání pracovního postupu schválení do knihovny

Tento scénář se zaměřuje na pracovní postup schválení, ale pokud chcete, můžete použít jiný typ pracovního postupu. Pokud používáte jiný typ pracovního postupu, možnosti pro tento pracovní postup může lišit od klasických popisované v tomto článku.

  1. Otevřete knihovnu, do kterého chcete přidat pracovní postup.

  2. V nabídce Nastavení klikněte na možnost nastavení pro typ knihovny, který chcete otevřít.

    Například u knihovny dokumentů klikněte na Nastavení knihovny dokumentů.

  3. V části Oprávnění a správa klikněte na Nastavení pracovního postupu.

  4. Klikněte na Přidat pracovní postup.

  5. Na stránce Přidat pracovní postup, v části pracovního postupu klikněte na schválení.

  6. V části Název napište jedinečný název pracovního postupu.

    1. V oddílu Seznam úkolů zadejte seznam úkolů můžete tento pracovní postup.

      Poznámky: 

      • Můžete použít výchozí seznam úkolů nebo vytvořte novou. Pokud používáte výchozí seznam úkolů, účastníci pracovního postupu bude moct snadno najít a zobrazit úkoly pracovního postupu pomocí zobrazení Vlastní úkoly v seznamu úkolů.

      • Pokud pro tento pracovní postup bude obsahuje odhalit citlivé nebo důvěrné informace, kterou chcete oddělit od obecného seznamu úkoly, měli vytvořit nový seznam úkolů.

      • Pokud vaše organizace bude mít více pracovních postupů nebo pokud pracovní postupy obsahují spoustu úkoly, měli byste vytvořit nový seznam úkolů. V takovém případě můžete vytvořit seznamy úkolů pro každý pracovní postup.

  7. V oddílu Seznam historie vyberte seznam historie, který se má použít s tímto pracovním postupem. V seznamu historie se zobrazí všechny události, ke kterým dojde během každé instance pracovního postupu.

    Můžete použít výchozí seznam Historie nebo vytvořte novou. Pokud vaše organizace bude mít více pracovních postupů, můžete vytvořit samostatný seznam historie pro každý pracovní postup.

  8. Pokud chcete povolit pracovní postup spuštěn ručně, zaškrtněte políčko Povolit tento pracovní postup ruční spuštění ověřený uživatel s oprávněním upravit položky v části Možnosti spuštění.

  9. Pokud mají další oprávnění ke spuštění pracovního postupu, zaškrtněte políčko Vyžadovat oprávnění Spravovat seznamy spustit pracovní postup.

  10. Zadejte libovolné další možnosti, které budete potřebovat, včetně toho, kdy se má pracovní postup spustit a potom klikněte na Další.

  11. Na stránce Přizpůsobit pracovní postup nastavení požadovaných možností, které budete potřebovat, včetně, jak se budou úkoly směrovat, výchozí pracovní postup počáteční hodnoty a jak dokončení pracovního postupu a potom klikněte na OK.

    V některém z těchto částí: Vyberte možnosti. Není nutné zadávat možnosti v každé části:

    Úkoly pracovního postupu

    Co chcete udělat

    Akce

    Úkoly přiřazovat taky všichni účastníci najednou (paralelní pracovní postup)

    Vyberte Všichni účastníci současně (paralelně).

    Přiřazení úkolů pro jeden účastník současně, vyžadující jednu účast úkol před další účastníkovi úkolu (sériový pracovní postup)

    Vyberte jeden účastník po jednom (sériově).

    Povolit účastníkům pracovního postupu přiřadit úkoly jiným uživatelům

    Zaškrtněte políčko přiřazení úkolu jinému uživateli.

    Povolte účastníkům pracovního postupu požadavek na změnu dokument nebo položku. Změna musí schválit, před dokončení úkolu.

    Požadavek na změnu před dokončením úkolu zaškrtněte políčko.

    Výchozí hodnoty spuštění pracovního postupu

    Co chcete udělat

    Akce

    Zadat výchozí seznam účastníků všechny výskyty tohoto pracovního postupu

    Zadejte jména účastníků, které chcete zahrnout při spuštění pracovního postupu, nebo klikněte na schvalovatele a pak vyberte osoby a skupiny z adresářové služby.

    Poznámky: 

    • Jména oddělená středníkem.

    • Pokud jste nastavili tento pracovní postup jako sériový pracovní postup, přidejte jména účastníků pracovního postupu v pořadí, ve kterém chcete tyto úkoly přiřadit.

    Přiřadit jeden úkol skupinám místo přiřazení jednotlivých úkolů pro každého člena skupiny

    Vyberte přiřadit jeden úkol pro každou skupinu zadali (přiřaďte) zaškrtávací políčko.

    Povolit uživatelům spustit pracovní postup ke změně ani přidat účastníky

    Zaškrtněte políčko Povolit úpravy seznamu účastníků, pokud je tento pracovní postup spuštěn.

    Zadat výchozí zprávu, která se zobrazí u jednotlivých úkolů

    Do textového pole zadejte zprávu nebo pokyny.

    Zadejte termín splnění paralelní pracovních postupů

    Zadejte datum ve skupinovém rámečku splnění úkolů (paralelně).

    Určení, jak dlouho mají účastníci sériový pracovní postup k dokončení úkolů pracovního postupu

    Přidělit jednotlivým uživatelům následující množství času na dokončení úkolu (sériově) zadejte číslo a potom vyberte dnech nebo týdnech jako časový úsek.

    Zadejte seznam lidí, kteří mají dostávat oznámení (nikoli přiřazení úkolu) při spuštění pracovního postupu

    V části Oznámení ostatní zadejte jména lidí, kterým chcete být odesláno oznámení, nebo kliknutím na kopie a vyberte osoby a skupiny z adresářové služby.

    Poznámka: Jména oddělená středníkem.

    Dokončení pracovního postupu

    Co chcete udělat

    Akce

    Určit, že je po určitý počet účastníků dokončení svých úkolech dokončení paralelní pracovního postupu

    Zaškrtněte políčko následující počet úkolů ukončili a zadejte číslo.

    Určete, že je pracovní postup dokončení při odmítnutí dokument nebo položku

    Zaškrtněte políčko Odmítnuto dokumentu.

    Určit, že pracovní postup je dokončen, pokud dojde ke změně dokumentu nebo položky

    Zaškrtněte políčko dojde ke změně dokumentu.

    Po dokončení pracovního postupu

    Co chcete udělat

    Akce

    Po dokončení pracovního postupu aktualizovat stav schválení pro dokument nebo položku

    Vyberte Aktualizovat stav schválení (použijte tento pracovní postup řídit schválení obsahu) zaškrtávací políčko.

    Poznámky: 

    • Pokud používáte pracovní postup schválení ke správě schválení obsahu pro knihovny a jste zaškrtli políčko Spustit tento pracovní postup schválení publikování hlavní verze položky na stránce Přidat pracovní postup, toto zaškrtávací políčko vybrané ve výchozím nastavení.

    • Pokud jste nevybrali zaškrtněte políčko Spustit tento pracovní postup schválení publikování hlavní verze položky na stránce Přidat pracovní postup vzhledem k tomu, že nechcete, aby tento pracovní postup je výchozí pracovní postup schválení obsahu pro knihovny, můžete vybrat toto políčko, chcete-li Tento pracovní postup konkrétním uživatelům možné ručně spustit pracovní postup sekundární schválení obsahu.

Začátek stránky

Krok 2: Přidání datového připojení do šablony formuláře

Následující postup vysvětluje, jak přidat sekundárního datového připojení pro zadávání dotazů stav pracovního postupu pracovního postupu, který jste přidali v kroku 1. Tento sekundárního datového připojení obsahuje data, která umožňuje pravidla ve formuláři pro přepnutí zobrazení podle stavu pracovního postupu.

  1. V aplikaci InfoPath v nabídce Nástroje klikněte na Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na Přidat.

  3. V Průvodci datovým připojením klikněte na vytvořit nové připojení k, klikněte na přijmout data a klikněte na tlačítko Další.

  4. Na další stránce průvodce klikněte na Knihovna nebo seznam SharePoint a potom na tlačítko Další.

  5. Na další stránce průvodce zadejte adresu URL webu služby SharePoint.

  6. V seznamu vyberte v seznamu nebo knihovně klikněte na název knihovny dokumentů, které jste přidali pracovního postupu schválení v kroku 1 a potom na tlačítko Další.

  7. Na další stránce průvodce v seznamu Vyberte pole zaškrtněte políčko vedle názvu pole, který odpovídá názvu pracovního postupu.

    Název pole, může se stát přesně název pracovního postupu. Pokud název pole začíná speciální znak než podtržítko nebo písmeno, bude v seznamu přizpůsobit název pracovního postupu.

  8. Zaškrtněte políčko Zahrnout data aktivní pouze pro formulář a potom na tlačítko Další.

  9. Zrušte zaškrtnutí políčka Uložit kopii data v šabloně formuláře a potom na tlačítko Další.

  10. Na další stránce průvodce Zadejte název pro toto políčko připojení dat zadejte popisný název tohoto sekundárního datového připojení. Tento název se zobrazí v seznamu zdroje dat v podokně úloh zdroj dat.

  11. Spusťte dotaz automaticky při každém otevření formuláře uživatelem, zaškrtněte políčko automaticky obnoví data při otevření formuláře.

  12. Na poslední stránce průvodce klikněte na tlačítko Dokončit.

  13. V dialogovém okně Datová připojení klikněte na Zavřít.

Začátek stránky

Krok 3: Přidání pravidla do šablony formuláře a zobrazit konkrétní zobrazení

Při navrhnout šablonu formuláře se automaticky zobrazí dialogové okno, nastavte hodnotu pole, dotaz nebo odeslání dat formuláře do datového připojení, přepnutí zobrazení, nebo otevření nebo zavření formuláře v odpovědi na některé události a podmínky pomocí pravidel. Události můžete zahrnout změnu v konkrétním poli nebo skupinu Zdroj dat, klikněte na tlačítko, vložení Opakující se oddíl nebo řádku v Opakující se tabulka nebo otevření nebo odeslání formuláře. Podmínky mohou obsahovat výpočty, výrazy XPath a role uživatelů. Podmínky mohou také obsahovat zda hodnotu z pole odkazuje na prázdnou buňku, je v určitém rozsahu, se rovná hodnotě jiné pole začíná nebo obsahuje určité znaky.

V tomto případě vytvoříte pravidlo pro přepnutí zobrazení na základě stavu pracovního postupu.

  1. V nabídce Nástroje klikněte na Možnosti formuláře.

  2. V seznamu druh klikněte na Otevřít a uložit.

  3. V části chování při otevření klikněte na pravidla.

  4. V dialogovém okně pravidla pro otevírání formulářů klikněte na Přidat.

  5. Do pole název zadejte název pravidla.

    Zadejte například Přepnout zobrazení.

  6. Chcete-li podmínky když by měla běžet pravidlo, klikněte na Nastavit podmínku.

  7. Ve skupinovém rámečku použít pravidlo, pokud tato podmínka pravdivá v prvním poli klikněte na Výběr pole nebo skupiny.

  8. V seznamu Zdroje dat klikněte na název sekundární zdroj dat, které jste přidali v kroku 2 a klikněte na OK.

  9. Klikněte na název pole, která odpovídá stav pracovního postupu.

    Budete muset rozbalte složky v okně se zobrazila požadované pole.

  10. V dialogovém podmínku v druhý seznam vstupních hodnot klikněte na je rovno.

  11. Ve třetím seznamu klikněte na typ Číslo a potom zadejte hodnotu, která odpovídá stav pracovního postupu.

    Zobrazení, která se zobrazí po dokončení pracovního postupu, například zadejte 5.

    Číselné hodnoty pro pracovní postup stavy pracovního postupu schválení

    Stav

    Číselná hodnota.

    Probíhá

    2

    Completed

    5

    Zrušení

    15

    Schváleno

    16

    Odmítnutí

    17

    Poznámky: 

    • Číselné hodnoty pro stavy v jiných pracovních postupů se můžou lišit.

    • Stav pracovního postupu v aplikaci InfoPath hodnotu určené jen pro čtení. To znamená, že nelze tak, aby uživatel můžete ručně změnit stav pracovního postupu zadáním hodnoty do ovládacího prvku ve formuláři samotné návrh šablony formuláře.

  12. Klikněte na OK.

  13. V dialogovém okně pravidla klikněte na Přidat akci.

  14. V části Akce klikněte na tlačítko Přepnout zobrazení.

  15. V části zobrazení klikněte na název zobrazení, které chcete zobrazit, když stav pracovního postupu odpovídá stav pro tuto podmínku a pak klikněte na OK.

    Například pokud jste zadali v kroku 11 2 , klikněte na název zobrazení, které chcete zobrazit, pokud je rovno Probíhá stav pracovního postupu.

  16. V dialogovém okně pravidla klikněte na OK.

  17. Opakujte kroky 4 až 16 vytvořit pravidla nehledá zobrazení můžete přepínat vhodné v každé fázi pracovního postupu.

Začátek stránky

Krok 4: Publikování šablony formuláře jako typu obsahu webu

Po publikování šablony formuláře můžete publikovat do knihovny dokumentů nebo publikovat jako typu obsahu webu, který lze do více knihoven dokumentu v kolekci webů. Protože již vytvořili knihovny dokumentů a přiřazenou pracovního postupu, musíte publikování šablony formuláře jako typu obsahu. Později můžete přiřadit typu obsahu webu šablony formuláře do knihovny, kterou jste vytvořili.

Kromě publikování šablony formuláře jako typu obsahu webu, můžete taky publikování šablony formuláře do sdílené síťové umístění nebo vytvořte novou knihovnu dokumentů, po publikování šablony formuláře s webem služby SharePoint. Další informace o publikování šablon formulářů v části Viz také.

  1. V nabídce Soubor klikněte na příkaz Uložit.

  2. V dialogovém okně Uložit jako přejděte do umístění, kam chcete uložit šablonu formuláře a potom klikněte na Uložit.

  3. Chcete-li otevřít podokno úloh Kontrola návrhu, klikněte v nabídce NástrojeKontrola návrhu.

  4. Pokud jsou uvedeny podokno úloh Kontrola návrhu, řešení těchto chyb a potom klikněte na Aktualizovat lze zjistit, zda pořád chyb.

  5. V nabídce soubor klikněte na Publikovat.

  6. V Průvodci publikování klikněte na server SharePoint pomocí hesla nebo bez služby InfoPath Forms Services a klikněte na tlačítko Další.

  7. Na další stránce průvodce, do pole Zadejte umístění serveru služby SharePoint nebo služby InfoPath Forms Services zadejte umístění webu služby SharePoint, ve které chcete publikovat šablony formuláře a klikněte na tlačítko Další.

  8. Pokud chcete, aby uživatelé vyplňovat uživatelé tento formulář pomocí webového prohlížeče na další stránce průvodce vyberte zaškrtávací políčko Povolit tento formulář vyplnění pomocí prohlížeče.

  9. Klikněte na Typ obsahu webu (Upřesnit) a klikněte na tlačítko Další.

  10. Na další stránce průvodce klikněte na vytvořit nový typ obsahu.

  11. V seznamu Založit typ obsahu na klikněte na formulář a potom na tlačítko Další.

  12. Na další stránce průvodce zadejte název a popis nového typu obsahu a klikněte na tlačítko Další.

  13. Na další stránce průvodce v dialogovém okně Zadejte umístění a název souboru pro šablonu formuláře zadejte umístění webu služby SharePoint a potom klikněte na Procházet.

  14. V dialogovém okně Procházet přejděte do umístění na serveru, ve které chcete publikovat šablony formuláře jako typu obsahu webu a do pole název souboru zadejte název šablony formuláře a klikněte na tlačítko Uložit.

  15. Klikněte na tlačítko Další.

  16. Vyberte pole v šabloně formuláře, který se má zobrazit jako sloupce v zobrazení výchozí knihovny dokumentů.

    Jak na to?

    1. Klikněte na Přidat.

    2. Vyberte pole, které chcete přidat jako sloupec v knihovně dokumentů a pak udělejte jednu z těchto věcí:

      • Do pole název sloupce zadejte název sloupce.

      • Vybrat sloupce webu v seznamu skupiny sloupců webu, vyberte název v seznamu název sloupce a potom klikněte na OK.

        Pokud jste vybrali opakujícímu se poli pro zobrazení dat v knihovně dokumentů, můžete definovat, jak budete chtít zobrazit pole v knihovně dokumentů po kliknutí na hodnotu v seznamu (funkce). Můžete vybrat zda mají být zobrazena první hodnotu v poli, poslední hodnota v poli nebo počtu všechny výskyty tohoto pole nebo jestli chcete sloučit všechny hodnoty.

    3. Klikněte na OK.

  17. Klikněte na tlačítko Další.

  18. Na další stránce průvodce zkontrolujte správnost údaji zobrazenému a potom klikněte na Publikovat.

  19. Klikněte na tlačítko Zavřít a potom zkontrolujte, že šablony formuláře typu obsahu na webu služby SharePoint.

    Jak na to?

    1. Otevření Sharepointového webu ve webovém prohlížeči.

    2. V nabídce Akce webu v pravém horním rohu webu klikněte na Nastavení webu.

    3. Ve skupinovém rámečku Nastavení webu klikněte v části Galerie na typy obsahu webu.

      Šablona formuláře by měl uvedené v části Typy obsahu aplikace InfoPath v Galerii typů obsahu webu.

Začátek stránky

Krok 5: Přidání typu obsahu do knihovny dokumentů

Typy obsahu umožňuje organizacím uspořádat a spravovat efektivnější zpracování obsahu v kolekci webů. Definování typů obsahu pro určité typy dokumentů, organizace můžete zajistit jednotlivé skupiny obsahu efektivněji spravovat. Můžete nastavit do seznamu nebo knihovny obsahující položky z více typů položek nebo dokumentů přidáním typy obsahu seznamu nebo knihovny.

Poznámka: Chcete-li přidat typy obsahu seznamu nebo knihovny, musíte aspoň oprávnění na úrovni návrh pro tento seznam nebo knihovnu.

Než začnete, ujistěte se, že knihovně nastavená možnost použití více typů obsahu.

Povolit více typů obsahu

  1. V nabídce Nastavení klikněte na Nastavení knihovny dokumentů.

  2. V části Obecné nastavení klikněte na Upřesnit nastavení.

  3. V části Typy obsahu vyberte Ano povolit více typů obsahu a potom klikněte na OK.

  1. Pokud nejsou seznam nebo knihovna otevřeny, klikněte na příslušný název na panelu Snadné spuštění.

    Poznámka: Pokud název požadovaného seznamu nebo knihovny nezobrazí, klikněte na Zobrazit veškerý obsah webu a potom klikněte na název požadovaného seznamu nebo knihovny.

  2. V nabídce Nastavení klikněte na Nastavení knihovny dokumentů.

  3. V části Typy obsahu klikněte na Přidat ze stávajících typů obsahu webu.

  4. V seznamu Vyberte typy obsahu webu v části Vyberte typy obsahu vyberte skupinu typy obsahu webu, ze kterých chcete vybrat.

  5. V seznamu Dostupné typy obsahu webu klikněte na typ obsahu, který chcete a potom klikněte na Přidat přesuňte vybraného typu obsahu do seznamu typů obsahu přidáte.

  6. Pokud chcete přidat další typy obsahu, opakujte kroky 4 a 5 a klikněte na OK.

Teď když uživatel vytvoří nový formulář v této knihovně, ve formuláři bude v zobrazení podle stavu pracovního postupu.

Začátek stránky

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×