Vytvoření kaskádového seznamu

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Kaskádové seznamy pomoc uživatelům rychlejší vyplňování formuláře a pomáhají zajistit, aby uživatelé zadávat data správně. Tento článek popisuje, jak vytvořit a naplňte hodnotami kaskádové seznamy s daty. V aplikaci Microsoft Office InfoPath můžete naplnit seznam data, která používá hodnot z formuláře, hodnot z externího dokumentu jazyk XML (Extensible Markup) nebo hodnoty z databáze aplikace Microsoft Office Access.

V tomto článku

Co je kaskádový seznam?

Krok 1: Vložení kaskádového seznamu

Krok 2: Obsahují data

Co je kaskádový seznam?

Kaskádový seznam je pole se seznamem s možnostmi, které změnit na základě hodnoty, které uživatel vybere v jiném seznamu. Pokud uživatel klikne na kořením v seznamu kategorie vidět na následujícím obrázku, například pole produkty zobrazí seznam koření.

Cascading list box example

Následující části ukazují, jak návrh šablony formuláře s dvěma seznamy, kde je filtrován druhý seznam na základě hodnoty, které uživatel vybere první seznamu. Při změně hodnoty v prvním seznamu, použije filtr automaticky do druhého seznamu, kterým se změní své hodnoty.

Důležité informace o kompatibilitě

Filtry můžete použít pouze v šablony formulářů, které slouží k vyplnění v aplikaci InfoPath. Filtry nejsou k dispozici v šablon formulářů kompatibilních s prohlížečem.

Začátek stránky

Krok 1: Vložení kaskádového seznamu

Pokud chcete vytvořit kaskádový seznam, vložíte dva seznamy v šabloně formuláře.

Poznámka: Po vložení kaskádového seznamu v šabloně formuláře zajištění dva seznamy není v Opakující se oddíl nebo Opakující se tabulka.

  1. Pokud není vidět podokno úloh Ovládací prvky, klikněte na Další ovládací prvky v nabídce Vložit nebo stiskněte klávesy ALT+I, C.

  2. Ve skupinovém rámečku ovládací prvky v podokně úloh ovládací prvky klikněte na Rozevírací seznam. Při vyplňování formuláře, který je založený na vaší šabloně formuláře, bude určovat výběru v rozevíracím seznamu voleb, které jsou k dispozici v druhém poli seznam.

  3. Klikněte na seznam. Šablona formuláře by teď měla obsahovat rozevíracím seznamem a standardní seznam.

    Drop-down list box and list box in a form

  4. Poklepejte na rozevírací seznam, který jste vložili v šabloně formuláře v kroku 2.

  5. V dialogovém okně Vlastnosti rozevíracího seznamu klikněte na kartu Data.

  6. Do pole název pole zadejte listBox1a potom klikněte na OK.

  7. Poklepejte na seznam, který jste vložili v šabloně formuláře v kroku 3.

  8. V dialogovém okně Vlastnosti seznamu klikněte na kartu Data.

  9. Do pole název pole zadejte listBox2Cascadea potom klikněte na OK.

Začátek stránky

Krok 2: Obsahují data

Teď jste vložili seznamů v šabloně formuláře, je nutné zadat data, která se zobrazí. Filtr musíte použít tak, že volby v druhém poli seznam vycházejí z výběru uživatele v prvním seznamu.

Tato část popisuje, jak obě pole spojí seznam s daty pomocí tří běžných metod: přidání dat do formuláře. připojení formuláře s existujícím dokumentem XML, která obsahuje data; nebo formuláři připojení k databázi, která obsahuje požadovaná data. Dokončete vytvoření kaskádového seznamu, klikněte na požadovanou metodu, která chcete použít v následujícím seznamu.

Připojení k datům ve formuláři

Připojení k externímu dokumentu XML

Připojení k databázi

Připojení k datům ve formuláři

V této části se dozvíte, jak k naplnění seznamů s daty z formuláře. K tomuto účelu musíte nejdřív konfigurovat pole v šabloně formuláře, tak, aby zadejte názvy kategorií a nastavit produktů pro každou kategorii.

Konfigurovat pole v šabloně formuláře

  1. Pokud podokno úloh Zdroj dat není viditelná, klikněte na Zdroj dat v nabídce Zobrazit.

  2. V podokně úloh Zdroj dat klikněte pravým tlačítkem skupinu mojePole a potom klikněte na Přidat.

  3. Do pole název v dialogovém okně Přidat pole nebo skupinu zadejte KategorieAProdukty.

  4. V seznamu Typ klikněte na Seskupit.

  5. Zaškrtněte políčko opakování a klikněte na OK.

  6. V podokně úloh Zdroj dat klikněte pravým tlačítkem skupinu KategorieAProdukty.

  7. Do pole název v dialogovém okně Přidat pole nebo skupinu zadejte kategoriea potom klikněte na OK. Toto pole obsahovalo názvy kategorií pro první seznam.

  8. Klikněte pravým tlačítkem na skupinu KategorieAProdukty a potom klikněte na Přidat.

  9. Do pole název v dialogovém okně Přidat pole nebo skupinu zadejte Product.

  10. Zaškrtněte políčko opakování a klikněte na OK. Toto pole obsahovalo názvy produktů pro druhý seznam.

Protože toto pole se seznamem vyplněné dat z formuláře, musíte data přidána do formuláře. Aby je dostala, budete muset vytvořit výchozích hodnot pro pole produkty a kategorie.

Tip

Můžete taky vytvořit seznam polí, které se zobrazí hodnoty, které uživatelé ve formuláři Typ sami. K tomuto účelu přidružit k seznamu polí, která jsou vázaný ovládací prvky ve formuláři. Pokud uživatel zadá hodnoty do ovládacích prvků, změnit možnosti v rozevíracím seznamu.

Vytvoření výchozích hodnot

  1. V nabídce Nástroje klikněte na Výchozí hodnoty.

  2. V dialogovém okně Upravit výchozí hodnoty ve skupině KategorieAProdukty vyberte pole kategorie (Ne zrušte zaškrtnutí políčka), a pak zadejte do pole Výchozí hodnotaryby.

  3. Vyberte pole Product (Ne zrušte zaškrtnutí políčka), a pak do pole Výchozí hodnota zadejte Krabí maso.

  4. Klikněte pravým tlačítkem myši pole produkt a potom klikněte na Přidat další produkt nad. Toto oprávnění umožňuje přidat druhý produkt pro ryby jako výchozí hodnotu.

  5. Klikněte pravým tlačítkem myši na druhou instanci aplikace pole produkt (Ne zrušte zaškrtnutí políčka), a pak zadejte do pole Výchozí hodnotaLosos.

  6. Klikněte pravým tlačítkem na skupinu KategorieAProdukty a potom klikněte na Přidat další KategorieAProdukty pod. Toto oprávnění umožňuje přidat druhé kategorie jako výchozí hodnotu.

  7. Pomocí předchozích kroků můžete určit výchozí hodnoty pro druhý výskyt pole kategorie a Productmléčné výrobky, čedar a čokoláda, respektive.

  8. Klikněte na OK.

Teď jste zadali výchozích hodnot pro pole produkty a kategorie, můžete první seznam připojit k data, která jste zadali.

První seznam připojit k datům

  1. V šabloně formuláře na rozevírací seznam poklikáte, které jste vložili dříve.

  2. Klikněte na kartu Data.

  3. V dialogovém okně Vlastnosti rozevíracího seznamu v části položky seznamu, klikněte na Vyhledat hodnoty ve zdroji dat formuláře.

  4. Klikněte na Vybrat výraz XPath Vzhled tlačítka vedle pole položky.

  5. V dialogovém okně Vybrat pole nebo skupiny ve skupině KategorieAProdukty klikněte na pole kategorií a potom klikněte na tlačítko OK.

Druhý seznam musíte teď se připojit k datům. Při tomto Datové připojení budete chtít použít filtr na druhý seznam. Tento filtr naplní druhý seznam s produkty, které podle vybrané v prvním seznamu kategorie. Filtr porovnává hodnota vybraná v prvním seznamu (pole Seznam1) se seznamem kategorie uložených ve formuláři (pole přiřazení kategorie).

Druhý seznam připojit k datům

  1. V šabloně formuláře poklepejte na standardní seznam, který jste vložili dříve.

  2. Klikněte na kartu Data.

  3. V dialogovém okně Vlastnosti seznamu v části položky seznamu, klikněte na Vyhledat hodnoty ve zdroji dat formuláře.

  4. Klikněte na Vybrat výraz XPath Vzhled tlačítka vedle pole položky.

  5. V dialogovém okně Vybrat pole nebo skupiny ve skupině KategorieAProdukty klikněte na pole produkt a potom klikněte na Filtrovat Data.

  6. V dialogovém okně Filtr dat klikněte na Přidat.

  7. V dialogovém okně Zadat podmínky filtru klikněte na Vybrat pole nebo skupinu do prvního pole.

  8. V dialogovém okně Vybrat pole nebo skupiny klikněte na listBox1 a potom klikněte na OK.

  9. V dialogovém okně Zadat podmínky filtru klikněte na Vybrat pole nebo skupiny ve třetím poli.

  10. V dialogovém okně Vybrat pole nebo skupiny klikněte na pole kategorie a potom klikněte na OK zavřete všechna otevřená dialogová okna.

Teď, když jste druhý seznam propojili s daty a filtr, jste připraveni k testování seznamy, abyste měli jistotu, že budou správně fungovat.

Testování seznamy

  1. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

  2. V rozevíracím seznamu klikněte na ryby. Standardní seznam byste měli vidět prázdný řádek, Krabí maso a Losos.

    Poznámka: Prázdný řádek umožňuje uživatelům zrušte jejich výběr ze seznamu.

Pokud seznamy nefunguje správně, zkontrolujte filtr pro druhý seznam a ujistěte se, že porovnává pole Seznam1 s poli kategorie.

Na začátek této části

Připojení k externímu dokumentu XML

V této části bude zjistěte, jak vytvořit datové připojení k dokumentu XML, který obsahuje hodnoty produkty a kategorie. Sekundární zdroj dat bude dokumentu XML. Pokud chcete vytvořit tento datové připojení, musíte vytvořit dokument XML, seznamy v šabloně formuláře přidružit dokumentu XML a pak použijte filtr druhý seznam tak, že seznam produktů změní řádně podporovat.

Před formuláři můžete přidružit sekundární zdroj dat, musíte napřed vytvořit dokument ve formátu XML.

Vytvoření dokumentu XML

  1. Spusťte Poznámkový blok nebo jiném textovém editoru.

  2. Zkopírujte a vložte následující XML data do textového editoru:

    <?xml version="1.0" encoding="UTF-8"?>
    <ListBoxData>
    <CategoriesAndProducts>
    <Categories>Seafood</Categories>
    <Products>
    <Product>Crab meat</Product>
    </Products>
    <Products>
    <Product>Salmon</Product>
    </Products>
    </CategoriesAndProducts>
    <CategoriesAndProducts>
    <Categories>Dairy</Categories>
    <Products>
    <Product>Chocolate milk</Product>
    </Products>
    <Products>
    <Product>Cheddar</Product>
    </Products>
    </CategoriesAndProducts>
    </ListBoxData>
  3. Uložte soubor do počítače jako dataSeznamu.XML.

Teď, když jste vytvořili dokument ve formátu XML, připojte ho k šabloně formuláře. Tím vytvoříte sekundární zdroj dat.

Připojení dokumentu XML do šablony formuláře

  1. V nabídce Nástroje klikněte na Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na Přidat.

  3. V Průvodci datovým připojením klikněte na přijmout data a klikněte na tlačítko Další.

  4. Na další stránce průvodce klikněte na dokument ve formátu XML a pak klepněte na tlačítko Další.

  5. Na další stránce průvodce klikněte na tlačítko Procházet, vyberte dataSeznamu.XML soubor, který jste uložili do počítače a potom klikněte na Otevřít.

  6. Na další stránce průvodce klikněte na Zahrnout data jako soubor prostředků v šabloně formuláře nebo část šablony a klikněte na tlačítko Další.

  7. Na další stránce průvodce, do pole Zadejte název tohoto datového připojení zadejte dataSeznamuSouborXML.

  8. Zaškrtněte políčko automaticky obnoví data při otevření formuláře. Zaručuje, že data pole seznamu bude k dispozici při každém otevření formuláře, místo vyžadující uživatele do dotazu pro něj.

  9. Klikněte na Dokončit.

  10. V dialogovém okně Datová připojení klikněte na Zavřít.

Teď jste připraveni na první pole v šabloně formuláře seznamu připojení k datům v dokumentu XML.

První seznam připojit k datům

  1. V šabloně formuláře na rozevírací seznam poklikáte, které jste vložili dříve.

  2. Klikněte na kartu Data.

  3. V dialogovém okně Vlastnosti rozevíracího seznamu v části položky seznamu, klikněte na Vyhledat hodnoty z externího zdroje dat.

  4. V dialogovém okně zdroj dat klikněte na dataSeznamuSouborXML.

  5. Klikněte na Vybrat výraz XPath Vzhled tlačítka vedle pole položky.

  6. V dialogovém okně Vybrat pole nebo skupiny ve skupině KategorieAProdukty klikněte na pole kategorie.

    Poznámka: Žluté pozadí v dialogovém okně Vybrat pole nebo skupinu označuje, že pracujete s sekundární zdroj dat.

  7. Poklikejte na tlačítko OK.

Teď budou mít druhý seznam připojit k dokumentu XML. Při vytváření tohoto datového připojení, budete chtít použít filtr na druhý seznam. Tento filtr naplní druhý seznam s produkty, které podle vybrané v prvním seznamu kategorie. Filtr porovnává hodnota vybraná v prvním seznamu (pole Seznam1) se seznamem kategorie uložených ve formuláři (pole přiřazení kategorie).

Druhý seznam připojit k datům

  1. V šabloně formuláře poklepejte na standardní seznam, který jste vložili dříve.

  2. Klikněte na kartu Data.

  3. V dialogovém okně Vlastnosti seznamu v části položky seznamu, klikněte na Vyhledat hodnoty z externího zdroje dat.

  4. V dialogovém okně zdroj dat klikněte na dataSeznamuSouborXML.

  5. Klikněte na Vybrat výraz XPath Vzhled tlačítka vedle pole položky.

  6. V dialogovém okně Vybrat pole nebo skupiny ve skupině KategorieAProdukty rozbalte skupinu produkty a potom klikněte na pole produkt.

  7. Klikněte na filtrovat Data.

  8. V dialogovém okně Filtr dat klikněte na Přidat.

  9. V dialogovém okně Zadat podmínky filtru klikněte na Vybrat pole nebo skupinu do prvního pole.

  10. V dialogovém okně zdroj dat v dialogovém okně Vybrat pole nebo skupiny klikněte na hlavní.

  11. Klepněte na položku Seznam1 a klikněte na OK.

  12. V dialogovém okně Zadat podmínky filtru klikněte na Vybrat pole nebo skupiny ve třetím poli.

  13. V dialogovém okně zdroj dat v dialogovém okně Vybrat pole nebo skupiny klikněte na dataSeznamuSouborXML (sekundární) a potom klikněte na kategorie.

  14. Klikáním na OK zavřete všechna dialogová okna.

Teď, když jste připojeni druhý seznam do dokumentu XML a filtr, jste připraveni k testování seznamy, abyste měli jistotu, že budou správně fungovat.

Testování seznamy

  1. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

  2. V rozevíracím seznamu klikněte na ryby. Standardní seznam byste měli vidět jenom prázdný řádek, Krabí maso a Losos.

    Poznámka: Prázdný řádek umožňuje uživatelům zrušte jejich výběr ze seznamu.

Pokud seznamy nefunguje správně, zkontrolujte filtr pro druhý seznam a ujistěte se, že porovnává pole Seznam1 s poli kategorie.

Na začátek této části

Připojení k databázi

V této části se dozvíte, jak k vytvoření datového připojení na dvě tabulky v databázi aplikace Access. K tomuto účelu přidružit databázi seznamech v šabloně formuláře a pak použijte filtr druhý seznam tak, že v seznamu druhého seznamu pole se změní řádně podporovat na základě hodnoty v prvním seznamu. V tomto příkladu jsme se předpokládá, že databáze aplikace Access obsahuje dva tabulky s názvem kategorie a produkty a, že dvěma jsou relačně vzájemně podle pole CategoryID, které se používá v každé tabulce.

Tabulky kategorie   

Pole CategoryID

CategoryName

1

Ryby

2

Mléčné výrobky

Tabulky produkty   

ID produktu

Pole CategoryID

ProductName

1

1

Krabí maso

2

1

Losos

3

2

Čokoláda

4

2

Čedar

Připojení ke zdroji dat na šablonu formuláře

Nejdřív vytvořte datové připojení mezi šabloně formuláře a tabulek v databázi. Vzhledem k tomu, že jste pouze zobrazení dat z databáze místo změny přímo, bude databáze aplikace Access sekundární zdroj dat pro šablonu formuláře.

  1. V nabídce Nástroje klikněte na Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na Přidat.

  3. V Průvodci datovým připojením klikněte na přijmout data a klikněte na tlačítko Další.

  4. Na další stránce průvodce klikněte na databáze (Microsoft SQL Server nebo Microsoft Office Access pouze) a klikněte na tlačítko Další.

  5. Na další stránce průvodce klikněte na Vybrat databázi a pak přejděte k a poklikejte na databázi aplikace Access na pevném disku.

  6. V dialogovém okně Vybrat tabulku klikněte na tabulku, která obsahuje data, která se má objevit v prvním seznamu (v tomto příkladu tabulky kategorie) a potom klikněte na OK. Určuje tabulky jako primární tabulka datového připojení.

  7. V průvodci klikněte na Přidat tabulku.

  8. V dialogovém okně Přidat tabulku nebo dotaz klikněte na tabulku, která obsahuje data, která se má objevit v druhém seznamu (v tomto příkladu tabulky produkty) a klikněte na tlačítko Další.

  9. V dialogovém okně Upravit relace zkontrolujte správnost propojená pole. V tomto příkladu jsou relačně vzájemně podle pole CategoryID.

    Tip: Propojená pole nejsou správné, vyberte pole a potom klikněte na Odebrat vztah. Potom klikněte na Přidat relaci, vyberte správná pole a potom klikněte na OK.

  10. Klikněte na Dokončit.

    Poznámka: V tomto příkladu obsahuje tabulky Kategorie-n relace na tabulku produkty, což znamená, že pro každou kategorii může být mnoho produktů. V databázi tohoto typu relace obvykle vytvořen pomocí klíče. V tomto případě klíčové pole CategoryID umožňují přístup k správnou sadu produkty přidružit příslušné kategorie.

  11. V Průvodci prohlédněte si struktuře zdrojových dat. Měli byste vidět dvěma tabulkami připojené k sobě: primární a sekundární tabulka. Zobrazíte jednotlivá pole v tabulce, zaškrtněte políčko Zobrazit sloupce tabulky. Až budete hotovi, kontroly struktury dat, klikněte na tlačítko Další.

  12. Zrušte zaškrtnutí políčka Uložit kopii data v šabloně formuláře a potom na tlačítko Další.

  13. Do pole Zadejte název tohoto datového připojení na další stránce průvodce zadejte název datového připojení.

  14. Zaškrtněte políčko automaticky obnoví data při otevření formuláře.

  15. Klikněte na tlačítko Dokončit a pak klepněte na tlačítko Zavřít v dialogovém okně Datová připojení.

Připojení k datům prvním seznamu

Teď, když jste vytvořili datové připojení k sekundární zdroj dat, můžete na první pole v šabloně formuláře seznam připojit k tabulek v databázi.

  1. V šabloně formuláře na rozevírací seznam poklikáte, které jste vložili dříve.

  2. Klikněte na kartu Data.

  3. V dialogovém okně Vlastnosti rozevíracího seznamu v části položky seznamu, klikněte na Vyhledat hodnoty z externího zdroje dat.

  4. V dialogovém okně zdroj dat zkontrolujte, zda je zaškrtnuto datového připojení, které jste vytvořili.

  5. Klikněte na Vybrat výraz XPath Vzhled tlačítka vedle pole položky.

  6. V dialogovém okně Vybrat pole nebo skupiny klikněte na název tabulky, která obsahuje data, která se má objevit v rozevíracím seznamu (v tomto příkladu d: kategorie ) a potom klikněte na OK.

    Poznámka: Žluté pozadí v dialogovém okně Vybrat pole nebo skupinu označuje, že pracujete s sekundární zdroj dat.

  7. Klikněte na Vybrat výraz XPath Vzhled tlačítka vedle pole hodnoty.

  8. V dialogovém okně Vybrat pole nebo skupiny, ujistěte se, že pole připojení (v tomto příkladu : Idkategorie ) zaškrtnuté a klikněte na OK. Toto je hodnota, která budou uloženy, když uživatel provede výběru v rozevíracím seznamu.

  9. Klikněte na Vybrat výraz XPath Vzhled tlačítka vedle pole Zobrazovaný název.

  10. V dialogovém okně Vybrat pole nebo skupiny klikněte na název pole, které se má zobrazovat v rozevíracím seznamu (v tomto příkladu : CategoryName ).

  11. Poklikejte na tlačítko OK.

Druhý seznam připojit k datům

Teď budou mít druhý seznam připojení k databázi. Při vytváření tohoto datového připojení, budete chtít použít filtr na druhý seznam. Tento filtr naplní druhý seznam s příslušnými hodnotami na základě hodnoty, které jsou vybrány v prvním seznamu.

  1. V šabloně formuláře na standardní seznam poklikáte.

  2. Klikněte na kartu Data.

  3. V dialogovém okně Vlastnosti seznamu v části položky seznamu, klikněte na Vyhledat hodnoty z externího zdroje dat.

  4. V dialogovém okně zdroj dat zkontrolujte, zda je zaškrtnuto datového připojení, které jste vytvořili.

  5. Klikněte na Vybrat výraz XPath Vzhled tlačítka vedle pole položky.

  6. V dialogovém okně Vybrat pole nebo skupinu rozbalte primární skupiny (v tomto příkladu d: kategorie ) a pak klikněte na vedlejší skupinu, která odpovídá tabulku obsahující data, která chcete zobrazit v kaskádového seznamu (v tomto třeba produkty ).

  7. Klikněte na filtrovat Data.

  8. V dialogovém okně Filtr dat klikněte na Přidat.

  9. V dialogovém okně Zadat podmínky filtru v prvním poli Ujistěte se, zda je vybráno pole spojovací z sekundární tabulky (v tomto příkladu produkty ).

    Důležité informace: Pokud propojená pole mít v obou tabulkách stejný název, ujistěte se, že jste vybrali správný. Pole ze všech tabulek společně řazení v seznamu. Proto můžete okolní názvy polí zjistěte, který není správná. V tomto příkladu jsme vyberte spojené pole, která se zobrazí s dalších polí z tabulky produkty.

  10. V dialogovém okně třetí klikněte na Výběr pole nebo skupiny.

  11. V dialogovém okně zdroj dat v dialogovém okně Vybrat pole nebo skupiny klikněte na hlavní, klikněte na pole Seznam1 a klikněte na OK.

    Teď jste nakonfigurovali filtru, které porovná hodnota vybraná v rozevíracím seznamu pole (Seznam1) se seznamem hodnot v seznamu standardní.

  12. Klikněte třikrát na OK se vrátíte do dialogového okna Vlastnosti seznamu.

  13. Klikněte na Vybrat výraz XPath Vzhled tlačítka vedle pole hodnoty.

  14. V dialogovém okně Vybrat pole nebo skupinu vyberte hodnotu, kterou chcete uložit, pokud uživatel zadá výběru v rozevíracím seznamu. V tomto příkladu jsme chcete uložit na základě pole pro pozdější použití. Proto doporučujeme vybrat : Idproduktu seskupit a potom klikněte na OK.

  15. Klikněte na Vybrat výraz XPath Vzhled tlačítka vedle pole Zobrazovaný název.

  16. V dialogovém okně Vybrat pole nebo skupiny klikněte na název pole, které chcete zobrazit v rozevíracím seznamu (v tomto příkladu : ProductName ).

  17. Poklikejte na tlačítko OK.

Testování seznamy

Teď, když jste připojení k databázi druhý seznam a filtr, jste připraveni k testování seznamy, abyste měli jistotu, že budou správně fungovat.

  1. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

  2. V rozevíracím seznamu vyberte hodnotu. Standardní seznam byste měli vidět odpovídající hodnoty z sekundární tabulky v závislosti na spojovací pole, které jste zvolili.

Tip: Pokud seznamy nefunguje správně, zkontrolujte filtr pro druhý seznam a ujistěte se, že porovnává pole Seznam1 s pole CategoryID.

Na začátek této části

Začátek stránky

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×