Office
Přihlásit se
Vytvoření histogramu v Excelu

Vytvoření histogramu v Excelu

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Histogram je sloupcový graf, ve kterém se zobrazují data četnosti.

Poznámka: Toto téma pouze pojednává o vytváření histogram. Informace o grafech Pareto (tříděný histogram) najdete v tématu Vytvoření Paretova grafu.

  1. Zkontrolujte, že jste vložili analytické nástroje. Další informace najdete v tématu zatížení analytické nástroje v aplikaci Excel.

  2. V listu zadejte do jednoho sloupce vstupní data. První buňka může obsahovat popisek.

    Použijte kvantitativní číselná data, například množství položek nebo skóre dosažená v testech. Nástroj Histogram nepracuje s kvalitativními číselnými daty, například s identifikačními čísly zadanými jako text.

  3. Do dalšího sloupce zadejte čísla tříd seřazená vzestupně. První buňka může obsahovat popisek.

    Doporučujeme použít vlastní čísla tříd, protože mohou být užitečnější pro vaši analýzu. Pokud nezadáte čísla tříd, nástroj Histogram vytvoří rovnoměrně rozdělené intervaly tříd použitím minimální a maximální hodnoty ve vstupní oblasti jako počátečního a koncového bodu.

  4. Klikněte na Data > Analýza dat.

    Skupina Analýza – tlačítko Analýza dat

  5. Klikněte na Histogram > OK.

    Dialogové okno Analýza dat

  6. Ve skupinovém rámečku Vstup udělejte tohle:

    1. Do pole Vstupní oblast zadejte odkaz na oblast buněk, která obsahuje vstupní čísla.

    2. Do pole Hranice tříd zadejte odkaz na oblast buněk, která obsahuje čísla tříd.

      Pokud jste v listu použili popisky sloupců, můžete je zahrnout do odkazů na buňky.

      Tip: Místo přímého zadávání odkazy ručně, můžete kliknout na Obrázek tlačítka čímž dočasně sbalíte dialogové okno Vybrat oblast na listu. Klepnutím na tlačítko znovu rozšíří dialogového okna.

  7. Pokud jste do odkazů na buňky zahrnuli popisky sloupců, zaškrtněte políčko Popisky.

  8. Ve skupinovém rámečku Možnosti výstupu zvolte umístění výstupu.

    Histogram můžete umístit na stejný list, na nový list v aktuálním sešitu nebo na list v novém sešitu.

  9. Zaškrtněte některé z těchhle políček:

    Pareto (tříděný histogram): Data se zobrazí v sestupném pořadí frekvencí.

    Kumulativní procentuální podíl:     Zobrazí se kumulativní procentuální podíly a do grafu histogramu se přidá čára pro kumulativní procentuální podíl.

    Vytvořit graf:     Zobrazí se vložený graf histogramu.

  10. Klikněte na OK.

    Pokud chcete přizpůsobit vaše histogram, můžete změnit text popisků a klikněte na libovolné místo v grafu histogramu použijte tlačítka Prvky grafu, Styly grafu a Filtry grafu na pravé straně grafu.

  1. Vyberte data.

    (Toto je typické příklad dat pro histogram.)

    Data použitá k vytvoření ukázky histogramu nahoře
  2. Klikněte na Vložení > Vložit statistický graf > Histogram.

    Příkaz Histogram po stisknutí tlačítka Vložit statistický graf

    Histogram můžete vytvořit taky na kartě Všechny grafy ve Skupině doporučené grafy.

Tipy: 

  • Přizpůsobení vzhledu grafu, použijte karty Návrh a Formát.

  • Pokud nevidíte následujících karet, klikněte na libovolné místo v histogramu přidáte Nástroje grafu na pásu karet.

Karty Návrh a Formát pro Nástroje grafu

  1. Klikněte pravým tlačítkem na vodorovnou osu grafu, klikněte na Formát osy a potom klikněte na Možnosti osy.

    Příkaz Formátovat osu v místní nabídce
  2. Pomocí pokynů v následující tabulce rozhodnout, jaké možnosti chcete nastavit v podokně úloh Formát osy.

    Možnost

    Popis

    Podle kategorie

    Vyberte tuto možnost, pokud kategorií (vodorovná osa) jsou založeny na text místo číselné. Histogram seskupení stejné kategorie a součet hodnot v popiskách osy.

    Tip: Pokud chcete spočítat výskyty textových řetězců, přidejte sloupec a vyplňte ho hodnotou 1, pak vykreslete histogram a nastavte intervaly na Podle kategorie.

    Automatické

    Toto je ve výchozím nastavení histogramy. Šířka Koš se počítají pomocí Scottovo normální referenční pravidlo.

    Šířka Koš

    Zadejte kladné desetinné číslo pro počet datových bodů v každém rozsahu.

    Počet intervalů

    Zadejte počet intervalů histogramu (včetně intervalů přetečení a podtečení).

    Interval přetečení

    Vyberte toto zaškrtávací políčko k vytvoření Koš pro všechny hodnoty nad hodnotu do pole vpravo. Pokud chcete změnit hodnotu, zadejte do pole různých desetinné číslo.

    Interval podtečení

    Vyberte toto zaškrtávací políčko k vytvoření koše všechny s hodnotou nižší než nebo rovná hodnotě v poli vpravo. Pokud chcete změnit hodnotu, zadejte do pole různých desetinné číslo.

    Podokno úloh Formát osy

Tip: Přečtěte si další informace o grafu histogramu a jak pomáhá vizualizace statistických údajů, najdete v článku tento příspěvek na blog na histogram, Paretův graf a Krabicový graf týmem aplikace Excel. Možná by vás zajímavé dozvědět další informace o dalších nové typech grafů popsaných v tomto blogu příspěvek.

Možnost automaticky (Scottovo normální referenční pravidlo)   

Možnost vzorce pro automatický výpočet

Scottovo normální referenční pravidlo se snaží minimalizovat odchylku histogramu porovnání se sadou dat předpokládaným normálním rozdělením.

Možnost Koš přetečení   

Vzorec pro možnost Přetečení přihrádky

Možnost Koš podtečení   

Vzorec pro možnost Podtečení přihrádky

  1. Vyberte data.

    (Toto je typické příklad dat pro histogram.)

    Data použitá k vytvoření ukázky histogramu nahoře
  2. Klikněte na Vložení > Graf.

    Tlačítko Graf ve skupině Ilustrace na kartě Vložit ve Wordu
  3. V dialogovém okně Vložit graf klikněte v části Všechny grafy klikněte na Histogram a klikněte na OK.

Tipy: 

  • Přizpůsobení vzhledu grafu, použijte karty Návrh a Formát na pásu karet.

  • Pokud nevidíte následujících karet, klikněte na libovolné místo v histogramu přidáte Nástroje grafu na pásu karet.

Karty Návrh a Formát pro Nástroje grafu

  1. Klikněte pravým tlačítkem na vodorovnou osu grafu, klikněte na Formát osy a potom klikněte na Možnosti osy.

    Příkaz Formátovat osu v místní nabídce
  2. Pomocí pokynů v následující tabulce rozhodnout, jaké možnosti chcete nastavit v podokně úloh Formát osy.

    Možnost

    Popis

    Podle kategorie

    Vyberte tuto možnost, pokud kategorií (vodorovná osa) jsou založeny na text místo číselné. Histogram seskupení stejné kategorie a součet hodnot v popiskách osy.

    Tip: Pokud chcete spočítat výskyty textových řetězců, přidejte sloupec a vyplňte ho hodnotou 1, pak vykreslete histogram a nastavte intervaly na Podle kategorie.

    Automatické

    Toto je ve výchozím nastavení histogramy.

    Šířka Koš

    Zadejte kladné desetinné číslo pro počet datových bodů v každém rozsahu.

    Počet intervalů

    Zadejte počet intervalů histogramu (včetně intervalů přetečení a podtečení).

    Interval přetečení

    Vyberte toto zaškrtávací políčko k vytvoření Koš pro všechny hodnoty nad hodnotu do pole vpravo. Pokud chcete změnit hodnotu, zadejte do pole různých desetinné číslo.

    Interval podtečení

    Vyberte toto zaškrtávací políčko k vytvoření koše všechny s hodnotou nižší než nebo rovná hodnotě v poli vpravo. Pokud chcete změnit hodnotu, zadejte do pole různých desetinné číslo.

    Podokno úloh Formát osy

Tip: Přečtěte si další informace o grafu histogramu a jak pomáhá vizualizace statistických údajů, najdete v článku tento příspěvek na blog na histogram, Paretův graf a Krabicový graf týmem aplikace Excel. Možná by vás zajímavé dozvědět další informace o dalších nové typech grafů popsaných v tomto blogu příspěvek.

Tímto postupem vytvoření histogramu v Excelu 2016 pro Mac:

  1. Vyberte data.

    (Toto je typické příklad dat pro histogram.)

    Data použitá k vytvoření ukázky histogramu nahoře
  2. Na pásu karet klikněte na kartu Vložení a pak klikněte Ikona statistického grafu (ikonaStatistická ) a v části HistogramHistogram.

Tipy: 

  • Přizpůsobení vzhledu grafu, použijte karty Grafu – návrh a formátování.

  • Pokud se nezobrazují karty Grafu – návrh a formátování, klikněte na libovolné místo v histogramu si je přidat na pás karet.

Pokud chcete vytvořit histogram v Excelu 2011 for Mac, musíte stáhnout doplněk třetích stran. Viz: nemůžu najít analytické nástroje v Excelu 2011 for Mac další podrobnosti.

V Excel Online můžete zobrazit histogram (sloupcový graf, který zobrazuje frekvenční data), ale nemůžete udělat, protože se musí analytické nástroje, Excel doplňku, který není podporovaný v Excel Online.

Pokud máte desktopovou aplikaci Excel, můžete pomocí tlačítka Upravit v aplikaci Excel otevřete Excel na ploše a vytvořte histogram.

Tlačítko pro úpravy v Excelu

  1. Klepnutím vyberte požadovaná data.

    Data použitá k vytvoření ukázky histogramu nahoře
  2. Pokud jste na telefonu, klepněte na ikonu úpravy Ikona Upravit zobrazte pás karet. a potom na kartu Domů.

  3. Klepněte na Vložení > graf > Histogram.

    V případě potřeby můžete upravit prvky grafu.

    Poznámka: Tato funkce je dostupná jenom v případě, že máte předplatné Office 365. Pokud předplatné Office 365 máte, zkontrolujte si, jestli máte nejnovější verzi Office.

    Vyzkoušejte Office 365 nebo nejnovější verzi Excelu

  1. Klepnutím vyberte požadovaná data.

    Data použitá k vytvoření ukázky histogramu nahoře
  2. Pokud jste na telefonu, klepněte na ikonu úpravy Ikona Upravit zobrazte pás karet a potom na kartu Domů.

  3. Klepněte na Vložení > graf > Histogram.

Pokud chcete vytvořit histogram v Excel, zadáte dva typy dat – data, která chcete analyzovat a Koš čísla, která představují intervalů, podle kterých chcete změřit frekvenci. Musíte uspořádání dat ve dvou sloupcích na listu. Tyto sloupce musí obsahovat následující údaje:

  • Zadávání dat    Toto je data, která chcete analyzovat pomocí nástroje Histogram.

  • Čísla tříd    Tyto čísla, představuje intervalů má Histogram nástroje pro účely měření zadávání dat do analýzy dat.

Při použití nástroje Histogram Excel spočítá počet datových bodů v každé dat Koš. Datový bod je součástí konkrétní Koš, pokud je číslo větší než dolní mez a rovna nebo menší než nejvyšší hodnota vazby pro data intervalu. Vynecháme-li hranice tříd Excel vytvoří sadu rovnoměrně distribuované intervalů mezi minimální a maximální hodnoty vstupní data.

Výstup analýzy histogram se zobrazí na nový list (nebo v novém sešitu) a zobrazí tabulku histogram a sloupcový graf, který znázorňuje data v tabulce histogram.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení na fóru Excel User Voice.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×