Grafy

Vytvoření grafu od začátku do konce

Vytvoření grafu od začátku do konce

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Grafy vám umožňují vizualizovat data způsobem, které na posluchače udělají maximální dojem. Zjistěte, jak vytvořit graf a přidat spojnici trendu.

Váš prohlížeč nepodporuje video. Nainstalujte si Microsoft Silverlight, Adobe Flash Player nebo Internet Explorer 9.

Vytvoření grafu

  1. Vyberte data, ze kterých chcete vytvořit graf.

  2. Klikněte na Vložení > Doporučené grafy.

  3. Po výběru typu grafu na kartě Doporučené grafy se vám zobrazí náhled grafu.

    Poznámka: Můžete si také graf vytvořit okamžitě, a to tak, že vyberete data, která chcete v grafu zobrazit, a stisknete ALT + F1. Nemusí se ale zobrazit graf, který je pro daná data nejvhodnější. Pokud se vám zobrazený graf nelíbí, můžete si výběrem karty Všechny grafy prohlédnout všechny dostupné typy grafů.

  4. Vyberte graf.

  5. Vyberte OK.

Přidání spojnice trendu

  1. Vyberte graf.

  2. Vyberte Návrh > Přidat prvek grafu.

  3. Vyberte Spojnice trendu a pak vyberte požadovaný typ spojnice trendu, napříkladLineární, Exponenciální, Lineární prognóza nebo Klouzavý průměr.

Poznámka: Část obsahu v tomto tématu nemusí být v některých jazycích k dispozici.

Grafy slouží k zobrazení dat v grafickém formátu, což může vám a vaší cílové skupině pomoct vizualizovat si vztahy mezi daty. Při vytváření grafu si můžete vybrat z řady typů grafů (například skládaný sloupcový graf nebo rozložený výsečový 3D graf). Vytvořený graf si můžete přizpůsobit použitím rychlých rozložení a stylů grafů.

Graf obsahuje několik prvků, jako je název, popisky os, legenda a mřížky. Tyto prvky můžete skrýt nebo zobrazit a můžete taky změnit jejich umístění a formátování.

Graf v Office s bublinovými popisky

Obrázek tlačítka Název grafu

Obrázek tlačítka Oblast grafu

Popisek 3 Legenda

Krok 4 Názvy os

Krok 5 Popisky os

Bublinový popisek 6 Značky

Bublinový popisek 7 Mřížky

Graf můžete vytvořit v Excelu, Wordu i PowerPointu. Data grafu se ale zadávají a ukládají do listu Excelu. Pokud vložíte graf do Wordu nebo PowerPointu, otevře se nový list v Excelu. Když uložíte wordový dokument nebo powerpointovou prezentaci, které obsahují graf, podkladová excelová data grafu se automaticky uloží ve wordovém dokumentu nebo powerpointové prezentaci.

Poznámka: Galerie excelových sešitů nahrazuje předchozího Průvodce grafem. Ve výchozím nastavení se galerie excelových sešitů otevře při spuštění Excelu. V galerii můžete procházet šablony a vytvořit nový sešit založený na jedné z nich. Pokud galerii excelových sešitů nevidíte, klikněte v nabídce File (Soubor) na New from Template (Nový ze šablony).

  1. V nabídce Zobrazení klikněte na Rozložení při tisku.

  2. Klikněte na kartu Vložení a potom klikněte na šipku vedle možnosti Graf.

    Klikněte na kartu Vložení a potom na Graf.

  3. Klikněte na typ grafu a pak poklikejte na graf, který chcete přidat.

    Při vložení grafu do Wordu nebo PowerPointu se otevře list v Excelu, který obsahuje tabulku s ukázkovými daty.

  4. V Excelu nahraďte ukázková data daty, která chcete vykreslit v grafu. Pokud už data máte v jiné tabulce, můžete je z této tabulky překopírovat přes ukázková data. V následující tabulce najdete pokyny, jak uspořádat data podle typu grafu.

    Typ grafu

    Uspořádání dat

    Plošný, pruhový, sloupcový, prstencový, spojnicový, paprskový nebo povrchový graf

    Do sloupců nebo řádků jako v následujících příkladech:

    Řada 1

    Řada 2

    Kategorie A

    10

    12

    Kategorie B

    11

    14

    Kategorie C

    9

    15

    nebo

    Kategorie A

    Kategorie B

    Řada 1

    10

    11

    Řada 2

    12

    14

    Bublinový graf

    Ve sloupcích, s umístěním hodnot X do prvního sloupce a odpovídajících hodnot Y a hodnot velikostí bublin do přilehlých sloupců, jako v následujícím příkladě:

    Hodnoty X

    Hodnota Y 1

    Velikost 1

    0,7

    2,7 %

    4

    1,8 %

    3,2

    5

    2,6 %

    0,08

    6

    Výsečový graf

    V jednom sloupci nebo řádku dat a jednom sloupci nebo řádku popisků dat, například:

    Prodej

    1. čtvrtletí

    25

    2. čtvrtletí

    30

    3. čtvrtletí

    45

    nebo

    1. čtvrtletí

    2. čtvrtletí

    3. čtvrtletí

    Prodej

    25

    30

    45

    Burzovní graf

    Ve sloupcích nebo řádcích v následujícím pořadí s použitím názvů nebo dat jako popisků, například:

    Počáteční

    Vysoká

    Nízká

    Konečná

    5. 1. 2002

    44

    55

    11

    25

    6. 1. 2002

    25

    57

    12

    38

    nebo

    5. 1. 2002

    6. 1. 2002

    Počáteční

    44

    25

    Vysoká

    55

    57

    Nízká

    11

    12

    Konečná

    25

    38

    XY bodový graf

    Ve sloupcích s umístěním hodnoty X do prvního sloupce a odpovídajících hodnot Y do přilehlých sloupců, například:

    Hodnoty X

    Hodnota Y 1

    0,7

    2,7 %

    1,8 %

    3,2

    2,6 %

    0,08

    nebo

    Hodnoty X

    0,7

    1,8 %

    2,6 %

    Hodnota Y 1

    2,7 %

    3,2

    0,08

  5. Pokud chcete změnit počet řádků nebo sloupců, které jsou součástí grafu, umístěte ukazatel myši do pravého dolního rohu vybraných dat a tažením vyberte další data. V následujícím příkladu je tabulka rozšířena tak, aby zahrnovala další kategorie a datové řady.

    Výběr dalších dat pro graf v Office

  6. Pokud chcete zobrazit výsledky změn, přepněte zpátky do Wordu nebo PowerPointu.

    Poznámka: Když zavřete wordový dokument nebo powerpointovou prezentaci, které obsahují graf, zavře se automaticky i excelová tabulka s daty grafu.

Po vytvoření grafu můžete změnit způsob, jakým se v grafu vykreslují řádky a sloupce tabulky. Vaše první verze grafu může například vykreslovat řádky dat z tabulky na svislé ose grafu (hodnoty) a sloupce dat na vodorovné ose (kategorie). V následujícím příkladu graf zvýrazňuje prodeje podle nástroje.

Graf znázorňující prodej podle kategorií

Ale pokud chcete, aby graf zvýrazňoval prodeje po měsících, můžete změnit způsob, jakým se graf vykreslí.

Graf znázorňující prodej podle měsíců

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf.

  3. Klikněte na kartu Návrh grafu a potom klikněte na Zaměnit řádek za sloupec.

    Klikněte na kartu Návrh grafu a potom na Zaměnit řádek za sloupec.

    Pokud není možnost Zaměnit řádek za sloupec dostupná

    Možnost Zaměnit řádek za sloupec je dostupná pouze pro určité typy grafů a pouze v případě, že je excelová tabulka s daty grafu otevřená. Data můžete také upravit tak, že kliknete na graf a pak upravíte list v Excelu.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf.

  3. Klikněte na kartu Návrh grafu a potom klikněte na Rychlé rozložení.

    Klikněte na kartu Návrh grafu a potom na Rychlé rozložení.

  4. Klikněte na požadované rozložení.

    Pokud chcete okamžitě vrátit zpět rychlé rozložení, které jste použili, stiskněte PŘÍKAZ + Z.

Styly grafu představují sadu doplňkových barev a efektů, které můžete použít pro graf. Když vyberete styl grafu, provedené změny se projeví v celém grafu.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf.

  3. Klikněte na kartu Návrh grafu a potom klikněte na požadovaný styl.

    Klikněte na kartu Návrh grafu a potom na některý styl grafu.

    Pokud chcete zobrazit více stylů, najeďte myší na styl a potom klikněte na Šipka Více .

    Pokud chcete okamžitě vrátit zpět styl, který jste použili, stiskněte klávesy PŘÍKAZ +Z.

  1. V nabídce Zobrazení klikněte na Rozložení při tisku.

  2. Klikněte na graf a potom klikněte na kartu Návrh grafu.

  3. Klikněte na Přidat prvek grafu.

    Klikněte na kartu Návrh grafu a potom na Přidat prvek grafu.

  4. Klikněte na Název grafu a zvolte možnosti formátu názvu. Pak se vraťte do grafu a zadejte název do pole Název grafu.

Viz také

Aktualizace dat v existujícím grafu

Typy grafů

Graf můžete vytvořit v Excelu, Wordu i PowerPointu. Data grafu se ale zadávají a ukládají do listu Excelu. Pokud vložíte graf do Wordu nebo PowerPointu, otevře se nový list v Excelu. Když uložíte wordový dokument nebo powerpointovou prezentaci, které obsahují graf, podkladová excelová data grafu se automaticky uloží ve wordovém dokumentu nebo powerpointové prezentaci.

Poznámka: Galerie excelových sešitů nahrazuje předchozího Průvodce grafem. Ve výchozím nastavení se galerie excelových sešitů otevře při spuštění Excelu. V galerii můžete procházet šablony a vytvořit nový sešit založený na jedné z nich. Pokud galerii excelových sešitů nevidíte, klikněte v nabídce File (Soubor) na New from Template (Nový ze šablony).

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Na kartě Charts (Grafy) v části Insert Chart (Vložit graf) klikněte na typ grafu a potom klikněte na graf, který chcete přidat.

    Karta Grafy, skupina Vložit graf

    Při vložení grafu do Wordu nebo PowerPointu se otevře list v Excelu, který obsahuje tabulku s ukázkovými daty.

  3. V Excelu nahraďte vzorová data údaji, které chcete použít v grafu. Pokud už data máte v jiné tabulce, můžete je z této tabulky zkopírovat a přepsat jimi vzorová data. V následující tabulce najdete pokyny, jak uspořádat data podle typu grafu.

    Typ grafu

    Uspořádání dat

    Plošný, pruhový, sloupcový, prstencový, spojnicový, paprskový nebo povrchový graf

    Do sloupců nebo řádků jako v následujících příkladech:

    Řada 1

    Řada 2

    Kategorie A

    10

    12

    Kategorie B

    11

    14

    Kategorie C

    9

    15

    nebo

    Kategorie A

    Kategorie B

    Řada 1

    10

    11

    Řada 2

    12

    14

    Bublinový graf

    Ve sloupcích, s umístěním hodnot X do prvního sloupce a odpovídajících hodnot Y a hodnot velikostí bublin do přilehlých sloupců, jako v následujícím příkladě:

    Hodnoty X

    Hodnota Y 1

    Velikost 1

    0,7

    2,7 %

    4

    1,8 %

    3,2

    5

    2,6 %

    0,08

    6

    Výsečový graf

    V jednom sloupci nebo řádku dat a jednom sloupci nebo řádku popisků dat, například:

    Prodej

    1. čtvrtletí

    25

    2. čtvrtletí

    30

    3. čtvrtletí

    45

    nebo

    1. čtvrtletí

    2. čtvrtletí

    3. čtvrtletí

    Prodej

    25

    30

    45

    Burzovní graf

    Ve sloupcích nebo řádcích v následujícím pořadí s použitím názvů nebo dat jako popisků, například:

    Počáteční

    Vysoká

    Nízká

    Konečná

    5. 1. 2002

    44

    55

    11

    25

    6. 1. 2002

    25

    57

    12

    38

    nebo

    5. 1. 2002

    6. 1. 2002

    Počáteční

    44

    25

    Vysoká

    55

    57

    Nízká

    11

    12

    Konečná

    25

    38

    XY bodový graf

    Ve sloupcích s umístěním hodnoty X do prvního sloupce a odpovídajících hodnot Y do přilehlých sloupců, například:

    Hodnoty X

    Hodnota Y 1

    0,7

    2,7 %

    1,8 %

    3,2

    2,6 %

    0,08

    nebo

    Hodnoty X

    0,7

    1,8 %

    2,6 %

    Hodnota Y 1

    2,7 %

    3,2

    0,08

  4. Pokud chcete změnit počet řádků nebo sloupců, které jsou součástí grafu, umístěte ukazatel myši do pravého dolního rohu vybraných dat a tažením vyberte další data. V následujícím příkladu je tabulka rozšířena tak, aby zahrnovala další kategorie a datové řady.

    Výběr dalších dat pro graf v Office

  5. Pokud chcete zobrazit výsledky změn, přepněte zpátky do Wordu nebo PowerPointu.

    Poznámka: Když zavřete wordový dokument nebo powerpointovou prezentaci, které obsahují graf, zavře se automaticky i excelová tabulka s daty grafu.

Po vytvoření grafu můžete změnit způsob, jakým se v grafu vykreslují řádky a sloupce tabulky.  Vaše první verze grafu může například vykreslovat řádky dat z tabulky na svislé ose grafu (hodnoty) a sloupce dat na vodorovné ose (kategorie). V následujícím příkladu graf zvýrazňuje prodeje podle nástroje.

Graf znázorňující prodej podle kategorií

Ale pokud chcete, aby graf zvýrazňoval prodeje po měsících, můžete změnit způsob, jakým se graf vykreslí.

Graf znázorňující prodej podle měsíců

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf.

  3. Na kartě Charts (Grafy) klikněte v části Data na Plot series by row (Vykreslit řady podle řádků) Řady podle řádku nebo Plot series by column (Vykreslit řady podle sloupců) Řady podle sloupce .

    Karta Grafy, skupina Data

    Pokud přepínač vykreslování není k dispozici

    Přepínač vykreslování je k dispozici pouze pro určité typy grafů a pouze pokud je excelová tabulka dat v grafu otevřená.

    1. Klikněte na graf.

    2. Na kartě Charts (Grafy) v části Data klikněte na šipku vedle možnosti Edit (Upravit) a poté na příkaz Edit Data in Excel (Upravit data v Excelu). Karta Grafy, skupina Data

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf.

  3. Na Kartě Charts v části Chart Quick Layouts (Rychlé rozložení grafu) klikněte na požadované rozložení.

    Karta Grafy, skupina Graf – rychlé rozložení

    Pokud chcete zobrazit další rozložení, přejděte na rozložení a potom klikněte na Šipka Více .

    Pokud chcete okamžitě vrátit zpět rychlé rozložení, které jste použili, stiskněte PŘÍKAZ + Z.

Styly grafu představují sadu doplňkových barev a efektů, které můžete použít pro graf. Když vyberete styl grafu, provedené změny se projeví v celém grafu.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf.

  3. Na kartě Charts v části Chart Styles (Styly grafu) klikněte na požadovaný styl.

    Karta Grafy, skupina Styly grafů

    Pokud chcete zobrazit více stylů, najeďte myší na styl a potom klikněte na Šipka Více .

    Pokud chcete okamžitě vrátit zpět styl, který jste použili, stiskněte klávesy PŘÍKAZ +Z.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf a potom na kartu Chart Layout (Rozložení grafu).

  3. V části Labels (Popisky) klikněte na Chart Title (Název grafu) a klikněte na to, co potřebujete.

    Karta Rozložení grafu, skupina Popisky

  4. Vyberte text v poli Chart Title a zadejte název grafu.

Viz také

Aktualizace dat v existujícím grafu

Typy grafů

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení na fóru Excel User Voice.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×