Vytvoření diagramu ve Vizualizéru dat

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Chcete automaticky vytvořit podrobný propracovaný vývojový diagram Visia z excelového sešitu? Můžete to udělat pomocí šablon Vizualizéru dat. Každá šablona má přidružený excelový sešit, který se použije k převodu dat procesu do vývojového diagramu Visia. Můžete také použít vlastní excelovou šablonu, určit mapování dat Excelu na obrazce v průvodci vytvořením diagramu z dat a automaticky vytvořit diagram. V Excelu můžete dokonce přidat další sloupce dat, které se převedou na vlastnosti obrazce Visia.

Visio podporuje také obousměrnou synchronizaci mezi diagramem Visia a excelovým sešitem. Je možné nejenom vytvářet vývojový diagram pomocí úprav dat v Excelu a aktualizací diagramu z Visia, ale i provádět změny v diagramu Visia a potom jimi aktualizovat excelová data. 

Přehled Vizualizéru dat

Šablony Vizualizéru dat můžete použít jenom ve Visiu Online – plán 2 v kanálu pro aktuální verze. Pokud nevíte, jakou verzi Visia používáte, vyberte Soubor > Účet > O produktu Visio. Další informace o verzi předplatného Visia najdete v tématu s názvem Visio Online – plán 2.

Pokud šablony Vizualizéru dat nevidíte nebo máte další otázky k tomu, jak začít, navštivte stránku Časté otázky k Vizualizéru dat.

Poznámka: Pokud ji chcete používat, musíte mít předplatné Office 365. Pokud máte předplatné Office 365, zkontrolujte si, jestli máte nejnovější verzi Office. Pokud jste odborník na IT, který zodpovídá za proces aktualizace Office 365, podívejte se na stránku vydaných verzí v kanálech aktualizací, kde zjistíte, jaké aktualizace jsou v jednotlivých kanálech poskytované.

V tomto článku

Vytvoření diagramu ve Vizualizéru dat

Než začnete

Shromážděte své nápady a zpracujte je jako koncept na papíře nebo ve formě rukopisu. Tento hrubý nástin vám pomůže rychle začít a usnadní vám i následující kroky.

Při vytváření diagramu ve Vizualizéru dat můžete pracovat současně v Excelu a Visiu. Na zařízení s Windows nebo v prostředí s více monitory pro vás možná bude výhodnější pracovat ve dvou oknech. Vizuálně si porovnávejte svou práci v Excelu a Visiu, abyste si ověřili, že postupujte správně.

Doporučeno:    Prohlédněte si toto praktické video pro Microsoft Office: Vizualizér dat: Ukázka.

1. fáze: Výběr šablony Vizualizéru dat

  1. Spusťte aplikaci Visio, případně – pokud upravujete diagram – vyberte Soubor > Nový.

  2. Vyberte ŠABLONY.

    Příkaz ŠABLONY
  3. Vyberte Vývojový diagram.

    Příkaz Vývojový diagram
  4. Vyberte základního vývojového diagramu - Visualizer dat, Vývojový diagram křížového procesu - Visualizer dat nebo diagramu auditu - Data Visualizer.

    Šablony Vizualizéru dat

    V šabloně Vizualizéru dat se v levém horním rohu nachází ikona Excelu.

Další informace o vývojových diagramech a používaných obrazcích najdete v tématech Vytvoření základního vývojového diagramu a Vytvoření vývojového diagramu křížového procesu.

2. fáze: Vytvoření excelového sešitu

  1. V náhledu šablony vyberte Šablona excelových dat.

    Výběr odkazu na šablonu dat v Excelu

    Poznámka:    Pokud budete chtít k referenčním účelům používat stejné ukázkové excelové šablony, které jsou použité v tomto článku, můžete si je stáhnout z těchto odkazů:

  2. Vyberte Soubor > Uložit zadejte umístění v počítači, na síťovém serveru nebo v knihovně dokumentů SharePointu, zadejte název souboru a vyberte Uložit.

  3. Pokud chcete přidat nový list, vyberte dole v sešitu Nový list Tlačítko Nový list .

  4. Vytvořte excelovou tabulku. Další informace o používání excelových tabulek najdete v tématu Přehled excelových tabulek, Vytvoření nebo odstranění excelové tabulky a Změna velikosti tabulky přidáním nebo odebráním řádků a sloupců.

  5. Přidejte do tabulky sloupce a řádky, které se použijí k vytvoření diagramu Visia. Pro záhlaví a hodnoty sloupců excelové tabulky platí specifické požadavky. Jako vizuální vodítko můžete použít informace v části Interakce excelových sloupců se součástmi vývojového diagramu Visia.

3. fáze: Přidání dalších vlastností obrazce do excelové tabulky (volitelné)

  1. V excelové šabloně si prohlédněte kartu Mapa procesu. Sloupce v excelové tabulce mají modrou a zelenou barvu. Barva slouží jako vizuální vodítko pro rozlišení sloupců.

    Modré sloupce se používají k vytvoření vývojového diagramu ve Visiu. Všechny sloupce jsou také přidané jako data obrazce.

  2. Pokud chcete přidat další data obrazce, přidejte do excelové tabulky jeden nebo více sloupců.

    Zelené sloupce označují další data obrazce, které můžete každému obrazci přidat. Přidat můžete libovolný počet dalších sloupců. Ve výchozím nastavení se tato data v diagramu nezobrazují, pokud nepřidáte datové symboly. Pokud chcete data obrazce zobrazit v diagramu Visia, vyberte Data > Okno dat obrazce. Další informace o datech obrazce a datových symbolech najdete v tématech Přidání dat do obrazců a Datové symboly – přehled.

4. fáze: Použití průvodce k vytvoření diagramu Visia

  1. Vraťte se zpátky do Visia. V náhledu šablony vyberte měrnou jednotku a pak vyberte Vytvořit.

  2. Na první stránce průvodce Vytvořit diagram z dat postupujte takto:

    1. V části Jaký diagram chcete z dat vytvořit si vyberte šablonu: Základní vývojový diagram, Vývojový diagram křížového procesu (vodorovný) nebo Vývojový diagram křížového procesu (svislý).

    2. V části Vybrat excelový sešit vyberte sešit ze seznamu nedávno použitých sešitů nebo vyberte Procházet a najděte sešit vytvořený ve 2. fázi.

    3. V části Vyberte tabulku nebo vlastní oblast v sešitu vyberte excelovou tabulku se zpracovávanými daty.

    4. Vyberte Dokončit. Tím potvrdíte všechny výchozí hodnoty, které Visio doplní do všech dalších stránek průvodce.

Výsledkem je, že se v kontejneru automaticky vytvoří diagram. Podle velikosti vývojového diagramu se do Visia přidají další stránky.

5. fáze: Uložení diagramu Visia

  • Vyberte Soubor > Uložit, najděte místo, zadejte název souboru a vyberte Uložit.

Doporučujeme uchovávat soubory Excelu a Visia na stejném místě, protože fungují společně.

6. fáze: Synchronizace dat a diagramu

Po vytvoření diagramu Vizualizérem dat ho možná budete chtít změnit. Visio podporuje obousměrnou synchronizaci mezi zdrojovými daty a diagramem.

Tip:    Po dokončení práce udržujte oba soubory synchronizované a aktuální. Když změníte excelová data, aktualizujte diagram. Když změníte obsah diagramu, aktualizujte excelová data.

Změny dat v Excelu a následná aktualizace diagramu

  1. Změňte zdrojová data v excelové tabulce. Přidejte řádky, aktualizujte je nebo je odstraňte.

  2. Uložte excelový sešit.

  3. Ve Visiu klikněte na kontejner diagramu, aby se na pásu karet zobrazila karta Datové nástroje – Návrh, a pak vyberte Aktualizovat diagram.

Výsledkem je, že změny provedené v excelovém sešitu se zobrazí v diagramu Visia. Upozornění:

  • Pokud jste v diagramu provedli změny, které by se mohly po aktualizaci ztratit, Visio zobrazí dialogové okno Aktualizovat diagram – konflikt.

  • Aktualizace změní jenom obrazce a spojnice, které jsou v kontejneru.

  • Všechny změny formátování obrazců a spojnic zůstanou zachované.

  • Proto v kontejneru udržujte všechny obrazce a spojnice diagramu. Ostatních objektů na stránce, které v kontejneru nejsou, se změna nedotkne. Další informace o kontejnerech najdete v tématu Zpřehlednění struktury diagramů pomocí kontejnerů a seznamů.

Změny obsahu v diagramu a následná aktualizace dat v Excelu

  1. Změňte diagram Visia. Přidejte obrazce a spojnice, aktualizujte je nebo je odstraňte.

  2. Pokud se excelový sešit nachází v desktopovém počítači nebo na síťovém souborovém serveru, zkontrolujte, jestli se uložil a zavřel.

  3. Klikněte na kontejner diagramu, aby se na pásu karet zobrazila karta Datové nástroje – Návrh, a pak vyberte Aktualizovat zdroj dat.

Výsledkem je, že změny provedené v diagramu Visia se aktualizují v excelovém sešitu. Pokud by v Excelu mohlo dojít ke ztrátě dat, Visio zobrazí dialogové okno Aktualizovat zdroj dat – konflikt. Problémům se dá předejít tak, že budete dodržovat následující doporučené postupy:

  • Před přepsáním změn si uložte záložní kopii excelových dat.

  • V excelovém sešitu používejte jako zdroj dat excelovou tabulku, nikoli vlastní oblast. Když v dialogovém okně Aktualizovat zdroj dat vyberete možnost Přepsat, Visio převede vlastní oblast na excelovou tabulku.

  • Ve zdrojových datech Excelu nepoužívejte vzorce. Když v dialogovém okně Aktualizovat zdroj dat vyberete možnost Přepsat, Visio převede vzorec na výsledek vzorce.

  • V průvodci vytvořením diagramu z dat, ve kterém se sloupce dat mapují na funkce a fáze, jste vytvořili diagram pomocí následující možnosti: Mapování > Další možnosti > Zachovejte pořadí hodnot sloupců z dat pro vytvoření > Vybrat funkci nebo plaveckou dráhu nebo Vybrat fázi nebo časovou osu. V tomto případě Visio vyžaduje další sloupec dat, který bude obsahovat propojení mezi obrazci. Když v dialogovém okně Aktualizovat zdroj dat vyberete možnost Přepsat, přidá se další sloupec.

  • Vytvořili jste vývojový diagram křížového procesu s plaveckými dráhami a fázemi založenými na pořadí hodnot dat v Excelu. V průvodci vytvořením diagramu z dat, ve kterém se sloupce dat propojují s kroky procesu a aktivitami, jste vytvořili diagram pomocí následující možnosti: Mapování > Určete, jak připojit kroky procesu nebo aktivity > Propojit sekvenčně. V tomto případě Visio vyžaduje další sloupec dat, který bude obsahovat propojení mezi obrazci. Pokud v diagramu změníte pořadí plaveckých drah nebo fází, změní se i pořadí ve zdroji dat. Když v dialogovém okně Aktualizovat zdroj dat vyberete možnost Přepsat, plavecké dráhy a fáze v diagramu už nebudou mít stejné pořadí jako data v excelovém sešitu.

7. fáze: Přizpůsobení interakce mezi excelovou tabulkou a diagramem Visia (volitelné)

Někdy můžete chtít vytváření diagramů ve Vizualizéru dat přizpůsobit. Můžete chtít použít jiné obrazce, které odpovídají normám organizace, nebo můžete chtít v excelové tabulce namapovat jiné názvy sloupců.

  1. Když vyberete Vytvořit, otevře se průvodce Vytvořit diagram z dat. Zadejte hodnoty na první stránce (viz 4. fáze). Výběrem možností Další nebo Zpět zobrazíte všechny stránky průvodce.

  2. Pokud potřebujete další informace o přizpůsobení všech možností na stránce, vyberte Nápověda (?). Další informace najdete v tématu Použití průvodce k vytvoření diagramu z dat.

Začátek stránky

Interakce excelových sloupců se součástmi vývojového diagramu Visia

Následující obrázek názorně ukazuje, jak se jednotlivé excelové sloupce používají k vytvoření vývojového diagramu Visia.

ID kroku procesu:   Číslo, které identifikuje každý obrazec vývojového diagramu. Tento sloupec je povinný. Každá hodnota v excelové tabulce musí být jedinečná a nesmí být prázdná. Tato hodnota se ve vývojovém diagramu nezobrazuje.

Spolupráce excelové mapy procesu s vývojovým diagramem Visia: ID kroku procesu

Popis kroku procesu:   Text přidaný do každého obrazce vývojového diagramu

Spolupráce excelové mapy procesu s vývojovým diagramem Visia: Popis kroku procesu

ID dalšího kroku:   ID kroku procesu, který je další v pořadí. Obrazec větvení má dva další kroky, které jsou označené čísly oddělenými čárkou (třeba 4,5). Dalších kroků může být více než dva.

Spolupráce excelové mapy procesu s vývojovým diagramem Visia: ID dalšího kroku

Popisek spojnice:   U obrazců větvení jsou popisky spojnic označené textem odděleným čárkou, například Ano, Ne. V uvedeném příkladu hodnota 4 znamená ano a 5 znamená ne.

Spolupráce excelové mapy procesu s vývojovým diagramem Visia: Popisek spojnice

Typ obrazce:   Typ obrazce, který chcete použít v diagramu Visia, třeba Proces nebo Rozhodnutí. Microsoft doporučuje používat k ověření výběru rozevírací seznamy.

Spolupráce excelové mapy procesu s vývojovým diagramem Visia: Typ obrazce

Funkce a fáze:   Funkce (neboli plavecká dráha) a fáze (neboli časová osa), ke které každý obrazec patří. Tento sloupec se používá jen u vývojových diagramů křížového procesu. Základní vývojový diagram ho ignoruje.

Spolupráce excelové mapy procesu s vývojovým diagramem Visia: Funkce a fáze

Začátek stránky

Vytváření diagramů ve Vizualizéru dat s využitím dalších vzorníků

Kromě použití šablony Visualizer dat, můžete také vzorníky z jiných šablon při vytváření diagramu Data Visualizer. Například vytváření diagramů procesů pro finanční transakce nebo Správa zásob. Existují jiné vzorníky procesů, včetně šablon BPMN základní a práce plovoucích objektů. Můžete dokonce přidat vlastní obrazců pomocí vzorníku Moje obrazce. Další informace najdete v tématu Vytvoření, uložení a sdílení vlastních vzorníků.

  1. Otevřete diagram Vizualizéru dat (základní vývojový diagram nebo vývojový diagram křížového procesu), který jste už vytvořili.

  2. Vyberte Vytvořit, aby se otevřel průvodce Vytvořit diagram z dat. Zadejte hodnoty na první stránce a pomocí tlačítka Další přejděte v průvodci na stránku Mapování obrazců.

  3. Přidejte jeden nebo více vzorníků pomocí možnosti Další obrazce.

  4. Vyberte libovolný obrazec a přetažením ho namapujte na hodnoty dat ve sloupci Typ obrazce.

Začátek stránky

Použití datových symbolů v diagramu

Diagram můžete vylepšit přidáním datových symbolů, které umožňují vizualizovat data obrazců v diagramu. Ve výsledku můžete diagram změnit na řídicí panel procesu, ve kterém datové symboly na základě dat obrazců zobrazují informace o klíčových ukazatelích výkonu pomocí ikon datových symbolů.

  1. Otevřete diagram Vizualizéru dat.

    Vyberte kontejner, ve kterém chcete použít datové symboly.

  2. Vyberte Data > Pole datových symbolů.

  3. Vyberte pole datových symbolů, která chcete přidat do diagramu.

    Použití datových symbolů pro diagram Vizualizéru dat

    Datové symboly se použijí na celý diagram. Pokud chcete datové symboly u určitých obrazců skrýt, nechte v excelovém sešitu hodnoty sloupců dat pro tyto řádky prázdné.

  4. Pokud chcete, můžete na kartě Data nastavit další možnosti. Další informace najdete v tématu Datové symboly – přehled.

Začátek stránky

Další kroky

Tady je několik úkolů, které možná budete chtít udělat po vytvoření diagramu ve Vizualizéru dat.

  • Motivy:    Motiv je ve Visiu sada barev a efektů, které můžete ve výkresu použít jedním kliknutím myši. Motivy představují rychlý způsob, jak dosáhnout profesionálního vzhledu výkresů. Další informace najdete v tématu Dosažení profesionálního vzhledu výkresů pomocí motivů.

  • Rozložení:    Visio má manuální vodítka a automatické nástroje, které pomáhají správně zarovnat a rozmístit obrazce diagramu. Díky nim bude váš výkres maximálně přehledný a uspořádaný. Další informace najdete v tématu Zarovnání a umístění obrazců v diagramu.

  • Export:    Diagram Vizualizéru dat a přidružený excelový sešit můžete exportovat do balíčku šablony Visia (.vtpx). Do balíčku šablony Visia se uloží nastavení diagramu, vzorníky a data, takže je ostatní můžou použít jako výchozí bod, který jim zjednoduší vytvoření vlastního diagramu Vizualizéru dat. Balíček šablony si ostatní uživatelé můžou nainstalovat do počítače. Další informace najdete v článku Export a instalace balíčku šablony funkce Vizualizér dat.

Začátek stránky

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×