Vytvoření řešení sledování majetku pomocí aplikace InfoPath a aplikace Excel

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Microsoft Office InfoPath umožňuje vytvářet šablony formuláře pro zadávání dat a kolekce. Microsoft Office Excel 2007 umožňuje uživatelům bylo možné vypočítat, graf a analyzovat data. Pomocí těchto aplikacích i XML můžete snadno vytvořit jednoduchý ale efektivní, bez použití kódu obchodního řešení pro sledování majetku ve firmě.

overview of solution to track assets

V tomto článku

Úvod do vytváření řešení pro sledování majetku

Krok 1: Přizpůsobení šablony formuláře sledování majetku

Krok 2: Mapování souboru schématu a přizpůsobení rozložení tabulky v Excelu

Krok 3: Vytvoření souhrnné sestavy kontingenčních tabulek a grafů

Krok 4: Mohli uživatelé přidávat informace o majetku

Krok 5: Import formuláře do aplikace Excel

Konečný myšlenky: Zvažte použití Accessové databáze nebo seznam SharePoint

Úvod do vytváření řešení pro sledování majetku

Si můžete vyměňovat XML dat mezi aplikací InfoPath a aplikace Excel. Příkaz aplikace Infopath Exportovat je jednoduché, sice jednoduchých až odesílání dat formuláře do aplikace Excel, je další možností, kterými můžete udělit mnohem větší flexibilitu. Explicitně mapování souboru schématu XML aplikace InfoPath (.xsd) v aplikaci Excel a pak importováním soubory formuláře aplikace InfoPath (.xml) do aplikace Excel můžete přizpůsobit rozložení dat a lépe využívat funkce aplikace Excel vám usnadní správu a analýza dat mnohem efektivněji.

V tomto článku používáme formuláře Ukázková šablona sledování majetku aplikace InfoPath znázorňující, jak je, aby aplikace InfoPath, XML a aplikace Excel spolupracují. Představte si, že každý rok organizaci zásoby prostředky v jednotlivých zaměstnancích office. Excelové sestavy je spusťte se můžete rozhodnout, jak přidělit rozpočtu zařízení pro následujícím roce. Následující diagram se dozvíte, jak můžete shromažďovat, sledovat a vykazování dat majetku ve vašem oddělení.

a

1. na šablonu formuláře sledování majetku je vytvořen.

2. souboru schématu je namapované tabulce aplikace Excel a přizpůsobit rozložení tabulky.

3. prázdné kontingenčních tabulek a souhrnné sestavy se vytvoří.

4. sledování majetku formulář slouží k shromáždit data od uživatele.

5. všechna data formuláře exportovat do tabulky aplikace Excel a aktualizovat sestavy kontingenčních tabulek a grafů.

Toto řešení zahrnuje následující role uživatelů a produkty:

Ikona úplné podpory = požadované Ikona nepodporování = není potřeba

Požadavky na software

Role

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Návrhář řešení

Ikona úplné podpory

Ikona úplné podpory

Ikona úplné podpory

Uvědomělému vztahu

Ikona úplné podpory

Ikona úplné podpory

Ikona úplné podpory

Zaměstnanci

Ikona úplné podpory

Ikona úplné podpory

Ikona nepodporování

Začátek stránky

Krok 1: Přizpůsobení šablony formuláře sledování majetku

Šablona sledování majetku formuláře, která je součástí aplikace InfoPath, umožňuje shromáždit informace o jednotlivých materiálů v office pro zaměstnance, oddělení, které patří zaměstnance, kategorie prostředky a podrobnosti každé materiálů. V tomto řešení odešle návrhu formuláře v šabloně formuláře rozhodnutí – maker e-mailového účtu pomocí Office Outlook 2007.

the asset tracker template

Úkol 1: Otevřete a přizpůsobení šablony formuláře sledování majetku

Protože nelze publikovat šablony formuláře do seznamu příjemců e-mailu, pokud je nějaký text ve formátu RTF ovládacího prvku typu pole obsahující odkazy na obrázky, budete muset změnit malé formuláři sledování majetku ukázkové šablony.

  1. V nabídce soubor klikněte na Návrh šablony formuláře.

  2. V dialogovém okně Navrhnout šablonu formuláře v části otevření šablony formuláře, klikněte na Přizpůsobit výběru.

  3. V dialogovém okně Začínáme klikněte na vzorek - sledování majetku a v části Formuláře úkolů, klikněte na Navrhnout tento formulář.

  4. Klikněte pravým tlačítkem myši na ovládací prvek assetNotes, přejděte na příkaz Vlastnosti Pole s formátovaným textem, klikněte na kartu zobrazení a potom v části Dostupné formátování, zrušte zaškrtnutí políčka Propojené obrázky.

Úkol 2: Definujte možnosti Odeslat

Dalším úkolem je definujte možnosti odesílání, aby se zaměstnanci můžete odeslat soubor jedinečně pojmenované formuláře (.xml) rozhodnutí – maker e-mailový účet jako připojený soubor.

  1. V nabídce Nástroje klikněte na Možnosti odeslání.

  2. V dialogovém okně Možnosti odeslání zaškrtněte políčko Povolit uživatelům odeslat tento formulář.

  3. Klikněte na odesílání dat formuláře do jednoho umístění a potom v seznamu, klikněte na e-mailu.

  4. Klikněte na Přidat.

    Zobrazí se Průvodce datovým připojením.

  5. Do pole Komu zadejte alias uvědomělému vztahu, který se zobrazí všem formulářům odeslané.

  6. Určení jedinečné předmět, do pole Předmět napište:

    • Klikněte na Vložit vzorec Obrázek tlačítka .

    • Zadejte následující vzorec:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Klikněte na Ověřit vzorec a potom dvakrát klikněte na OK.

  • V dialogovém okně Úvod zadejte příslušnou zprávu nebo přidat důležité pokyny pro toto řešení.

  • Klikněte na tlačítko Další.

  • Na další stránce průvodce klikněte na odesílání dat formuláře jako přílohu a pak zaškrtněte políčko Připojit šablony formuláře zajistit, aby uživatelé mohli otevřít formulář.

    Díky tomu, že zaměstnanců mít taky přístup k souboru šablony formuláře (s příponou XSN) v případě, že němu nemají přístup z jeho umístění v síti.

  • Chcete-li zadat jedinečný název souboru pro každý soubor formuláře (.xml) do pole Název přílohy:

    1. Klikněte na Vložit vzorec Obrázek tlačítka .

    2. Ve vzorci jako na řádek Předmět napište

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Klikněte na Ověřit vzorec a potom dvakrát klikněte na OK.

  • Klikněte na tlačítko Další.

  • Datové připojení pro odesílání na další stránce průvodce, do pole Zadejte název tohoto datového připojení zadejte popisný název pro tento.

  • Zkontrolujte, že správné informace v části Souhrn a potom klikněte na Dokončit.

  • Uložte formulář ji do složky veřejné sítě přístupných osobám s postižením uvědomělému vztahu a pro všechny zaměstnance.

Začátek stránky

Krok 2: Mapování souboru schématu a přizpůsobení rozložení tabulky v Excelu

Nastavení připojení mezi aplikací InfoPath a Excel vyžaduje tři úlohy: extrahování souboru schématu pro šablonu formuláře sledování majetku mapování tento soubor schématu v aplikaci Excel a přizpůsobení výchozí rozložení obsahující importovaného souboru XML tabulky aplikace Excel Formulář datové soubory.

Úkol 1: Extrahování souboru schématu z aplikace InfoPath

  1. V aplikaci InfoPath otevřete soubor šablony formuláře sledování majetku.

  2. V nabídce Nástroje klikněte na Navrhnout tento formulář.

  3. V nabídce soubor klikněte na Uložit jako zdrojové soubory.

  4. V dialogovém okně vyhledejte složku vyberte složku nebo vytvořte novou složku, kam chcete ukládat souboru schématu.

Poznámka: umístění složky, kde jsou uloženy všechny soubory, zdroje a název souboru schématu, v tomto případě myschema.xsd, která obsahuje definice schématu XML dat ve formuláři.

Úkol 2: Mapování souboru schématu aplikace InfoPath v aplikaci Excel

  1. Vytvoření nového souboru aplikace Excel a pak uložte do umístění přístupné pro uvědomělému vztahu.

  2. V aplikaci Excel Pokud není karta Vývojář viditelná, postupujte takto:

    1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a pak na Možnosti aplikace Excel.

    2. V kategorii Oblíbené v části Nejpoužívanější možnosti při práci s aplikací Excel zaškrtněte políčko Zobrazit kartu Vývojář na pásu karet a potom klikněte na OK.

      Poznámka: Pás karet je součástí Fluent systému Microsoft Office.

  3. Na kartě Vývojář klikněte ve skupině XML na Zdroj.

    Skupina XML na pásu karet

    Zobrazí se podokno úloh Zdroj XML.

  4. Klikněte na Mapování XML a potom v dialogovém okně Mapování XML, klikněte na Přidat.

  5. Na počítači se systémem Windows Vista   

    1. Na panelu Adresa klikněte na disku nebo složku, která obsahuje myschema.xsd soubor, který jste vytvořili v kroku 2 části úkol 1: extrahování souboru schématu z aplikace InfoPath.

      Na počítači se systémem Microsoft Windows XP   

    2. V seznamu Oblast hledání klikněte na disku nebo složku, která obsahuje myschema.xsd soubor, který jste vytvořili v kroku 2 části úkol 1: extrahování souboru schématu z aplikace InfoPath.

  6. Klikněte na soubor a potom na Otevřít.

  7. Pokud se zobrazí dialogové okno Více odmocniny, klikněte na uzel kořenové assetTracking, která je definovaná v souboru myschema.xsd a klikněte na OK.

    Mapování XML se zobrazí v podokně úloh Zdroj XML.

  8. Element uzel ns1:asset, což je opakující se element XML, přetáhněte do místa na listu místo, kam chcete tabulku aplikace Excel a zobrazit.

    mapping the inopath schema file into excel

Krok 3: Přizpůsobení rozložení Tabulka aplikace Excel

Ve výchozím nastavení Excel použije názvy elementů XML jako záhlaví sloupců tabulky. Záhlaví sloupců však můžete změnit úpravou buněk záhlaví sloupce.

  1. Chcete-li změnit výchozí záhlaví sloupců, zachovat umístění tabulky aplikace Excel vybraná, najděte následující předpony řetězec ns1:asset a odeberte ho. Například změníte ns1:assetIDID.

    customizing the excel table headers

  2. Přizpůsobit šířku sloupce, klikněte na tlačítko Vybrat vše a potom poklikejte na libovolné ohraničení záhlaví sloupce.

Začátek stránky

Krok 3: Vytvoření souhrnné sestavy kontingenčních tabulek a grafů

Politiky pomocí kontingenční tabulky a sestavy kontingenčního grafu na analyzovat, prozkoumávání a vizualizaci souhrnných dat. Pomocí nastavení v sestavách kontingenčních tabulek a grafů, které chcete použít v tomto scénáři předem, bude jednoduché operace pro uvědomělému vztahu ke spuštění sestavy s údaji dokončený později.

  1. Vyberte buňku v tabulce aplikace Excel.

  2. Na kartě Vložení ve skupině tabulky klikněte na kontingenční tabulka a potom klikněte na kontingenční tabulka.

    Vzhled pásu karet aplikace Excel

    Excel zobrazí dialogové okno Vytvořit kontingenční tabulku.

  3. Když Pokud chcete dát sestavu kontingenční tabulky do nového listu počínaje buňkou A1, klikněte na Nový list a klikněte na OK.

    Excel do zadaného umístění přidá prázdnou sestavu kontingenční tabulky a zobrazí Seznam polí kontingenční tabulky, takže můžete přidat pole, vytvářet v ní rozložení a přizpůsobit sestavu kontingenční tabulky.

  4. Pokud chcete vytvořit více tabulkovou sestavu data, přetáhněte pole ID do oblasti hodnoty, oddělení pole do oblasti popisky sloupců, pole kategorie do oblasti popisky řádků a pole přiřazeno do oblasti filtru sestavy.

  5. Klikněte na sestavu kontingenční tabulky.

  6. Na kartě Vložení ve skupině grafy klikněte na typ grafu panelu.

    Vzhled pásu karet aplikace Excel

  7. V části 2D panelu vyberte Skupinový pruhový.

  8. Upravte velikost a umístění sestavy kontingenčního grafu, který své preference.

the blank pivottable and pivotchart reports

Začátek stránky

Krok 4: Mohli uživatelé přidávat informace o majetku

Nyní je, že na šablonu formuláře chtít vyplňovat všech zaměstnanců, budete muset publikovat formuláře a jeho odeslání do každého zaměstnance. Po dokončení formulář odešle všechny zaměstnance, se pošle jako datového souboru XML (.xml) připojené e-mailové zprávy rozhodnutí – maker e-mailový účet. Uvědomělému vztahu můžete přesuňte všechny zprávy vyhrazené složky aplikace InfoPath v aplikaci Outlook. V tomto scénáři je vhodné přiřazení určitého časového období pro všechny uživatele, aby udělali formuláře tak, aby uvědomělému vztahu sestavu s vyplněné formuláře dosáhne shromažďování dat konečného termínu.

entering data in the asset tracker forms

  1. V aplikaci InfoPath, otevřete šablony formuláře (s příponou XSN), který jste si uložili v Krok 1: návrh šablony formuláře ukázkové sledování majetku

  2. V nabídce Nástroje klikněte na Navrhnout tento formulář.

  3. V nabídce soubor klikněte na Publikovat.

  4. V Průvodci publikování klikněte na seznam příjemců e-mailu a klikněte na tlačítko Další.

  5. Na další stránce průvodce, do pole název šablony formuláře zadejte název šablony formuláře a potom na tlačítko Další. Název šablony formuláře se zobrazí v poli Předmět nadpis zprávy, která se pošle příjemci e-mailové zprávy.

  6. V případě potřeby na další stránce Průvodce vytvořením sloupců, které se objeví ve vaší Outlookové k uspořádání e-mailové zprávy.

  7. Klikněte na tlačítko Další.

  8. Klikněte na Publikovat.

  9. Po ukončení Průvodce publikováním publikování šablony formuláře, otevře se e-mailovou zprávu s formulářem.

  10. Vyplňte zprávy, zadejte jména zaměstnanců nebo použít distribučního seznamu a odešlete zprávu.

V aplikaci Outlook můžete uspořádat uvědomělému vztahu všech odeslaných formulářů XML jedním ze dvou způsobů:

  • Pokud složky formulářů aplikace InfoPath objeví zpráva první zprávu otevře, klikněte na Vytvořit složku formuláře.

  • Vytvoření pravidla v Outlooku všechny související formuláře aplikace InfoPath, přejděte ke složce aplikace InfoPath.

    Další informace najdete v tématu Správa zpráv pomocí pravidel.

Začátek stránky

Krok 5: Import formuláře do aplikace Excel

Vzhledem k tomu, že jste již vytvořili Excelu sešit kroky 2 a 3, je jednoduché maker rozhodnutí exportovat a prohlížení dat formuláře. Rozhodnutí o maker jednoduše musí export soubory xml (.xml) z aplikace Outlook, importovat všechny soubory formuláře (.xml) do sešitu aplikace Excel a pak aktualizace dat.

Úkol 1: Exportujte formuláře z aplikace Outlook do složky Windows

  1. V aplikaci Outlook vyberte složku, která obsahuje všechny formulářů, které jste dostali od zaměstnanců a stiskněte kombinaci kláves CTRL + A vyberte všechny formuláře e-mailové zprávy.

  2. Klikněte pravým tlačítkem myši na výběr, přejděte na Akce aplikace InfoPath a potom klikněte na Exportovat formuláře.

  3. V dialogovém okně Exportovat formuláře vyberte složku a klikněte na tlačítko OK.

Úkol 2: Import formuláře do aplikace Excel

  1. V Excelovém sešitu, který jste vytvořili v Krok 2: mapování souboru schématu a přizpůsobení rozložení tabulky v Excelu, vyberte některou z mapovaných buněk v tabulce aplikace Excel.

  2. Na kartě Vývojář ve skupině XML na tlačítko importovat.

    Skupina XML na pásu karet

    Zobrazí se dialogové okno Importovat XML.

  3. Na počítači se systémem Windows Vista   

  4. Proveďte jednu z následujících akcí:

    • Pokud jsou souvislé soubory, stiskněte klávesu SHIFT a potom klikněte na první a poslední soubor v seznamu.

    • Pokud soubory, které nejsou souvislé, podržte stisknutou klávesu CTRL a potom klikněte na každý soubor, který chcete importovat v seznamu.

  5. Klikněte na Importovat.

    excel table of imported data

Ve výchozím nastavení Excel databáze přepíše existujících dat v mapovaných buňkách, což je požadovaný konečný výsledek pro tento obchodního řešení. Však uvědomělému vztahu, například naimportovat data několikrát ke sledování průběhu před plánované lhůty můžete použít.

Poznámka: V aplikaci Excel, můžete rovněž přidat data pomocí možnosti Připojit nová data k existujícím tabulkám XML (na kartě Vývojář ve skupině XML na tlačítko Vlastnosti mapy ), který může být vhodné další řešení.

Další informace najdete v tématu Import XML dat.

Krok 3: Aktualizace kontingenční tabulky a sestavy kontingenčního grafu

  • Klikněte na buňku v kontingenční tabulce.

  • Na kartě Možnosti ve skupině Data klikněte na šipku vedle Aktualizovat vše a potom klikněte na Aktualizovat.

    Pás karet v aplikaci Outlook

final pivottable and pivotchart report

Sešit aplikace Excel teď jsou všechna data a souhrnné sestavy, budete muset vám přidělit rozpočtu zařízení pro následujícím roce. Samozřejmě můžete dělat další analýza v sešitu aplikace Excel v případě potřeby, třeba řazení, filtrování nebo podmíněné formátování data.

Začátek stránky

Konečný myšlenky: Zvažte použití Accessové databáze nebo seznam SharePoint

Jako alternativu zvažte možnost Sharepointového seznamu nebo databázi, místo XML, přenášet data mezi aplikací InfoPath a aplikace Excel.

Použití seznamu služby SharePoint

Z aplikace InfoPath můžete snadno použijete seznam služby SharePoint jako zdroje dat jen pro čtení. Můžete udělat jednu z těchto akcí:

  • Ze seznamu služby SharePoint exportujte dat do aplikace Excel automaticky vytvoří datového připojení v Excelu.

  • Z Excelu explicitně připojení dat k seznamu služby SharePoint.

Po vytvoření datového připojení můžete aktualizovat data v Excelu k načtení aktuální data.

Seznam služby SharePoint slouží k přidání a aktualizace dat, pomocí formuláře aplikace InfoPath zobrazíte položky ze seznamu (například složité nebo dlouhý položce nejlepší zobrazí ve svislém směru) a potom dál analyzovat data v aplikaci Excel.

combining infopath, a sharepoint list, and excel

1. zobrazení jedné položky pro snadné revize v aplikaci InfoPath.

2. Přidání a aktualizace dat v seznamu služby SharePoint.

3. aktualizace a informujte aktuální s Excelem.

Další informace najdete v tématu Přidání datového připojení k seznamu nebo knihovny dokumentů služby SharePoint

Použití Accessové databáze

Z aplikace InfoPath můžete vytvořit pro čtení i zápis připojení k databázi Accessu. Z aplikace Excel můžete vytvořit explicitně datového připojení k databázi aplikace Access, kterou je možné aktualizovat aktuální data načíst. Můžete dokonce definovat připojení k automaticky aktualizovat při opětovném otevření sešitu nebo pravidelně aktualizovat, například každé 5 minut.

Použití Accessové databáze jako zprostředkovatel mezi aplikací InfoPath a aplikace Excel. Po odeslání formuláře aplikace InfoPath pro přístup k aktualizaci databáze aplikace Access. Pokud aktualizace datového připojení v Excelu aktualizovaná data načtete z aplikace Access. V podstatě jste odeslali dat nepřímo z aplikace InfoPath k Excelovému sešitu.

combining infopath, access, and excel

1. zobrazení a odeslání formuláře do databáze aplikace Access.

2. v databázi aplikace Access obsahují data.

3. aktualizace a informujte aktuální s Excelem.

Další informace najdete v tématu Navrhnout šablonu formuláře, který je založený na databáze aplikace Microsoft Access.

Tip: Věděli jste, že můžete vytvořit formulář aplikace InfoPath přímo z aplikace Access? Pokud vaši uživatelé mají Outlook 2007 nebo 2010 a aplikace InfoPath 2007 nebo 2010 na svém počítači nainstalovanou, můžete získat data z různých uživateli přímo z aplikace Access pomocí průvodce Shromáždit data z e-mailové zprávy. Další informace naleznete v tématu nápovědy přístup, Přidání dat shromážděných prostřednictvím e-mailů do databáze aplikace Access.

Začátek stránky

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×