Vytváření a úpravy souborů .csv pro import do Outlooku

Vytváření a úpravy souborů .csv pro import do Outlooku

Soubor CSV (Comma Separated Values) je zvláštní typ souboru, který můžete vytvořit nebo upravit v Excelu. Informace se v souborech CSV neukládají do sloupců, ale oddělují se čárkami. Pokud text a čísla uložíte do souboru CSV, můžete je snadno přenést z jedné aplikace do druhé. Do souboru CSV můžete třeba exportovat svoje kontakty z Googlu a pak je importovat do Outlooku.

Pokud chcete importovat seznam kalendářových položek do Outlooku, a nevíte jak, přečtěte si téma Import a export e-mailů, kontaktů a kalendáře Outlooku.

Vytvoření souboru .csv z jiného programu nebo jiným poskytovatelem e-mailu

Při exportu kontaktů z jiné aplikace, třeba z Gmailu, si většinou můžete vybrat z několika formátů. V Gmailu si můžete vybrat soubor Google CSV, Outlook CSV nebo vCards. Při exportu dat z jednoho outlookového profilu a jejich importu do jiného profilu můžete vybrat export do souboru s hodnotami oddělenými čárkami (.csv) nebo do datového souboru Outlooku (.pst).

Stažení a otevření ukázkového souboru .csv pro import kontaktů do Outlooku

Pokud soubor CSV s kontakty vytvořit ručně, můžete to udělat několika způsoby.

Vytvoření excelového souboru a jeho uložení do souboru CSV

Pokud máte informace o kontaktech v aplikaci, která neumožňuje jejich export, můžete je zadat ručně.

  1. Vytvořte v Excelu nový dokument.

  2. Pro každou zaznamenávanou informaci (třeba pro jméno, příjmení, e-mailovou adresu, telefonní číslo a narozeniny) přidejte nadpis sloupce a pak do příslušných sloupců zadejte informace.

  3. Až to budete mít, měl by excelový soubor vypadat zhruba takto:

    Takto vypadá ukázkový soubor .csv v Excelu.

  4. Vyberte Soubor > Uložit jako.

  5. V rozevírací nabídce vyberte CSV (textový soubor s oddělovači) (*.csv), pojmenujte soubor a vyberte Uložit.

    Uložení excelového souboru ve formátu CSV

  6. Teď můžete nový soubor CSV použít k importu kontaktů do Outlooku.

Stažení šablony souboru CSV

Pokud chcete začít prázdným souborem CSV, stáhněte si následující ukázkový soubor.

  1. Stáhněte si do počítače tento ukázkový soubor .csv. Po zobrazení výzvy zvolte možnost, že chcete soubor Uložit do počítače jako soubor CSV. Pokud ho uložíte jako excelový soubor (.xls nebo .xlsm), budou všechna data nacpaná do jednoho sloupce!

    Při stažení ukázkového souboru .csv si tento soubor uložte do počítače jako soubor typu .csv.

  2. Na počítači otevřete Excel.

  3. V Excelu přejděte na Soubor > Otevřít a přejděte k souboru .csv, který jste si právě stáhli do počítače. Abyste soubor .csv našli, hledejte Všechny soubory. Otevřete soubor .csv kliknutím na jeho název.

    Abyste soubor .csv našli, hledejte Všechny soubory.

Při práci s tímto ukázkovým souborem CSV pamatujte na několik věcí:

  • Outlook vyžaduje, aby záhlaví sloupců byla na prvním řádku. Proto je nenahrazujte jinými údaji.

    Takto vypadá ukázkový soubor .csv v Excelu.

  • Data v řádcích 2 až 6 (ukázková jména, telefonní čísla, e-mailové adresy a další položky) můžete odstranit.

  • Nemusíte zadávat hodnoty do všech sloupců. Zadejte jenom informace, které chcete.

  • Uložte soubor pod novým názvem jako soubor typu CSV (.csv). Pokud na souboru pracujete v Excelu a chcete ho uložit, Excel se vás několikrát zeptá, jestli ho chcete opravdu uložit ve formátu CSV. Vždycky zvolte Ano. Pokud zvolíte Ne, soubor se uloží v nativním formátu Excelu (.xlsx), ze kterého Outlook nedokáže importovat data.

  • Vyzkoušejte si import souboru CSV na několika kontaktech a zkontrolujte, jestli jste s výsledkem spokojeni. Potom můžete importované kontakty odstranit, přidat do souboru CSV další kontakty a soubor znovu importovat.

    Pokud jste importovali data z ukázkového souboru CSV, vypadalo by to v Outlooku na webu pro Office 365 takto:

    Po naimportování budou kontakty v Outlooku na webu vypadat takto.

Úprava souboru .csv s kontakty, které chcete importovat do Outlooku

Řekněme, že chcete upravit soubor .csv, který jste vyexportovali z Outlooku, a pak ho importovat zpátky do Outlooku nebo k jinému poskytovateli e-mailu. V Excelu můžete soubor .csv snadno upravit.

Při úpravách souboru .csv pamatujte na několik věcí:

  • V prvním řádku musí být záhlaví sloupců.

  • Při ukládání se vás Excel několikrát zeptá, jestli chcete opravdu soubor uložit ve formátu CSV. Pokaždé zvolte Ano. Pokud zvolíte Ne, soubor se uloží v nativním formátu Excelu (.xlsx), který nepůjde importovat do Outlooku.

Problém: Všechna data jsou v prvním sloupci

Příklad souboru .csv uloženého ve formátu .xls

Tady je několik možných příčin problému a navrhovaných postupů, jak ho můžete zkusit vyřešit.

  • Pokud soubor CSV uložíte v jiném formátu, třeba jako soubor .xls, .xlsx nebo .xlm, zobrazí se všechna data v prvním sloupci. Vraťte se k původnímu souboru CSV a uložte ho jako soubor typu .csv.

  • Je možné, že aplikace při vytváření souboru CSV umísťovala do dat nadbytečné uvozovky. Excel pak považuje data za jediný celek. Řekněme například, že data vypadají takto:

    a, b, c, d – Excel umístí každé písmeno do samostatného sloupce.

    "a, b, c, d", e – Excel umístí řetězec a, b, c, d do jednoho sloupce a písmeno e do dalšího sloupce.

    Abyste zjistili, jestli je problém v souboru, otevřete soubor v Poznámkovém bloku: Ve Windows klikněte pravým tlačítkem na soubor CSV a zvolte Otevřít v programu > Poznámkový blok. Hledejte nadbytečné uvozovky.

    Pokud najdete nadbytečné uvozovky, opravte soubor tímto postupem:

    1. Otevřete soubor CSV v Excelu. Všechna data budou ve sloupci A a uvozovky budou pryč.

    2. Teď použijte průvodce převodem textu do sloupců k rozdělení dat ve sloupci A do jednotlivých sloupců: Na pásu karet zvolte Data > Text do sloupců.

      Zvolte Data > Text do sloupců.

    3. Zvolte Oddělovač > Další. Pak zvolte Čárka > Dokončit.

    4. Uložte soubor jako soubor typu .csv, abyste ho mohli naimportovat do Outlooku.

Viz také

Import kontaktů do Outlooku

Export kontaktů z Outlooku

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×