Vyhodnocení vnořeného vzorce po jednotlivých krocích

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Vysvětlení, jak vnořené Vzorec počítá konečný výsledek je někdy složité protože mívají několik průběžných výpočtů logických testů. Pomocí dialogu Vyhodnocení vzorce různé části vnořeného vzorce vyhodnocené v pořadí, ve kterém vzorec počítá uvidíte. Například vzorec =když(průměr(F2:F5) > 50,SUM(G2:G5),0) je snadněji pochopitelný, když uvidíte následující intermediate výsledky:

Kroky zobrazené v dialogovém okně

Popis

=KDYŽ(PRŮMĚR(F2:F5)>50;SUMA(G2:G5);0)

Nejdřív se zobrazí vnořený vzorec. Funkce PRŮMĚR a SUMA jsou vnořené ve funkci KDYŽ.

=KDYŽ(40>50;SUMA(G2:G5);0)

F2: F5 oblast buněk s hodnotami 55, 35, 45 a 25 a výsledek funkce průměr(F2:F5) je vlastně 40.

=KDYŽ(Nepravda;SUMA(G2:G5);0)

40 není větší než 50, takže je výrazů v prvním argumentu funkce když (argumentu podmínka) NEPRAVDA.

0

Funkce když vrátí hodnotu argumentu třetího (argument ne). Funkce SUM není vyhodnocena, protože je druhým argumentem funkce když (argument PRAVDA) a je vrácena jenom při splnění výraz.

  1. Vyberte buňky, které chcete vyhodnotit. Buňky můžete upravovat jenom jednotlivě.

  2. Na kartě Vzorce klikněte ve skupině Závislosti vzorců na tlačítko Vyhodnocení vzorce.

    Skupina Závislosti vzorců na kartě Vzorce

  3. Kliknutím na Vyhodnotit prozkoumejte hodnotu podtrženého odkazu. Výsledek vyhodnocení se zobrazí kurzívou.

    Pokud podtržená část vzorce tvoří odkaz na jiný vzorec, kliknutím na Vstoupit zobrazte další vzorec v okně Vyhodnocení. Kliknutím na Vystoupit se vraťte k předchozí buňce a vzorci.

    Poznámka: Tlačítko Vstoupit není pro odkaz dostupné při druhém zobrazení odkazu ve vzorci, a to ani když vzorec odkazuje na buňku v samostatném sešitu.

  4. Pokračujte, dokud nevyhodnotíte všechny části vzorce.

  5. Pokud chcete znovu zobrazit vyhodnocení, klikněte na Restartovat.

    Pokud chcete vyhodnocení ukončit, klikněte na Zavřít.

    Poznámky: 

    • Nejsou některé části vzorce, které používáte IF a ZVOLTE funkce Vyhodnocená a #není_k_dispozici se zobrazí v poli vyhodnocení.

    • Pokud je odkaz prázdný, zobrazí se v poli Vyhodnocení nulová hodnota (0).

    • Vzorce s cyklické odkazy nemusí být podle očekávání. Pokud budete chtít jsou cyklické odkazy, můžete Povolit iterativní přepočet.

    • Budou přepočítány následující funkce každé změně sešitu a mohou způsobit nástroj Vyhodnocení vzorce do jiné položek zobrazených v buňce výsledky: NÁHČÍSLO, ODSAZENÍ, BUŇKY, nepřímý.odkaz, nyní dnes, RANDBETWEEN, stav a SUMIF (v některých scénáře).

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×