Office
Přihlásit se

Vyhledání vlastních uživatelských položky v Projectu Online a Project serveru uživatele exportovat data

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Tento článek popisuje, jak hledat určité uživatele vlastní položky (zobrazení, filtry, přílohy, tabulky a makra) v projektu po výběru export dat uživatelů v Projectu Online nebo Project Server. Tato volba zahrnuje:

Postupy uvedené v tomto článku vyžadují, abyste mít takto:

  • Soubor MPP projektu

  • Soubor XML projektu

Pro Project Online oba soubory jsou vám poskytovány při exportu uživatelská data pomocí postupů ve Exportovat uživatelská data z Projectu Online.

Pro Project Server musíte se soubor určitý projekt uložit ve formátu XML k vytvoření souboru XML.

Poznámka: Při uložení souboru projektu ve formátu XML v aplikaci Project Professional, ujistěte se, že jste nainstalovali nejnovější aktualizace.

Najít a uložení vlastního zobrazení

  1. Otevřete soubor XML konkrétní projektu v textovém editoru.

  2. Text najděte < Zobrazení > zobrazíte seznam uživatelů zobrazení projektu.

  3. V seznamu zobrazení vyhledejte zobrazení, které mají vlastnost IsCustomized nastavena na hodnotu true. Například následující střední zobrazení s názvem aktivních úkolů byl upraven z globální/výchozí šablonu:

    <View>
    <Name>Task Sheet</Name>
    <IsCustomized>true</IsCustomized>
    </View>
    
  4. Nyní otevřete soubor MPP projektu v Projectu Online plochy klienta nebo Projectu Professional 2016.

  5. V nabídce Zobrazit na otevřete pás karet a na pásu karet vyberte v rozevírací nabídce Další zobrazení a potom klikněte na Další zobrazení.

  6. V okně Další zobrazení v seznamu zobrazení vyberte zobrazení hledáte a potom klikněte na použít.

    Další filtry
  7. Vybrané zobrazení se zobrazí. Udělat snímek obrazovky části zobrazení a uložte jej.

  8. Použijte stejný postup pro všechny zbývající vlastní zobrazení, které jste našli v souboru XML.

Tento postup na jednotlivé projekty, ve kterém chcete najít pro vaše uživatele přizpůsobených zobrazení můžete zopakovat.

Najít a uložit vlastní filtry

  1. Otevřete soubor XML konkrétní projektu v textovém editoru.

  2. Text najděte < filtry > zobrazíte seznam uživatelů filtrů projektu.

  3. V seznamu filtrů vyhledejte všechny filtry, které mají vlastnost IsCustomized nastavena na hodnotu true. Například následující střední filtru s názvem aktivních úkolů byl upraven z globální/výchozí šablonu:

    <Filters>
    <Name>Active Tasks</Name>
    <IsCustomized>true</IsCustomized>
    </Filter>
    
  4. Uložit zobrazení, otevřete soubor MPP projektu v Projectu Online plochy klienta nebo Projectu Professional 2016.

  5. Klikněte na kartě zobrazení a v rozevírací nabídce filtry vyberte Další filtry.

  6. V nabídce Další filtry vyberte filtr hledáte a potom klikněte na Upravit.

    Další filtry
  7. Definice filtru pro vybraný filtr se zobrazí. Můžete udělat snímek obrazovky definice filtru a uložte jej.

  8. Použijte stejný postup pro všechny zbývající vlastní filtry, které jste našli v souboru XML.

Tento postup na jednotlivé projekty, ve kterém chcete hledat uživatele přizpůsobení filtry můžete zopakovat.

Najít a uložení příloh

  1. Otevřete soubor XML konkrétní projektu v textovém editoru.

  2. Text najděte < úkoly > zobrazíte seznam uživatelů úkolů projektu.

  3. V seznamu úkolů vyhledejte všechny úkoly, které mají vlastnost NoteContainsObjects nastavena na hodnotu true. Například následující znamená, že úkol 18 obsahuje přílohy:

    <Task>
    <UID>18</UID>
    <NoteContainsObjects>true</NoteContainsObjects>
    </Task>
    
  4. Pokud chcete uložit přílohu, otevřete soubor MPP projektu v Projectu Online plochy klienta nebo Projectu Professional 2016.

  5. Klikněte na nabídku úkoly a otevřete úkol přidružený k přílohy (například úkol #18).

  6. V okně Informace o úkolu klikněte na kartu poznámky . Měli byste vidět přílohu položky seznamu.

    Přílohy k úkolům
  7. Otevřete přílohu a uložte jej.

  8. Použijte stejný postup pro všechny zbývající přílohy, které jste našli v souboru XML.

Tento postup na jednotlivé projekty, ve kterém chcete najít pro vaše uživatele přílohy můžete zopakovat.

Najít a uložit vlastní tabulky

  1. Otevřete soubor XML konkrétní projektu v textovém editoru.

  2. Text najděte < tabulkami > a najít tabulky v projektu.

  3. V seznamu tabulek vyhledejte všechny tabulky, které mají vlastnost IsCustomized nastavena na hodnotu true. Například následující střední tabulku zadání byl upraven z globální/výchozí šablonu:

    <Tables>
    <Table>Entry</Name>
    <IsCustomized>true</IsCustomized>
    </Table>
    
  4. Nyní otevřete soubor MPP projektu v Projectu Online plochy klienta nebo Projectu Professional 2016.

  5. V nabídce Zobrazit na otevřete pás karet a na pásu karet vyberte v rozevírací nabídce tabulky a potom klikněte na Další tabulky.

  6. V okně Další tabulky v seznamu tabulek vyberte tabulku hledáte a potom klikněte na Upravit.

    Definice tabulky
  7. Definice tabulky se zobrazí pro vybranou tabulku. V okně Definice udělat snímek obrazovky všechny informace a uložte jej.

  8. Použijte stejný postup pro všechny zbývající vlastní tabulky, které jste našli v souboru XML.

Tento postup na jednotlivé projekty, ve kterém chcete najít pro vaše uživatele upravené tabulky můžete zopakovat.

Vyhledání a jejich ukládání makra uživatele

Poznámka: Soubory XML projektu nebude příznak obsahující makra jazyka VBA. Je třeba ručně otevřete projekty uživatele k ověření, zda obsahuje makra jazyka VBA.

  1. Otevřete soubor MPP projektu v Projectu Online plochy klienta nebo Projectu Professional 2016.

  2. V nabídce Zobrazit na otevřete pás karet a na pásu karet vyberte v rozevírací nabídce makra a potom klikněte na Zobrazit makra.

  3. Na stránce makra vyberte Visual Basicu k otevření editoru jazyka Visual Basic.

  4. V editoru jazyka Visual Basic můžete uložit jednotliví uživatelé vlastní soubory VBA.

Můžete opakujte tento postup na jednotlivé projekty, ve kterém chcete najít pro vaše uživatele přizpůsobit nastavení maker.

Viz taky

Export dat uživatele z Projectu Online

Export dat uživatele ze serveru Project Server

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×