Office
Přihlásit se
Volba možností Automatických oprav pro velká písmena, pravopis a symboly

Volba možností Automatických oprav pro velká písmena, pravopis a symboly

Funkci automatických oprav můžete použít k opravě překlepů, chyb v psaní velkých písmen a slov s chybami pravopisu, stejně jako k automatickému vkládání symbolů a jiných částí textu. Automatické opravy používají standardně seznam typických překlepů a symbolů, položky v tomto seznamu ale můžete změnit.

Poznámka: Text obsažený v hypertextových odkazech není automaticky opravován.

Všechny postupy popsané v tomto článku se provádějí na kartě Automatické opravy.

Dialog Automatické opravy

Nejdříve podle pokynů pro konkrétní aplikaci Office otevřete kartu Automatické opravy a pak níže v tomto článku klikněte na to, co chcete udělat.

Kde najdete kartu Automatické opravy v aplikacích Office

Všechny aplikace kromě Outlooku:

  • Klikněte na Soubor > Možnosti > Kontrola pravopisu a mluvnice > Možnosti automatických oprav.

    Zobrazení dialogového okna Automatické opravy

Outlook:

  • Klikněte na Soubor > Možnosti > Pošta > Možnosti editoru > Kontrola pravopisu a mluvnice > Možnosti automatických oprav.

    Zobrazení dialogového okna Automatické opravy

Word, Excel, Access a PowerPoint:

  • Klikněte na tlačítko Microsoft Office Obrázek tlačítka > Možnosti [aplikace] > Kontrola pravopisu a mluvnice > Možnosti automatických oprav.

    Zobrazení dialogového okna Automatické opravy

Outlook:

  • Otevřete položku pošty a klikněte na tlačítko Microsoft Office Obrázek tlačítka > Možnosti editoru > Kontrola pravopisu a mluvnice > Možnosti automatických oprav.

    Zobrazení dialogového okna Automatické opravy

OneNote, Project, Publisher a Visio:

  • V nabídce Nástroje klikněte na Možnosti automatických oprav.

    Zobrazení dialogového okna Automatické opravy

Přejděte na kartu Revize, klikněte na šipku vedle tlačítka Pravopis a gramatika, aby se zobrazila nabídka, a vyberte Možnosti automatických oprav.

Rozbalený seznam možností kontroly pravopisu a gramatiky ve Wordu Online

Office Online teď nabízí mírně omezenější sadu možností automatických oprav než Office v desktopové verzi.

Kliknutím na následující nadpisy zobrazíte další informace.

Na kartě Automatické opravy můžete povolit nebo zakázat různé možnosti automatické opravy velkých písmen.

Na kartě Automatické opravy zaškrtněte jakékoli z následujících políček, nebo jeho zaškrtnutí zrušte:

  • Opravit DVě POčáteční VElká PÍsmena

  • Velká písmena na začátku vět

  • Psát první písmeno v buňce tabulky velkým písmenem (není v Excelu ani OneNotu)

  • Velká počáteční písmena u názvů dnů

  • Opravit nechtěné zapnutí klávesy cAPS LOCK

U několika pravidel pro psaní velkých písmen můžete zadat výjimky. Nastavené výjimky platí ve všech aplikacích Office podporujících funkci automatických oprav, takže jakákoli změna, kterou uděláte v tomto seznamu v jedné aplikaci, ovlivní taky ostatní aplikace.

Na kartě Automatické opravy klikněte na Výjimky a udělejte jeden z těchto kroků:

  • Pokud jste zaškrtli políčko Opravit DVě POčáteční VElká PÍsmena a nechcete, aby funkce automatických oprav opravovala konkrétní slovo, které obsahuje kombinaci velkých a malých písmen (třeba CSc.), klikněte na kartu POčáteční VElká.

    Slovo přidáte do seznamu výjimek tak, že ho zadáte do příslušného pole a kliknete na Přidat. Slovo odstraníte tak, že ho vyberete a kliknete na Odstranit.

  • Pokud jste zaškrtli políčko Velká písmena na začátku vět a nechcete, aby funkce automatických oprav opravovala slova následující po určitých zkratkách (třeba např.), klikněte na kartu První písmeno.

    Slovo přidáte do seznamu výjimek tak, že ho zadáte do příslušného pole a kliknete na Přidat. Slovo odstraníte tak, že ho vyberete a kliknete na Odstranit.

Poznámka: V některých programech Office taky můžete zaškrtnout políčko Automaticky přidat slova do seznamu nebo jeho zaškrtnutí zrušit. Tato možnost se uplatní při úpravách souboru nebo položky. Pokud Automatické opravy provedou nežádoucí opravu, můžete ji vrátit zpět stisknutím kombinace kláves CTRL+Z. Pokud je zaškrtnuté políčko Automaticky přidat slova do seznamu, přidají se nechtěné opravy, které vrátíte zpět, do seznamu výjimek.

Automatické opravy využívají dva paralelní seznamy slov. V prvním je slovo, které zadáte, a ve druhém je slovo nebo spojení, kterým aplikace slovo automaticky nahradí.

Seznam automatických oprav

Seznam automatických oprav platí pro všechny aplikace Office podporující funkci automatických oprav, takže když v tomto seznamu přidáte nebo odstraníte slovo v jedné aplikaci Office, projeví se tato změna i v ostatních aplikacích Office.

Můžete přidat více položek, které se budou nahrazovat stejným textem v poli „Za“. Například „přelkep“, „překep“ i „preklep“ se může nahradit výrazem „překlep“. Stačí přidat pro každou z těchto změn samostatnou položku.

Důležité informace: Pokud se vám zdá, že funkce Automatické opravy vůbec nefunguje, ověřte, jestli je na kartě Automatické opravy zaškrtnuté políčko Nahrazovat text během psaní.

Přidání, změna nebo odstranění položky v seznamu automatických oprav

Položku přidáte takto:

  1. Přejděte na kartu Automatické opravy.

  2. Do pole Nahrazovat zadejte slovo nebo slovní spojení, které píšete často chybně, například obyvkle.

  3. Do pole Za zadejte slovo správně, v tomto případě obvykle.

  4. Klikněte na tlačítko Přidat.

Pokud chcete změnit text, kterým se položka nahradí, vyberte ji v seznamu položek a zadejte nový text do pole Za.

Položku odstraníte tak, že ji vyberete v seznamu a kliknete na Odstranit.

Poznámka: Seznam Výjimky říká kontrole pravopisu, aby automaticky nenahrazovala některé položky, které může považovat za chybně napsané. Pokud je slovo automaticky nahrazováno a ověřili jste, že není v seznamu automatických oprav, přidejte toto slovo do seznamu výjimek, abyste zajistili, že ho kontrola pravopisu nebude automaticky nahrazovat.

Přidání položky pomocí editoru

Pokud jste předplatitelem Office 365 a máte nainstalované nejnovější aktualizace, měli byste mít v desktopových aplikacích Office funkci Editor. Pokud Office zjistí nesprávně napsané slovo, podtrhne ho červenou vlnovkou. Klikněte pravým tlačítkem myši na nesprávně napsané slovo a otevře se místní nabídka s navrhovanými opravami. Pokud chcete přidat chybně napsané slovo nebo opravnou dvojici do automatických oprav, stačí kliknout na šipku vedle opravy a zvolit Přidat do automatických oprav.

Místní nabídka editoru pod chybně napsaným slovem se zvýrazněnou možností Přidat do automatických oprav

Pokud nechcete používat žádné automatické opravy a změny, otevřete kartu Automatické opravy a postupujte takto:

  • Zrušením zaškrtnutí všech políček v horní části této karty vypněte všechny možnosti oprav velkých písmen.

  • Zrušením zaškrtnutí políčka Nahrazovat text při psaní vypněte všechna automatická nahrazování textu.

Tip: Pokud Office něco automaticky opravil za vás a vy změnu nechcete, stačí kliknout na Zpět nebo stisknout CTRL+Z na klávesnici.

Po instalaci Microsoft Office je funkce automatických oprav standardně nastavená tak, aby vyhledávala chybně zadaná slova a opravovala je podle slov v hlavním slovníku, který se používá při kontrole pravopisu. Pokud chcete ověřit, že je tato možnost povolená, postupujte takto.

  1. Na kartě Automatické opravy zaškrtněte políčko Automaticky použít návrhy kontroly pravopisu (pokud už není zaškrtnuté).

  2. Pokud jste udělali změnu, kliknutím na OK ji potvrďte.

Pokud chcete symbol rychle vložit, aniž byste museli použít některou z nabídek, přiřaďte danému symbolu klávesovou zkratku nebo text. To se vám bude hodit hlavně v případě, že daný symbol chcete vkládat často a nechcete ho pokaždé vybírat pomocí příkazu Symboly na pásu karet.

V Excelu nebo PowerPointu a ve Wordu se postup mírně liší, a proto z rozevírací nabídky níže vyberte produkt, který používáte:

  1. Na kartě Vložení klikněte na Symbol > Další symboly.

  2. Najděte v seznamu symbol, který chcete použít, a klikněte na něj.

    Tip: Většinu z běžně používaných symbolů najdete v sadách písem Wingdings. Vyhledání si urychlíte nastavením písma na Wingdings v dialogovém okně Symbol.

  3. Klikněte na Automatické opravy.

    Vybraný symbol se automaticky zobrazí v poli Za.

  4. Do pole Nahrazovat zadejte slovo nebo frázi, které chcete k symbolu zaškrtnutí přiřadit – zadejte třeba zaškrtnutí1.

    Do pole Nahrazovat na kartě Automatické opravy zadejte slovo nebo frázi, které chcete přidružit k symbolu zaškrtnutí.
  5. Klikněte na Přidat > OK.

  6. Kdykoli budete chtít právě definovaný symbol zaškrtnutí použít, stačí, když napíšete slovo, které jste použili v kroku 5 pro přidání symbolu.

Tip: Pokud se vložil nesprávný znak, zvýrazněte vložený znak a zkontrolujte, že písmo daného znaku je Wingdings.

V Excelu a PowerPointu musíte požadovaný symbol jednou vložit, zkopírovat ho a potom přidat pravidlo automatických oprav. Po dokončení 8. kroku níže můžete symbol, který jste vložili z důvodu vytvoření pravidla, odstranit, pokud budete chtít, takže si nemusíte dělat starosti s tím, kam ho vložíte.

  1. Na kartě Vložení klikněte na Symbol > Další symboly.

  2. V seznamu vyhledejte symbol, který chcete vložit do souboru, a poklikejte na něj. Zavřete dialogové okno symbolů.

    Tip: Většinu z běžně používaných symbolů najdete v sadách písem Wingdings. Vyhledání si urychlíte nastavením písma na Wingdings v dialogovém okně Symbol.

  3. V sešitě vyberte vložený symbol a na pásu karet na kartě Domů klikněte na Kopírovat (můžete také stisknout CTRL+C).

  4. Klikněte na Soubor > Možnosti > Kontrola pravopisu a mluvnice > Možnosti automatických oprav.

  5. Klikněte do pole Čím a stisknutím CTRL+V vložte zkopírovaný symbol do pole.

  6. Do pole Nahrazovat zadejte slovo nebo frázi, které chcete k symbolu přiřadit – zadejte třeba zaškrtnutí1.

    Do pole Nahrazovat na kartě Automatické opravy zadejte slovo nebo frázi, které chcete přidružit k symbolu zaškrtnutí.
  7. Klikněte na Přidat > OK.

  8. Kdykoli budete chtít právě definovaný symbol zaškrtnutí použít, stačí, když napíšete slovo, které jste použili v kroku 7 pro přidání symbolu.

Tip: Pokud se vložil nesprávný znak, zvýrazněte vložený znak a zkontrolujte, že písmo daného znaku je Wingdings.

Vrácení automatické opravy

Pokud Office něco automaticky opravil za vás a vy změnu nechcete, stačí kliknout na Zpět nebo stisknout CTRL+Z na klávesnici.

Viz také

Kontrola pravopisu a gramatiky v jiném jazyce

Přidání nebo úprava slov ve slovníku kontroly pravopisu

Konfigurace nebo vypnutí automatického formátování textu (automatického formátu).

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×