Určení počtu jedinečných hodnot mezi duplicitními položkami

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Řekněme, že chcete zjistit počet jedinečných textových nebo číselných hodnot v oblasti jsou. Například pokud sloupec obsahuje text hodnoty Bradley, Donátová, Donátová, Donátová, existují dva jedinečné hodnoty – Bradley a Donátová. Pokud tato oblast obsahuje čísla 5, 6, 7, 6, jsou jedinečné hodnoty 5, 6 a 7.

Pokud chcete spočítat jenom jedinečné hodnoty, použijte kombinaci následujících funkcí. Viz ukázkový sešit dole:

  • Pomocí funkce když pro přiřazení hodnoty 1 každé podmínce, která je TRUE.

  • Pomocí funkce SUMA přidejte všechny jedinečné hodnoty.

  • Určení počtu jedinečných hodnot pomocí funkce četnosti . Tato funkce ignoruje text a nulových hodnot. U prvního výskytu určitou hodnotu vrátí číslo rovná počet výskytů daná hodnota. U každého výskytu stejnou hodnotu po prvním tato funkce vrátí hodnotu 0.

  • Funkce POZVYHLEDAT slouží k vrácení pozici textové hodnoty v oblasti. Funkce četnosti používá výslednou hodnotu k vyhodnocení odpovídající textové hodnoty.

  • Použití funkce délka k nalezení prázdné buňky. Prázdné buňky mít délku 0 (počtu znaků).

Příklad

Zkopírujte tabulku do buňky A1 prázdného listu v Excelu a můžete začít pracovat s příklady vzorců využívajících funkce.

Data

Data

986

Novotný

Zelenka

563

67

789

235

Novotný

Zelenka

689

789

Zelenka

143

56

237

67

235

Vzorec

Popis (výsledek)

=SUMA(KDYŽ(ČETNOSTI(A2:A10,A2:A10)>0,1))

Určí počet jedinečných číselných hodnot v buňkách A2:A10, nepočítá však prázdné buňky a textové hodnoty (4).

=SUMA(KDYŽ(ČETNOSTI(POZVYHLEDAT(B2:B10,B2:B10,0),POZVYHLEDAT(B2:B10,B2:B10,0))>0,1))

Určí počet jedinečných textových a číselných hodnot v buňkách B2:B10 (nesmí obsahovat prázdné buňky) (7).

=SUMA(KDYŽ(ČETNOSTI(KDYŽ(DÉLKA(A2:A10)>0,POZVYHLEDAT(A2:A10,A2:A10,0),""), KDYŽ(DÉLKA(A2:A10)>0,POZVYHLEDAT(A2:A10,A2:A10,0),""))>0,1))

Určí počet jedinečných textových a číselných hodnot v buňkách A2:A10, nepočítá však prázdné buňky nebo textové hodnoty (6).

Poznámky: 

  • Vzorce v tomhle příkladu musí být zadány jako maticové vzorce. Vyberte každou buňku, která obsahuje vzorec, stiskněte klávesu F2 a stiskněte kombinaci kláves Ctrl + Shift + Enter.

  • Pokud chcete vidět vyhodnocování funkce krok po kroku, vyberte buňku obsahující vzorec a poté na kartě Vzorce ve skupině Závislosti vzorců klikněte na možnost Vyhodnocení vzorce.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×