Vzorce a funkce

Funkce SUMA

SUMA (funkce)

Funkce SUMA sečte hodnoty. Můžete sčítat jednotlivé hodnoty, odkazy na buňky nebo oblasti, anebo kombinaci všech tří možností.

Příklady:

  • =SUMA(A2:A10) Sečte hodnoty v buňkách a2:10.

  • =SUMA(A2:A10;C2:C10) Sečte hodnoty v buňkách a2:10 i v buňkách C2: C10.

Váš prohlížeč nepodporuje video. Nainstalujte si Microsoft Silverlight, Adobe Flash Player nebo Internet Explorer 9.

SUMA(číslo1;[číslo2];...)

Název argumentu

Popis

Číslo1:   

Povinné

První číslo, které budete chtít sčítat. Může to být číslo, například 4, Odkaz na buňku jako třeba B6 nebo Oblast buněk, například B2:B8.

číslo2 – 255   

Nepovinný

Toto je druhé číslo, které chcete sečíst. Tímto způsobem můžete zadat až 255 čísel.

V této části jsou popsané některé osvědčené postupy práce pro funkci SUMA. Spoustu těchto postupů můžete použít i u jiných funkcí.

Metoda =1+2 nebo =A+B. Když zadáte =1+2+3 nebo =A1+B1+C2, dostanete samozřejmě přesný výsledek. Tato metoda je ale náchylná k chybám, a to z několika důvodů:

  1. Překlepy – představte si, že chcete zadat víc hodnot nebo mnohem vyšší hodnoty, například:

    • =14598,93+65437,90+78496,23

    Potom zkuste ověřit, jestli jsou položky zadané správně. Mnohem jednodušší je zadat tyto položky do samostatných buněk a použít funkci SUMA. Navíc můžete hodnoty v samostatných buňkách formátovat, takže budou čitelnější, než když je zapíšete do vzorce.

    Místo abyste hodnoty ve vzorcích zadávali ručně, použijte funkci SUMA.  Vzorec v buňce D5 je =SUMA(D2:D4).
  2. Chyba #HODNOTA! při odkazování na text místo na čísla.

    Pokud použijete vzorce, jako je třeba:

    • =A1+B1+C1 nebo =A1+A2+A3

    Příklad špatné konstrukce vzorce.  Vzorec v buňce D2 je =A2+B2+C2.

    Když budou v odkazovaných buňkách nečíselné hodnoty (text), může být vzorec neplatný a vrátit chybu #HODNOTA!. Pokud je pozice, kterou uvedete, před první položkou nebo za poslední položkou v poli, bude výsledkem vzorce chyba #REF!. SUMA ignoruje textové hodnoty a sečte jenom číselné hodnoty.

    Správná konstrukce vzorců.  Místo =A2+B2+C2 je v buňce D2 tento vzorec: =SUMA(A2:C2).
  3. Chyba #REF! způsobená odstraněním řádků nebo sloupců

    Chyba #REF! způsobená odstraněním sloupce.  Vzorec se změnil na =A2+#REF!+B2.

    Pokud odstraníte řádek nebo sloupec, vzorec se neaktualizuje tak, aby odstraněné buňky vynechal, a vrátí chybu #ODKAZ!, zatímco funkce SUMA se aktualizuje automaticky.

    Funkce SUMA se automaticky přizpůsobí vloženým nebo odstraněným řádkům a sloupcům.
  4. Při vložení řádků nebo sloupců vzorce neaktualizují odkazy

    Když přidáte řádky, vzorce =A+B+C se neaktualizují.

    Pokud vložíte řádek nebo sloupec, vzorec se neaktualizuje tak, aby přidané buňky zahrnul, zatímco funkce SUMA se aktualizuje automaticky (pokud přidané buňky neleží mimo oblast odkazovanou ve vzorci). To je důležité hlavně tehdy, když očekáváte, že se vzorec aktualizuje, ale nestane se tak. Výsledky jsou pak neúplné a chyba se obtížně napravuje.

    Příklad znázorňuje automatické rozšíření vzorce součtu ze =SUMA(A2:C2) na =SUMA(A2:D2) při vložení sloupce.
  5. SUMA s individuálními odkazy na buňky vs. Oblasti

    Použití vzorce, jako je:

    • =SUMA(A1;A2;A3;B1;B2;B3)

    Tato metoda je při vkládání řádků do odkazované oblasti nebo jejich odstraňování z ní stejně náchylná k chybám jako předchozí, a to ze stejných důvodů. Mnohem lepší je používat jednotlivé oblasti, jako třeba:

    • =SUMA(A1:A3;B1:B3)

    Po přidání nebo odstranění řádků se tento vzorec aktualizuje.

  1. Chci jenom sečíst/odečíst/vynásobit/vydělit čísla Podívejte se na tuto řadu videí na téma Základní matematika v Excelu nebo Využití aplikace Excel jako kalkulačky.

  2. Jak můžu zobrazit víc nebo míň desetinných míst? – Můžete změnit formátování čísel. Vyberte zmíněnou buňku nebo oblast buněk a pomocí kombinace kláves Ctrl+1 vyvolejte dialogové okno Formát buněk, klikněte na kartu Číslo a vyberte požadovaný formát. Zkontrolujte, jestli je nastavený správný počet desetinných míst.

  3. Jak sčítat nebo odčítat časy? Časy můžete sčítat a odčítat několika různými způsoby. Například pro účely výpočtu mezd můžete získat rozdíl mezi 8:00:00 a 12:00 takto: =("12:00"-"8:00")*24, zadejte nejdřív koncový čas a od něho pak odečtěte počáteční čas. Všimněte si, že Excel počítá čas jako zlomek dne, takže ho musíte vynásobit číslem 24, pokud chcete výsledek zobrazil jako počet hodin. V prvním příkladu používáme vzorec =((B2-A2)+(D2-C2))*24 a získáme tak počet hodin od začátku do konce směny minus přestávka na oběd (celkově 8,50 hodin).

    Pokud jen sčítáte hodiny a minuty a chcete je také tak zobrazit, pak je můžete jenom rychle sečíst a není potřeba výsledek násobit číslem 24. Takže ve druhém příkladu použijeme pro součet funkci =SUMA(A6:C6) a výsledek je ve formátu hodin a minut (5:36, neboli 5 hodin a 36 minut).

    Výpočet času

    Další informace najdete tady: Sčítání a odčítání časových hodnot.

  4. Jak získám rozdíl mezi kalendářními daty? Stejně jako v případě času, můžete kalendářní data sčítat a odečítat. Běžným příkladem je počítání dní mezi dvěma daty. Stačí jednoduchý vzorec: =B2-A2. Klíčem pro práci s daty a časy je, abyste začali s koncovým datem a časem a odečetli jste od něj počáteční datum a čas.

    Výpočet doby mezi dvěma daty

    Další způsoby práce s daty najdete v tématu: Výpočet počtu dní mezi dvěma daty.

  5. Jak se sečíst jenom viditelné buňky? Někdy můžete ručně nebo automatickým filtrem skrýt řádky, aby byla zobrazena pouze určitá data, a potom chtít sečíst jenom viditelné buňky. Můžete použít funkci SUBTOTAL. Pokud v tabulce Excelu používáte řádek souhrnů, všechny funkce, které vyberete z rozevírací nabídky, budou automaticky zadány jako mezisoučet (SUBTOTAL). Další informace najdete v tématu Součty dat v tabulce aplikace Excel.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení na fóru Excel User Voice.

Viz také

Další informace o funkci SUMA

Funkce SUMIF sečte jenom hodnoty, které splňují jedno kritérium

Funkce SUMIFS sečte jenom hodnoty, které splňují víc kritérií

Funkce COUNTIF spočítá jenom hodnoty, které splňují jedno kritérium

Funkce COUNTIFS spočítá jenom hodnoty, které splňují více kritérií

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Nalezení a oprava chyb ve vzorcích

Běžné problémy se vzorci a jejich řešení

Matematické a trigonometrické funkce

Funkce Excelu (podle abecedy)

Funkce Excelu (podle kategorie)

Poznámka:  Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát vědět, jestli vám informace pomohly? Pokud chcete, můžete se podívat na anglickou verzi článku.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×