Správa oblastí externích dat a jejich vlastností

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Můžete změnit vlastnosti oblasti externích dat k datům ovládací prvek, který má importovat do listu pomocí připojení ke zdroji externích dat, jako je databáze, webového dotazu nebo textový soubor.

Oblast externích dat (nazývané také tabulky dotazů) je definovaný název nebo název tabulky, která definuje umístění data, která je uvedena v listu. Když se připojíte k externím datům, Excel automaticky vytvoří oblasti externích dat. Jedinou výjimkou tohoto pravidla je sestava kontingenční tabulky, který je připojen ke zdroji dat – sestavy kontingenční tabulky nepoužívá oblasti externích dat. V aplikaci Excel můžete formátovat a rozvržení oblasti externích dat nebo použít ve výpočtech, stejně jako u jakékoli další data.

Vlastnosti oblasti externích dat

Oblast externích dat obsahuje další vlastnosti (ne zaměňovat s vlastnosti připojení), můžete určit data, jako je uchovávání buňky formátování a šířku sloupce. Tyto vlastnosti oblasti externích dat můžete změnit kliknutím na tlačítko Vlastnosti na kartě Data klikněte ve skupině připojení. Proveďte požadované změny následujícím způsobem:

  • Oblasti externích dat, které jsou vytvořené v aplikaci Microsoft Query a Průvodce datovým připojením použijte dialogové okno Vlastnosti externích dat.

  • Oblasti externích dat, které jsou vytvořené z importovaného textového souboru nebo webového dotazu, který načítá data ve formátu HTML použijte dialogové okno Vlastnosti oblasti externích dat.

  • Oblasti externích dat, které jsou vytvořené z webového dotazu, který načítá XML data použijte dialogové okno Vlastnosti mapování XML.

Použití šablony s oblasti externích dat

Pokud chcete sdílet souhrn nebo sestavu, která je založená na externích datech, možnost poskytnout jiným uživatelům sešit, ve kterém oblasti externích dat nebo vytvoření šablony sestavy. Šablona sestavy umožňuje uložit souhrn nebo sestavu bez uložení externích dat, aby tento soubor je menší. Při otevření šablony sestavy je načíst externí data.

  1. Vyberte list, ve kterém chcete hledat Oblast externích dat.

  2. Na Řádek vzorců klikněte na šipku vedle Pole Název a potom klikněte na název oblasti externích dat, které chcete.

  1. Na kartě Vzorce ve skupině Definované názvy klikněte na Správce názvů.

    Vzhled pásu karet aplikace Excel

  2. V dialogovém okně Správce názvů klikněte na název oblasti externích dat a potom klikněte na Upravit. Poklikejte na položku název.

  3. V dialogovém okně Upravit název zadejte nový název pro odkaz do pole název.

Poznámka: Tlačítko Zavřít zavřete pouze dialogové okno Správce názvů. Nemusíte k potvrzení již provedených změn klikněte na tlačítko Zavřít.

Můžete změnit dotaz pro oblast externích dat, který byl vytvořený z aplikace Microsoft Query, importovaného textového souboru, webového dotazu nebo Průvodce datovým připojením.

  1. Klikněte na buňku v oblasti externích dat, pro kterou chcete změnit dotaz.

  2. Na kartě Data klikněte ve skupině připojení klikněte na Vlastnosti.

    Vzhled pásu karet aplikace Excel

  3. V dialogovém okně Vlastnosti externích dat klikněte na Vlastnosti připojení Obrázek tlačítka .

  4. V dialogovém okně Vlastnosti spojení klikněte na kartu definice a potom klikněte na Upravit dotaz.

Další informace o vytváření a úpravách dotazů v aplikaci Microsoft Query najdete v nápovědě k aplikaci Microsoft Query.

  1. Klikněte na buňku v oblasti externích dat, pro kterou chcete změnit dotaz.

  2. Na kartě Data klikněte ve skupině Připojení na Připojení.

    Vzhled pásu karet aplikace Excel

  3. V dialogovém okně Připojení sešitu klikněte na Vlastnosti.

  4. V dialogovém okně Vlastnosti spojení klikněte na kartu definice a potom klikněte na Upravit dotaz.

  5. V dialogovém okně Importovat textový soubor klikněte na importovat.

  6. Změňte importovaného textového souboru v Průvodci importem textu a potom klikněte na Dokončit.

    Další informace o importu textových souborů najdete v článku Import nebo export soubory ve formátu RTF.

  1. Klikněte na buňku v oblasti externích dat, pro kterou chcete změnit dotaz.

  2. Na kartě Data klikněte ve skupině připojení klikněte na Vlastnosti.

    Vzhled pásu karet aplikace Excel

  3. V dialogovém okně Připojení sešitu klikněte na Vlastnosti.

  4. V dialogovém okně Vlastnosti spojení klikněte na kartu definice a potom klikněte na Upravit dotaz.

  5. Změňte webový dotaz v dialogovém okně Upravit webový dotaz a potom klikněte na Dokončit.

Další informace o vytváření a úpravách webové dotazy najdete v článku připojení k webové stránky (Power Query).

  1. Klikněte na buňku v oblasti externích dat, pro kterou chcete změnit dotaz.

  2. Na kartě Data klikněte ve skupině připojení klikněte na Vlastnosti.

    Vzhled pásu karet aplikace Excel

  3. V dialogovém okně Vlastnosti externích dat klikněte na Vlastnosti připojení Obrázek tlačítka .

  4. V dialogovém okně Vlastnosti spojení klikněte na kartu definice.

  5. Udělejte něco z tohoto:

    • V poli Typ příkazu klikněte na tabulku a pak v dialogovém okně příkazu text změňte hodnotu jméno příslušné tabulky, zobrazení nebo dotazu.

    • V poli Typ příkazu klikněte na SQL ( výchozí) a do pole text příkazu upravit v SQL výrazu.

      Poznámka: V závislosti na tom, jak byla definována připojení, zadejte příkaz nemusí být k dispozici (je zobrazeno šedě).

  1. Na řádku vzorců klikněte na šipku vedle Pole Název a vyberte název oblasti externích dat, který chcete zkopírovat.

    Tabulky aplikace Excel vyberte název oblasti a potom stiskněte kombinaci kláves CTRL + A vyberte záhlaví.

    Pokud chcete zahrnout popisky sloupců nebo vzorce, které nejsou součástí externích dat, vyberte buňky, které obsahují popisky sloupců nebo vzorce, které chcete kopírovat. Klikněte na šipku vedle Pole Název na řádku vzorců a klikněte na název oblasti externích dat, který chcete zkopírovat.

  2. Na kartě Domů klikněte ve skupině Schránka na tlačítko Kopírovat.

    Vzhled pásu karet aplikace Excel

  3. Přejděte do sešitu, do které chcete vložit externích dat.

  4. Klikněte na levou horní buňku Oblast pro vložení.

    Abyste měli jistotu, že Externí data nenahrazuje existující data, ujistěte se, že list neobsahuje žádná data ve skupinovém rámečku nebo napravo od aktuální buňky, které můžete kliknout.

  5. Na kartě Domů klikněte ve skupině Schránka na Vložit.

Poznámka: Pokud zkopírujete pouze část oblasti externích dat, základní Dotaz nezkopíruje a zkopírovaná data se nedá aktualizovat.

Můžete určit způsob zpracování menší nebo větší k sadám dat, která se vrátí do aplikace Excel při aktualizaci dat.

  1. Na kartě Data klikněte ve skupině připojení klikněte na Vlastnosti.

    Vzhled pásu karet aplikace Excel

  2. V dialogovém okně Vlastnosti oblasti externích dat vyberte v části Při počet řádků v oblasti dat po aktualizaci, jednu z následujících akcí:

    • Vložení buňky pro nová data, odstranit nepoužité buňky

      Poznámky: 

      • Po přidání jednoho nebo víc řádků ve zdroji dat dolů buněk přímo pod externích dat, ale buňky vpravo od externích dat nepřesouvat.

      • Pokud jeden nebo více řádků se odstraní ve zdroji dat, nahoru buněk přímo pod externích dat, ale buňky vpravo od externích dat nepřesouvat.

    • Vložit celé řádky pro nová data, zrušte zaškrtnutí políčka nepoužité buňky

      Poznámky: 

      • Po přidání jednoho nebo víc řádků ve zdroji dat buněk přímo pod a napravo od externích dat dolů.

      • Při odstranění jednoho nebo víc řádků ve zdroji dat, buňky, přímo pod a napravo od externích dat nepřesunou.

    • Přepsat existující buňky nová data, zrušte zaškrtnutí políčka nepoužité buňky

      Poznámky: 

      • Po přidání jednoho nebo víc řádků ve zdroji dat přepíšou buněk přímo pod externích dat, ale buňky vpravo od externích dat nepřesouvat.

      • Při odstranění jednoho nebo víc řádků ve zdroji dat, buňky, přímo pod a napravo od externích dat nepřesunou.

  1. Na kartě Data klikněte ve skupině připojení klikněte na Vlastnosti.

    Vzhled pásu karet aplikace Excel

  2. V části Formát dat a rozložení proveďte některou z následujících akcí:

    • Zahrnout názvy polí jako první řádek, zaškrtněte políčko Zahrnout názvy polí.

      Poznámka: Toto zaškrtávací políčko je dostupný jenom u oblasti externích dat, která je převedena z aplikace sady Microsoft Office 2003 nebo do oblasti externích dat, která se vytvoří programově.

    • Pokud chcete sečíst sloupec čísel řádků, zaškrtněte políčko Zahrnout čísla řádků.

      Poznámka: Toto políčko není k dispozici pro importovaného textového souboru, souboru XML nebo webového dotazu.

    • Chcete-li zachovat formátování použít buněk, zaškrtněte políčko Zachovat formát buněk.

      Poznámka: Pro webového dotazu je tato možnost automaticky zrušeno vyberete Úplné formátování HTML v dialogovém okně Možnosti. Dialogové okno Možnosti aplikace access v dialogovém okně Upravit dotaz.

    • Chcete-li zachovat šířky sloupců, které jste nastavili, zaškrtněte políčko nastavit šířku sloupce.

    • Chcete-li zachovat sloupci řazení, filtrování a rozložení, které můžete použít, zaškrtněte políčko Zachovat řazení nebo filtrování/rozvržení sloupců.

      Poznámka: Toto políčko není k dispozici pro webového dotazu.

    • Chcete-li zachovat filtrování sloupce, které můžete použít, zaškrtněte políčko Zachovat filtrování sloupců.

      Poznámka: Toto zaškrtávací políčko je k dispozici pouze pro webového dotazu, který je založený na XML dat.

Poznámka: Následující postup platí jenom pro oblasti externích dat, která je převedena z aplikace sady Microsoft Office 2003 nebo do oblasti externích dat, která se vytvoří programově. Všechny oblasti externích dat, které jsou vytvořené pomocí uživatelského rozhraní vzniká jako tabulky aplikace Excel. V této tabulce automaticky rozbalit nové řádky se přidají a vyplnit dolů počítaných sloupců.

  1. Zadejte vzorec do buněk, které jsou sousedící první řádek dat v oblasti externích dat.

    Poznámka: První řádek dat může být první nebo druhý řádek v oblasti externích dat v závislosti na tom, jestli první řádek obsahuje záhlaví.

  2. Vyberte buňku a poklikejte na Úchyt ke kopírování vzorce do všech řádků v oblasti externích dat.

  3. Klikněte na buňku v oblasti externích dat.

  4. Na kartě Data klikněte ve skupině připojení klikněte na Vlastnosti.

    Vzhled pásu karet aplikace Excel

  5. V dialogovém okně Vlastnosti oblasti externích datVložit vzorce do sloupce vedle dat zaškrtněte políčko.

    Poznámka: Pokud externích dat zvětší při můžete Aktualizovat, aplikace Excel zkopíruje pouze vzorce, které jsou vedle sebe a nebo v rámci externích dat.

Ukotvení oblasti externích dat zachová data, ale ne jeho dotaz, takže oblast zmrazených externích dat se nedá aktualizovat.

  1. Klikněte na list obsahující tabulku aplikace Excel, ze kterého chcete odebrat datové připojení.

  2. Na řádku vzorců klikněte na šipku vedle Pole Název a potom klikněte na název oblasti externích dat, ze kterého chcete odebrat datové připojení. Potom je vybraný rozsah dat.

  3. Na kartě Nástroje ve skupině Externí Data tabulky klikněte na Zrušit propojení. Oblast dat zůstává a pořád má stejný název, ale připojení se odstraní.

Poznámka: Následující postup platí jenom pro oblasti externích dat, která je převedena z aplikace sady Microsoft Office 2003 nebo do oblasti externích dat, která se vytvoří programově. Všechny oblasti externích dat, které jsou vytvořené pomocí uživatelského rozhraní vzniká jako tabulky aplikace Excel. V této tabulce automaticky rozbalit nové řádky se přidají a vyplnit dolů počítaných sloupců.

  1. Na kartě Data klikněte ve skupině připojení klikněte na Vlastnosti.

    Vzhled pásu karet aplikace Excel

  2. V části definice dotazu zrušte zaškrtnutí políčka Uložit definice dotazu.

Poznámka: Když svůj sešit uložíte, v podkladovém dotazu odstraní ze sešitu. Však se dotazu soubory uložené databáze (soubory DQY nebo ODC) neodstraní. Pokud jste uložili dotaz, když jste vytvořili v Průvodci dotazu nebo v aplikaci Microsoft Query, soubor dotazu je uložený na vašem počítači a dotaz můžete znovu použít k načítání externích dat. Další informace najdete v nápovědě k aplikaci Microsoft Query.

Poznámka: Následující postup platí pouze pro oblasti externích dat, která se vytvoří pomocí Průvodce datovým připojením nebo aplikace Microsoft Query (a nechcete importovaného textového souboru nebo webového dotazu) převést z aplikace sady Microsoft Office 2003 nebo externí oblasti externích dat oblast dat vytvořili programově. Všechny oblasti externích dat, které jsou vytvořené pomocí uživatelského rozhraní vzniká jako tabulky aplikace Excel.

  1. Vložte prázdný řádek nad externích dat jedním z těchto věcí:

    • Vyberte buňky nad, který chcete vložit nový řádek. Potom na kartě Domů ve skupině buňky na šipku vedle tlačítka Vložit a potom klikněte na Vložit řádky listu. Vzhledem k tomu, že jste vybrali jednu buňku, jeden nový řádek vloží nad aktuálním řádkem.

    • Klikněte na volič řádku řádek, nad který chcete vložit nový řádek. Potom ve skupině buňky na kartě Domů klikněte na Vložit. Vzhledem k tomu, že jste vybrali jednu celý řádek, jeden nový řádek vloží nad ve vybraném řádku.

  2. Zadejte popisky, které chcete v buňkách v prázdném řádku.

  3. Klikněte na buňku v oblasti externích dat.

  4. Na kartě Data klikněte ve skupině připojení klikněte na Vlastnosti.

    Vzhled pásu karet aplikace Excel

  5. V dialogovém okně Vlastnosti oblasti externích dat v části Formát dat a rozložení zrušte zaškrtnutí políčka Zahrnout názvy polí a pak klikněte na OK.

  6. Pokud chcete odebrat existující názvy polí a aktualizace externích dat, klikněte na buňku v oblasti externích dat a klikněte na Aktualizovat Data Vzhled tlačítka .

Poznámka: Když data načtete z databáze, všechny změny názvů sloupců v aplikaci Microsoft Query zachovány v oblasti externích dat. Informace o změně názvy sloupců v dotazu najdete v nápovědě k aplikaci Microsoft Query.

  1. Klikněte na list, který obsahuje oblasti externích dat, který chcete odstranit.

  2. Na řádku vzorců klikněte na šipku vedle Pole Název a potom klikněte na název oblasti externích dat, který chcete odstranit.

    Pokud je oblast externích dat tabulky aplikace Excel, stisknutím kombinace kláves CTRL + A vyberte celou tabulku.

  3. Chcete-li odstranit oblast externích dat, stiskněte klávesu DELETE.

  4. Pokud chcete odstranit dotaz, klikněte na Ano Pokud Excel zobrazí výzvu.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení na fóru Excel User Voice.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×