Sloučení více formulářů aplikace InfoPath

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

InfoPath Forms Services je technologie server, k dispozici v Microsoft Office Forms Server 2007 a Microsoft Office SharePoint Server 2007, který umožňuje uživatelům vyplňovat Microsoft Office InfoPath 2007 pomocí webového prohlížeče, ne nebo kromě Office InfoPath 2007 klientským programem. Tato technologie umožňuje rozsáhlejší přístup k formulářům než bylo možné v předchozích verzích aplikace Microsoft Office InfoPath.

Tento článek vysvětluje, jak sloučit Office InfoPath 2007 formuláře na serveru InfoPath Forms Services.

V tomto článku

Základní informace

Sloučení více formulářů Infopathu v knihovně

Základní informace

Knihovna je umístění na webu, kde můžete spolu s členy týmu vytvářet, shromažďovat, aktualizovat a spravovat soubory. Každá knihovna zobrazuje seznam souborů a klíčové informace o souborech, což umožňuje uživatelům s těmito soubory společně pracovat.

Uložením formulářů Infopathu v knihovně můžete sdílet a sledovat formulářům snadno. Můžete například vytvořit knihovnu pro váš tým stav sestavy formuláře. Pokud má návrhář šablony formuláře aktivní formuláři sloučení možnost pro šablonu formuláře, můžete také sloučit formuláře v knihovně. Slučování formulářů umožňuje uživatelům konsolidovat data z mnoha různých formuláře založené na této šabloně. Sloučení dat formuláře je užitečné, když chcete porovnat nebo souhrny dat z několika formulářů. Například můžete odpovědi jehož týmu vyplní týdenní formulář zprávy o stavu sloučení dat z několika formulářů do jednoho souhrnné pro vedoucího. Data v původní formuláře není odstraněna při sloučení formulářů. Vaši uživatelé dál vidět původní data po otevření jednotlivé formuláře jednotlivě.

Sloučení formulářů v knihovně, použijete příkaz Sloučit dokumenty v nabídce Zobrazit pro tuto knihovnu. Tento příkaz se přidá do nabídky Zobrazit pro knihovnu dokumentů, když návrhář šablony formuláře publikování šablony formuláře do nové knihovny z aplikace Microsoft Office InfoPath. Příkaz se taky přidá po přidání typu obsahu webu, který podporuje slučování formulářů do existující knihovnu.

Pokud příkaz Sloučit dokumenty není k dispozici, můžete vybrat soubory, které chcete sloučit bez otevření některé soubory. Při sloučení formulářů aplikace InfoPath pomocí příkazu Sloučit dokumenty, InfoPath spustí a zobrazí nový formulář, který obsahuje sloučené data z vybraných formulářů. Nový formulář: otevře v aplikaci InfoPath i v případě formuláře založené na Šablona formuláře s podporou prohlížeče. Pokud uložíte nového formuláře do knihovny stejný jako původní formuláře, bude s podporou prohlížeče podobně jako jiné formuláře v této knihovně.

Poznámky: 

  • Abyste měli jistotu, že šablony formulářů s podporou prohlížeče vždy otevře v prohlížeči, musíte klikněte na Zobrazit jako webovou stránku na stránce Upřesnit nastavení knihovny.

  • Ve výchozím nastavení při sloučení více formulářů do jednoho formuláře, pouze data sloučený jsou data, která je součástí Opakující se tabulka nebo Opakující se oddíl nebo data, která je přidružená k seznamu ovládacího prvku nebo ovládacího prvku pole s formátovaným textem. Ale když návrh šablony formuláře můžete určit, že by měl také sloučit data v dalších typů ovládacích prvků.

Začátek stránky

Sloučení více formulářů Infopathu v knihovně

Sloučení více formulářů, které jsou uložené v knihovně dokumentů, postupujte takto:

  1. Pokud knihovnu ještě není otevřený, klepněte na jeho název na panelu Snadné spuštění.

    Pokud se název knihovny nezobrazuje, klikněte na Zobrazit veškerý obsah webu. Potom klikněte na název knihovny.

  2. V nabídce zobrazení Nabídka Zobrazení klikněte na Sloučit dokumenty.

  3. Ve sloupci sloučení zaškrtněte políčka vedle formulářů, které chcete sloučit.

  4. Na panelu nástrojů seznamu klikněte na Sloučit vybraný dokumenty.

    Otevře se aplikace InfoPath s nový formulář, který je založený na této šabloně a obsahuje sloučená data.

    Poznámka: Při sloučení e-mailových formulářů aplikace InfoPath, může obsahovat sloučená data z ovládacích prvků s opakováním prázdný řádek. Například, pokud uživatel sloučí tři formuláře vyúčtování výdajů které obsahovat jedním řádkem nákladů v tabulce s opakováním, tabulka s opakováním ve formuláři aplikace InfoPath e-mailu, obsahující sloučená data může prázdný řádek, následovaný tří řádků dat ze všech typ objektu svou e-mailových formulářů aplikace InfoPath.

  5. Uložte formulář, který obsahuje sloučené dat v nabídce soubor klikněte na Uložit jako, přejděte do umístění, kam chcete uložte formulář a potom klikněte na Uložit.

Začátek stránky

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×