Share schedule and task details with a Visio Gantt chart

Share schedule and task details with a Visio Gantt chart

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

A Gantt chart helps you schedule your project tasks and then helps you track your progress. To communicate detailed task and schedule information to managers or other team members, you can create a Gantt chart in Microsoft Visio. You can also use a Gantt chart to manage the project's schedule at the task level.

Set up a Gantt chart

  1. In the Categories list, click the Schedule category.

  2. Klikněte na možnost Ganttův diagram a potom na tlačítko Vytvořit.

  3. V dialogovém okně Možnosti Ganttova diagramu nastavte data pro časové měřítko:

    • Klikněte na kartu Datum a zvolte požadované možnosti.
      Možnost Hlavní jednotky určuje největší časovou jednotku (například roky nebo měsíce), kterou chcete v diagramu použít, a možnost Vedlejší jednotky určuje nejmenší časovou jednotku (například dny nebo hodiny).

    • Na kartě Formát vyberte obrazce a popisky, které chcete použít v panelech úkolů, milnících a souhrnných panelech, a klikněte na tlačítko OK.
      Pokud nevíte, jaké formátování zvolit, přijměte výchozí volby. Formátování lze později změnit.

Přidání dat do Ganttova diagramu

Úkoly

Každý úkol v Ganttově diagramu zabírá jeden řádek v rámci diagramu. Při zadávání názvů úkolů do buněk ve sloupci Název úkolu jsou hodnoty trvání úkolů znázorněny jako panely úkolů v oblasti pod časovým měřítkem.

Cíl

Akce

Změna názvu úkolu

  • Ve sloupci Název úkolu klikněte do buňky, která obsahuje daný úkol, a zadejte nový název.

Nastavení nebo změna hodnoty trvání úkolu

  • V rámci Ganttova diagramu klikněte do buňky obsahující datum a hodnotu trvání, které chcete změnit, a potom zadejte nové informace.

Hodnoty trvání zadávejte následujícími způsoby:

  • 1h for 1 hour

  • 1d for 1 day

  • 1w for 1 week

  • 1m for 1 month

Přidání nových řádků úkolů

  • Přetáhněte obrazec Řádek z okna Obrazce do diagramu na požadované místo pro nový řádek.

Přidání indikátorů dokončených procent k úkolům

  1. Vyberte sloupec nalevo od místa, kde se má zobrazit sloupec s indikátorem dokončených procent.

  2. Na kartě Ganttův diagram klikněte ve skupině Sloupce na tlačítko Vložit.

  3. V seznamu Typ sloupce klikněte na položku Dokončeno % a pak na tlačítko OK.

Do nového sloupce zadávejte v průběhu úkolu procento dokončeného úkolu. Indikátor dokončených procent bude zobrazen na panelu úkolu.

Odstranění úkolu

  • Vyberte libovolnou buňku v řádku představujícím úkol, který chcete odstranit, a na kartě Ganttův diagram klikněte ve skupině Úkoly na tlačítko Odstranit.

Milníky

Jelikož milník představuje v plánu spíše důležitou událost než úkol, nastavte jeho trvání na nulovou hodnotu.

Cíl

Akce

Přidání nového milníku

  1. Přetáhněte obrazec Milník z okna Obrazce do diagramu na požadované místo pro vytvoření nového řádku milníku.

  2. Klikněte pravým tlačítkem myši v řádku představujícím milník na buňku ve sloupci Zahájení a v místní nabídce klikněte na příkaz Upravit datum.

  3. Nastavte požadované datum a klikněte na tlačítko OK. Datum ve sloupci Dokončení se změní tak, aby odpovídalo datu ve sloupci Zahájení, hodnota Trvání bude nastavena na nulu (0).

Převedení existujícího úkolu na milník

  • Type a duration of zero (0) in the Duration column of the row representing the task that you want to convert to a milestone.

Změna vzhledu značky milníku

  • Klikněte pravým tlačítkem myši na značku milníku a v místní nabídce klikněte na příkaz Možnosti úkolů. Zvolte požadované možnosti a klikněte na tlačítko OK.

Odstranění milníku

  • Vyberte libovolnou buňku v řádku představujícím milník, který chcete odstranit, a na kartě Ganttův diagram klikněte ve skupině Úkoly na tlačítko Odstranit.

Souhrnné úkoly

Souhrnné úkoly je možné použít, chcete-li spojit několik podřízených úkolů pod jeden úkol, který je bude zastřešovat.

Cíl

Akce

Vytvoření podřízených úkolů v souhrnném úkolu

Souhrnný úkol je normální řádek úkolu. Shrnuje podřízené úkoly, jež jsou odsazeny pod ním. Postup pro vytvoření podřízených úkolů:

  1. Vyberte buňku obsahující název úkolu. Více úkolů lze vybrat klikáním se stisknutou klávesou SHIFT.

  2. Na kartě Ganttův diagram klikněte ve skupině Úkoly na tlačítko Zvětšit odsazení.

Odsazený úkol je nyní podřízeným úkolem souhrnného úkolu, který je nad ním.

Nastavení trvání u souhrnného úkolu

  1. Klikněte v řádku prvního podřízeného úkolu na buňku ve sloupci Zahájení a zadejte datum zahájení úkolu.

  2. U stejného podřízeného úkolu klikněte na buňku ve sloupci Dokončení a zadejte datum dokončení úkolu.

  3. Opakujte kroky 1 a 2 pro každý podřízený úkol.

Trvání souhrnného úkolu bude vyplněno automaticky po přidání informace o trvání u všech podřízených úkolů.

Zvýšení úrovně (zmenšení odsazení) úkolu

  • Klikněte pravým tlačítkem myši na úkol, u kterého chcete zvýšit úroveň, a v místní nabídce klikněte na příkaz Zmenšit odsazení.

Změna vzhledu panelu souhrnného úkolu

  1. Klikněte pravým tlačítkem myši na souhrnný úkol, který chcete změnit, a v místní nabídce klikněte na příkaz Možnosti úkolů.

  2. Ve skupinovém rámečku Souhrnné panely vyberte požadované symboly pro zahájení a dokončení panelů a klikněte na tlačítko OK.

Závislosti (propojené úkoly)

Učiníte-li v Ganttově diagramu jeden úkol závislý na jiném, zobrazí se šipka spojující tyto dva panely úkolů. Jestliže změníte datum nebo trvání úkolu, na kterém je závislý jiný úkol, data závislého úkolu se také změní.

Cíl

Akce

Nastavení závislostí mezi úkoly

  1. Vyberte buňky s názvy úkolů a milníků, které chcete propojit. Více úkolů lze vybrat pomocí výběru se stisknutou klávesou CTRL.

  2. Na kartě Ganttův diagram klikněte ve skupině Úkoly na tlačítko Propojit.

Odstranění závislostí mezi úkoly

  1. Kliknutím na buňky obsahující názvy úkolů se závislostmi, které chcete odstranit, tyto úkoly vyberete. Více úkolů lze vybrat pomocí výběru se stisknutou klávesou CTRL.

  2. Na kartě Ganttův diagram klikněte ve skupině Úkoly na tlačítko Zrušit propojení.

Změna stylu šipek závislosti

  • Při otevřeném Ganttově diagramu klikněte pravým tlačítkem myši na stránku výkresu a v místní nabídce klikněte na příkaz Spojnice typu S.

Přidání sloupců

Cíl

Akce

Přejmenování existujícího sloupce

  • Klikněte na záhlaví sloupce, který chcete přejmenovat, a zadejte nový název.

Přidání nového, předem navrženého sloupce dat

  1. Vyberte záhlaví sloupce nalevo od místa, kde chcete zobrazit nový sloupec.

  2. Na kartě Ganttův diagram klikněte ve skupině Sloupce na tlačítko Vložit.

  3. V seznamu Typ sloupce klikněte na název sloupce, jenž odpovídá typu dat, která chcete přidat, a klikněte na tlačítko OK.

Přidání nového sloupce dat navrženého uživatelem

  1. Vyberte záhlaví sloupce nalevo od místa, kde chcete zobrazit nový sloupec.

  2. Na kartě Ganttův diagram klikněte ve skupině Sloupce na tlačítko Vložit.

  3. V seznamu Typ sloupce klikněte na jeden z uživatelem definovaných sloupců, jehož formát odpovídá formátu dat, která bude sloupec obsahovat (například Uživatelem definované desetinné číslo, Uživatelem definovaný text nebo Uživatelem definovaný čas), a klikněte na tlačítko OK.

  4. Zadejte nový název sloupce.

Poznámka: Chcete-li přidat více sloupců textu, klikněte při každém výběru na jinou možnost pro uživatelem definovaný text. Například pro první sloupec klikněte na možnost Uživatelem definovaný text 1, pro druhý sloupec na možnost Uživatelem definovaný text 2 atd.

Odstranění (skrytí) sloupce dat

  • Vyberte záhlaví sloupce, který chcete odstranit (skrýt).

  • Na kartě Ganttův diagram klikněte ve skupině Sloupce na tlačítko Skrýt.

Poznámka: Po odstranění sloupce z diagramu, či jeho skrytí, jsou data z tohoto sloupce ponechána v souboru. Budete-li chtít sloupec později opět zobrazit, klikněte pravým tlačítkem myši na záhlaví sloupce a poté klikněte na příkaz Vložit sloupec. V rozevíracím seznamu vyberte sloupec, který chcete opět zobrazit, a klikněte na tlačítko OK.

Přesunutí sloupce dat

  1. Klikněte na záhlaví sloupce, který chcete přesunout.

  2. Pomocí myši přetáhněte sloupec na nové místo.

  3. Proveďte jednu z následujících akcí:

    • Chcete-li sloupec přesunout nalevo od jiného sloupce, umístěte střední bod sloupce, který přesouváte, nalevo od středního bodu druhého sloupce.

    • Chcete-li sloupec přesunout napravo od jiného sloupce, umístěte střední bod sloupce, který přesouváte, napravo od středního bodu druhého sloupce.

    • Chcete-li sloupec přesunout napravo od oblasti časového měřítka, umístěte střední bod sloupce, který přesouváte, napravo od středního bodu oblasti časového měřítka.

Časové měřítko

Časové měřítko je měřítko hlavních a vedlejších časových jednotek, které sahá od data zahájení do data dokončení projektu. U časového měřítka lze definovat časové jednotky, datum zahájení a dokončení a dny pokládané za nepracovní.

Cíl

Akce

Změna data zahájení nebo data dokončení, nebo obou dat

  1. Na kartě Ganttův diagram klikněte ve skupině Spravovat na tlačítko Možnosti grafu.

  2. V dialogovém okně Možnosti Ganttova diagramu nastavte ve skupinovém rámečku Rozsah časového měřítka rozsah dat.

Změna časových jednotek

  1. Na kartě Ganttův diagram klikněte ve skupině Spravovat na tlačítko Možnosti grafu.

  2. V dialogovém okně Možnosti Ganttova diagramu vyberte ve skupinovém rámečku Časové jednotky požadované položky v seznamech Hlavní jednotky a Vedlejší jednotky a potom klikněte na tlačítko OK.

Nastavení nepracovních dnů

  1. Na kartě Ganttův diagram klikněte ve skupině Spravovat na tlačítko Konfigurace pracovní doby.

  2. V dialogovém okně Konfigurace pracovní doby vyberte požadované možnosti ve skupinových rámečcích Pracovní dny a Pracovní doba a potom klikněte na tlačítko OK.

Posunutí na konkrétní úkol nebo milník

  1. Kliknutím na buňku obsahující název úkolu vyberte úkol či milník, na který se chcete posunout.

  2. Na kartě Ganttův diagram klikněte ve skupině Navigace na tlačítko Přejít na úkol.

Posunutí na konkrétní datum

  • To scroll to the end of the timescale, on the Gantt Chart tab, in the Navigation group, click Go to Finish.

  • To scroll one minor unit to the left, on the Gantt Chart tab, in the Navigation group, click Next.

  • To scroll one minor unit to the right, on the Gantt Chart tab, in the Navigation group, click Previous.

  • To scroll to the beginning of the timescale, on the Gantt Chart tab, in the Navigation group, click Go to Start.

Změna šířky oblasti časového měřítka

  1. Vyberte sloupec časového měřítka.

  2. Přetažením ovládacího úchytu na pravé straně sloupce libovolným směrem nastavte požadovanou šířku oblasti.

Zobrazení více časových jednotek

  1. Kliknutím na plnou čáru ohraničující Ganttův diagram vyberte rámec.

  2. Pomocí myši přetáhněte ovládací úchyt na pravém okraji ve středu rámce směrem doprava.

Poznámka: Prodloužením časového měřítka a zobrazením více časových jednotek změníte také koncové datum přidružené k projektu.

Co chcete udělat?

Use a Gantt chart as a communication tool

Set up a Gantt chart

Add data to a Gantt chart

Print a large Gantt chart

Use a Gantt chart as a communication tool

In a Gantt chart, graphical elements such as bars and arrows represent tasks and the dependencies between them so you can track how the changes in one task affect the others.

You can also group several subordinate tasks under one summary task and add descriptions, required resources, and completion percentages to each task.

Tasks are displayed as bars on a timescale.

Ganttův diagram s pruhy úkolů

You can quickly produce a visually appealing annotated schedule for a presentation by applying a color scheme and adding text labels to a Gantt chart.

If you start a schedule for a complex project as a Visio Gantt chart, you can easily export the schedule data to Microsoft Project 2010, and then use Project to plan and manage the project in detail.

Product

Use when

Visio

  • You want to prepare a visually appealing annotated schedule for a presentation.

  • You want to define the basic tasks in a schedule in the early stages of a project.

  • Your schedule includes fewer than 30 tasks.

Project

  • You want to use a full-featured project management tool for planning and scheduling a project.

  • Your schedule includes dozens of tasks.

  • You need to assign multiple resources to tasks or connect schedules for different projects.

Top of Page

Set up a Gantt chart

  1. Na kartě Soubor klikněte na Nový.

  2. Under Choose a Template, click Schedule, and then double-click Gantt Chart.

  3. In the Gantt Chart Options dialog box, set up the dates for the timescale. You can also choose how you want to format the task bars, milestones, and other chart elements:

    • Click the Date tab, and then choose the options that you want.

      Poznámka: Major units are the longest unit of time (such as years or months) that you want to use in the chart, and Minor units are the smallest (such as days or hours).

    • On the Format tab, click the shapes and labels that you want to use on the task bars, milestones, and summary bars, and then click OK.
      The Gantt Chart Options dialog box

Poznámka:  If you aren't sure what formatting to choose, just accept the default choices. You can change the formatting later.

A chart frame up close

After you set up a Gantt chart, a generic chart frame appears.

The frame is like a blank canvas on which you can paint the details of your schedule:

  • In the Task Name column, click a cell, and then type to replace the generic text with a specific task name. You can add more tasks as your project progresses.

  • Initially, the dates in the Start and Finish columns reflect the start date that you specified for the project. To change the date, click a cell, and then type.

  • The Duration column updates automatically as you type new start and finish dates. You can also type one of the dates and the duration to indicate the length of a task.

  • In the Timescale (the area labeled 2000 with months shown below), Major units are on top, and Minor units are on the bottom. The timescale starts and ends with the start and finish dates that you specified. As you add task start and end dates or durations, task bars appear in the area below the timescale, and the area expands.

Tip: To record additional data about each task, you can add more columns. For example, you can add a Resource column so your Gantt chart reflects who is responsible for each task.

Top of Page

Přidání dat do Ganttova diagramu

You can fill the frame with data that reflects the details of your project schedule. You can add and refine the following schedule elements:

Tasks

Milestones

Summary tasks

Dependencies (Linked tasks)

Data columns

Timescale

Úkoly

Ganttův diagram s pruhy úkolů

Každý úkol v Ganttově diagramu zabírá jeden řádek v rámci diagramu. Při zadávání názvů úkolů do buněk ve sloupci Název úkolu jsou hodnoty trvání úkolů znázorněny jako panely úkolů v oblasti pod časovým měřítkem.

Cíl

Akce

Změna názvu úkolu

  • Ve sloupci Název úkolu klikněte do buňky, která obsahuje daný úkol, a zadejte nový název.

Nastavení nebo změna hodnoty trvání úkolu

  • V rámci Ganttova diagramu klikněte do buňky obsahující datum a hodnotu trvání, které chcete změnit, a potom zadejte nové informace.

Poznámka: Hodnoty trvání zadávejte následujícími způsoby:

  • 1h for 1 hour

  • 1d for 1 day

  • 1w for 1 week

  • 1m for 1 month

Add new tasks at the bottom of the Gantt chart

  • Select the Gantt chart frame by clicking the solid line that surrounds the chart. To create a new task row, on the Gantt Chart tab, in the Tasks group, click New.
    The Tasks group

Add a new task between two existing tasks

  • Select any cell in the row that you want a new task row to appear above, and then on the Gantt Chart tab, in the Tasks group, click New.
    The Tasks group

Přidání indikátorů dokončených procent k úkolům

  1. Select the shaded portion at the top of the column to the left of where you want a percent complete column to appear, and then on the Gantt Chart tab, in the Columns group, click Insert.
    The Columns group

  2. V seznamu Typ sloupce klikněte na položku Dokončeno % a pak na tlačítko OK.

  3. Do nového sloupce zadávejte v průběhu úkolu procento dokončeného úkolu. Indikátor dokončených procent bude zobrazen na panelu úkolu.

Odstranění úkolu

  • Select any cell in the row that represents the task you want to delete, and then on the Gantt Chart tab, in the Tasks group, click Delete.
    The Tasks group

Milníky

Milníky v Ganttově diagramu

Jelikož milník představuje v plánu spíše důležitou událost než úkol, nastavte jeho trvání na nulovou hodnotu.

Cíl

Akce

Přidání nového milníku

  1. Drag a Milestone shape from the Gantt Chart Shapes stencil onto the Gantt chart frame, and drop it between the cells containing the task names for the tasks that you want the milestone to follow and precede.

  2. Klikněte pravým tlačítkem myši v řádku představujícím milník na buňku ve sloupci Zahájení a v místní nabídce klikněte na příkaz Upravit datum.

  3. Type the date that you want, and then click OK. The date in the Finish column changes to match the date in the Start column, and the Duration is set to zero (0).

Převedení existujícího úkolu na milník

  • Type a duration of zero (0) in the Duration column of the row representing the task that you want to convert to a milestone.

Změna vzhledu značky milníku

  • Klikněte pravým tlačítkem myši na značku milníku a v místní nabídce klikněte na příkaz Možnosti úkolů. Zvolte požadované možnosti a klikněte na tlačítko OK.

Odstranění milníku

  • Select any cell in the row that represents the milestone that you want to delete, and then on the Gantt Chart tab, in the Tasks group, click Delete.
    The Tasks group

Souhrnné úkoly

Ganttův diagram se souhrnnými a podřízenými úkoly

Souhrnné úkoly je možné použít, chcete-li spojit několik podřízených úkolů pod jeden úkol, který je bude zastřešovat.

Cíl

Akce

Create a summary task with subordinate tasks

  1. Add a summary task and subordinate tasks or milestones to the Gantt chart.

  2. To select a subordinate task, select a cell containing the task name. To select multiple tasks, hold down SHIFT while you click.

  3. On the Gantt Chart tab, in the Tasks group, click Indent.
    The Tasks group

Nastavení trvání u souhrnného úkolu

  1. Klikněte v řádku prvního podřízeného úkolu na buňku ve sloupci Zahájení a zadejte datum zahájení úkolu.

  2. U stejného podřízeného úkolu klikněte na buňku ve sloupci Dokončení a zadejte datum dokončení úkolu.

  3. Opakujte kroky 1 a 2 pro každý podřízený úkol.

Poznámka: Trvání souhrnného úkolu bude vyplněno automaticky po přidání informace o trvání u všech podřízených úkolů.

Demote (Indent) a task

  • Select the name of the task that you want to demote, and then on the Gantt Chart tab, in the Tasks group, click Indent.
    The Tasks group

Zvýšení úrovně (zmenšení odsazení) úkolu

  • Right-click the name of the task that you want to promote, and then on the Gantt Chart tab, in the Tasks group, click Oudent.
    The Tasks group

Změna vzhledu panelu souhrnného úkolu

  1. Right-click the task bar of a summary task that you want to change, and then click Task Options on the shortcut menu.

  2. Ve skupinovém rámečku Souhrnné panely vyberte požadované symboly pro zahájení a dokončení panelů a klikněte na tlačítko OK.

Závislosti (propojené úkoly)

Milníky v Ganttově diagramu

Učiníte-li v Ganttově diagramu jeden úkol závislý na jiném, zobrazí se šipka spojující tyto dva panely úkolů. Jestliže změníte datum nebo trvání úkolu, na kterém je závislý jiný úkol, data závislého úkolu se také změní.

Cíl

Akce

Nastavení závislostí mezi úkoly

  1. Select the tasks and milestones between which you want to set dependencies by clicking in the cells containing the task names. To select multiple tasks, hold down SHIFT while you select.

  2. On the Gantt Chart tab, in the Tasks group, click Link.
    The Tasks group

Odstranění závislostí mezi úkoly

  1. Select the tasks with dependencies that you want to break by clicking in the cells containing the task names. To select multiple tasks, hold down SHIFT while you select.

  2. On the Gantt Chart tab, in the Tasks group, click Unlink.
    The Tasks group

Změna stylu šipek závislosti

  • Při otevřeném Ganttově diagramu klikněte pravým tlačítkem myši na stránku výkresu a v místní nabídce klikněte na příkaz Spojnice typu S.

Data columns

A project schedule is built from task-specific data. The accumulation of task start dates and durations determines the finish date for the project. In a Visio Gantt chart, you store task data in data columns.

If you want to record and display additional task data in a Gantt chart, you can add new columns. For example, you may want to add a column for task notes in which you can describe complex or unique tasks, a column for resources to list the people responsible for completing each task, or a column for percent complete to track what percentage of each task is completed.


Ganttův diagram s pruhy úkolů

By default, when you create a new Gantt chart, the chart contains Task Name, Start, Finish, and Duration columns. You can rearrange the existing columns, add new columns, and delete columns that you no longer need.

Cíl

Akce

Přejmenování existujícího sloupce

  • Klikněte na záhlaví sloupce, který chcete přejmenovat, a zadejte nový název.

Přidání nového, předem navrženého sloupce dat

  1. Vyberte záhlaví sloupce nalevo od místa, kde chcete zobrazit nový sloupec.

  2. On the Gantt Chart tab, in the Columns group, click Insert.
    The Columns group

  3. V seznamu Typ sloupce klikněte na název sloupce, jenž odpovídá typu dat, která chcete přidat, a klikněte na tlačítko OK.

Přidání nového sloupce dat navrženého uživatelem

  1. Vyberte záhlaví sloupce nalevo od místa, kde chcete zobrazit nový sloupec.

  2. On the Gantt Chart tab, in the Columns group, click Insert.
    The Columns group

  3. V seznamu Typ sloupce klikněte na jeden z uživatelem definovaných sloupců, jehož formát odpovídá formátu dat, která bude sloupec obsahovat (například Uživatelem definované desetinné číslo, Uživatelem definovaný text nebo Uživatelem definovaný čas), a klikněte na tlačítko OK.

  4. Zadejte nový název sloupce.

Poznámka: Chcete-li přidat více sloupců textu, klikněte při každém výběru na jinou možnost pro uživatelem definovaný text. Například pro první sloupec klikněte na možnost Uživatelem definovaný text 1, pro druhý sloupec na možnost Uživatelem definovaný text 2 atd.

Odstranění (skrytí) sloupce dat

  • Vyberte záhlaví sloupce, který chcete odstranit (skrýt).

  • On the Gantt Chart tab, in the Columns group, click Hide.
    The Columns group

Poznámka: Po odstranění sloupce z diagramu, či jeho skrytí, jsou data z tohoto sloupce ponechána v souboru. Budete-li chtít sloupec později opět zobrazit, klikněte pravým tlačítkem myši na záhlaví sloupce a poté klikněte na příkaz Vložit sloupec. V rozevíracím seznamu vyberte sloupec, který chcete opět zobrazit, a klikněte na tlačítko OK.

Přesunutí sloupce dat

  1. Klikněte na záhlaví sloupce, který chcete přesunout.

  2. Pomocí myši přetáhněte sloupec na nové místo.

  3. Proveďte jednu z následujících akcí:

    • Chcete-li sloupec přesunout nalevo od jiného sloupce, umístěte střední bod sloupce, který přesouváte, nalevo od středního bodu druhého sloupce.

    • Chcete-li sloupec přesunout napravo od jiného sloupce, umístěte střední bod sloupce, který přesouváte, napravo od středního bodu druhého sloupce.

    • Chcete-li sloupec přesunout napravo od oblasti časového měřítka, umístěte střední bod sloupce, který přesouváte, napravo od středního bodu oblasti časového měřítka.

Poznámka: If the timescale region is long, you may have to zoom out to move the column past the region's midpoint. To zoom out, on the View menu, point to Zoom, and then click the zoom level that you want.

Časové měřítko

Časové měřítko je měřítko hlavních a vedlejších časových jednotek, které sahá od data zahájení do data dokončení projektu. U časového měřítka lze definovat časové jednotky, datum zahájení a dokončení a dny pokládané za nepracovní.

Ganttův diagram s pruhy úkolů

You can scroll to a particular date or task on the timescale, and you can change the width of the timescale region and display more dates.

Cíl

Akce

Změna data zahájení nebo data dokončení, nebo obou dat

  1. On the Gantt Chart tab, in the Manage group, click Chart Options.
    The Manage group

  2. In the Gantt Chart Options dialog box, under Timescale range, change the click the date that you want to change.

Změna časových jednotek

  1. On the Gantt Chart tab, in the Manage group, click Chart Options.
    The Manage group

  2. V dialogovém okně Možnosti Ganttova diagramu vyberte ve skupinovém rámečku Časové jednotky požadované položky v seznamech Hlavní jednotky a Vedlejší jednotky a potom klikněte na tlačítko OK.

Nastavení nepracovních dnů

  1. On the Gantt Chart tab, in the Manage group, click Configure Working Time.
    The Manage group

  2. V dialogovém okně Konfigurace pracovní doby vyberte požadované možnosti ve skupinových rámečcích Pracovní dny a Pracovní doba a potom klikněte na tlačítko OK.

Posunutí na konkrétní úkol nebo milník

  1. Kliknutím na buňku obsahující název úkolu vyberte úkol či milník, na který se chcete posunout.

  2. On the Gantt Chart tab, in the Navigation group, click Scroll To Task.
    The Navigation group

Posunutí na konkrétní datum

  • To scroll to the end of the timescale, on the Gantt Chart tab, in the Navigation group, click Go to Finish.

  • To scroll one minor unit to the left, on the Gantt Chart tab, in the Navigation group, click Next.

  • To scroll one minor unit to the right, on the Gantt Chart tab, in the Navigation group, click Previous.

  • To scroll to the beginning of the timescale, on the Gantt Chart tab, in the Navigation group, click Go to Start.
    The Navigation group

Změna šířky oblasti časového měřítka

  1. Click once in the gray area at the top of the timescale region, and then click again to select the timescale column.

  2. Drag the blue selection handle on the right side of the column in either direction until the region is the width that you want.

Zobrazení více časových jednotek

  1. Kliknutím na plnou čáru ohraničující Ganttův diagram vyberte rámec.

  2. Drag the blue selection handle at the right-center of the frame toward the right.

Poznámka: Prodloužením časového měřítka a zobrazením více časových jednotek změníte také koncové datum přidružené k projektu.

Top of Page

Print a large Gantt chart

Unless you are creating a schedule for a small project, your Gantt chart is likely to extend beyond the boundaries of one standard printer page. The following table describes some printing problems that you may encounter and steps that you can take before you print that will help you get the results that you expect.

Problem

Solution

Akce

Only part of the Gantt chart is printed.

Make sure the whole chart fits on a drawing page.

  1. On the Design tab, in the Page Setup group, click Page Setup dialog box launcher.

  2. In the Page Setup dialog box, click the Page Size tab, under Print zoom, select Fit to.

  3. Next to Fit to, type “1” in the sheet(s) across box and type “1” in the sheet(s) down box.

  4. Klikněte na Použít a potom na OK.

The printed page and drawing page orientations are not the same.

Change the printer page orientation.

  • On the Design tab, in the Page Setup group, click Orientation, and then click the orientation that you want.

You don't know how many pages the chart will be printed across.

Preview how the drawing will be printed before you print it.

  • On the File tab, click Print, and then click Print Preview.

You don't know where the page breaks will occur.

Turn on page breaks to see how many pages the chart will tile across.

  • On the View tab, in the Show group, select Page Breaks. Gray lines on the chart indicate where the page breaks will occur.

The breaks between the printed pages occur at awkward positions.

Change the margin settings to control the overlap between pages. The larger the margins, the larger the overlap between pages.

  1. On the Design tab, in the Page Setup group, click Page Setup dialog box launcher.

  2. On the Print Setup tab, under Printer paper, click Setup.

  3. Type the margin settings that you want, and then click OK two times.

Top of Page

Co chcete udělat?

Use a Gantt chart as a communication tool

Set up a Gantt chart

Add data to a Gantt chart

Print a large Gantt chart

Use a Gantt chart as a communication tool

In a Gantt chart, graphical elements such as bars and arrows represent tasks and the dependencies between them so you can track how the changes in one task affect the others.

You can also group several subordinate tasks under one summary task and add descriptions, required resources, and completion percentages to each task.

Tasks are displayed as bars on a timescale.

Příklad Ganttova diagramu

You can quickly produce a visually appealing annotated schedule for a presentation by applying a color scheme and adding text labels to a Gantt chart.

If you start a schedule for a complex project as a Visio Gantt chart, you can easily export the schedule data to Microsoft Office Project, and then use Office Project to plan and manage the project in detail. For more information about exporting Gantt charts from Office Visio, see Help in Microsoft Office Visio.

Product

Use when

Office Visio

  • You want to prepare a visually appealing annotated schedule for a presentation.

  • You want to define the basic tasks in a schedule in the early stages of a project.

  • Your schedule includes fewer than 30 tasks.

Office Project

  • You want to use a full-featured project management tool for planning and scheduling a project.

  • Your schedule includes dozens of tasks.

  • You need to assign multiple resources to tasks or connect schedules for different projects.

Top of Page

Set up a Gantt chart

First set up the basic chart frame and the dates for the timescale. You can also choose how you want to format the task bars, milestones, and other chart elements.

Later you can change the dates, add or delete tasks and milestones, and create dependencies between tasks. You can also apply a color scheme and add a title and legend.

  1. In Visio, on the File menu, point to New, point to Schedule, and then click Gantt Chart.

  2. Click the Date tab, and then choose the options that you want.

    Major units are the longest unit of time (such as years or months) that you want to use in the chart, and Minor units are the smallest (such as days or hours).

  3. On the Format tab, click the shapes and labels that you want to use on the task bars, milestones, and summary bars, and then click OK.

If you aren't sure what formatting to choose, just accept the default choices. You can change the formatting later.

A chart frame up close

After you set up a Gantt chart, a generic chart frame appears.

The frame is like a blank canvas on which you can paint the details of your schedule:

  • In the Task Name column, click a cell, and then type to replace the generic text with a specific task name. You can add more tasks as your project progresses.

  • Initially, the dates in the Start and Finish columns reflect the start date that you specified for the project. To change the date, click a cell, and then type.

  • The Duration column updates automatically as you type new start and finish dates. You can also type one of the dates and the duration to indicate the length of a task.

  • In the Timescale (the area labeled 2000 with months shown below), Major units are on top, and Minor units are on the bottom. The timescale starts and ends with the start and finish dates that you specified. As you add task start and end dates or durations, task bars appear in the area below the timescale, and the area expands.

To record additional data about each task, you can add more columns. For example, you can add a Resource column so your Gantt chart reflects who is responsible for each task.

Top of Page

Přidání dat do Ganttova diagramu

You can fill the frame with data that reflects the details of your project schedule. You can add and refine the following schedule elements:

Tasks

Milestones

Summary tasks

Dependencies (Linked tasks)

Data columns

Timescale

Úkoly

Ganttův diagram s pruhy úkolů

Každý úkol v Ganttově diagramu zabírá jeden řádek v rámci diagramu. Při zadávání názvů úkolů do buněk ve sloupci Název úkolu jsou hodnoty trvání úkolů znázorněny jako panely úkolů v oblasti pod časovým měřítkem.

Cíl

Akce

Změna názvu úkolu

  • Ve sloupci Název úkolu klikněte do buňky, která obsahuje daný úkol, a zadejte nový název.

Nastavení nebo změna hodnoty trvání úkolu

  • V rámci Ganttova diagramu klikněte do buňky obsahující datum a hodnotu trvání, které chcete změnit, a potom zadejte nové informace.

Hodnoty trvání zadávejte následujícími způsoby:

  • 1h for 1 hour

  • 1d for 1 day

  • 1w for 1 week

  • 1m for 1 month

Add new tasks at the bottom of the Gantt chart

  • Select the Gantt chart frame by clicking the solid line that surrounds the chart. To create new task rows, drag the green selection handle at the lower center of the frame.

Add a new task between two existing tasks

  • Right-click any cell in the row that you want a new task row to appear above, and then click New Task on the shortcut menu.

Přidání indikátorů dokončených procent k úkolům

  1. Right-click the shaded portion at the top of the column to the left of where you want a percent complete column to appear, and then click Insert Column on the shortcut menu.

  2. V seznamu Typ sloupce klikněte na položku Dokončeno % a pak na tlačítko OK.

  3. Do nového sloupce zadávejte v průběhu úkolu procento dokončeného úkolu. Indikátor dokončených procent bude zobrazen na panelu úkolu.

Odstranění úkolu

  • Right-click any cell in the row that represents the task you want to delete, and then click Delete Task on the shortcut menu.

Change the way a task bar looks

  • Right-click the task bar, and then click Task Options on the shortcut menu. From the list, click the options you want, and then click OK.

Milníky

Milníky v Ganttově diagramu

Jelikož milník představuje v plánu spíše důležitou událost než úkol, nastavte jeho trvání na nulovou hodnotu.

Cíl

Akce

Přidání nového milníku

  1. Drag a Milestone shape from the Gantt Chart Shapes stencil onto the Gantt chart frame, and drop it between the cells containing the task names for the tasks that you want the milestone to follow and precede.

  2. Klikněte pravým tlačítkem myši v řádku představujícím milník na buňku ve sloupci Zahájení a v místní nabídce klikněte na příkaz Upravit datum.

  3. Type the date that you want, and then click OK. The date in the Finish column changes to match the date in the Start column, and the Duration is set to zero (0).

Převedení existujícího úkolu na milník

  • Type a duration of zero (0) in the Duration column of the row representing the task that you want to convert to a milestone.

Změna vzhledu značky milníku

  • Klikněte pravým tlačítkem myši na značku milníku a v místní nabídce klikněte na příkaz Možnosti úkolů. Zvolte požadované možnosti a klikněte na tlačítko OK.

Odstranění milníku

  • Right-click any cell in the row that represents the milestone that you want to delete, and then click Delete Task on the shortcut menu.

Souhrnné úkoly

Ganttův diagram se souhrnnými a podřízenými úkoly

Souhrnné úkoly je možné použít, chcete-li spojit několik podřízených úkolů pod jeden úkol, který je bude zastřešovat.

Cíl

Akce

Create a summary task with subordinate tasks

  1. Add a summary task and subordinate tasks or milestones to the Gantt chart.

  2. To select a subordinate task, click a cell containing the task name. To select multiple tasks, hold down SHIFT while you click.

  3. Right-click one of the selected tasks, and then click Indent on the shortcut menu.

Nastavení trvání u souhrnného úkolu

  1. Klikněte v řádku prvního podřízeného úkolu na buňku ve sloupci Zahájení a zadejte datum zahájení úkolu.

  2. U stejného podřízeného úkolu klikněte na buňku ve sloupci Dokončení a zadejte datum dokončení úkolu.

  3. Opakujte kroky 1 a 2 pro každý podřízený úkol.

Trvání souhrnného úkolu bude vyplněno automaticky po přidání informace o trvání u všech podřízených úkolů.

Demote (Indent) a task

  • Right-click the name of the task that you want to demote, and then click Indent on the shortcut menu.

Zvýšení úrovně (zmenšení odsazení) úkolu

  • Right-click the name of the task that you want to promote, and then click Outdent on the shortcut menu.

Změna vzhledu panelu souhrnného úkolu

  1. Right-click the task bar of a summary task that you want to change, and then click Task Options on the shortcut menu.

  2. Ve skupinovém rámečku Souhrnné panely vyberte požadované symboly pro zahájení a dokončení panelů a klikněte na tlačítko OK.

Závislosti (propojené úkoly)

Milníky v Ganttově diagramu

Učiníte-li v Ganttově diagramu jeden úkol závislý na jiném, zobrazí se šipka spojující tyto dva panely úkolů. Jestliže změníte datum nebo trvání úkolu, na kterém je závislý jiný úkol, data závislého úkolu se také změní.

Cíl

Akce

Nastavení závislostí mezi úkoly

  1. Select the tasks and milestones between which you want to set dependencies by clicking in the cells containing the task names. To select multiple tasks, hold down SHIFT while you select.

  2. Right-click one of the selected tasks, and then click Link Tasks on the shortcut menu.

Odstranění závislostí mezi úkoly

  1. Select the tasks with dependencies that you want to break by clicking in the cells containing the task names. To select multiple tasks, hold down SHIFT while you select.

  2. Right-click one of the selected tasks, and then click Unlink Tasks on the shortcut menu.

Změna stylu šipek závislosti

  • With the Gantt chart open, right-click the drawing page, and then click S Type Connectors on the shortcut menu.

Data columns

A project schedule is built from task-specific data. The accumulation of task start dates and durations determines the finish date for the project. In a Visio Gantt chart, you store task data in data columns.

If you want to record and display additional task data in a Gantt chart, you can add new columns. For example, you may want to add a column for task notes in which you can describe complex or unique tasks, a column for resources to list the people responsible for completing each task, or a column for percent complete to track what percentage of each task has been completed.


Ganttův diagram s pruhy úkolů

By default, when you create a new Gantt chart, the chart contains Task Name, Start, Finish, and Duration columns. You can rearrange the existing columns, add new ones, and delete columns you no longer need.

Cíl

Akce

Přejmenování existujícího sloupce

  • Klikněte na záhlaví sloupce, který chcete přejmenovat, a zadejte nový název.

Přidání nového, předem navrženého sloupce dat

  1. Right-click the heading of the column to the left of where you want the new column to appear, and then click Insert Column on the shortcut menu.

  2. V seznamu Typ sloupce klikněte na název sloupce, jenž odpovídá typu dat, která chcete přidat, a klikněte na tlačítko OK.

Přidání nového sloupce dat navrženého uživatelem

  1. Right-click the heading of the column to the left of where you want the new column to appear, and then Click Insert Column on the shortcut menu.

  2. V seznamu Typ sloupce klikněte na jeden z uživatelem definovaných sloupců, jehož formát odpovídá formátu dat, která bude sloupec obsahovat (například Uživatelem definované desetinné číslo, Uživatelem definovaný text nebo Uživatelem definovaný čas), a klikněte na tlačítko OK.

  3. Zadejte nový název sloupce.

Poznámka: Chcete-li přidat více sloupců textu, klikněte při každém výběru na jinou možnost pro uživatelem definovaný text. Například pro první sloupec klikněte na možnost Uživatelem definovaný text 1, pro druhý sloupec na možnost Uživatelem definovaný text 2 atd.

Odstranění (skrytí) sloupce dat

  • Right-click the heading of the column that you want to delete (hide), and then click Hide Column on the shortcut menu.

Poznámka:  When you delete, or hide, a column from the chart, the data from the column is preserved in a file. To show the column again later, right-click a column heading, and then click Insert Column on the shortcut menu. From the list, select the column that you want to show again, and then click OK.

Přesunutí sloupce dat

  1. Klikněte na záhlaví sloupce, který chcete přesunout.

  2. Pomocí myši přetáhněte sloupec na nové místo.

  3. Proveďte jednu z následujících akcí:

    • Chcete-li sloupec přesunout nalevo od jiného sloupce, umístěte střední bod sloupce, který přesouváte, nalevo od středního bodu druhého sloupce.

    • Chcete-li sloupec přesunout napravo od jiného sloupce, umístěte střední bod sloupce, který přesouváte, napravo od středního bodu druhého sloupce.

    • Chcete-li sloupec přesunout napravo od oblasti časového měřítka, umístěte střední bod sloupce, který přesouváte, napravo od středního bodu oblasti časového měřítka.

Poznámka: If the timescale region is long, you may have to zoom out to move the column past the region's midpoint. To zoom out, on the View menu, point to Zoom, and then click the zoom level that you want.

Časové měřítko

Časové měřítko je měřítko hlavních a vedlejších časových jednotek, které sahá od data zahájení do data dokončení projektu. U časového měřítka lze definovat časové jednotky, datum zahájení a dokončení a dny pokládané za nepracovní.

Ganttův diagram s pruhy úkolů

You can scroll to a particular date or task on the timescale, and you can change the width of the timescale region and display more dates.

Cíl

Action to take

Změna data zahájení nebo data dokončení, nebo obou dat

  1. In your Gantt chart, right-click anywhere in the timescale, and then click Date Options on the shortcut menu.

  2. Under Timescale range, select a new start or end date or time, and then click OK.

Změna časových jednotek

  1. In your Gantt chart, right-click anywhere in the timescale, and then click Date Options on the shortcut menu.

  2. Under Time units, select the Major units and Minor units that you want, and then click OK.

Nastavení nepracovních dnů

  1. In your Gantt chart, right-click anywhere in the timescale, and then click Configure Working Time on the shortcut menu.

  2. Select the options that you want for Working days and Working time, and then click OK.

Posunutí na konkrétní úkol nebo milník

  1. Select the task or milestone that you want to scroll to by clicking in the cell containing the task name.

  2. On the Gantt Chart toolbar, click the Scroll To Task button.

Poznámka:  If you don't see the Gantt Chart toolbar, on the View menu, point to Toolbars, and then click Gantt Chart.

Posunutí na konkrétní datum

In your Gantt chart, right-click anywhere in the timescale, and then click one of the following on the shortcut menu:

  • Scroll to Finish Date, to scroll to the end of the timescale.

  • Scroll One Unit Left, to scroll one minor unit to the left.

  • Scroll One Unit Right, to scroll one minor unit to the right.

  • Scroll to Start Date, to scroll to the beginning of the timescale.

Změna šířky oblasti časového měřítka

  1. Click once in the gray area at the top of the timescale region, and then click again to select the timescale column.

  2. Drag the green selection handle on the right side of the column in either direction until the region is the width that you want.

Zobrazení více časových jednotek

  1. Kliknutím na plnou čáru ohraničující Ganttův diagram vyberte rámec.

  2. Drag the green selection handle at the right-center of the frame toward the right.

Poznámka: Prodloužením časového měřítka a zobrazením více časových jednotek změníte také koncové datum přidružené k projektu.

Top of Page

Print a large Gantt chart

Unless you are creating a schedule for a small project, your Gantt chart is likely to extend beyond the boundaries of one standard printer page. The following table describes some printing problems you may encounter and steps you can take before you print that will help you get the results you expect.

Problem

Sol ution

Akce

Only part of the Gantt chart is printed.

Make sure the entire chart fits on a drawing page.

  1. V nabídce Soubor klikněte na Vzhled stránky.

  2. Click the Page Size tab, click Size to fit drawing contents, and then click OK.

The printed page and drawing page orientations are not the same.

Change the printer page orientation.

  1. V nabídce Soubor klikněte na Vzhled stránky.

  2. Click the Print Setup tab, click the orientation you want, and then click OK.

You don't know how many pages the chart will be printed across.

Preview how the drawing will be printed before you print it.

  • On the File menu, click Print Preview.

You don't know where the page breaks will occur.

Turn on page breaks to see how many pages the chart will tile across.

  • On the View menu, click Page Breaks. Gray lines on the chart indicate where the page breaks will occur.

The breaks between the printed pages occur at awkward places.

Change the margin settings to control the overlap between pages. The larger the margins, the larger the overlap between pages.

  1. V nabídce Soubor klikněte na Vzhled stránky.

  2. Na kartě Nastavení tisku klikněte na Nastavení.

  3. Type the margin settings that you want, and then click OK twice.

Top of Page

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×