Sčítání čísel v oblastech pomocí funkce SUMA

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Pomocí jednoduchého vzorce můžete sčítat čísla v oblasti (skupinu buněk), ale funkce SUMA je jednodušší, když pracujete s více než několika čísly. Například = SUMA (a2: A6) znamená méně pravděpodobné, že se překlepy přepíší do = a2 + a3 + a4 + A5 + A6.

Použití funkce SUMA se dvěma oblastmi buněk

Tady je vzorec, který používá dvě oblasti buněk: = SUMA (a2: A4, C2: C3) Sečte čísla v oblastech a2: A4 a C2: C3. Stisknutím klávesy ENTER získáte celkem 39787.

Vzorec vytvoříte takto:

  1. Do buňky zadejte = SUMA a za ní pak otevírací závorku (.

  2. Chcete-li zadat první oblast vzorců, která se nazývá argument (část dat, kterou musí vzorec spustit), zadejte a2: A4 (nebo vyberte buňku a2 a táhněte myší buňku A6).

  3. Pokud chcete oddělit první argument od dalšího, zadejte čárku (,).

  4. Zadejte druhý argument, C2: C3 (nebo tažením vyberte buňky).

  5. Napište pravou závorku )a pak stiskněte ENTER.

Každý argument může být oblast, číslo nebo jednoduché odkazy na buňky oddělené čárkami.

  • = SUMA (A2: A4; 2429; 10482)

  • = SUMA (4823; A3: A4; C2: C3)

  • = SUMA (4823; 12335; 9718; C2: C3)

  • = SUMA (A2; A3; A4; 2429; 10482)

Tip:  Pokud potřebujete sečíst sloupce nebo řádky s čísly vedle sebe, pomocí funkce AutoSum sečtěte čísla.

Vyzkoušejte si to

Pokud chcete hrát s našimi ukázkovými daty, tady je pár dat, která se mají použít.

Jak funkce SUMA funguje, zkopírováním následující tabulky do listu a vložením do buňky a1.

Data

-5

0,15

končí

' 5

PRAVDA

Vzorec

Popis

Výsledek

= SUMA (3; 2)

Sečte 3 a 2.

0,5

= SUMA ("5"; 15; PRAVDA)

Přičte 5, 15 a 1. Textová hodnota 5 se nejprve převede na číslo a logická hodnota pravda se nejprve převede na číslo 1.

dvacet

=SUMA(A2:A4)

Sečte hodnoty v buňkách a2 až A4.

40

= SUMA (A2: A4; 15)

Sečte hodnoty v buňkách a2 až A4 a za výsledek přičte 15.

55

= SUMA (A5; A6; 2)

Sečte hodnoty v buňkách A5 a A6 a k tomuto výsledku přičte 2. Protože nečíselné hodnoty v odkazech nejsou přeloženy – hodnota v buňce A5 (' 5) a hodnota v buňce A6 (pravda) jsou považovány za text – hodnoty v těchto buňkách jsou ignorovány.

2

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení na fóru Excel User Voice.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×