Propojené záznamy v Excelu

V Excelu je nový datový typ, kterému se říká propojený záznam. Propojený záznam nejsou jenom čísla nebo text. Je to speciální datový typ, který obsahuje připojení k online zdroji. Toto připojení dokáže načíst zajímavé informace, se kterými můžete pracovat a které můžete v Excelu aktualizovat. V následujícím příkladu jsme použili propojené záznamy, abychom získali informace na základě geografických lokalit. Záznamy můžete ale také použít k tomu, abyste získali informace o cenách akcií.

Sloupec A: Francie, Španělsko, Švédsko a Norsko, všechny s ikonou mapy; Sloupec B: počty populace; Sloupec C: počty městské populace; Sloupec D: ceny paliv; Sloupec E: kódy měn

Ve výše uvedených příkladech obsahují propojené záznamy buňky s názvy zemí ve sloupci A. To, že se jedná o propojené záznamy, poznáte podle toho, že mají malé ikony ( Ikona propojeného záznamu pro Geografii ) uvnitř buněk. Kromě toho sloupce B, C, D a E zobrazují informace přidružené k těmto záznamům. To znamená, že populace, městská populace, ceny paliv a kódy měn se extrahují z propojených záznamů ve sloupci A.

Poznámka: Tato funkce se zákazníkům zpřístupňuje postupně v průběhu několika dnů nebo týdnů. Nejdříve bude dostupná pro účastníky programu Office Insider a později pro předplatitele Office 365. Pokud máte předplatné Office 365, zkontrolujte si, že máte nejnovější verzi Office.

1. Vytvořte tabulku.

Karta Vložení, tlačítko Tabulka

I když není to nutné, doporučujeme vám, abyste si nejdříve vytvořili excelovou tabulku. Díky tomu bude extrahování informací ze záznamů snadnější. Klikněte na buňku ve svých datech a potom klikněte na Vložení > Tabulka. Pokud vaše data mají sloupce, zaškrtněte políčko Tabulka obsahuje záhlaví.

2. Vyberte buňky.

Čtyři vybrané buňky, každá má název země

Teď vyberte několik buněk, které obsahují text. Excel má v době psaní tohoto článku dva typy propojených záznamů: Akcie a Geografie. V tomto příkladu máme zájem o geografická data, takže vybereme buňky s názvy zemí. Můžete ale také vybrat buňky s názvy krajů, území, států, měst atd. Pokud byste chtěli použít propojené záznamy pro akcie, mohli byste vybrat buňky s názvy společností, názvy fondů, burzovními symboly a tak dále.

3. Klikněte na Akcie nebo Geografie.

Karta Data, tlačítka Akcie a Geografie

Na kartě Data klikněte buď na Akcie, nebo na Geografie.

4. Objeví se propojené záznamy.

Čtyři buňky, každá má ikonou mapy a název země

Když Excel najde shodu mezi textem v buňkách a našimi online zdroji, převede váš text na propojené záznamy. To, že se jedná o propojené záznamy, poznáte podle této ikony pro geografii: Ikona propojeného záznamu pro Geografii nebo této ikony pro akcie: Ikona propojeného záznamu pro Akcie .

Poznámka: Pokud místo ikony uvidíte Ikona otazníku , znamená to, že má Excel problém najít shodu mezi vaším textem a záznamem v našich online zdrojích. Opravte pravopisné chyby a my se po stisknutí klávesy Enter pokusíme najít odpovídající záznam. Můžete také kliknout na Ikona otazníku . Objeví se podokno Volič záznamu. Potom vyhledejte záznam pomocí jednoho nebo dvou klíčových slov a nakonec klikněte na Vybrat.

Můžete dělat spoustu dalších věcí

Buňka s propojeným záznamem pro Francii; ikona klikajícího ukazatele myši; odhalená karta

Po převedení textu na propojený záznam se v buňce zobrazí ikona. Kliknutím na tuto ikonu si zobrazte kartu. Tato karta zobrazí seznam polí a odpovídajících hodnot. V závislosti na záznamu se vám může zobrazit několik polí/hodnot, se kterými můžete pracovat.

Na tomto obrázku například můžete vidět kartu propojeného záznamu Francie. Jedním z dostupných polí pro tento záznam je Hlavní město a hodnotou tohoto pole je Paříž. Další pole je Nejvyšší představitelé státu a hodnotami jsou jména nejvyšších představitelů státu.

Pokud chcete vidět více dvojic polí a hodnot, posuňte se uvnitř karty dolů. Pokud vás zajímá, odkud tato pole a hodnoty pochází, posuňte se úplně dolů na konec karty a klikněte na zdrojové odkazy.

Pokud už vaše data v excelové tabulce jsou, můžete z propojeného záznamu získat další informace přidáním sloupců vytvořených na základě propojeného záznamu.

1. Vyberte v tabulce buňku.

Buňka propojeného záznamu vybraná v tabulce

Nejdříve zkontrolujte, že jsou záznamy uvnitř excelové tabulky, a potom vyberte buňku v této tabulce.

2. Klikněte na tlačítko Přidat sloupec.

Ukazatel myši klikající na tlačítko Přidat sloupec

Klikněte na tlačítko Přidat sloupec, které se objeví v pravém horním rohu tabulky.

3. Vyberte z nabídky pole.

Pole Populace vybrané v nabídce

Objeví se nabídka se seznamem polí, které jsou pro tyto záznamy k dispozici. Vyberte to, které vás zajímá.

4. Vytvoří se nový sloupec.

Nově přidaný sloupec, hodnoty pocházející z propojeného záznamu

Vytvoří se nový sloupec tabulky, který bude zobrazovat hodnoty tohoto pole.

5. Postup zopakujte.

Druhý sloupec přidaných dat

Pokud chcete získat ještě více dat, zopakujte celý postup znovu.

6. Další nový sloupec

Další nový sloupec přidaný do tabulky

Přidá se další nový sloupec, který bude zobrazovat hodnoty vybraného pole.

Tip: Když máte data v excelové tabulce, nemusíte používat tlačítko Přidat sloupec. Místo toho jednoduše začněte zadávat nový název sloupce. Kdybyste například zadali do této tabulky slovo Populace, Excel automaticky načte pro záznamy pole Populace. Stejně to funguje u řádků: Zadejte nový řádek, a pokud k němu Excel najde online propojený záznam, připojí ho k němu a načte pro tento záznam všechna pole.

Buňka A2 obsahuje text „Francie“; Buňka B2 obsahuje text =A2. a objeví se nabídka automatického dokončování vzorce s poli z propojeného záznamu.

Můžete také zadávat vzorce, které používají hodnoty z polí záznamu. Můžete použít operátor tečka (.), který Excelu říká, aby jako parametr použil pole záznamu. V tomto příkladu jsme zadali =A2. a potom se objevila excelová nabídka Automatické dokončování s dostupnými poli pro propojený záznam „Francie.“ Další informace najdete v tématu FIELDVALUE (funkce).

Tipy a triky

Stiskněte Ctrl+Shift+F2.

Propojené záznamy odkazují na data, která jsou online. Jakmile jeden vložíte, naváže se v sešitě externí datové připojení. Když se potom data, která jsou online, změní, můžete je aktualizovat jejich opětovným načtením v Excelu. Pokud chcete propojený záznam a přidružená data aktualizovat, klikněte pravým tlačítkem na záznam a potom klikněte na Aktualizovat. Tím se aktualizuje vybraný propojený záznam a všechny sousední záznamy.

Pokud chcete aktualizovat všechny propojené záznamy a všechna externí datová připojení, které můžou v sešitě být (včetně dotazů, dalších datových přípojení a kontingenčních tabulek), klikněte na Data > Aktualizovat vše nebo stiskněte Ctrl+Alt+F5.

Jeden záznam můžete zaměnit (vyměnit) za jiný. Stačí kliknout pravým tlačítkem do buňky se záznamem a kliknout na Záznam > Změnit záznam. Vpravo se objeví podokno. Vyhledejte požadovaný záznam a potom původní záznam nahraďte kliknutím na Vybrat.

Pokud už propojený záznam v buňce nechcete, stačí kliknout pravým tlačítkem na buňku a kliknout na Záznam > Převést na text. Záznam se potom odebere, online připojení zmizí a hodnota v buňce se převede na text.

Data v Excelu můžete kdykoliv seřadit a filtrovat pomocí tlačítek filtru v záhlavích sloupců. (Tlačítka filtru zapnete kliknutím na Data > Filtr.) Máme pro vás ale i tip pro propojené záznamy: Klikněte na tlačítko filtru nad propojenými záznamy a rozhodněte se, jak je chcete seřadit nebo filtrovat. Pokud to chcete udělat podle zobrazeného názvu záznamu, nechejte v části Vybrat pole vybranou možnost Zobrazená hodnota. Pokud chcete seřadit nebo filtrovat podle jiného pole (zobrazeného nebo nezobrazeného v Excelu), vyberte v části Vybrat pole jiné pole.

Časté otázky

V současné době existují propojené záznamy pouze pro Akcie a Geografii. Do budoucna doufáme, že zpřístupníme více druhů záznamů, jak se bude postupně tato funkce vylepšovat.

Ano, ale musí mít předplatné Office 365 a nainstalovanou nejnovější verzi Excelu pro Office 365.

Poznámka: Tato funkce se zákazníkům zpřístupňuje postupně v průběhu několika dnů nebo týdnů. Nejdříve bude dostupná pro účastníky programu Office Insider a později pro předplatitele Office 365. Pokud máte předplatné Office 365, zkontrolujte si, že máte nejnovější verzi Office.

V současné době jsou propojené záznamy podporované pouze v Excelu 2016 pro předplatitele Office 365. Propojené záznamy můžou být postupem času podporované také v dalších verzích Excelu. Když otevřete soubor s propojeným záznamem ve verzi Excelu, která propojené záznamy nepodporuje, objeví se na místě propojených záznamů text #HODNOTA! a na místě ostatních vzorců, které odkazují na propojené záznamy, text #NÁZEV?.

Ne. V současné době nemůžete výběrem buňky s propojeným záznamem a přetažením jejího úchytu dolů vytvářet nové záznamy. Totéž platí pro možnost Kopírovat formát. Doufáme, že se při vylepšování této funkce přidá postupem času podpora i pro ostatní funkce.

Propojené záznamy jsou velmi novou funkcí a existují některé tradiční excelové funkce, které by si s ní nemusely dobře rozumět. Pokud se například pokusíte vytvořit kontingenční tabulku na základě tabulky s propojenými záznamy, objeví se chyba #HODNOTA!. Použití propojených záznamů s Power Pivotem, Power Query nebo dokonce některými grafy nemusí fungovat podle očekávání. Doufáme, že se při vylepšování propojených záznamů zlepší postupem času i podpora těchto ostatních funkcí, aby dobře spolupracovaly.

V současné době jsou propojené záznamy k dispozici, pouze pokud je jazykem operačního systému angličtina. V rámci vylepšování této funkce se budeme snažit v budoucnosti zpřístupnit více jazyků.

Viz také

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×