Použití funkce KDYŽ ke kontrole, jestli je buňka prázdná

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Někdy je potřeba zkontrolovat, jestli je buňka prázdná, obvykle proto, že nechcete, aby vzorec zobrazoval výsledek bez vstupních hodnot.

Vzorec v buňce E2 je =KDYŽ(D2=1;"Ano";KDYŽ(D2=2;"Ne";"Možná"))

V tomto případě používáme funkci KDYŽ v kombinaci s funkcí JE.PRÁZDNÉ:

  • =KDYŽ(JE.PRÁZDNÉ(D2);"Prázdné";"Není prázdné")

Tento vzorec říká KDYŽ(buňka D2 je prázdná; vrať hodnotu "Prázdné"; jinak vrať hodnotu "Není prázdné"). Stejně snadno můžete pro podmínku "Není prázdné" použít i vlastní vzorec. V dalším příkladu používáme místo funkce JE.PRÁZDNÉ výraz prázdného řetězce: "". Výraz "" v zásadě znamená „nic“.

Kontrola, jestli není buňka prázdná: Vzorec v buňce E2 je =KDYŽ(JE.PRÁZDNÉ(D2);"Prázdné";"Není prázdné")

=KDYŽ(D3="";"Prázdné";"Není prázdné")

Tento vzorec říká KDYŽ(buňka D3 nemá žádný obsah; vrať hodnotu "Prázdné"; jinak vrať hodnotu "Není prázdné"). Tady je příklad velmi běžného způsobu použití výrazu "" k tomu, aby se zabránilo výpočtu vzorce v případě, že je závislá buňka prázdná:

  • =KDYŽ(D3="";"";VášVzorec())

    Jestliže (D3 je nic zpáteční není nic, jinak výpočet vzorec).

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×