Použití funkce KDYŽ s funkcemi A, NEBO a NE

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Funkce KDYŽ testuje podmínku a při jejím splnění nebo nesplnění vrátí výsledek. Umožňuje tak logické porovnání mezi nějakou hodnotou a tím, co očekáváte.

  • =KDYŽ(je něco pravda; udělej něco; jinak udělej něco jiného)

Ale co v případě potřeby testování více podmínek, které Řekněme, že všechny podmínky muset být True nebo False (a) nebo jenom jedna podmínka musí být True nebo False (nebo) nebo Pokud chcete zkontrolovat, pokud se podmínka nevyhovují zadaným kritériím ? Všechny 3 funkcí lze na vlastní, ale je mnohem častější je spárované s funkcí když zobrazíte.

Použijte funkci KDYŽ s funkcemi A, NEBO a NE, pokud chcete udělat několik vyhodnocení a zjistit, jestli jsou podmínky pravdivé nebo nepravdivé.

Syntaxe

  • KDYŽ(A()) – KDYŽ(A(Logická1; [logická2];...); Ano; [Ne]))

  • KDYŽ(NEBO()) – KDYŽ(NEBO(Logická1; [logická2];...); Ano; [Ne]))

  • KDYŽ(NE()) – KDYŽ(NE(Logická1); Ano; [Ne]))

Název argumentu

Popis

Podmínka (povinné)

Podmínka, kterou chcete testovat

Ano (povinné)

Hodnota, která se má vrátit, když se podmínka vyhodnotí jako PRAVDA

Ne (volitelné)

Hodnota, která se má vrátit, když se podmínka vyhodnotí jako NEPRAVDA

Tady je přehled toho, jak strukturovat anebo funkce a Ne jednotlivě. Při každém z nich můžete kombinovat s příkaz IF, přečtěte si takto:

  • A – =KDYŽ(A(něco je PRAVDA; něco jiného je PRAVDA); Hodnota když PRAVDA; Hodnota když NEPRAVDA)

  • NEBO – =KDYŽ(NEBO(něco je PRAVDA; něco jiného je PRAVDA); Hodnota když PRAVDA; Hodnota když NEPRAVDA)

  • NE – =KDYŽ(NE(něco je PRAVDA); Hodnota když PRAVDA; Hodnota když NEPRAVDA)

Příklady

Tady jsou příklady některých běžných vnořené příkazy o IF(AND()), IF(OR()) a IF(NOT()). A a nebo funkce podporuje maximálně 255 jednotlivé podmínek, ale není vhodné používat víc než několik, protože složité, vnořeného vzorce můžete získat velmi obtížně srozumitelný k vytváření, otestujte a udržovat. Funkce NOT trvá jenom jedna podmínka.

Příklady používání funkce KDYŽ s funkcemi A, NEBO a NE k vyhodnocení číselných hodnot a textu

Tady jsou vyjmenované vzorce podle jejich použití logických operátorů:

Vzorec

Popis

=KDYŽ(A(A2>0;B2<100);PRAVDA;NEPRAVDA)

Když A2 (25) je větší než 0, B2 a (75) je menší než 100, pak vrátí hodnotu TRUE, jinak zpáteční NEPRAVDA. V tomto případě jsou obě podmínky PRAVDA, tak, aby vzorec vrátí hodnotu PRAVDA.

=KDYŽ(A(A3=“Červená“;B3=“Zelená“);PRAVDA;NEPRAVDA)

Pokud A3 ("modrá") = "Červený", a B3 ("zelená") je rovno "Zelený" vrátí hodnotu PRAVDA, jinak vrátí hodnotu FALSE. V tomto případě pouze první podmínka pravdivá, takže vrátí se hodnota NEPRAVDA.

=KDYŽ(NEBO(A4>0;B4<50);PRAVDA;NEPRAVDA)

Když A4 (25) je větší než 0, nebo B4 (75) je menší než 50, pak vrátí hodnotu TRUE, jinak zpáteční NEPRAVDA. V tomto případě pouze první podmínky PRAVDA, ale vyžaduje jeden argument je PRAVDA, že vzorec vrátí hodnotu PRAVDA, protože nebo jenom.

=KDYŽ(NEBO(A5=“Červená“;B5=“Zelená“);PRAVDA;NEPRAVDA)

Když A5 ("modrá") je rovno "Červený", nebo B5 ("zelená") je rovno "Zelený" vrátí hodnotu PRAVDA, jinak vrátí hodnotu FALSE. V tomto případě druhý argument je PRAVDA, aby vzorec vrátí hodnotu PRAVDA.

=KDYŽ(NE(A6>50);PRAVDA;NEPRAVDA)

Když A6 (25) není větší než 50 a potom zpáteční PRAVDA, jinak vrátí hodnotu FALSE. V tomto případě 25 není větší než 50, aby vzorec vrátí hodnotu PRAVDA.

=KDYŽ(NE(A7=“Červená“);PRAVDA;NEPRAVDA)

KDYŽ se A7 (“Modrá“) nerovná “Červená“, vrátit hodnotu PRAVDA, v opačném případě vrátit hodnotu NEPRAVDA.

Nezapomeňte, že některé příklady mít napište pravou závorku po zadání obě odpovídajících podmínky. Zbývající argumenty True nebo False jsou klikněte vlevo v rámci vnější když vyhodnocena. Můžete taky nahradit textové nebo číselné hodnoty pro hodnotu TRUE nebo FALSE budou vráceny v příkladech.

Tady je pár příkladů použití funkcí A, NEBO a NE pro vyhodnocování kalendářní dat.

Příklady používání funkce KDYŽ s funkcemi A, NEBO a NE k vyhodnocení dat

Tady jsou vyjmenované vzorce podle jejich použití logických operátorů:

Vzorec

Popis

=KDYŽ(A2>B2;PRAVDA;NEPRAVDA)

Pokud A2 je větší než B2 zpáteční hodnotu PRAVDA, jinak vrátí hodnotu FALSE. 03/12/14 je větší než 01/01/14, aby vzorec vrátí hodnotu PRAVDA.

=KDYŽ(A(A3>B2;A3<C2);PRAVDA;NEPRAVDA)

Pokud je větší než B2 a A3 je menší než C2 A3, vrátí hodnotu PRAVDA, v opačném případě vrátí hodnotu FALSE. V tomto případě oba argumenty podmínek, aby vzorec vrátí hodnotu PRAVDA.

=KDYŽ(NEBO(A4>B2;A4<B2+60);PRAVDA;NEPRAVDA)

Pokud buňka A4 je větší než B2 nebo A4 je menší než B2 + 60, vrátí hodnotu TRUE, jinak zpáteční NEPRAVDA. V tomto případě první argument je PRAVDA, ale druhý vyhodnotí jako NEPRAVDA. Protože nebo jenom vyžaduje jeden z argumentů je PRAVDA, vzorec vrátí hodnotu PRAVDA. Pokud použijete Průvodce vyhodnocení vzorce na kartě vzorce uvidíte, jak Excel vyhodnotí funkci.

=KDYŽ(NE(A5>B2);PRAVDA;NEPRAVDA)

Pokud A5 není větší než B2, vrátí hodnotu TRUE, jinak zpáteční NEPRAVDA. V tomto případě A5 je větší než B2, aby vzorec vrátí hodnotu FALSE.

Příklad dialogového okna Průvodce vyhodnocením vzorce

Používání A, NEBO a NE s podmíněným formátováním

Můžete taky použít a nebo a nechcete kritérium podmíněné formátování s možností vzorec. Když provedete můžete vynechat funkce když a a nebo a ne na vlastní.

Na kartě Domů klikněte na podmíněné formátování > nové pravidlo. Potom vyberte možnost "pomocí jednoduchého vzorce určit buňky k formátování", zadejte vzorec a použití formátu podle svého výběru.

Podmíněné formátování > dialogové okno Upravit pravidlo zobrazující metodu Vzorec

Výše uvedené vzorce s kalendářními daty by teď vypadaly takto.

Příklady používání funkcí A, NEBO a NE k otestování podmíněného formátování

Vzorec

Popis

=A2>B2

KDYŽ A2 je pozdější než B2, naformátovat buňku, v opačném případě nedělat nic.

=A(A3>B2;A3<C2)

KDYŽ A3 je pozdější než B2 A A3 je dřívější než C2, naformátovat buňku, v opačném případě nedělat nic.

=NEBO(A4>B2;A4<B2+60)

KDYŽ A4 je pozdější než B2 NEBO A4 je dřívější než B2 + 60 (dní), naformátovat buňku, v opačném případě nedělat nic.

=NE(A5>B2)

Pokud A5 není větší než B2, naformátovat buňku, jinak nic. V tomto případě A5 je větší než B2, aby výsledek vrátí hodnotu FALSE. Pokud by bylo potřeba změnit vzorec do =NOT(B2>A5) ho by vrátí hodnotu PRAVDA, a by formátované buňky.

Poznámka: Běžné chyby je zadejte vzorec do podmíněné formátování bez symbolem rovná se (=). Pokud to uděláte uvidíte, že dialogovém okně Podmíněné formátování přidá symbolem rovná se a nabídky ve vzorci - = "OR(A4>B2,A4<B2+60)", budete muset odeberte nabídky a pak vzorec odpoví správně.

Začátek stránky

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení ve fóru Excel User Voice.

Viz také

Podívejte se na video o používání funkce když

Informace o používání vnořených funkcí ve vzorci

KDYŽ

A

NEBO

NE

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Zjišťování chyb ve vzorcích

Klávesové zkratky v Excelu pro Windows

Klávesové zkratky v Excelu pro Mac

Logické funkce (odkazy)

Funkce Excelu (podle abecedy)

Funkce Excelu (podle kategorie)

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×