Použití argumentu Tabulka ve vyhledávací funkci

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Při vytváření vzorce pomocí funkce SVYHLEDAT nebo VVYHLEDAT , zadejte argument tabulka, která je oblast buněk, například D2:F39. Funkce hledá oblasti pro data, která chcete vyhledat.

Argument Tabulka je vždy druhý argument ve funkci SVYHLEDAT nebo VVYHLEDAT (první je hodnota, kterou se snažíte najít) a tyto funkce bez něho nebudou fungovat.

Prvním argumentem může být konkrétní hodnota (třeba 41 nebo Novák) nebo odkaz na buňku (třeba F2). První argument může vypadat třeba nějak takto:

=SVYHLEDAT(F2;...

Za hledanou hodnotou vždy následuje argument Tabulka, třeba takto:

=SVYHLEDAT(F2;B4:D39;...

Oblast buněk uvedená v argumentu Tabulka může využívat relativní nebo absolutní odkazy na buňky. Pokud budete vzorec kopírovat do dalších buněk, měli byste použít absolutní odkazy na buňky (se znakem $), třeba takto:

=SVYHLEDAT(F2;$B$2:$D$39;...

Pokud jsou buňky v argumentu Tabulka na jiném listu v sešitu, měl by tento argument zahrnovat název listu následovaný vykřičníkem. Syntaxe by vypadala asi takto:

=SVYHLEDAT(F2;List2!$C$14:$E$42;...

Třetím argumentem, který budete zadávat, je sloupec obsahující hodnoty, které se snažíte najít. Říká se mu vyhledávací sloupec. Pokud jsou hodnoty, které chcete najít, ve sloupci D (to znamená ve třetím sloupci oblasti buněk v argumentu Tabulka), bude mít třetí argument hodnotu 3.

=SVYHLEDAT(F2;B4:D39;3)

Není to sice povinné, ale doporučuje se používat i čtvrtý argument s hodnotou Nepravda nebo Pravda. Pokud hledáte přesnou shodu, použijte hodnotu Nepravda.

=SVYHLEDAT(F2;B4:D39;3;Nepravda)

Pokud použijete hodnotu Pravda nebo necháte čtvrtý argument prázdný, vrátí funkce přibližnou shodu pro hodnotu vašeho prvního argumentu. Když má první argument hodnotu Novák a použijete hodnotu Pravda, funkce vrátí hodnoty Novák, Nováková apod. Pokud ale použijete hodnotu Nepravda, vrátí funkce jenom hodnotu Novák jakožto přesnou shodu, což požaduje většina lidí.

Použití argumentu Pravda je ještě složitější v tom, že pokud vyhledávací sloupec (ten, který určujete ve třetím argumentu) není seřazený vzestupně (od A do Ž nebo od nejnižšího po nejvyšší číslo), může funkce vrátit nesprávný výsledek.

Další informace o funkcích SVYHLEDAT a VVYHLEDAT najdete v tématu vyhledávací funkce a funkce pro odkazy (odkazy).

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×