Použití argumentu Tabulka ve vyhledávací funkci

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Když vytvoříte funkci SVYHLEDAT nebo VVYHLEDAT , zadejte oblast buněk, například D2:F39. Oblasti je označená jako argument tabulka a argument je jednoduše data, která chcete-li spustit funkci. V tomto případě funkce hledá tyto buňky pro data, která chcete vyhledat.

Argument Tabulka je vždy druhý argument ve funkci SVYHLEDAT nebo VVYHLEDAT (první je hodnota, kterou se snažíte najít) a tyto funkce bez něho nebudou fungovat.

První argument, hodnota, kterou chcete najít, může být nějaká určitá hodnota jako třeba „41“ nebo „novák“, nebo i odkaz na buňku, jako třeba F2. Takže první argument může vypadat nějak takto:

= SVYHLEDAT (F2, ...

Argument tabulky vždy sleduje hledanou hodnotu, jako třeba:

= SVYHLEDAT (F2, B4:D39, ...

Rozsah buňky uvedený v argumentu Tabulka může využívat relativní nebo absolutní odkazy na buňky. Pokud budete funkci kopírovat, budete muset použít absolutní odkaz, jako je to tady:

= SVYHLEDAT (F2, $B$ 2: $39, BD ...

Buňky v argumentu Tabulka taky můžou přesahovat až do dalších listů v sešitu. Pokud to tak je, pak argument zahrnuje i název listu a syntaxe potom vypadá takto:

= SVYHLEDAT (F2, List2! $C$ 14: E$ 42, ...

Ujistěte se, že jste za název listu dali vykřičník.

Nakonec (whew), můžete zadat třetí argument sloupec obsahující hodnoty, které chcete najít. Je místo toho možnost vyhledávací sloupec. V našem první příkladu jsme použili oblast buněk B4 až D39, který přesahuje přes tři sloupce. Pojďme předstírají hodnoty, které chcete vidět, že živou ve sloupci D, třetího sloupce v oblasti buněk, takže poslední argument je 3.

=SVYHLEDAT(F2;B4:D39;3)

Můžete použít čtvrtý, volitelný argument, a to Pravda nebo Nepravda. Většinu času budete chtít použít Nepravda.

Pokud použijete Pravda nebo necháte čtvrtý argument prázdný, funkce vrátí přibližnou shodu pro hodnotu vašeho prvního argumentu. Takže abychom navázali na náš příklad, pokud je váš první argument „novák“ a vy použijete Pravda, funkce vrátí „Novák“, „Nováková“ a tak dále. Pokud ale použijete Nepravda, vrátí vám funkce pouze „Novák“, jakožto přesnou shodu, což je to, co většina lidí chce.

Aby pomocí True i trickier, když vyhledávací sloupec – sloupci určíte v třetí argument – není seřazený vzestupně (od A do Z nebo od nejnižší k nejvyšší číslo), funkce může vrátit nesprávné výsledky. Další informace o, najdete v tématu vyhledávání hodnot pomocí funkce SVYHLEDAT a další funkce.

A o funkcích SVYHLEDAT a VVYHLEDAT se dozvíte víc tady:

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×