Použijete hodnoty z databáze SQL serveru k naplnění seznam, rozevírací seznam nebo pole se seznamem

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Můžete naplnit seznam, rozevírací seznam nebo pole se seznamem data z dotazu datového připojení k databázi Microsoft SQL Server.

V tomto článku

Základní informace

Než začnete

Krok 1: Přidání datového připojení dotazu

Krok 2: Nakonfigurujte ovládacího prvku

Základní informace

Seznam, rozevírací seznam nebo pole se seznamem slouží k zobrazení položek, které může uživatel vybrat při vyplňování formuláře, který je založený na vaší šabloně. Můžete nakonfigurovat tyto typy ovládacích prvků zobrazení dat z sekundárního datového připojení k databázi Microsoft SQL Server. Sekundárního datového připojení je jakékoli datové připojení k externímu zdroji dat, které přidáte do šablony formuláře tak, aby uživatelé vyplňovat formuláře založené na této šabloně formuláře můžete získat data z nebo odeslat ke zdroji externích dat, jako jsou webové služby.

Když přidáte sekundárního datového připojení, že získávání dat do šablony formuláře aplikace Microsoft Office InfoPath vytvoří sekundární Zdroj dat s datová pole a skupiny, které odpovídá tak, jak data uložena v databázi. Datové připojení dotazu získává data z webové služby a jejich ukládání v sekundární zdroj dat formuláře. Ve výchozím nastavení dat v sekundární zdroj dat neexistuje pouze během uživatelům připojení k síti. Můžete nakonfigurovat sekundárního datového připojení k uložení výsledků dotazu na počítačích vašich uživatelů, aby měli přístup k datům, když formuláře není připojený k síti.

Poznámka zabezpečení: Pokud používáte sekundárního datového připojení k načtení citlivá data z externího zdroje dat, můžete k zakázání této funkce se můžete pomoci chrá data před neoprávněným použitím v případě ztráty či krádeže počítače. Pokud jste tuto funkci zakázat, data budou dostupná jenom v případě, že uživatel je připojen k síti.

Protože struktura dat v sekundární zdroj dat se musí shodovat způsobu uložení dat v databázi, nelze změnit existující pole a skupin na sekundární zdroj dat. Odkazy na další informace o datových připojení a zdrojů dat v části Viz také.

Začátek stránky

Než začnete

Před použitím hodnot z databáze SQL serveru k naplnění ovládacího prvku v šabloně formuláře, musíte tyto informace od správce databáze:

  • Název serveru s databází, který budete používat s touto šablonou formuláře.

  • Název databáze, který budete používat s touto šablonou formuláře.

  • Ověřování vyžaduje databáze. Databáze můžete použít ověřování systému Windows nebo ověřování serveru SQL Server a zjistit, jak uživatelé můžete získat přístup k databázi.

  • Název tabulky, která obsahuje data, která chcete poslat do formuláře. Toto je primární tabulky. Pokud chcete používat víc než jednu tabulku v databázi, potřebujete druhého jména, podřízené tabulky. Budete potřebovat názvy polí v podřízené tabulky s relacemi v polích primární tabulky.

  • Zda je možné bezpečně uložit výsledky dotazu na počítačích vašich uživatelů pro použití v offline režimu.

Začátek stránky

Krok 1: Přidání datového připojení dotazu

Pokud nemáte existujícího datového připojení dotazu, které můžete použít v šabloně formuláře, přidání sekundárního datového připojení do šablony formuláře dotazů takto: Pokud šablona formuláře už sekundárního datového připojení, které můžete použít, můžete tuto část přeskočit a přejít na Krok 2: nakonfigurujte ovládací prvek.

  1. V nabídce Nástroje klikněte na Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na Přidat.

  3. V Průvodci datovým připojením klikněte na vytvořit nové připojení k, klikněte na přijmout data a klikněte na tlačítko Další.

  4. Na další stránce průvodce klikněte na databáze (Microsoft SQL Server nebo Microsoft Office Access pouze) a klikněte na tlačítko Další.

  5. Na další stránce průvodce klikněte na Vybrat databázi.

  6. V dialogovém okně Vybrat zdroj dat klikněte na Nový zdroj.

  7. Na další stránce průvodce v seznamu druh zdroj dat Opravdu chcete připojit k klikněte na Microsoft SQL Server a klikněte na tlačítko Další.

  8. Do pole název serveru zadejte název serveru, který obsahuje databáze SQL serveru.

  9. V části přihlašovací pověření proveďte jednu z následujících akcí:

    • Pokud databáze určuje, kdo má přístup podle přihlašovacích údajů použitých v síti Microsoft Windows, klikněte na Použít ověřování systému Windows.

    • Pokud databáze určuje, kdo má přístup na základě zadané uživatelské jméno a heslo, které se zobrazí od správce databáze, klikněte na použít následující uživatelské jméno a heslo a potom zadejte svoje uživatelské jméno a heslo Uživatelské jméno a Heslo polí.

  10. Klikněte na tlačítko Další.

  11. V seznamu Vyberte databázi obsahující data, která se má klikněte na název databáze, kterou chcete použít, klikněte na připojit k určité tabulky, klikněte na název primární tabulky a klikněte na tlačítko Další.

  12. Na další stránce průvodce, do pole Název souboru zadejte název souboru, který obsahuje informace o připojení a klikněte na tlačítko Dokončit uložte toto nastavení.

    Pokud chcete používat další tabulky v dotazu datové připojení, můžete přidat další tabulky na této stránce průvodce.

    Přidání dalších tabulek

    1. Klikněte na Přidat tabulku.

    2. V dialogovém okně Přidat tabulku nebo dotaz klikněte na název podřízené tabulky a klikněte na tlačítko Další. InfoPath se pokusí nastavit vztahy porovnáním názvů polí v obou tabulkách. Pokud nechcete použít navrženou relaci, vyberte vztah a pak klikněte na Odebrat vztah. Přidání relace, klikněte na Přidat relaci. V dialogovém okně Přidat relaci klikněte na název každého související pole ve sloupci odpovídajících a potom klikněte na OK.

    3. Klikněte na Dokončit.

    4. Pokud chcete přidat další podřízené tabulky, opakujte tento postup.

  13. Klikněte na tlačítko Další.

  14. Uložení výsledků dotazů pomocí šablony formuláře, zaškrtněte políčko Uložit kopii data v šabloně formuláře. Výsledky dotazu zaškrtnutí tohoto políčka ukládá v šabloně formuláře. Becuase data uložena v šabloně formuláře. data jsou k dispozici ve formulářích, které uživatelé vyplňovat uživatelé, i když počítačích nejste připojení k síti.

    Poznámka zabezpečení: Výsledky dotazu zaškrtnutí tohoto políčka ukládá v šabloně formuláře. Protože jsou data uložena v šabloně formuláře, je k dispozici ve formulářích, které uživatelé vyplňovat uživatelé, i když počítačích nejste připojení k síti. Pokud se zobrazují citlivá data z tohoto datového připojení, můžete k zakázání této funkce se můžete pomoci chrá data v případě ztráty či krádeže počítače.

  15. Klikněte na tlačítko Další.

  16. Na další stránce průvodce zadejte popisný název tohoto sekundárního datového připojení. Pokud budete potřebovat formuláře, který se automaticky obnoví data při otevření formuláře, zaškrtněte políčko automaticky obnoví data při otevření formuláře.

Začátek stránky

Krok 2: Nakonfigurujte ovládacího prvku

  1. Pokud šablona formuláře obsahuje více zobrazení, klikněte v nabídce Zobrazit přejděte na zobrazení s ovládacím prvkem, ve které chcete zobrazit data z sekundární zdroj dat na název zobrazení.

  2. Poklikejte na seznam, rozevíracím seznamem nebo ovládací prvek pole se seznamem, kterou chcete vyplnit.

  3. Klikněte na kartu Data.

  4. V části položky seznamu klikněte na Vyhledat hodnoty z externího zdroje dat.

  5. V seznamu Zdroj dat klikněte na zdroj dat, který chcete použít.

  6. Klikněte na Vybrat výraz XPath Vzhled tlačítka vedle pole položky.

  7. V dialogovém okně Vybrat pole nebo skupiny určete, jaká data se zobrazí uživateli a jaká data se odešle ke zdroji externích dat jedním z těchto věcí.

    Zadejte data, která se uživateli zobrazí jsou stejná data, která uživatel odešle

    • Klikněte na pole a potom klikněte na OK.

    Zadejte data, která se uživateli zobrazí se liší od data, která uživatel odešle

    Poznámka: V tomto scénáři je data, která se uživateli zobrazí z některého z polí ve skupině a data, která uživatel odešle pole je v jiném ve stejné skupině.

    1. Klikněte na skupinu a klikněte na OK.

    2. V dialogovém okně Vlastnosti ovládacího prvku klikněte na Vybrat výraz XPath Vzhled tlačítka vedle pole hodnoty.

    3. V dialogovém okně Vybrat pole nebo skupiny klikněte na pole obsahující data, že uživatel odeslat ke zdroji externích dat a klikněte na tlačítko OK.

    4. V dialogovém okně Vlastnosti ovládacího prvku klikněte na Vybrat výraz XPath Vzhled tlačítka vedle pole Zobrazovaný název.

    5. V dialogovém okně Vybrat pole nebo skupiny klikněte na pole obsahující data, která se zobrazí v ovládacím prvku a klikněte na OK.

  8. Pokud pole do pole Zobrazovaný název obsahuje hodnoty s podobnými zobrazovanými názvy a chcete-li zobrazit pouze jedinečné názvy, zaškrtněte políčko Zobrazit pouze položky s jedinečnými zobrazovanými názvy.

Začátek stránky

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×