Používání vnořených funkcí ve vzorcích

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Použití funkce a jeden z argumentů ve vzorci, který používá funkci se nazývá vnoření budeme označovat s touto funkcí jako vnořené funkce. Například vnořením funkci průměr a SUMA v argumentech funkce když následující vzorec sečte množiny čísel (G2:G5) jenom v případě, že je větší než 50 průměr jiné množiny čísel (F2: F5). V ostatních případech vrátí hodnotu 0.

Vnořené funkce

Funkce průměr a SUMA jsou vnořené funkce když.

Do jednoho vzorce lze vnořit až 64 úrovní funkcí.

  1. Klikněte na buňku, do které chcete zadat vzorec.

  2. Pokud chcete vzorec začít funkcí, klikněte na Vložit funkci Obrázek tlačítka podle vzorce pruhu Obrázek tlačítka .

    Aplikace Excel automaticky vloží symbol rovná se (=).

  3. V poli se seznamem Vybrat kategorii vyberte položku Vše.

    Máte-li zkušenosti s kategoriemi funkcí, můžete také vybrat kategorii.

    Pokud si nejste jisti tím, kterou funkci chcete použít, můžete do pole Vyhledat funkci zadat dotaz, který vystihuje, co si přejete udělat (například text „sečíst čísla“ vrátí funkci SUMA).

  4. Pokud chcete jako argument zadat jinou funkci, zadejte ji do požadovaného pole argumentu.

    Části vzorce zobrazené v dialogovém okně Argumenty funkce odpovídají funkci vybrané v předchozím kroku.

    Kliknete-li například na funkci KDYŽ, budou v dialogovém okně Argumenty funkce zobrazeny argumenty funkce KDYŽ. Další funkci vnoříte jednoduše tím, že ji vepíšete do pole s argumenty. Můžete například zadat SUMA(G2:G5) do pole Ano u funkce KDYŽ.

  5. Zadejte další argumenty, které jsou potřebné k dokončení vzorce.

    Namísto zadávání odkazů na buňky stačí vybrat buňku, na kterou chcete odkazovat. Kliknutím na tlačítko Obrázek tlačítka minimalizujte dialogové okno, vyberte buňky, na které chcete odkazovat, a kliknutím na tlačítko Obrázek tlačítka dialogové okno znovu rozbalte.

    Tip: Další informace o funkci a jejích argumentech more získáte kliknutím na položku Nápověda k této funkci.

  6. Po zadání argumentů pro vzorec klikněte na tlačítko OK.

  1. Klikněte na buňku, do které chcete zadat vzorec.

  2. Pokud chcete vzorec začít funkcí, klikněte na Vložit funkci Obrázek tlačítka podle vzorce pruhu Obrázek tlačítka .

  3. V dialogovém okně Vložit funkci v dialogovém okně Zvolte nějakou kategorii vyberte položku vše.

    Máte-li zkušenosti s kategoriemi funkcí, můžete také vybrat kategorii.

  4. Jako argument zadat jinou funkci, zadejte ji do pole argumentu v Tvůrci vzorec nebo přímo do buňky.

  5. Zadejte další argumenty, které jsou potřebné k dokončení vzorce.

  6. Po zadání argumentů pro vzorec stisknutím klávesy ENTER.

Příklady

Na následujícím obrázku je příklad použití vnořené když testování funkcí k přiřazení oznámkování testu číselného skóre.

Zkopírujte vzorová data v následující tabulce a vložte je do buňky A1 nového excelového sešitu. Aby vzorce zobrazily výsledky, vyberte je, stiskněte F2 a potom stiskněte Enter. Pokud potřebujete, můžete přizpůsobit šířky sloupců a zobrazit si všechna data.

Skóre

45

90

78

Vzorec

Popis

Výsledek

'=KDYŽ(A2>89,"A",KDYŽ(A2>79,"B", KDYŽ(A2>69,"C",KDYŽ(A2>59,"D","F"))))

Použije vnořené podmínky KDYŽ k přiřazení oznámkování testu ke skóre v buňce A2.

=KDYŽ(A2>89,"A",KDYŽ(A2>79,"B",KDYŽ(A2>69,"C",KDYŽ(A2>59,"D","F"))))

'=KDYŽ(A3>89,"A",KDYŽ(A3>79,"B", KDYŽ(A3>69,"C",KDYŽA3>59,"D","F"))))

Použije vnořené podmínky KDYŽ k přiřazení oznámkování testu ke skóre v buňce A3.

=KDYŽ(A3>89,"A",KDYŽ(A3>79,"B",KDYŽ(A3>69,"C",KDYŽ(A3>59,"D","F"))))

'=KDYŽ(A4>89,"A",KDYŽ(A4>79,"B", KDYŽ(A4>69,"C",KDYŽ(A4>59,"D","F"))))

Použije vnořené podmínky KDYŽ k přiřazení oznámkování testu ke skóre v buňce A4.

=KDYŽ(A4>89,"A",KDYŽ(A4>79,"B",KDYŽ(A4>69,"C",KDYŽ(A4>59,"D","F"))))

Tipy: 

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení na fóru Excel User Voice.

Viz taky

Video: Když vnořené funkce

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×