Office
Přihlásit se

Přidání spojnic mezi obrazce

Visio usnadňuje spojování obrazců ve výkresu. Automatické spojování spojuje obrazce při přidávání a existující obrazce můžete spojit pomocí nástroje Spojnice. Můžete také změnit obrazce, které se zobrazují na minipanelu nástrojů, a zapnout nebo vypnout automatické spojení.

Automatické připojení obrazce

Spojování obrazců, které už jsou na stránce

Připojení k obrazci na jiné stránce

Použití motivů ke změně vzhledu spojnice

Použití alternativních obrazců spojnic

Změna obrazců na minipanelu nástrojů pro automatické spojení

Zapnutí nebo vypnutí funkce automatického spojení

Automatické připojení obrazce

Jednou z možností spojení obrazců je nechat je ve Visiu spojovat automaticky při přidávání obrazců na stránku. To je vhodné zejména při vytváření vývojového diagramu.

  1. Ověřte, že je funkce Automatické připojení aktivní. Na kartě Zobrazení ve skupině Vizuální pomůcky ověřte, že je zaškrtnuté políčko Automatické připojení.

  2. Přetáhněte obrazec z podokna Obrazce na stránku

  3. Podržte ukazatel myši nad obrazcem, dokud se kolem něj nezobrazí šipky pro automatické spojení.

    Když je funkce automatického spojení aktivní, umístěte ukazatel myši na obrazec, aby se zobrazily šipky spojení.
  4. Podržte ukazatel myši nad šipkou v tom směru, kam chcete přidat obrazec.

    Když na šipku automatického spojení umístíte ukazatel myši, zobrazí se panel nástrojů s obrazci, které můžete přidat.

    Zobrazí se minipanel nástrojů obsahující první čtyři rychlé obrazce, které jsou momentálně ve vzorníku Rychlé obrazce. Pokud nastavíte ukazatel myši na obrazec na panelu nástrojů, Visio zobrazí náhled tohoto obrazce na stránce.

  5. Klikněte na obrazec, který chcete přidat.

  6. Pokud chcete pokračovat, přejděte myší na šipku automatického připojení na nově přidaném obrazci a přidejte jiný obrazec, který bude také automaticky připojen.

    Když na nově přidaný obrazec umístíte ukazatel myši, zobrazí se šipky automatického spojení pro přidání dalšího obrazce.

Začátek stránky

Spojování obrazců, které už jsou na stránce

Tip: Příkazy ve skupině Nástroje na kartě Domů přepnou Visio do jiného stavu nebo režimu, což může být někdy matoucí. Pomocí klávesnice můžete pohodlně přepínat mezi nástroji Ukazatel Výběr objektů (stiskněte Ctrl+1) a Spojnice Obrázek tlačítka (stiskněte Ctrl + 3). Ať už používáte jakýkoli nástroj, například Blok textu nebo Spojovací bod, opakovaným stisknutím klávesy Esc se vrátíte k nástroji Ukazatel.

  1. Na kartě Domů klikněte ve skupinovém rámečku Nástroje na položku Spojnice Obrázek tlačítka nebo stiskněte Ctrl+3.

  2. Klikněte na obrazec a přetáhněte spojnici na jiný obrazec.

  3. Potom na kartě Domů klikněte ve skupině Nástroje na tlačítko Ukazatel Výběr objektů nebo stiskněte Ctrl+1.

Nástroj Spojnice spojuje obrazce s bodovým spojením na každém konci.

Můžete také přidat na pás karet příkaz Spojit obrazce a používat ho ke spojení více obrazců v pořadí, ve kterém byly vybrány.

Tip: Užitečné příkazy, které ještě nejsou na pásu karet, se dají přidat kliknutím na Soubor > Možnosti > Přizpůsobit pás karet.

Začátek stránky

Připojení k obrazci na jiné stránce

Spojnice můžete použít jenom mezi obrazci na stejné stránce. Pokud chcete provést připojení k obrazci na jiné stránce, použijte obrazec Odkaz na jinou stránku, který vytvoří hypertextový odkaz z jedné stránky na jinou, nebo k některému obrazci přidejte Hypertextový odkaz a akci Poklikání, aby mohl navigovat na jinou stránku ve stejném dokumentu.

Použití obrazce Odkaz na jinou stránku

  1. Otevřete vzorník Obrazce základních vývojových diagramů a potom přetáhněte obrazec Odkaz na jinou stránku na aktuální stránku.

    Obrazec Odkaz na jinou stránku
  2. V dialogovém okně Odkaz na jinou stránku výběrem OK přidejte obrazec na aktuální stránku a nově vytvořenou stránku.

  3. Na nové stránce pokračujte vytvořením diagramu.

  4. Pokud chcete změnit vzhled obrazce Odkaz na jinou stránku, klikněte pravým tlačítkem myši na obrazec a pak vyberte Odchozí, Příchozí, Kruh nebo Šipka.

Mezi stránkami můžete přecházet tak, že na libovolné stránce poklikáte na obrazec Odkaz na jinou stránku. Další informace najdete v tématu Dialogové okno Odkaz na jinou stránku.

Použití hypertextového odkazu a poklikání

  1. Pravým tlačítkem myši klikněte na jakýkoli obrazec nebo stiskněte CTRL+K a pak vyberte Hypertextový odkaz.

  2. Klikněte na Procházet vedle pole Podadresa a pak klikněte na rozevírací seznam vedle položky Stránka a vyberte požadovanou stránku.

    Dialogové okno Hypertextový odkaz

    Poznámka: Jako hypertextový odkaz jde také zadat název obrazce na cílové stránce. Klikněte na kartu Vývojář a pak vyberte Název obrazce. Použijte výchozí název v poli Název, nebo ho upravte, a potom klikněte na OK.

  3. Pokud chcete nastavit akci při poklikání obrazce, klikněte na kartu Vývojář a pak vyberte Chování.

  4. Klikněte na kartu Poklikání, vyberte možnost Přejít na stránku, potom klikněte na rozevírací seznam a vyberte požadovanou stránku.

    Akce Poklikání ve Visiu

    Poznámka: Proveďte to až po upravení názvů stránek, protože se tady automaticky neaktualizují.

Začátek stránky

Použití motivů ke změně vzhledu spojnice

I když výchozím vzhledem spojnic můžou být jednoduché čáry, dají se upravit pomocí motivů, které přidávají různé ozdobné prvky, jako třeba hroty šipek. Předdefinované motivy můžete použít z galerie Motivy na kartě Návrh.

Poznámky: 

  • Pokud chcete zobrazit další ozdobné prvky, klikněte na kartu Návrh. Ve skupině Varianty klikněte na šipku rozevíracího seznamu a pak vyberte Spojnice.

Použití alternativních obrazců spojnic

Všechny obrazce spojnic, například ty ve vzorníku Další obrazce > Visio Extra > Spojnice, můžou sloužit ke spojení obrazců místo výchozího obrazce Dynamická spojnice. Tyto obrazce spojnic můžete přetáhnout na stránku nebo je vybrat a použít s nástroji Spojnice a Spojit obrazce nebo s nimi jednoduše nahradit stávající spojnice.

  1. Otevřete vzorník obsahující alternativní obrazce spojnic.

  2. Vyberte na stránce stávající spojnice, které chcete nahradit.

  3. Na kartě Domů klikněte ve skupině Úpravy na Změnit obrazec a pak vyberte požadovaný obrazec spojnice.

Poznámka: Funkce Změnit obrazec se objevila ve Visiu 2013, ale nástroje Spojnice a Spojit obrazce byly zavedeny před Visiem 2007.

Začátek stránky

Změna obrazců na minipanelu nástrojů Automatické připojení

Obrazce na minipanelu nástrojů pocházejí ze vzorníku diagramu Rychlé obrazce. Minipanel nástrojů zobrazuje až čtyři obrazce. Obrazce zobrazované na minipanelu obrazců si můžete přizpůsobit. V následujícím postupu je jako příklad použitý Základní diagram

  1. Ve výchozím nastavení obsahuje minipanel nástrojů první čtyři obrazce ze vzorníku, který bezprostředně následuje po vzorníku Rychlé obrazce. Níže jsou například zobrazené první čtyři obrazce ve vzorníku Základy.

    Minipanel nástrojů s výchozími základními obrazci
  2. Pokud chcete pro určitý vzorník v minipanelu nástrojů zobrazit jiné obrazce, můžete změnit pořadí obrazců jejich přetažením do horní části vzorníku. Můžete například přetáhnout obrazce Čtyřcípá hvězda, Pěticípá hvězda, Šesticípá hvězda a Sedmicípá hvězda do horní části vzorníku Základy.

    Minipanel nástrojů s novými základními obrazci
  3. Můžete také změnit pořadí vzorníků jejich přetažením výš nebo níž v podokně Obrazce. Podmnožina těchto obrazců se zobrazí ve vzorníku Rychlé obrazce a to ve stejném pořadí, v jakém jsou zobrazené v podokně Obrazce. Když například v podokně Obrazce přetáhnete vzorník Ozdobné obrazce hned za vzorník Rychlé obrazce, změní se pořadí ve vzorníku Rychlé obrazce.

    Minipanel nástrojů s jiným vzorníkem po změně pořadí

    Poznámka: Po zavření a opětovném otevření diagramu se automaticky obnoví výchozí pořadí vzorníků v podokně Obrazce, což se projeví také ve vzorníku Rychlé obrazce.

  4. Pokud chcete jako základ pro minipanel nástrojů použít jiný vzorník, vyberte ve vzorníku Rychlé obrazce obrazec v podmnožině obrazců požadovaného vzorníku. Vyberte například Vennův diagram ve vzorníku Grafy a matematické obrazce.

    Minipanel nástrojů s novým vzorníkem po výběru

Tip: Pokud chcete obnovit výchozí posloupnost obrazců ve vzorníku, klikněte pravým tlačítkem myši na název vzorníku v podokně Obrazce a pak vyberte Obnovit vzorník.

Poznámka: Ne všechny vzorníky mají obrazce, které je možné použít na minipanelu nástrojů. Například obrazce ve vzorníku Obrazce šipek se na minipanelu nástrojů nezobrazí.

Začátek stránky

Zapnutí nebo vypnutí funkce automatického spojení

Můžete aktivovat a deaktivovat automatické spojení pro aktuální výkres nebo jako výchozí nastavení pro všechny výkresy Visia.

Zapnutí nebo vypnutí funkce automatického spojení v aktivním diagramu

  • Na kartě Zobrazení zaškrtněte ve skupinovém rámečku Vizuální pomůcky políčko Automaticky připojit.

    Zaškrtnutím nebo zrušením zaškrtnutí políčka Automaticky připojit na kartě Zobrazení můžete aktivovat nebo deaktivovat funkci automatického spojení.

Pokud zaškrtávací políčko Automaticky připojit není dostupné, zkontrolujte pomocí následujícího postupu, jestli není funkce automatického spojení vypnuta pro všechny diagramy.

Zapnutí nebo vypnutí funkce automatického spojení ve všech diagramech

  1. Klikněte na kartu Soubor a pak na tlačítko Možnosti.

  2. V dialogovém okně Možnosti aplikace Visio klikněte na Upřesnit.

  3. Ve skupinovém rámečku Možnosti úprav zaškrtnutím políčka Povolit automatické spojení zapnete funkci automatického spojení. Pokud chcete funkci automatického spojení vypnout, zaškrtnutí tohoto políčka zrušte.

    Zaškrtnutím nebo zrušením zaškrtnutí políčka Povolit automatické spojení můžete aktivovat nebo deaktivovat funkci automatického spojení pro všechny diagramy a výkresy.
  4. Klikněte na OK.

Začátek stránky

Spojení obrazců pomocí funkce automatického spojení

Jednou z možností spojení obrazců je nechat je ve Visiu spojovat automaticky při přidávání obrazců do výkresu. To je vhodné zejména při vytváření vývojového diagramu.

Pomocí následujícího postupu přidáte do výkresu obrazec, který aplikace Visio automaticky spojí s existujícím obrazcem.

Použití automatického spojení při přetažení obrazců na stránku

  1. Přetáhněte obrazec ze vzorníku na stránku výkresu a umístěte ho poblíž jiného obrazce.

    Obrazec umístěný blízko jiného obrazce.

  2. Podržte stisknuté tlačítko myši a umístěte ukazatel nad některý z modrých trojúhelníků. Trojúhelník změní barvu na tmavě modrou.

    Přesunutí ukazatele nad modrý trojúhelník způsobí změnu barvy trojúhelníku na tmavě modrou.

  3. Uvolněte tlačítko myši. Obrazec se umístí na stránku výkresu a k oběma obrazcům je přidána a připevněna spojnice.

    Obrazec je umístěn na stránku výkresu a k oběma obrazcům je přidána a připevněna spojnice.

Tip: Pokud neradi přetahujete obrazce, můžete dosáhnout stejného výsledku tak, že vyberete požadovaný obrazec ve vzorníku, umístíte ukazatel nad obrazec ve výkresu a potom kliknete na některý z modrých trojúhelníků zobrazených u obrazce.

Použití automatického spojení s obrazci, které už jsou na stránce

  1. Umístěte ukazatel nad obrazec, ze kterého chcete spojení vytvořit.

    Ukazatel přesunutý nad obrazec, ze kterého chcete spojení vytvořit

  2. Přesuňte ukazatel na modrý trojúhelník nejblíže k obrazci, ke kterému se chcete připojit.

    Ukazatel je umístěn na modrém trojúhelníku nejblíže k obrazci, který chcete připojit.

    Trojúhelník změní barvu na tmavě modrou a okolo cílového obrazce se objeví červený rámeček.

    Poznámka: Pokud se kolem cílového obrazce neobjeví červený rámeček, je tento obrazec možná příliš daleko. Přesuňte obrazec blíž a zkuste to znovu nebo použijte nástroj Spojnice.

  3. Klikněte na modrý trojúhelník. K oběma obrazcům je přidána a připevněna spojnice.

    Obrazec je umístěn na stránku výkresu a k oběma obrazcům je přidána a připevněna spojnice.

Povolení nebo zakázání funkce automatického spojení

Můžete povolit nebo zakázat funkci automatického spojení pro všechny výkresy Visia nebo jenom pro aktuální výkres. Pro všechny výkresy:

  1. V nabídce Nástroje klikněte na Možnosti.

  2. Klikněte na kartu Obecné.

  3. V části Okno výkresu zaškrtněte políčko Povolit automatické spojení.

Jenom pro aktuální výkres:

  • Na panelu nástrojů Standardní klikněte na nástroj Automaticky připojit.

    Poznámka: Pokud kliknutím na nástroj Automaticky připojit nepovolíte automatické spojení, zkontrolujte, jestli je zaškrtnuté políčko Povolit automatické spojení v dialogovém okně Možnosti.

Spojení obrazců pomocí nástroje Spojnice

Jedním z nejpružnějších způsobů, jak přidat a připevnit spojnici, je nakreslení spojnice pomocí nástroje Spojnice Obrázek tlačítka , který je dostupný na panelu nástrojů Standardní.

  1. Na panelu nástrojů Standardní klikněte na nástroj Spojnice Obrázek tlačítka .

  2. Proveďte jednu z následujících akcí:

    • Pokud chcete spojnici připevnit ke konkrétnímu bodu na obrazci, přetáhněte ukazatel myši ze spojovacího bodu Vzhled spojovacího bodu – modrý křížek na prvním obrazci do spojovacího bodu na druhém obrazci. Když se obrazce propojí, koncové body spojnice zčervenají. Tomu se říká spojení typu bod k bodu. Když použijete tento typ spojení, a některý z obrazců přesunete, zůstane spojnice připevněná ke stejným spojovacím bodům.

    • Pokud chcete, aby se spojnice přesunula k nejbližšímu dostupnému spojovacímu bodu, umístěte nástroj Spojnice na střed prvního obrazce tak, aby se kolem něj zobrazil červený rámeček. Podržte tlačítko myši a přetáhněte spojnici na střed druhého obrazce. Když se kolem druhého obrazce zobrazí červený rámeček, uvolněte tlačítko myši. Tomu se říká spojení typu obrazec k obrazci. Když použijete tento typ spojení, a některý z obrazců přesunete, zůstane spojnice připevněná ke každému obrazci, ale přesune se na nejbližší spojovací bod. Pokud nejsou dostupné žádné spojovací body, přesune se spojnice na nejbližší strany.

      Poznámka: Můžete také vytvořit takové spojení mezi obrazci, kde je jeden konec spojnice připojený ke spojovacímu bodu a druhý konec spojnice je připojený k obrazci (a naopak).

  3. Když se budete chtít vrátit k běžným úpravám, klikněte na panelu nástrojů Standardní na nástroj Ukazatel Tlačítko Ukazatel .

    Poznámky: 

    • Pokud chcete přidat spojnici z jednoho obrazce k několika obrazcům, musíte použít několik spojnic. Neexistuje žádný „větvený“ obrazec spojnice.

    • Pokud se pokoušíte vytvořit spojení typu bod k bodu a nedaří se vám připevnit spojnici přesně na požadované místo, vyzkoušejte různá nastavení přichycení a připevnění:

    • V nabídce Nástroje klikněte na Přichytit a připevnit a potom na kartě Obecné vyberte požadované možnosti.

      Pokud chcete spojnici připevnit ke geometrii, úchytu nebo vrcholu obrazce, automaticky se přidá spojovací bod, pokud ještě neexistuje.

Přepínání mezi spojením k obrazci a k bodu

Spojnice můžete připevnit z jednoho bodu na obrazci k jinému bodu na jiném obrazci nebo z celého obrazce k jinému celému obrazci. Můžete také vytvořit spojení, kdy je jeden konec spojnice připevněný k bodu na obrazci a druhý konec spojnice k celému obrazci.

  1. Přetáhněte koncový bod spojnice mimo obrazec.

  2. Udělejte jednu z těchto věcí:

    • Abyste připevnili koncový bod spojnice ke spojovacímu bodu na obrazci, přetáhněte koncový bod k některému ze spojovacích bodů obrazce, až se kolem spojovacího bodu zobrazí červený rámeček.

    • Pokud chcete připevnit koncový bod spojnice k celému obrazci, přetáhněte koncový bod ke středu obrazce, až se kolem celého obrazce zobrazí červený rámeček.

Viz taky

Přidání a úprava textu spojnice

Vytvoření vlastní spojnice

Připevnění nebo zrušení připevnění spojnic

Školení pro Visio

Všechno, co potřebujete vědět o spojnicích Visia (blog týmu Visio)

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×