Office
Přihlásit se

Přidání datového připojení webové služby

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Jedno nebo více sekundárního datového připojení můžete přidat do šablony formuláře, který můžete dotazu nebo odeslat data webové služby.

V tomto článku

Základní informace

Důležité informace o kompatibilitě

Než začnete

Přidání datového připojení dotazu

Přidání datového připojení pro odesílání

Základní informace

Sekundárního datového připojení je jakékoli datové připojení k externímu zdroji dat, které přidáte do šablony formuláře. Datové připojení se liší od hlavní datové připojení, která se vytvoří při navrhování šablony formuláře založené na databáze, webové služby nebo nastavení v knihovně připojení. Přidejte sekundárního datového připojení jenom při splnění nelze dotazu nebo odešlete data prostřednictvím datového připojení.

Pokud přidáte sekundárního datového připojení k šabloně formuláře získávání dat, Microsoft Office InfoPath vytvoří sekundární Zdroj dat s datová pole a skupiny, který odpovídá Schéma XML webové služby. Protože struktura dat v sekundární zdroj dat se musí shodovat schéma XML, nelze změnit existující pole nebo skupiny v sekundární zdroj dat. Po přidání připojení pro odesílání dat do šablony formuláře nakonfigurovat uživatelům povolit odesílání dat formuláře v šabloně formuláře a můžete nakonfigurovat možnosti odeslání formuláře založené na šabloně formuláře.

Začátek stránky

Důležité informace o kompatibilitě

Datové připojení pro odesílání nejde nakonfigurovat v Šablona formuláře kompatibilní s prohlížečem povolit uživatelům odeslat změnit informace spolu s jejich dat formuláře do webové služby, která přijímá Microsoft ADO.NET DataSet. Informace o změnách se změny, které uživatel udělá dat uložených v databázi. Databázi používá webové služby pro připojení k databázi uživatelů. ADO.NET můžete změnit informace a zjistěte, jak aktualizovat data v databázi. Požádejte správce webu služby pokud webová služba vyžaduje jak měnit informace o aktualizaci databáze. Pokud ano, by návrh šablony formuláře, jejíž formuláře lze vyplnit pouze pomocí aplikace InfoPath.

Začátek stránky

Než začnete

Než přidáte sekundárního datového připojení do šablony formuláře, musíte tyto informace ze správce webové služby:

  • Umístění webové služby.

  • Ověření, že webová služba používá doslovné dokumentu kódování. Aplikace InfoPath můžete využívat pouze dokumentu/literál stylu webové služby.

  • Název operaci webové služby, odešlete data nebo přijímání dat z formuláře založené na této šabloně.

Začátek stránky

Přidání datového připojení dotazu

Pokud chcete uživatelům umožnit dotaz na data z webové služby pomocí šablony formuláře, musíte udělat v šabloně formuláře následující kroky:

  1. Přidání sekundárního datového připojení.

  2. Konfigurace šablony formuláře na používání sekundárního datového připojení.

Krok 1: Přidání sekundárního datového připojení

  1. V nabídce Nástroje klikněte na Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na Přidat.

  3. V Průvodci datovým připojením klikněte na vytvořit nové připojení k, klikněte na přijmout data a klikněte na tlačítko Další.

  4. Ve skupinovém rámečku, ze které chcete zobrazit data klikněte na Webová služba a klikněte na tlačítko Další.

  5. Na další stránce průvodce zadejte umístění webové služby a klikněte na tlačítko Další.

    Poznámka: Pokud chcete hledat webové služby pomocí serveru univerzální popis zjišťování a hodnocení integrace UDDI (), klikněte na Hledat UDDI, zadejte adresu URL UDDI serveru, na kterém chcete hledat, zadejte, jestli chcete najít poskytovatele nebo služba k dispozici, zadejte klíčové slovo pro hledání a klikněte na Hledat. Webové služby, které odpovídají vaší klíčové slovo pro hledání se zobrazí v seznamu výsledků hledání. Vyberte webová služba, kterou chcete použít a klikněte na tlačítko OK.

  6. V seznamu Vyberte operaci na další stránce průvodce klikněte na operaci webové služby, který vrací data do formuláře a klikněte na tlačítko Další.

  7. Pokud Průvodce datovým připojením narazí neznámý prvek schématu webové služby, na další stránce průvodce můžete zadat ukázkové hodnoty všech parametrů rozhodnout, která pole nebo skupiny, které chcete přidat do hlavního zdroje dat požádat.

    Jak na to?

    1. Vyberte parametru v tabulce Parametry a potom klikněte na Nastavit ukázkovou hodnotu.

    2. V poli Ukázka hodnota zadejte hodnotu, že uživatel může použít pro toto pole a klikněte na tlačítko OK.

    3. Opakujte tento postup pro každý parametr v tabulce Parametry a klikněte na tlačítko Další.

    Podrobné technické informace

    Při konfiguraci datového připojení webové služby v Průvodci datovým připojením aplikace Microsoft Office InfoPath připojí k webové službě a požadavky Web služby (soubor Description Language WSDL). Soubor WSDL obsahuje schématu pomocí webové služby. Webová služba odpoví na žádost tak, že tento soubor aplikace InfoPath. Pro přidání příslušná pole a skupiny do sekundární zdroj dat v šabloně formuláře aplikace InfoPath používají informace v tomto souboru. Pokud aplikace InfoPath najde typu neznámý prvek v souboru WSDL, InfoPath používá ukázková data k určení definici typu neznámý prvek a potom přidá odpovídající pole a skupiny do sekundární zdroj dat.

  8. Pokud chcete výsledky dotazu, aby byl k dispozici, když formuláři není připojený k síti, zaškrtněte políčko Uložit kopii data v šabloně formuláře.

    Poznámka zabezpečení: Výsledky dotazu zaškrtnutí tohoto políčka ukládá v šabloně formuláře. Protože jsou data uložena v šabloně formuláře, je k dispozici ve formulářích, které uživatelé vyplňovat uživatelé, i když počítačích nejste připojení k síti. Pokud se zobrazují citlivá data z tohoto datového připojení, můžete k zakázání této funkce se můžete pomoci chrá data v případě ztráty či krádeže počítače.

  9. Klikněte na tlačítko Další.

  10. Na další stránce průvodce zadejte popisný název datového připojení dotazu.

  11. Povolit formuláře založené na této šabloně automaticky obnoví data při otevření, zaškrtněte políčko automaticky obnoví data při otevření formuláře.

  12. Zkontrolujte správné informace v části Souhrn a potom klikněte na Dokončit.

  13. Klikněte na Zavřít.

Krok 2: Nakonfigurujte šablony formuláře na používání sekundárního datového připojení

Datové připojení dotazu přidáte do šablony formuláře, ve výchozím nastavení formuláře založené na této šabloně formuláře pomocí datového připojení otevřeném uživatelem. Můžete taky nakonfigurovat šablony formuláře použití datového připojení dotazu v jednom z těchto způsobů:

  • Přidání pravidla    Můžete nakonfigurovat pravidlo pro použití datového připojení dotazu při každém výskytu podmínka pravidla.

  • Tlačítko Přidat    Přidání tlačítka na šablonu formuláře, který uživatelů můžou kliknout na získání dat pomocí datového připojení dotazu.

  • Použití vlastního kódu    Pokud nemůžete přidat pravidla nebo tlačítka, můžete použít vlastní kód k získání dat pomocí datového připojení dotazu. Použití vlastního kódu vyžaduje vývojář k vytvoření vlastního kódu.

Add a rule

Přidání pravidla do šablony formuláře k načtení dat z datové připojení dotazu kdykoli splnění podmínky pravidla. Následující postup předpokládá, že jste vytvořili datové připojení dotazu pro šablonu formuláře a že jste nakonfigurovali ovládacího prvku v šabloně formuláře pro zobrazení dat z daného datového připojení.

  1. Pokud šablona formuláře obsahuje více zobrazení, klikněte v nabídce Zobrazit přejděte na zobrazení s ovládacím prvkem, ve které chcete zobrazit data z sekundární zdroj dat na název zobrazení.

  2. Poklepejte na ovládací prvek, který chcete přidat pravidlo.

  3. Klikněte na kartu Data.

  4. V části ověření a pravidla klikněte na pravidla.

  5. V dialogovém okně pravidla klikněte na Přidat.

  6. Do pole název zadejte název pravidla.

  7. Chcete-li podmínky když by měla běžet pravidlo, klikněte na Nastavit podmínku a zadejte podmínka. Pravidlo se spustí, když dojde k podmínka. Pokud není nastavený podmínky, pravidla se spustí pokaždé, když uživatel změní hodnotu v ovládacím prvku a přejde přihlásil kurzor směrem od tohoto ovládacího prvku.

  8. Klikněte na Přidat akci.

  9. V seznamu Akce klikněte na dotazu pomocí datového připojení.

  10. V seznamu datové připojení klikněte na datové připojení dotazu, které chcete použít a potom klikněte na OK zavřete všechna otevřená dialogová okna.

  11. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

Přidání tlačítka

Přidání ovládacího prvku tlačítka do šablony formuláře mohou uživatelé klepnout k načtení dat z datové připojení dotazu. Následující postup předpokládá, že jste vytvořili datové připojení dotazu pro šablonu formuláře.

  1. Pokud šablona formuláře obsahuje více zobrazení, klikněte v nabídce Zobrazit přejděte na zobrazení s ovládacím prvkem, ve které chcete zobrazit data z sekundární zdroj dat na název zobrazení.

  2. Pokud není vidět podokno úloh Ovládací prvky, klikněte na Další ovládací prvky v nabídce Vložit nebo stiskněte klávesy ALT+I, C.

  3. Přetáhněte ovládací prvek tlačítko na vaší šabloně.

  4. Poklikejte na tlačítko, které jste právě přidali do šablony formuláře.

  5. Klikněte na kartu Obecné.

  6. V seznamu Akce klikněte na Aktualizovat.

  7. Do pole Popisek zadejte název, který se má zobrazit na tlačítko v šabloně formuláře.

  8. Klikněte na tlačítko Nastavení.

  9. V dialogovém okně aktualizace klikněte na jeden sekundární zdroj dat.

  10. V seznamu vyberte sekundární zdroj dat klikněte na sekundární zdroj dat, který bude přidružený datového připojení pro dotazy a potom klikněte na OK zavřete všechna otevřená dialogová okna.

  11. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

Začátek stránky

Přidání datového připojení pro odesílání

Umožňuje uživatelům odeslání formuláře založené na šabloně formuláře do webové služby nejdřív přidat sekundárního datového připojení do šablony formuláře, které odesílá data a nakonfigurujte šablony formuláře umožníte uživatelům odesílání dat formuláře.

Krok 1: Přidání sekundárního datového připojení

  1. V nabídce Nástroje klikněte na Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na Přidat.

  3. V Průvodci datovým připojením klikněte na vytvořit nové připojení k, klikněte na Odeslat data a klikněte na tlačítko Další.

  4. V části, jak chcete odeslat data klikněte na webová služba a klikněte na tlačítko Další.

  5. Na další stránce průvodce zadejte umístění webové služby, kde uživatelé budou odesílat data a klikněte na tlačítko Další.

    Poznámka: Pokud chcete hledat webové služby pomocí serveru univerzální popis zjišťování a hodnocení integrace UDDI (), klikněte na Hledat UDDI, zadejte adresu URL UDDI serveru, na kterém chcete hledat, zadejte, jestli chcete najít poskytovatele nebo služba k dispozici, zadejte klíčové slovo pro hledání a klikněte na Hledat. Webové služby, které odpovídají vaší klíčové slovo pro hledání se zobrazí v seznamu výsledků hledání. Vyberte webová služba, kterou chcete použít a klikněte na tlačítko OK.

  6. V seznamu Vyberte operace klikněte na operaci webové služby, které bude přijímání dat formuláře a klikněte na tlačítko Další.

  7. Na další stránce průvodce vyberte jaká data ve formuláři můžou odeslat pro každý parametr webové služby, provedením jedné z následujících akcí:

    Odeslání dat do pole nebo skupiny

    1. V seznamu Parametry klikněte parametr webové služby, který zobrazí data z formuláře.

    2. Ve skupinovém rámečku Možnosti parametrů klikněte na pole nebo skupiny.

    3. Klikněte na Upravit Vzhled tlačítka .

    4. V dialogovém okně Vybrat pole nebo skupiny klikněte na pole nebo skupiny, jejichž data, které chcete odeslat a potom klikněte na OK.

    5. V dialogovém okně Zahrnout klikněte na Text a podřízené elementy chcete odeslat pouze data v tomto poli a podřízené elementy pole nebo skupiny, nebo klikněte na dílčí stromová struktura XML, včetně vybraný prvek můžou odeslat název pole data v poli, a podřízené elementy ve vybrané skupině nebo pole.

    Odeslání všech dat ve formuláři

    1. V seznamu Parametry klikněte parametr webové služby, který zobrazí data z formuláře.

    2. Ve skupinovém rámečku Možnosti parametrů klikněte na celý formulář (dokument ve formátu XML, včetně instrukce pro zpracování).

    Odeslání dat jako řetězec

    1. V seznamu Parametry klikněte parametr webové služby, který zobrazí data z formuláře.

    2. Ve skupinovém rámečku Možnosti parametrů klikněte na celý formulář (dokument ve formátu XML, včetně instrukce pro zpracování).

    3. Zaškrtněte políčko Odeslat data jako řetězec.

      Poznámka: Obvykle zaškrtnete toto políčko odeslat digitálně podepsanou data. Ve většině případů zrušte zaškrtnutí políčka.

    Technická upozornění o ADO.NET datovou sadu objektů

    Pokud webová služba vyžaduje objektu ADO.NET datovou sadu, vyberte datovou sadu uzel při konfiguraci tohoto datového připojení. Pokud používáte jiný typ uzel pro datové připojení webové služby, který vyžaduje objekt ADO.NET datovou sadu, akce odeslání se nezdaří.

  8. Klikněte na tlačítko Další.

  9. Na další stránce průvodce zadejte název datového připojení pro odesílání.

  10. Zkontrolujte správné informace v části Souhrn a potom klikněte na Dokončit.

  11. Klikněte na Zavřít.

Po přidání datového připojení pro odesílání sekundární musíte nakonfigurovat uživatelům umožnit odesílat datové připojení pro odesílání dat formuláře pomocí této šablony formuláře.

Krok 2: Povolit odesílání v šabloně formuláře

Při konfiguraci šablony formuláře umožníte uživatelům odesílání dat formuláře aplikace InfoPath přidá tlačítko Odeslat na panelu nástrojů Standardní a příkaz Odeslat do nabídky soubor ve formuláři. Můžete také upravit možnosti odesílání pro šablonu formuláře následujícími způsoby:

  • Změňte text, který se zobrazí na tlačítko Odeslat a příkaz Odeslat.

  • Změna klávesové zkratky pro tlačítko Odeslat a příkaz Odeslat.

  • Vytvoření vlastních zpráv, které se uživateli zobrazí při odeslání formuláře.

  • Určete, zda chcete ponechat formulář otevřený, zavřete formulář nebo otevřít nový prázdný formulář po odeslání formuláře.

  • V nabídce Nástroje klikněte na Možnosti odeslání.

  • V dialogovém okně Možnosti odeslání zaškrtněte políčko Povolit uživatelům odeslat tento formulář, klikněte na odesílání dat formuláře do jednoho umístění a potom v seznamu, klikněte na Webová služba.

  • V seznamu Vybrat datové připojení pro odesílání klepněte na název datového připojení pro odesílání webové službě jste vytvořili v předchozích krocích.

    1. Pokud chcete změnit jméno tlačítko Odeslat, které se zobrazí na panelu nástrojů Standardní a příkaz Odeslat, který se zobrazí v nabídce soubor při vyplňování formuláře, zadejte nový název do pole Titulek v Odeslat Možnosti dialogové okno.

      Tip: Pokud chcete přiřadit klávesovou zkratku na toto tlačítko a příkaz, zadejte znak ampersand (&) před znak, který chcete použít jako klávesové zkratky. ALT + B přiřadit jako klávesové zkratky pro tlačítko Odeslat a příkaz, zadejte například & deslat.

  • Pokud nechcete, aby lidi, aby použili příkaz Odeslat nebo tlačítko Odeslat na panelu nástrojů Standardní při vyplňování formuláře, zrušte zaškrtnutí políčka Zobrazit na položku Odeslat nabídky a tlačítko na panelu nástrojů odeslat.

    1. Ve výchozím nastavení po odeslání formuláře aplikace InfoPath ponechá formulář otevřený a zobrazí zprávy, která označuje, pokud byla úspěšně odeslání formuláře. Chcete-li změnit výchozí chování, klikněte na položku Upřesnit a pak udělejte jednu z těchto věcí:

      • Zavřete formulář nebo vytvořte nový prázdný formulář po odeslání dokončené formuláře, klikněte na požadovanou možnost v seznamu Po odeslání.

      • Pokud chcete vytvořit vlastní zprávy, která označuje, pokud byla úspěšně odeslání formuláře, zaškrtněte políčko použít vlastní zprávy a zadejte svoje zprávy v polích na úspěšné a o chybě.

        Tip: Umožňuje zprávu do pole na selhání sdělte uživatelům, co dělat, když nemohou odeslat formuláře. Můžete například navrhnout, aby uživatelé uložení formuláře a obrátit pro další pokyny.

      • Pokud nechcete zobrazit zprávu po odeslání formuláře, zrušte zaškrtnutí políčka Zobrazit úspěšné a neúspěšné zprávy.

Začátek stránky

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×