Přidání datového připojení pomocí nastavení v knihovně připojení

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

V tomto článku

Základní informace

Než začnete

Přidání datového připojení dotazu

Přidání datového připojení pro odesílání

Základní informace

Pokud navrhujete několik šablon formulářů používajících podobné datových připojení, zvažte použití soubor datového připojení místo abyste vytvářeli datového připojení k externímu zdroji dat u každé šablony formuláře. Tímto způsobem, musíte aktualizovat pouze jeden soubor datového připojení při změně informace o připojení pro sadu šablon pro odpovídajícího formuláře. Například Obsah přesouvaných šablon formulářů ze sítě test k síti výrobní, musíte aktualizovat data nastavení připojení jenom jednou v knihovně připojení namísto aktualizace datového připojení v jednotlivých šablonách formulářů. Pokud formuláře založené na šabloně formuláře, který používá soubor datového připojení používá datové připojení, datové připojení automaticky aktualizován nové nastavení.

Soubor datového připojení je soubor XML pomocí souboru .xml nebo UDCX příponu, který obsahuje informace o připojení pro jeden externí zdroj dat. Tento soubor uložený v knihovně datových připojení na serveru Microsoft Office SharePoint Server 2007. Soubor datového připojení se vytvoří vývojář nebo když převedete datové připojení v existující šablony formuláře do soubor datového připojení kliknutím na tlačítko Převést v dialogovém okně Datových připojení (nabídkaNástroje ).

Výhody používání soubory datových připojení, patří:

  • Stejný soubor datového připojení, může používat více formulářů, takže není nutné k vytvoření stejného datového připojení přímo u každé šablony formuláře.

  • Je-li změnit nastavení umístění nebo připojení k externímu zdroji dat, potřebujete aktualizovat jenom soubor datového připojení, nikoli každou šablonu formuláře.

  • Soubor datového připojení může obsahovat alternativní ověřovací informace, které lze serverem při vyplňování formuláře pomocí webového prohlížeče.

  • Formuláře založené na šabloně formuláře kompatibilní s prohlížečem vyplňované v prohlížeči můžete připojit k serverům v jiné doméně pouze u datových připojení, která používají soubory datových připojení.

Poznámka: Microsoft Office InfoPath používá datové připojení soubory, které následují za univerzální datové připojení verze 2.0 formátu. Tato verze je podmnožina verze 1.0 formátu používaný v aplikaci Microsoft Office FrontPage a v aplikaci Microsoft Excel. Aplikace InfoPath nelze použít soubory datových připojení ve verze 1.0 formátu.

Když přidáte datové připojení do šablony formuláře pomocí nastavení v knihovně datových připojení, vytvoříte sekundárního datového připojení v této šabloně. Datové připojení se liší od hlavní datové připojení, která se vytvoří při navrhování šablony formuláře založené na databáze, webové služby nebo nastavení v knihovně datových připojení. Přidejte sekundárního datového připojení jenom v případě, že nelze získat nebo odešlete data prostřednictvím datového připojení.

Začátek stránky

Než začnete

Chcete-li přidat datové připojení do šablony formuláře pomocí nastavení, které jsou uložené v knihovně datových připojení, je potřeba tyto údaje od správce webu:

  • Umístění serveru, na kterém běží Microsoft Office SharePoint Server 2007, která obsahuje na web obsahující knihovnu datových připojení

  • Název souboru datového připojení v knihovně datových připojení, který chcete použít

  • Určuje, zda soubor datového připojení obsahuje nastavení pro připojení dotazu dat nebo datového připojení pro odesílání

  • Jestli můžete nakonfigurovat bezpečně uložení výsledků dotazů ve formuláři pro použití v offline režimu, pokud nastavení pro datové připojení dotazu v šabloně formuláře

Začátek stránky

Přidání datového připojení dotazu

Chcete-li přidat datové připojení do šablony formuláře pomocí nastavení v knihovně připojení, je nutné provést následující postupy:

  1. Přidání sekundárního datového připojení k šabloně formuláře.

  2. Ovládací prvky svázat pole dotazu a data v sekundární zdroj dat.

  3. Konfigurace šablony formuláře pomocí datového připojení na tlačítko nebo pravidla.

Krok 1: Přidání sekundárního datového připojení

  1. V nabídce Nástroje klikněte na Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na Přidat.

  3. V Průvodci datovým připojením klikněte na Hledat připojení na serveru Microsoft Office SharePoint Server a klikněte na tlačítko Další.

  4. Na další stránce průvodce v seznamu webů klikněte na název webu na serveru Office SharePoint Server 2007 s knihovnou připojení.

    Osobní web není v seznamu

    Přidání webu do seznamu, postupujte takto:

    1. Klikněte na Spravovat weby.

    2. V dialogovém okně Spravovat weby klikněte na Přidat.

    3. Do pole Adresa URL zadejte umístění knihovny datových připojení.

    4. Do pole Zobrazovaný název zadejte název knihovny datových připojení. Tento název se zobrazí v seznamu webů v Průvodci datovým připojením.

    5. Klikněte na OK.

    6. Klikněte na Zavřít.

  5. Klikněte na název knihovny datových připojení zobrazit seznam souborů datových připojení, klikněte na název datového připojení souboru, který chcete použít pro toto připojení dat a klikněte na tlačítko Další.

  6. V závislosti na nastavení připojení v soubor datového připojení na další stránce průvodce vás může požádat o zadání ukázkových hodnot pro každý parametr.

    Jak určit ukázkové hodnoty?

    1. Vyberte parametru v tabulce Parametry a potom klikněte na Nastavit ukázkovou hodnotu.

    2. V poli Ukázka hodnota zadejte hodnotu, že uživatel může použít pro toto pole a klikněte na tlačítko OK.

    3. Opakujte tento postup pro každý parametr v tabulce Parametry a klikněte na tlačítko Další.

    Technické poznámky

    Při konfiguraci datového připojení webové služby v Průvodci datovým připojením aplikace Microsoft Office InfoPath připojí k webové službě a požadavky Web služby (soubor Description Language WSDL). Soubor WSDL obsahuje schématu pomocí webové služby. Webová služba odpoví na žádost tak, že tento soubor aplikace InfoPath. Pro přidání příslušná pole a skupiny do sekundární zdroj dat v šabloně formuláře aplikace InfoPath používají informace v tomto souboru. Pokud aplikace InfoPath najde typu neznámý prvek v souboru WSDL, InfoPath používá ukázková data k určení definici typu neznámý prvek a potom přidá odpovídající pole a skupiny do sekundární zdroj dat.

  7. Pokud chcete výsledky dotazu, aby byl k dispozici, když formuláři není připojený k síti, zaškrtněte políčko Uložit kopii data v šabloně formuláře.

    Poznámka zabezpečení: Výsledky dotazu zaškrtnutí tohoto políčka ukládá v šabloně formuláře. Protože jsou data uložena v šabloně formuláře, je k dispozici ve formulářích, které uživatelé vyplňovat uživatelé, i když počítačích nejste připojení k síti. Pokud se zobrazují citlivá data z tohoto datového připojení, můžete k zakázání této funkce se můžete pomoci chrá data v případě ztráty či krádeže počítače.

  8. Klikněte na tlačítko Další.

    Další stránka Průvodce zobrazí souhrn nastavení tohoto datového připojení.

  9. Zadejte popisný název datového připojení. Tento název se zobrazí v seznamu Zdroje dat v podokně úloh Zdroj dat.

  10. Povolit formuláře založené na této šabloně, můžete toto připojení dat při otevření, zaškrtněte políčko automaticky obnoví data při otevření formuláře.

Začátek stránky

Krok 2: Přidání ovládací prvek, který zobrazí data pro vaše uživatele

  1. Pokud není vidět podokno úloh Ovládací prvky, klikněte na Další ovládací prvky v nabídce Vložit nebo stiskněte klávesy ALT+I, C.

  2. Přetáhněte ovládací prvek na šablonu formuláře.

  3. V dialogovém okně Vazba ovládacího prvku vyberte pole, které chcete navázat ovládací prvek a klikněte na OK.

Krok 3: Konfigurace šablony formulářů na datové připojení

Pokud chcete uživatelům načtení dat z datové připojení po otevření formuláře, vytvořit pravidlo můžete přidat do šablony formuláře, který používá datové připojení pod určitou podmínkou nebo přidání tlačítka na šablonu formuláře, pomocí kterého uživatelé můžou použít connec dat synchronizace.

Add a rule

Přidání pravidla do šablony formuláře kompatibilní datové připojení dotazu kdykoli splnění podmínky pravidla. Následující postup předpokládá, že jste vytvořili datové připojení dotazu pro šablonu formuláře a že jste nakonfigurovali ovládacího prvku v šabloně formuláře pro zobrazení dat z datové připojení.

  1. Pokud šablona formuláře obsahuje více zobrazení, klikněte v nabídce Zobrazit přejděte na zobrazení s ovládacím prvkem, ve které chcete zobrazit data z sekundární zdroj dat na název zobrazení.

  2. Poklepejte na ovládací prvek, který chcete přidat pravidlo.

  3. Klikněte na kartu Data.

  4. V části ověření a pravidla klikněte na pravidla.

  5. V dialogovém okně pravidla klikněte na Přidat.

  6. Do pole název zadejte název pravidla.

  7. Chcete-li podmínky když by měla běžet pravidlo, klikněte na Nastavit podmínku a zadejte podmínka. Pravidlo se spustí, když dojde k podmínka. Pokud není nastavený podmínky, pravidla se spustí pokaždé, když uživatel změní hodnotu v ovládacím prvku a přejde přihlásil kurzor směrem od tohoto ovládacího prvku.

  8. Klikněte na Přidat akci.

  9. V seznamu Akce klikněte na dotazu pomocí datového připojení.

  10. V seznamu datové připojení klikněte na datové připojení dotazu, které chcete použít a potom klikněte na OK zavřete všechna dialogová okna.

  11. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

Přidání tlačítka použití datového připojení dotazu

Přidání ovládacího prvku tlačítka do šablony formuláře mohou uživatelé klepnout při vyplňování formuláře založené na šabloně formuláře. Po kliknutí na toto tlačítko načtení dat z datové připojení dotazu.

  1. Pokud šablona formuláře obsahuje více zobrazení, klikněte v nabídce Zobrazit přejděte na zobrazení s ovládacím prvkem, ve které chcete zobrazit data z sekundární zdroj dat na název zobrazení.

  2. Pokud není vidět podokno úloh Ovládací prvky, klikněte na Další ovládací prvky v nabídce Vložit nebo stiskněte klávesy ALT+I, C.

  3. Přetáhněte ovládací prvek tlačítko na vaší šabloně.

  4. Poklikejte ovládací prvek, který jste právě přidali do šablony formuláře.

  5. Klikněte na kartu Obecné.

  6. V seznamu Akce klikněte na Aktualizovat.

  7. Do pole Popisek zadejte název, který se má zobrazit na tlačítko v šabloně formuláře.

  8. Klikněte na tlačítko Nastavení.

  9. V dialogovém okně aktualizace klikněte na jeden sekundární zdroj dat.

  10. V seznamu vyberte sekundární zdroj dat klikněte na sekundární zdroj dat, který je spojený s datovým připojením dotazu.

  11. Postupným kliknutím na tlačítka OK zavřete všechna otevřená dialogová okna.

  12. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

Začátek stránky

Přidání datového připojení pro odesílání

Obsahuje-li soubor datového připojení nastavení pro datové připojení pro odesílání, můžete nakonfigurovat šablony formuláře umožníte uživatelům odesílání dat formuláře prostřednictvím tohoto datového připojení. Konfigurace šablony formulářů umožníte uživatelům odesílání dat formuláře aplikace InfoPath přidá na panel nástrojů Standardní a příkazu Odeslat v nabídce soubor tlačítko Odeslat. Možnosti odeslání šablony formuláře můžete nakonfigurovat v dialogovém okně Možnosti odeslání (nabídkaNástroje ). Možnosti odeslání nakonfigurovaná stejným způsobem jako v případě, že jste přidali sekundárního datového připojení, která je datové připojení pro odesílání. Odkazy na další informace o přidávání datové připojení pro odesílání do šablony formuláře v části Viz také.

  1. V nabídce Nástroje klikněte na Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na Přidat.

  3. V Průvodci datovým připojením klikněte na Hledat připojení na serveru Microsoft Office SharePoint Server a klikněte na tlačítko Další.

  4. Na další stránce průvodce v seznamu webů klikněte na název webu s knihovnou připojení.

    Osobní web není v seznamu

    Přidání webu do seznamu, postupujte takto:

    1. Klikněte na Spravovat weby.

    2. V dialogovém okně Spravovat weby klikněte na Přidat.

    3. Do pole Adresa URL zadejte umístění knihovny datových připojení.

    4. Do pole Zobrazovaný název zadejte název knihovny datových připojení. Tento název se zobrazí v seznamu webů v Průvodci datovým připojením.

    5. Klikněte na OK.

    6. Klikněte na Zavřít.

  5. Klikněte na název knihovny datových připojení zobrazte seznam souborů datových připojení, klikněte na název, který chcete použít pro tento soubor datového připojení datové připojení pro odesílání a potom na tlačítko Další.

  6. Pokud nastavení pro odeslání datové připojení webové služby, aplikace InfoPath lze zjistit, jaké parametry webové služby můžete zobrazit data. Můžete nakonfigurovat datové připojení pro odesílání odeslání dat nebo jeho část data v šabloně formuláře.

    Jak na to?

    1. V seznamu Parametry klikněte na parametr, který zobrazí data z formuláře.

    2. Odeslání všech dat ve formuláři pro tento parametr, včetně kořenovém prvku a pokyny pro zpracování, postupujte takto:

      1. Klikněte na celý formulář (dokument ve formátu XML, včetně instrukce pro zpracování).

      2. Odeslat data jako řetězec, zaškrtněte políčko Odeslat data jako řetězec. Obvykle zaškrtnete toto políčko odeslat digitálně podepsanou data. Ve většině případů zrušte zaškrtnutí políčka.

    3. Chcete-li pole nebo skupiny pro tento parametr, postupujte takto:

      1. Ve skupinovém rámečku Možnosti parametrů klikněte na pole nebo skupiny.

      2. Klikněte na Upravit Vzhled tlačítka .

      3. V dialogovém okně Vybrat pole nebo skupiny klikněte na pole nebo skupiny, jejichž data, které chcete odeslat a potom klikněte na OK.

      4. V seznamu zahrnutí klikněte na Text a podřízené elementy a odeslat pouze obsah pole nebo skupiny, nebo klikněte na dílčí stromová struktura XML, včetně vybraný prvek chcete odeslat obsah i vybrané.

    4. Opakujte tento postup pro každý parametr.

  7. Klikněte na tlačítko Další.

  8. Datové připojení pro odesílání na další stránce průvodce, do pole Zadejte název tohoto datového připojení zadejte popisný název pro tento.

Začátek stránky

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×