Přidání datového připojení k databázi Microsoft Accessu

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Pokud vaši uživatelé potřebují dat z databáze Microsoft Office Access 2007 (ACCDB) nebo z databáze aplikace Access uložené v dřívější verzi (MDB) vyplňovat formuláře založené na šabloně formuláře aplikace Microsoft Office InfoPath, můžete přidat sekundárního datového připojení do formuláře Šablona, dotazy databáze aplikace Access.

Můžete přidat sekundárního datového připojení, ale tato datová připojení jenom dotazu databáze aplikace Access. Nemůžete přidat sekundárního datového připojení pro odesílání dat formuláře do databáze aplikace Access.

Pokud chcete uživatelům odesílání dat formuláře do databáze aplikace Access, můžete navrhnout šablonu formuláře, který je založený na databáze aplikace Access a povolení datového připojení pro odesílání hlavní datové připojení. Můžete taky můžete přidat sekundárního datového připojení k webové službě, se kterými spolupracuje databáze aplikace Access.

Odkazy na další informace o navrhování šablon formulářů, které jsou založeny na databáze aplikace Access a přidání sekundárního datového připojení webové služby v části Viz také.

V tomto článku

Základní informace

Důležité informace o kompatibilitě

Než začnete

Krok 1: Přidání sekundárního datového připojení

Krok 2: Nakonfigurujte šablony formuláře použití datového připojení

Základní informace

Sekundární Datové připojení je datové připojení, které přidáte do šablony formuláře. Sekundárního datového připojení se liší od hlavního datové připojení, které vytvoříte, když návrh nové šablony formuláře, který je založený na databázi nebo webové služby. Hlavní datové připojení šablony formuláře můžete zobrazit data z externího zdroje dat a můžete taky odeslání dat formuláře do externího zdroje dat. Šablony formuláře však může mít jenom jeden datového připojení.

Můžete přidat tolik sekundárního datového připojení do šablony formuláře jak chcete. Předpokládejme například, že Accesovou databázi obsahující tabulku, která obsahuje údaje o zaměstnancích a druhou tabulku, která jsou uložená data o zákaznících. Můžete přidat sekundárního datového připojení, která načte data v tabulce Zaměstnanci a také můžete přidat další sekundárního datového připojení, který načítá data z tabulky Zákazník ve stejné databázi aplikace Access.

I když sekundárního datového připojení můžete přidat do šablony formuláře, který můžete odeslání dat formuláře ke zdroji externích dat, jako jsou webové služby nebo knihovna služby Windows SharePoint Services, můžete použít pouze sekundárního datového připojení k načtení dat z aplikace Access databáze. Nemůžete přidat sekundárního datového připojení pro odesílání dat formuláře do databáze aplikace Access.

Když přidáte dotazu datového připojení k databázi, aplikace InfoPath vytvoří sekundární Zdroj dat obsahující datová pole a skupiny, které odpovídají způsobu uložení data v databázi. Vzhledem k tomu struktura dat v sekundární zdroj dat se musí shodovat způsobu uložení dat v databázových tabulkách, nelze měnit pole nebo skupiny v sekundární zdroj dat.

Můžete nakonfigurovat každého dotazu datového připojení pro uložení jeho výsledky, aby uživatelé měli přístup k datům, když formuláře není připojený k síti. Podle povahy data můžete zobrazit výsledky dotazu pouze v případě, že uživatelé připojení k síti.

Poznámka zabezpečení: Pokud používáte sekundárního datového připojení k načtení citlivá data z externího zdroje dat, můžete k zakázání této funkce se můžete pomoci chrá data před neoprávněným použitím v případě ztráty či krádeže počítače. Pokud jste tuto funkci zakázat, data budou dostupná jenom v případě, že uživatel je připojen k síti.

Datové připojení dotazu přidáte do šablony formuláře, ve výchozím nastavení formuláře založené na této šabloně formuláře pomocí datového připojení otevřeném uživatelem. Můžete taky nakonfigurovat šablony formuláře použití datového připojení dotazu v jednom z těchto způsobů:

  • Přidání pravidla    Můžete nakonfigurovat pravidlo pro použití datového připojení dotazu při každém výskytu podmínka pravidla.

  • Tlačítko Přidat    Přidání tlačítka na šablonu formuláře, který uživatelů můžou kliknout na získání dat pomocí datového připojení dotazu.

  • Použití vlastního kódu    Pokud nemůžete přidat pravidla nebo tlačítka, můžete použít vlastní kód k získání dat pomocí datového připojení dotazu. Použití vlastního kódu vyžaduje vývojář k vytvoření vlastního kódu.

Začátek stránky

Důležité informace o kompatibilitě

Připojení dat nemůžete přidat do databáze aplikace Access pro Šablona formuláře kompatibilní s prohlížečem.

Začátek stránky

Než začnete

Než přidáte sekundárního datového připojení k databázi aplikace Access do šablony formuláře, je potřeba tyto údaje:

  • Název a umístění databáze.

    Poznámka: Pokud databáze aplikace Access uložený ve umístění v síti, ujistěte se, že je databáze mají uživatelé přístup.

  • Název tabulky nebo dotazu, které slouží k zadání dat do formuláře založené na této šabloně. Použijete tento tabulky nebo dotazu jako primární tabulky nebo dotazu při konfiguraci dotazu datové připojení.

  • Názvy jiných tabulek nebo dotazů, které poskytují další data do primární tabulky nebo dotazu. Ve většině případů jsou už povolili relací mezi tabulkami v databázi. Pokud budete muset ručně vytvořit relace mezi primární tabulka nebo dotaz a další tabulku nebo dotaz, budete potřebovat související pole názvy tabulek nebo dotazů.

Začátek stránky

Krok 1: Přidání sekundárního datového připojení

  1. V nabídce Nástroje klikněte na Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na Přidat.

  3. V Průvodci datovým připojením klikněte na vytvořit nové připojení k, klikněte na přijmout data a klikněte na tlačítko Další.

  4. Na další stránce průvodce klikněte na databáze (Microsoft SQL Server nebo Microsoft Office Access pouze) a klikněte na tlačítko Další.

  5. Na další stránce průvodce klikněte na Vybrat databázi.

  6. V dialogovém okně Vybrat zdroj dat přejděte do umístění databáze.

    Poznámka: Pokud je databáze uložená v umístění v síti, přejděte na cestu konvence UNC umístění. Není přejděte do umístění v síti prostřednictvím síťovou jednotku. Pokud používáte síťovou jednotku, uživatelé, kteří vytvářejí formuláře založené na této šabloně vyhledá tuto databázi síťovou jednotku. Pokud uživatel nemá síťovou jednotku, formuláři nenajde databáze.

  7. Klikněte na název databáze a pak klikněte na Otevřít.

  8. V dialogovém okně Vybrat tabulku klikněte na primární tabulka nebo dotaz, který chcete použít a klikněte na OK.

  9. Na další stránce průvodce zaškrtněte políčko Zobrazit sloupce tabulky.

    Ve výchozím nastavení všech polí v tabulce nebo dotazu se přidají do hlavního zdroje dat šablony formuláře.

  10. Zrušte zaškrtnutí políček u polí, která nechcete zahrnout sekundární zdroj dat.

    Přidání dalších tabulek nebo dotazů do datového připojení.

    Jak na to?

    1. Klikněte na Přidat tabulku.

    2. V dialogovém okně Přidat tabulku nebo dotaz klikněte na název podřízené tabulky a klikněte na tlačítko Další. InfoPath se pokusí nastavit vztahy porovnáním názvů polí v obou tabulkách. Pokud nechcete použít navrženou relaci, vyberte vztah a pak klikněte na Odebrat vztah. Přidání relace, klikněte na Přidat relaci. V dialogovém okně Přidat relaci klikněte na název každého související pole ve sloupci odpovídajících a potom klikněte na OK.

    3. Klikněte na Dokončit.

    4. Pokud chcete přidat další podřízené tabulky, opakujte tento postup.

  11. Klikněte na tlačítko Další.

  12. Výsledky dotazu datového připojení k dispozici na formuláři není připojený k síti, zaškrtněte políčko Uložit kopii data v šabloně formuláře.

    Poznámka zabezpečení: Zaškrtnutím tohoto políčka jsou uložená data na počítači uživatele formuláře při použití tohoto datového připojení. Pokud formuláři načítá citlivá data z tohoto datového připojení, můžete k zakázání této funkce se můžete pomoci chrá data v případě ztráty či krádeže počítače.

  13. Klikněte na tlačítko Další.

  14. Na další stránce průvodce zadejte popisný název tohoto sekundárního datového připojení a ověřte správnost informace v části Souhrn.

  15. Pokud chcete nakonfigurovat formuláře, který se automaticky obnoví data při otevření formuláře, zaškrtněte políčko automaticky obnoví data při otevření formuláře.

Začátek stránky

Krok 2: Nakonfigurujte šablony formuláře použití datového připojení

Pokud budete potřebovat formuláře založené na této šabloně formuláře a použít tento datové připojení po otevření formuláře, Pravidlo můžete přidat do šablony formuláře, který používá datové připojení pod určitou podmínkou nebo přidání tlačítka na šablonu formuláře, který uživatele můžete kliknutím datové připojení.

Add a rule

Přidání pravidla do šablony formuláře, který slouží k načtení dat z datové připojení dotazu kdykoli splnění podmínky pravidla. Textové pole můžete například přidat do šablony formuláře, který uživatel vyplňovat přejít specifická data z externího zdroje dat. Pak můžete přidat pravidlo, které používá datové připojení pokaždé, když uživatel zadá data do textového pole.

Následující postup předpokládá, že jste vytvořili datové připojení dotazu pro šablonu formuláře a že jste nakonfigurovali ovládacího prvku (jiné než tlačítko) v šabloně formuláře pro zobrazení dat z daného datového připojení.

  1. Pokud šablona formuláře obsahuje více zobrazení, klikněte v nabídce Zobrazit přejděte na zobrazení s ovládacím prvkem, ve které chcete zobrazit data z sekundární zdroj dat na název zobrazení.

  2. Poklepejte na ovládací prvek, který chcete přidat pravidlo.

  3. Klikněte na kartu Data.

  4. V části ověření a pravidla klikněte na pravidla.

  5. V dialogovém okně pravidla klikněte na Přidat.

  6. Do pole název zadejte název pravidla.

  7. Chcete-li podmínky když by měla běžet pravidlo, klikněte na Nastavit podmínku a zadejte podmínka. Pravidlo se spustí, když dojde k podmínka. Pokud není nastavený podmínky, pravidla se spustí pokaždé, když uživatel změní hodnotu v ovládacím prvku a přejde přihlásil kurzor směrem od tohoto ovládacího prvku.

  8. Klikněte na Přidat akci.

  9. V seznamu Akce klikněte na dotazu pomocí datového připojení.

  10. V seznamu datové připojení klikněte na datové připojení dotazu, které chcete použít a potom klikněte na OK zavřete všechna otevřená dialogová okna.

  11. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

Přidání tlačítka

Přidání ovládacího prvku tlačítka do šablony formuláře mohou uživatelé klepnout k načtení dat z datové připojení dotazu.

  1. Pokud šablona formuláře obsahuje více zobrazení, klikněte v nabídce Zobrazit přejděte na zobrazení s ovládacím prvkem, ve které chcete zobrazit data z sekundární zdroj dat na název zobrazení.

  2. Pokud není vidět podokno úloh Ovládací prvky, klikněte na Další ovládací prvky v nabídce Vložit nebo stiskněte klávesy ALT+I, C.

  3. Přetáhněte ovládací prvek tlačítko na vaší šabloně.

  4. Poklikejte ovládací prvek, který jste právě přidali do šablony formuláře.

  5. Klikněte na kartu Obecné.

  6. V seznamu Akce klikněte na Aktualizovat.

  7. Do pole Popisek zadejte název, který se má zobrazit na tlačítko v šabloně formuláře.

  8. Klikněte na tlačítko Nastavení.

  9. V dialogovém okně Aktualizovat proveďte jednu z následujících akcí:

    • Pro příjem nejnovější data ze všech zdrojů externích dat s sekundárního datového připojení na této šabloně, klikněte na Všechny sekundární zdroje dat.

    • Abyste mohli nakonfigurovat cílem zobrazit aktuální data z jednoho zdroje externích dat s sekundárního datového připojení do šablony formuláře, klikněte jeden sekundárního datového připojení a potom na sekundární zdroj dat ve zdroji dat Zvolit sekundární seznamu.

  10. Postupným kliknutím na tlačítka OK zavřete všechna otevřená dialogová okna.

  11. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

Začátek stránky

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×