Přehrávání animace Adobe Macromedia Flash v prezentaci

PowerPoint pro Office 365, PowerPoint 2019, PowerPoint 2016, PowerPoint 2013, PowerPoint 2010

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Pokud máte animovaný obrázek, který byl vytvořený pomocí Adobe Macromedia Flash a uložili jako Shockwave soubor s příponou .swf, můžete soubor přehrát v prezentaci PowerPoint.

Přidání souboru Flash do prezentace v PowerPointu 2010 a novější vkládání a propojování souboru na snímku.

Poznámky: 

  • Může být určitá omezení při používání Flash v PowerPointu, včetně nelze použití zvláštních efektů (jako jsou stíny, odrazy, efektů záře, měkké okraje, zkosení a 3D otočení), Zeslabit a PROČISTIT funkcí a možnost komprese tyto soubory Jednodušší sdílení a rozdělení.

  • Aplikace PowerPoint 2010 – 64bitová verze není kompatibilní s 32bitové verze QuickTime nebo Flash. Musíte buď nainstalovat 64bitovou verzi QuickTime nebo Flash nebo 32bitovou verzi aplikace PowerPoint 2010.

Vložení souboru ve formátu Flash

  1. V normálním zobrazení klikněte na snímek, do kterého chcete vložit video.

  2. Na kartě Vložení ve skupině Multimédia klikněte na šipku pod tlačítkem Video a potom klikněte na Video v mém počítači nebo Video ze souboru.

  3. V dialogovém okně Vložit Video vyhledejte a klikněte na video, které chcete vložit a potom klikněte na Vložit.

  4. Pokud chcete zobrazit náhled dynamického animace, zaškrtněte políčko Přehrát na kartě Formát nástrojů Video.

Odkaz na souboru ve formátu Flash

  1. V normálním zobrazení klikněte na kartě Snímky na snímek, do kterého chcete přidat video nebo animovaný obrázek ve formátu GIF.

  2. Na kartě Vložení klikněte ve skupině Média na šipku pod tlačítkem Video.

  3. Klikněte na Video v mém počítači nebo Video ze souboru, vyhledejte a klikněte na soubor, který chcete vytvořit odkaz.

  4. Na tlačítku Vložit klikněte na šipku dolů a potom klikněte na možnost Připojit k souboru.

    Důležité informace: Chcete-li předejít možným potížím s přerušenými odkazy, je vhodné před vytvořením odkazu na videa zkopírovat videa do stejné složky jako prezentaci.

  5. Pokud chcete zobrazit náhled dynamického animace, zaškrtněte políčko Přehrát na kartě Formát nástrojů Video.

Přidat soubor .swf v aplikaci PowerPoint 2007, použijte ovládací prvek ActiveX s názvem objekt Shockwave Flash a Adobe Macromedia Flash Player. Přehrát soubor ve formátu Flash, přidejte do snímku ovládací prvky ActiveX a vytvoření odkazu z něho souboru ve formátu Flash.

Nastavení zabezpečení ovládacích prvků ActiveX najdete v Centru zabezpečení nastavuje zabezpečení a ochrana osobních údajů pro aplikace Microsoft Office 2007. Budete muset upravit nastavení zabezpečení za účelem povolení ovládacích prvků ActiveX na spustit. Nastavení ovládacích prvků ActiveX v Centru zabezpečení platí pro všechny Office 2007 produkty. Například změnit nastavení v aplikaci PowerPoint toto nastavení je také změní ostatních aplikacích sady Office, které pomocí Centra zabezpečení. Další informace o ovládací prvky ActiveX a změny nastavení najdete v článku Povolení nebo zakázání nastavení ovládacích prvků ActiveX v souborech Office.

Důležité informace: 

  • Objekt Shockwave Flash musí být registrována na vašem počítači chcete přehrát soubor ve formátu Flash v prezentaci. Chcete-li zobrazit, zda je registrovaná na objekt Shockwave Flash, na kartě Vývojář ve skupině ovládací prvky klikněte na Další ovládací prvky Obrázek tlačítka . Pokud na objekt Shockwave Flash se zobrazí v seznamu ovládacích prvků, je na počítači registrované. Pokud není registrovaný, Stáhněte si nejnovější verzi Flash Playeru z webu Adobe webu k registraci na objekt Shockwave Flash v počítači.

  • Pokud chcete zaručit bezchybnou funkčnost složitých animací, nainstalujte si nejnovější verzi Flash Playeru, i když jsou na počítači registrované starší verze objektu Shockwave Flash.

Přidání souboru Flash do prezentace

  1. Nainstalujte si do počítače přehrávač Flash.

  2. V normálním zobrazení PowerPointu zobrazte snímek, na kterém chcete přehrát animaci.

  3. Klikněte na tlačítko Microsoft Office Obrázek tlačítka a pak klikněte na Možnosti aplikace PowerPoint.

  4. Klikněte na Populární, v části Hlavní možnosti práce s aplikací PowerPoint zaškrtněte políčko Zobrazit na pásu kartu Vývojář a potom klikněte na OK.

  5. Na kartě Vývojář klikněte ve skupině Ovládací prvky na Další ovládací prvky Obrázek tlačítka .

  6. Na seznamu ovládacích prvků klikněte na objekt Shockwave Flash, klikněte na OK a potom přetáhněte ovládací prvek na snímek, abyste ho vykreslili.

    Velikost ovládacího prvku změníte přetažením úchytů pro změnu velikosti.

  7. Klikněte pravým tlačítkem myši na objekt Shockwave Flash a potom klikněte na Vlastnosti.

  8. Klikněte na kartě Abecední na vlastnost Video.

  9. Zadejte do sloupce hodnota (prázdná buňka vedle Video) úplnou cestu k jednotce, včetně názvu souboru (třeba C:\MyFile.swf), nebo adresu URL (Uniform Resource Locator) souboru Flash, který chcete přehrát.

  10. Pokud chcete nastavit konkrétní možnosti pro přehrávání animace, použijte následující postup a potom zavřete dialogové okno Vlastnosti:

    • Pokud chcete soubor automaticky přehrát při zobrazení snímku, nastavte vlastnost Přehrávání na Pravda. Pokud má soubor Flash vestavěný ovládací prvek Zahájit přehrávání / Převinout zpět, můžete vlastnost Přehrávání nastavit na Nepravda.

    • Pokud nechcete, aby se animace přehrávala opakovaně, nastavte vlastnost Smyčka na Nepravda.

Zobrazení náhledu animace v zobrazení prezentace

  • Klikněte na kartě Zobrazení ve skupině Zobrazení prezentace na Prezentace. Taky můžete stisknout F5.

    Pokud chcete ukončit prezentaci a vrátit se do normálního zobrazení, stiskněte ESC.

Poznámky: 

  • Na rozdíl od obrázky nebo kresby Flash soubory jsou vždy propojené s prezentací v aplikaci PowerPoint 2007, není v ní vložený ho. Po vložení propojeného souboru PowerPointu vytvoří odkaz na aktuální umístění souboru. Pokud později přesunutí souboru do jiného umístění, PowerPoint nelze najít ho chcete soubor přehrát. Je vhodné před vložením soubory Flash zkopírovat Flash souborů do stejné složky jako prezentaci. PowerPoint vytvoří odkaz na soubor ve formátu Flash a můžete najít soubor ve formátu Flash, dokud si ji nechali ve složce prezentaci, i když přesunete nebo zkopírujete složky na jiném počítači. Dalším způsobem, abyste měli jistotu, že jsou propojené soubory do stejné složky jako prezentaci je použil funkci balíček pro disk CD. Tato funkce slouží ke kopírování všechny soubory do jednoho umístění (disk CD nebo složky) s prezentací a automaticky aktualizuje všechny odkazy pro soubory. Pokud prezentace obsahuje propojené soubory, třeba kopírujete propojené soubory, jakož i prezentaci Pokud budete chtít předvedení prezentace v jiném počítači nebo ho někomu poslat e-mailu.

  • Produkty jiných výrobců popisované v tomto článku vyrábějí společnosti nezávislé na společnosti Microsoft. Neposkytujeme žádnou záruku (odvozenou ani jinou) týkající se jejich výkonu a spolehlivosti.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×