Příprava zdroje dat v Excelu pro hromadnou korespondenci ve Wordu

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Základní kroku v procesu hromadné korespondence Word nastavení a příprava zdroje dat. Můžete použít existujícího zdroje dat Excel nebo vytvořit nové importováním oddělený tabulátory (TXT) nebo souboru textový soubor s oddělovači (CSV). Jakmile jste nastavili a připravit zdroj dat, můžete provést hromadné korespondence pomocí příkazu DDE (Dynamic Data Exchange) v Průvodci hromadnou korespondencí krok za krokem nebo pomocí metody odpisu ruční hromadné korespondence.

Pokud nepoužíváte existujícího zdroje dat Excel pro hromadnou korespondenci, můžete seznamu kontaktů nebo adresáře v txt nebo souboru CSV. Průvodce importem textu vás provede kroky pro získání data, která jsou v souboru .csv nebo .txt do Excel.

  1. Otevřete Excel.

  2. Na kartě Data vyberte Z Text/CSV.

  3. Kliknutím na .csv nebo .txt soubor a pak zvolte importovat.

  4. V Průvodci importem textu zvolte v podokně Zdrojový datový typ možnost Oddělovač.

    Excel, Načíst externí data, Z textu, Průvodce importem textu, Krok 1 ze 3

  5. Pokud importovaný soubor obsahuje záhlaví, zaškrtněte políčko Data obsahují záhlaví nad podoknem Náhled. Potom zvolte Další.

  6. V podokně Oddělovače zaškrtněte políčko u oddělovače, který je použitý u vašich dat (například Tabulátor nebo Středník), a pak zvolte Další.

    V Průvodci importem textu jsou zvýrazněné možnosti pro Oddělovače.

    Tip: Podokno Náhled dat ukazuje, jak budou výsledky vypadat v tabulkovém formátu.

  7. V podokně Náhled dat zvolte sloupec, který obsahuje poštovní směrovací čísla (PSČ) a v podokně Formát dat ve sloupcích zvolte Text.

    V Průvodci importem textu je pro Formát dat ve sloupcích zvýrazněná možnost Text.

    Poznámky: 

    • Dostupné formáty jsou Obecný, Text a Datum. Název formátu se pokaždé, když na sloupec použijete formát dat, objeví v záhlaví tabulky tohoto sloupce.

    • Sloupec, který obsahuje číselná data, například hodnotu procent nebo měny, je možné formátovat až po naimportování souboru. Další informace najdete v pododdílu Formátování číselných dat v Excelu dále v tomto článku.

  8. Krok 7 opakujte podle potřeby. Vyberte sloupec, který chcete změnit, a formát dat, který chcete použít.

  9. Zvolte Dokončit.

  10. V dialogovém okně Importovat data přijměte výchozí nastavení Existující list a adresu buňky a pak zvolte OK.

    V dialogovém okně Import dat zvolte, jestli chcete data umístit do existujícího listu (výchozí nastavení), nebo do nového listu.

    Upozornění: Adresa buňky v dialogovém okně Importovat data odpovídá aktuálně vybrané buňce. Data se naimportují do oblasti začínající uvedenou adresou buňky.

  11. Až budete hotovi, uložte zdroj dat pod novým názvem souboru.

Formátování číselných dat v Excelu

Zformátujte veškerá číselná data, jako jsou hodnoty procent nebo měny, ve všech nových nebo existujících excelových zdrojích dat, které chcete použít v hromadné korespondenci ve Wordu. Aby se při hromadné korespondenci zachovala číselná data, která jste zformátovali jako procenta nebo měnu, postupujte podle pokynů v části Krok 2: Použití technologie DDE (Dynamic Data Exchange) pro hromadnou korespondenci.

Excel zdroje dat, které budete používat pro hromadnou korespondenci v hromadné korespondenci Word zkontrolujte, že naformátujete sloupce číselná data správně. Formátování sloupce s čísly, například podle určité kategorie třeba Měna.

  1. Otevřete excelový zdroj dat.

  2. Zvolte sloupec, který chcete zformátovat.

  3. Na kartě Domů ve skupině Číslo zvolte šipku dolů u pole Formát čísla – Obecný a pak vyberte jednu z možností v seznamu.

    V Excelu na kartě Domů ve skupině Číslo zvolte šipku dolů u pole Obecný a zvolte požadovaný číselný formát.

  4. Podle potřeby opakujte kroky 2 a 3.

  5. Až to budete mít, zvolte Uložit.

Když budete mít zdroj dat Excel, který obsahuje formátovaný čísel jako procent a hodnoty s měnou, některá data na číselné nemusí jeho formátování zachovat při hromadné korespondenci. Zobrazí se výsledky hromadné korespondence a pak můžete zachovat formát číselných dat v Excel pomocí rozhraní DDE.

Formát dat v Excelu v porovnání s polem Sloučit ve Wordu při použití a nepoužití DDE

Poznámka: Pokud se rozhodnete DDE nepoužít, postupujte podle pokynů v článku Použití hromadné korespondence k posílání hromadných e-mailových zpráv.

  1. Otevřete Word, zvolte Soubor > Možnosti > Upřesnit.

  2. V části Obecné zaškrtněte políčko Při otevírání potvrdit převod formátu souboru.

    Možnost Při otevírání potvrdit převod formátu souboru

  3. Zvolte OK.

  4. Na kartě korespondence zvolte Spustit hromadnou korespondenci > Průvodce hromadnou korespondencí krok za krokem.

    Ve Wordu na kartě Korespondence zvolte Spustit hromadnou korespondenci a potom vyberte Podrobného průvodce hromadnou korespondencí.

  5. V podokně Hromadná korespondence v části Vybrat příjemce zvolte Použít existující seznam.

    Podokno úloh Hromadná korespondence ve Wordu, které se otevře při výběru Podrobného průvodce hromadnou korespondenci ve skupině Hromadná korespondence

  6. V části Použít existující seznam zvolte Procházet a potom otevřete formátovanou tabulku.

  7. V dialogovém okně Potvrdit zdroj dat zaškrtněte políčko Zobrazit vše a zvolte Sešity MS Excel pomocí rozhraní DDE (*.xls) > OK.

    Dialogové okno Potvrdit zdroj dat

  8. V dialogovém okně Microsoft Excel zvolte Celý list > OK.

    Dialogové okno Microsoft Excelu ve Wordu

  9. V dialogovém okně Příjemci hromadné korespondence, které se otevře, zvolte OK.

    Dialogové okno Příjemci hromadné korespondence, které zobrazuje obsah excelové tabulky použité jako zdroj dat pro seznam adresátů

  10. Pokračujte v psaní dopisu, e-mailové zprávy, štítku nebo obálky pro hromadnou korespondenci.

Tip: Pokud nechcete, aby vám Word při každém otevření datového souboru zobrazoval výzvu, proveďte následující postup. Po připojení k seznamu adresátů přejděte na Soubor > Možnosti > Upřesnit. V oddílu Obecné zrušte zaškrtnutí políčka Při otevírání potvrdit převod formátu souboru.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×