Oprava chyby #HODNOTA! u funkce CONCATENATE

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Důležité informace: V aplikacích Excel 2016, Excel Mobile a Excel Online byla funkce CONCATENATE nahrazena funkcí CONCAT. I když je funkce CONCATENATE kvůli zpětné kompatibilitě pořád k dispozici, měli byste zvážit možnost používání funkce CONCAT, protože je výkonnější.

Jedním z nejobvyklejších případů, kdy dojde k chybě #HODNOTA! u funkce CONCATENATE je, když se pokusíte vytvořit řetězec, který obsahuje odkaz na buňku s chybou, například #HODNOTA!.

V následujícím příkladu chceme zřetězit hodnoty buněk D2, E2 a F2, přičemž v buňce E2 je chyba #HODNOTA!.

Chyba #HODNOTA! u funkce CONCATENATE

Chyba v E2 způsobí, že funkce zobrazíte #VALUE! došlo k chybě. Aby se nezdaří musíte se chyba nahraďte hodnotu než chyby do schránky. Můžete vytvořit vzorec, který hledá výskyt chyby ve odkaz na buňku a pokud ano, zobrazit textového řetězce kde místo chyby se zobrazuje 0 (nebo nahradíte vlastního textu pro 0, ale budete muset zalomit text v uvozovkách – "Svůj Text").

Takovýto vzorec bude fungovat:

=KDYŽ(JE.CHYBA(E2),CONCATENATE(D2;" ";0;" ";F2))

Funkce KDYŽ a JE.CHYBHODN použité jako alternativní řešení k řetězení řetězce s chybou #HODNOTA!

Jak funguje, které fungují? Funkce když používá funkci IFERROR lze zjistit, zda dojde k chybě v E2 a pokud existuje, funkce CONCATENATE sloučí hodnoty v D2, E2 a F2 (funkce nahradí k chybě 0) a zobrazí se výsledný textový řetězec. Všimněte si vzorec taky používá mezery ("") pomůže oddělte hodnoty.

Oprava chyby #HODNOTA! pomocí funkce CONCATENATE v Excelu 2003 a starších verzích

Pokud se zobrazují #VALUE! Chyba v Office Excel 2003 nebo starší verze, musíte se zrušte zaškrtnutí políčka vyhodnocení vzorce přechodu (TFE) v Excel. Postupujte podle kroků uvedených v #VALUE! chyby při zřetězení buněk tento problém vyřešit.

Máte konkrétní otázku k funkci?

Zadejte dotaz do komunitního fóra Excelu.

Pomozte nám vylepšit Excel

Máte nějaké návrhy na zlepšení dalších verzí Excelu? Pokud ano, podívejte se prosím na témata v části Názor uživatele Excelu.

Viz také

Oprava chyby #HODNOTA!

CONCATENATE

CONCAT

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Zjišťování chyb ve vzorcích

Všechny funkce Excelu (podle abecedy)

Všechny funkce v Excelu (podle kategorie)

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×