Oprava chyby #HODNOTA! u funkce CONCATENATE

Důležité informace: V Excel 2016, Excel Mobile a Excel pro web je funkce CONCATENATE nahrazena funkcí CONCAT. I když je funkce CONCATENATE kvůli zpětné kompatibilitě pořád k dispozici, měli byste zvážit možnost používání funkce CONCAT, protože je výkonnější.

Jedním z nejobvyklejších případů, kdy dojde k chybě #HODNOTA! u funkce CONCATENATE je, když se pokusíte vytvořit řetězec, který obsahuje odkaz na buňku s chybou, například #HODNOTA!.

V následujícím příkladu chceme zřetězit spojení D2, E2 a F2, kde E2 obsahuje #VALUE! Pokud je pozice, kterou uvedete, před první položkou nebo za poslední položkou v poli, bude výsledkem vzorce chyba #REF!.

Chyba #HODNOTA! u funkce CONCATENATE

Chyba v E2 způsobí, že funkce zobrazí #VALUE! Pokud je pozice, kterou uvedete, před první položkou nebo za poslední položkou v poli, bude výsledkem vzorce chyba #REF!. Abyste mohli úspěšně pracovat, budete muset chybu nahradit jinou hodnotou, než je chyba. Můžete vytvořit vzorec, který vyhledá chybu v odkazu na buňku, a pokud to dělá, zobrazí se textový řetězec, kde se místo chyby zobrazuje 0 (nebo můžete použít vlastní text pro 0, ale text v uvozovkách).

Takovýto vzorec bude fungovat:

=KDYŽ(JE.CHYBA(E2),CONCATENATE(D2;" ";0;" ";F2))

Funkce když a IsError se používají jako alternativní řešení k zřetězení řetězce s #VALUEem! pomocí funkce KDYŽ

Jak to funguje? Funkce KDYŽ používá funkci IFERROR ke zjištění, jestli je chyba v buňce E2, a pokud tam je, zkombinuje funkce CONCATENATE hodnoty v buňce D2, E2 a F2 (funkce nahradí chybu číslem 0) a zobrazí výsledný textový řetězec. Poznámka: K vizuálnímu oddělení hodnot se ve vzorci používají mezery (" ").

Oprava chyby #HODNOTA! pomocí funkce CONCATENATE v Excelu 2003 a starších verzích

Pokud se zobrazuje chyba #HODNOTA! v aplikaci Office Excel 2003 nebo starších verzích, bude nutné v aplikaci Excel zrušit zaškrtnutí možnosti převodu výpočtu vzorců (TFE). Postupujte podle kroků uvedených v #VALUE! Chyba při zřetězení buněk .

Máte konkrétní otázku k funkci?

Zadejte dotaz do komunitního fóra Excelu

Pomozte nám vylepšit Excel

Máte nějaké návrhy na zlepšení dalších verzí Excelu? Pokud ano, podívejte se prosím na témata na webu Excel User Voice.

Viz také

Oprava chyby #HODNOTA! pomocí funkce KDYŽ

CONCATENATE

Funkce CONCAT

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Zjišťování chyb ve vzorcích

Všechny funkce Excelu (podle abecedy)

Všechny funkce v Excelu (podle kategorie)

Poznámka:  Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát vědět, jestli vám informace pomohly? Pokud chcete, můžete se podívat na anglickou verzi článku.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×