Oprava chyby #HODNOTA! u funkcí PRŮMĚR a SUMA

Pokud funkce PRŮMĚR nebo SUMA odkazují na buňky, které obsahují chyby #HODNOTA!, bude výsledkem vzorců chyba #HODNOTA!.

Chyba #HODNOTA! u funkce PRŮMĚR

Aby se nebraly v úvahu chybové hodnoty, vytvoříme vzorec, který ignoruje chyby v referenční oblasti, a vypočteme průměr se zbývajícími „normálními“ hodnotami.

Tento scénář obejdeme tak, že pomocí kombinace funkcí PRŮMĚR, KDYŽ a JE.CHYBHODN určíme, jestli je v zadané oblasti chyba. Tento konkrétní scénář vyžaduje maticový vzorec:

=PRŮMĚR(KDYŽ(JE.CHYBHODN(B2:D2);"";B2:D2))

Poznámka: Toto je maticový vzorec, který je potřeba zadat pomocí kombinace kláves CTRL+SHIFT+ENTER. Excel za vás vzorec automaticky uzavře do složených závorek {}. Pokud se je pokusíte zadat ručně, Excel vzorec zobrazí jako text.

Maticová funkce ve funkci PRŮMĚR pro řešení chyby #HODNOTA!

Poznámka: Výše uvedená funkce bude kromě funkce #HODNOTA! fungovat také pro funkce #NENÍ_K_DISPOZICI, #NULL, #DĚLENÍ_NULOU! a další.

Stejným způsobem můžete použít také funkci SUMA:

=SUMA(KDYŽ(JE.CHYBHODN(B2:D2);"";B2:D2))

Máte konkrétní otázku k funkci?

Zadejte dotaz do komunitního fóra Excelu.

Pomozte nám vylepšit Excel

Máte nějaké návrhy na zlepšení dalších verzí Excelu? Pokud ano, podívejte se prosím na témata na webu Excel User Voice.

Viz taky

Oprava chyby #HODNOTA!

Funkce PRŮMĚR

Funkce SUMA

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Oprava chyb ve vzorcích pomocí kontroly chyb

Všechny funkce Excelu (podle abecedy)

Všechny funkce Excelu (podle kategorie)

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×