Oprava chyby #HODNOTA! u funkcí PRŮMĚR a SUMA

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Pokud funkce průměr nebo suma odkazuje na buňky obsahující #VALUE chyby, výsledkem vzorců bude #VALUE! U všech ostatních hodnot vrátí funkce FORECAST.ETS.STAT chybu #NUM!.

Chyba #HODNOTA! u funkce PRŮMĚR

Aby se nebraly v úvahu chybové hodnoty, vytvoříme vzorec, který ignoruje chyby v referenční oblasti, a vypočteme průměr se zbývajícími „normálními“ hodnotami.

Tento scénář obejdeme tak, že pomocí kombinace funkcí PRŮMĚR, KDYŽ a JE.CHYBHODN určíme, jestli je v zadané oblasti chyba. Tento konkrétní scénář vyžaduje maticový vzorec:

=PRŮMĚR(KDYŽ(JE.CHYBHODN(B2:D2);"";B2:D2))

Toto je maticový vzorec. Abyste mohli buď stisknout ENTER (jenom v případě, že používáte Office365) nebo CTRL + SHIFT + ENTER ve vzorci.

Poznámka: Pokud máte aktuální verzi Office 365, můžete jednoduše zadat vzorec do výstupní buňky a stisknutím klávesy ENTER vzorec potvrdit jako dynamický maticový vzorec. V opačném případě musí být vzorec zadán jako starší maticový vzorec tak, že nejdříve vyberete výstupní buňku, zadáte vzorec do výstupní buňky a potom ho potvrďte stisknutím kombinace kláves CTRL + SHIFT + ENTER . Excel vloží na začátek a konec vzorce složené závorky. Další informace o maticových vzorcích najdete v tématu s pokyny k používání a příklady maticových vzorců.

Funkce Array v průměru pro vyřešení #VALUE! pomocí funkce KDYŽ

Poznámka: Výše uvedená funkce bude kromě funkce #HODNOTA! fungovat také pro funkce #NENÍ_K_DISPOZICI, #NULL, #DĚLENÍ_NULOU! a další.

Stejným způsobem můžete použít také funkci SUMA:

=SUMA(KDYŽ(JE.CHYBHODN(B2:D2);"";B2:D2))

Máte konkrétní otázku k funkci?

Publikování dotazu ve fóru komunity Excelu

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení na fóru Excel User Voice.

Viz taky

Oprava chyby #HODNOTA!

Průměr

SUMA

Základní informace o vzorcích v Excelu

Zjištění chyb ve vzorcích

Všechny funkce aplikace Excel (podle abecedy)

Všechny funkce aplikace Excel (podle kategorie)

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×