Oprava chyby #HODNOTA! u funkcí PRŮMĚR a SUMA

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Pokud funkce PRŮMĚR nebo SUMA odkazují na buňky, které obsahují chyby #HODNOTA!, bude výsledkem vzorců chyba #HODNOTA!.

Chyba #HODNOTA! u funkce PRŮMĚR

Aby se nebraly v úvahu chybové hodnoty, vytvoříme vzorec, který ignoruje chyby v referenční oblasti, a vypočteme průměr se zbývajícími „normálními“ hodnotami.

Tento scénář obejdeme tak, že pomocí kombinace funkcí PRŮMĚR, KDYŽ a JE.CHYBHODN určíme, jestli je v zadané oblasti chyba. Tento konkrétní scénář vyžaduje maticový vzorec:

=PRŮMĚR(KDYŽ(JE.CHYBHODN(B2:D2);"";B2:D2))

Poznámka: Jedná se o maticový vzorec, musí být zadán pomocí kombinace kláves CTRL + SHIFT + ENTER. Excel automaticky zalamován vzorec do složených závorek {}. Pokud se pokusíte vkládejte sami Excel zobrazí vzorec jako text.

Maticová funkce ve funkci PRŮMĚR pro řešení chyby #HODNOTA!

Poznámka: Výše uvedená funkce bude kromě funkce #HODNOTA! fungovat také pro funkce #NENÍ_K_DISPOZICI, #NULL, #DĚLENÍ_NULOU! a další.

Stejným způsobem můžete použít také funkci SUMA:

=SUMA(KDYŽ(JE.CHYBHODN(B2:D2);"";B2:D2))

Máte konkrétní otázku k funkci?

Zadejte dotaz do komunitního fóra Excelu.

Pomozte nám vylepšit Excel

Máte nějaké návrhy na zlepšení dalších verzí Excelu? Pokud ano, podívejte se prosím na témata v části Názor uživatele Excelu.

Viz také

Oprava chyby #HODNOTA!

PRŮMĚR

SUMA

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Zjišťování chyb ve vzorcích

Všechny funkce Excelu (podle abecedy)

Všechny funkce v Excelu (podle kategorie)

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×