Odeslání dat formuláře pod určitou podmínkou

Důležité informace:  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Šablonu formuláře můžete navrhnout tak, aby uživatelům povolila odeslání dat z formulářů založených na šabloně formuláře pouze tehdy, pokud je ve formuláři splněna určitá podmínka. Příklad: Navrhnete šablonu formuláře zprávy o výdajích, kterou mohou uživatelé odeslat pouze tehdy, pokud je celková suma nákladů větší než určitá částka.

Chcete-li využít tuto možnost, nastavte šablonu formuláře tak, aby uživatelům dovolila formulář odeslat, a poté vytvořte pravidlo, které povolí odeslání formuláře pouze tehdy, pokud formulář splní určitou podmínku. Po přidání tohoto pravidla můžete vybrat datové připojení pro odesílání, které bude použito v případě, že je podmínka splněna.

Po nastavení šablony formuláře tak, aby povolila uživatelům odesílat vyplněné formuláře, přidá aplikace Microsoft Office InfoPath při vyplňování formuláře tlačítko Odeslat na panel nástrojů Standardní a příkaz Odeslat do nabídky Soubor.

Při nastavení šablony formuláře a podmíněném povolení odesílání dat uživatelem můžete rovněž přizpůsobit následující možnosti odesílání dat šablony formuláře:

  • Změna textu, který se zobrazuje na tlačítku Odeslat na panelu nástrojů Standardní a v příkazu Odeslat v nabídce Soubor.

  • Změna klávesové zkratky pro tlačítko Odeslat na panelu nástrojů Standardní a příkaz Odeslat v nabídce Soubor.

  • Vytvoření vlastních zpráv, které se uživateli zobrazí po odeslání formuláře.

  • Výběr z možností, zda po odeslání formulář zavřít, nechat jej otevřený nebo zda otevřít nový nevyplněný formulář.

Přidání pravidla odeslání dat pouze po splnění určité podmínky

  1. V nabídce Nástroje klikněte na Možnosti odeslání.

  2. V dialogovém okně Možnosti odeslání zaškrtněte políčko Povolit uživatelům odeslat tento formulář.

    Poznámka: Po zaškrtnutí tohoto políčka přidá aplikace Microsoft Office InfoPath při vyplňování formuláře na panel nástrojů Standardní tlačítko Odeslat a do nabídky Soubor přidá příkaz Odeslat.

  3. Klepněte na položku Provést vlastní akci pomocí pravidel a poté na položku Pravidla.

  4. V dialogovém okně Pravidla pro odesílání formulářů klepněte na tlačítko Přidat.

  5. Do pole Název zadejte název pravidla, který popisuje umístění pro odesílání. Příklad: Pokud chcete uživatelům povolit, aby formulář odesílali pomocí e-mailu pouze tehdy, jestliže hodnota určitého pole je vyšší než 50$, zadejte Odeslání e-mailem pro více než 50$.

  6. V dialogovém okně Pravidlo klepněte na tlačítko Nastavit podmínku.

  7. V dialogovém okně Podmínka zadejte, kdy má být datové připojení použito, a klepněte na tlačítko OK.

  8. V dialogovém okně Pravidlo klepněte na tlačítko Přidat akci.

  9. V seznamu Akce klepněte na možnost Odeslat pomocí datového připojení, v seznamu Datové připojení vyberte datové připojení, které chcete pro tuto akci odesílání použít, a klepněte na tlačítko OK.

  10. Klepněte dvakrát na tlačítko OK.

    1. Chcete-li změnit název tlačítka Odeslat, které se zobrazuje na panelu nástrojů Standardní a příkazu Odeslat, který se zobrazuje v nabídce Soubor, když uživatelé vyplní formulář, zadejte nový název do pole Titulek v dialogovém okně Možnosti odeslání.

      Tip: Pokud chcete k tomuto tlačítku a příkazu přiřadit klávesovou zkratku, zadejte znak ampersandu (&) před znak, který chcete použít jako klávesovou zkratku. Chcete-li k tlačítku a příkazu Odeslat přiřadit například klávesovou zkratku ALT+D, zadejte O&deslat.

  11. Chcete-li uživatelům zabránit v použití příkazu Odeslat nebo tlačítka Odeslat na panelu nástrojů Standardní během vyplňování formuláře, zrušte zaškrtnutí políčka Zobrazit položku nabídky Odeslat a tlačítko Odeslat na panelu nástrojů.

    1. Ve výchozím nastavení zůstane formulář po odeslání otevřený a aplikace InfoPath zobrazí zprávu s informacemi o tom, zda byl formulář úspěšně odeslán. Jestliže chcete toto výchozí chování změnit, klepněte na tlačítko Upřesnit a proveďte jeden z následujících kroků:

      • Chcete-li po odeslání vyplněného formuláře uživatelem formulář zavřít nebo vytvořit nový prázdný formulář, klepněte na požadovanou možnost v rozevíracím seznamu Po odeslání.

      • Chcete-li vytvořit vlastní zprávu s informacemi o tom, zda byl formulář úspěšně odeslán, zaškrtněte políčko Použít vlastní zprávy a potom zadejte požadované zprávy do polí Při úspěchu a Při neúspěchu.

        Tip: Pomocí zprávy v poli Při neúspěchu uživatelům sdělte, co je třeba provést, pokud nelze formulář odeslat. Můžete uživatelům například navrhnout, aby uložili formulář a požádali o další pokyny jinou osobu.

      • Pokud nechcete, aby se po odeslání formuláře uživateli zobrazila zpráva, zrušte zaškrtnutí políčka Zobrazit zprávy o úspěšném nebo neúspěšném provedení.

Poznámka: Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×