Načtení dat ze služby Analysis Services

Důležité informace:  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Služba Analysis Services poskytuje rozměrová data, která se výborně hodí pro průzkum dat v sestavách kontingenční tabulky a nástroje Power View. Data služby Analysis Services můžete získat z těchto zdrojů:

  • Datové krychle OLAP na multidimenzionálním serveru služby Analysis Services.

  • Tabulkové modely na tabulkovém serveru služby Analysis Services.

  • Excelové sešity v Sharepointu 2010 nebo novější, pokud sešit obsahuje datový model.

Můžete analyzovat data z externího zdroje dat služby Analysis Services pomocí online připojení. Zatímco v sestavě používáte kontingenční tabulky nebo grafy, děláte průřezy a filtrujete, Excel se dotazuje služby Analysis Services na data, která jste požadovali. K analýze dat tímto způsobem je potřeba online připojení ke zdroji dat.

Další možností je pracovat offline. Offline můžete pracovat tak, že importujete data do vašeho sešitu, aby byly vizualizace dat a sestav sobestačné a plně přenositelné v jednom souboru. Pokud se rozhodnete data importovat, měli byste vědět, že to s sebou nese další požadavky. Kromě jiného potřebujete doplněk Power Pivot, základní znalosti MDX a dostatek místa na disku pro ukládání větších sešitů. Tento článek popisuje, jak importovat data z různých zdrojů dat služby Analysis Services.

Excelové sešity, které uložíte na SharePoint nebo Office 365 se vztahují maximální velikost souboru. Pomocí Průvodce importem tabulky v doplňku Power Pivot selektivně importem tabulek, sloupců a řádků zmenšete celkovou velikost souboru. Pokud je sešit moc velký pro zobrazení v Excel Online, kterou můžete otevřít v Excelu místo.

Office 365 zakazuje aktualizace dat z externích zdrojů dat, včetně řešení Analysis Services, která běží na serverech v síti. Pokud jsou jedním z vašich požadavků aktualizovatelná data, použijte raději SharePoint nebo sdílení síťového souboru.

V tomto článku

Požadavky

Připojení k datové krychli, tabulkovému modelu nebo datovému modelu doplňku Power Pivot

Import dat z datové krychle

Import dat z tabulkového modelu

Import dat z datového modelu sešitu v SharePointu

Aktualizace dat z externí databáze služby Analysis Services

Požadavky

Datové krychle služby Analysis Services musí být verzi SQL Server 2005 nebo novější.

Databáze tabulkových modelů služby Analysis Services jsou pouze ve verzi SQL Server 2012 nebo novější.

Musíte vědět, jak se připojit k databázi služby Analysis Services. Informujte se u správce databáze služby Analysis Services na názvy serveru a databáze a přihlašovací údaje, které máte použít.

Pokud chcete importovat data do datového modelu, musíte mít doplněk Power Pivot, který se dodává se sadou Office Professional Plus. Je taky potřeba vědět, jak napsat dotaz MDX načítající data, která chcete použít. Alternativou k psaní dotazu MDX je mimo jiné použití tvůrce dotazů, pomocí kterého si vyberete, které míry, atributy dimenzí a hierarchie chcete analyzovat.

K připojení do kontingenční tabulky nebo grafu pomocí Excelu nepotřebujete znát jazyk MDX. Excel se připojuje k celé datové krychli OLAP nebo tabulkovém modelu.

Velikost souborů bude větší, než na jakou jste pravděpodobně zvyklí. Pro srovnání: sešit využívající připojení dat může mít i pod 100 kilobajtů, zatímco stejný sešit s importovanými daty může být i desetinásobně větší. Pokud nemáte na disku dost místa, budete muset nějaké místo pro větší soubory uvolnit.

Power Pivot sešity, které použijete jako zdroje dat je možné publikovat na Sharepointu 2010 nebo novější. Na Sharepointovém webu musí běžet na jiný počítač, než tu, kterou používáte k vytvoření sestavy. Zobrazení oprávnění musí mít na webu služby SharePoint na sestavu týkající se sešitů na Sharepointu.

Připojení k datové krychli, tabulkovému modelu nebo datovému modelu doplňku Power Pivot

Nejjednodušším způsobem, jak analyzovat data v modelu nebo datové krychli služby Analysis Services, je nastavit připojení k externí databázi. Kontingenční tabulka nebo sestava bude mít aktivní připojení ke zdroji dat. Pokaždé, když přetáhnete pole do oblasti Hodnoty, Řádky, Sloupce nebo Filtr seznamu polí, Excel vytvoří dotaz a odešle ho do služby Analysis Services.

Aktivní připojení k datům, která analyzujete, má svoje výhody. Můžete provést vlastní analýzu. Stačí do kontingenční tabulky nebo sestavy přidat libovolné pole a služba Analysis Services vám poskytne požadovaná data. Seznam polí, který je připojený ke službě Analysis Services, zahrnuje všechny objekty v datové krychli nebo modelu, takže k získání požadovaných dat není nutné psát MDX.

Mezi nevýhody patří závislost na připojení k serveru. Pokud server spadne nebo pokud chcete pracovat offline, interakce s daty se okamžitě přeruší.

Začátek stránky

Import dat z datové krychle

Data obsažená v databázi služby SQL Server Analysis Services jde zkopírovat do datového modelu v Excelu. Můžete extrahovat celou dimenzi nebo její část, nebo z datové krychle získat řezy a agregace, jako třeba součet všech prodejů za jednotlivé měsíce v aktuálním roce.

Následující proces uvádí, jak jde pomocí doplňku a MDX získat podmnožinu dat z tradiční datové krychle v instanci služby Analysis Service. Jazyk MDX se používá vždycky, když vytváříte dotaz pomocí doplňku Power Pivot.

V tomto procesu se při popisu importu podmnožiny datové krychle používá ukázková databáze Adventure Works DW Multidimensional 2012. Pokud máte přístup k serveru služby Analysis Services, který ukázkovou databázi Adventure Works DW Multidimensional 2012 obsahuje, zjistíte podle tohoto postupu, jak importovat data ze služby Analysis Services.

  1. V okně Power Pivot klikněte na Načíst externí data > Z databáze > Ze služby Analysis Services nebo doplňku Power Pivot.

  2. V části Připojit ke službě Microsoft SQL Server Analysis Services zadejte do pole Název serveru nebo souboru název počítače, na kterém běží Analysis Services.

  3. Klikněte na šipku dolů umístěnou vpravo vedle seznamu Název databáze a vyberte ze seznamu databázi služby Analysis Services. Máte-li například přístup k ukázkové databázi Adventure Works DW Multidimensional 2012, vyberte položku Adventure Works DW Multidimensional 2012.

  4. Kliknutím na tlačítko Testovat připojení ověřte, zda je server služby Analysis Services dostupný.

  5. Klikněte na Další.

  6. Na stránce Zadání dotazu v jazyce MDX otevřete tvůrce dotazů MDX kliknutím na položku Návrh.

    V tomto kroku přetáhněte do velké oblasti návrhu dotazu všechny míry, atributy dimenzí, hierarchie a počítané členy, které chcete importovat.

    Vyberte aspoň jednu míru a jednu nebo víc dimenzí.

    Pokud už máte příkaz MDX, který chcete použít, vložte ho do textového pole a kliknutím na Ověřit ověřte, jestli bude příkaz fungovat. Další informace o použití návrháře najdete v tématu Návrhář dotazů MDX služby Analysis Services (Power Pivot).

    V tomto procesu postupujte takto (jako příklad je použita ukázková datová krychle Adventure Works):

    1. V podokně Metadata rozbalte seznam Míry a poté rozbalte položku Souhrn prodejů.

    2. Přetáhněte položku Průměrná částka prodeje do velkého podokna návrhu.

    3. V podokně Metadata rozbalte dimenzi Produkt.

    4. Přetáhněte položku Kategorie produktů do levé části položky Průměrná částka prodeje ve velké oblasti návrhu.

    5. V podokně Metadata rozbalte dimenzi data a potom rozbalte položku kalendáře.

    6. Přetáhněte položku datum.kalendářní Rok do levé části kategorie ve velké oblasti návrhu.

    7. Pokud chcete přidejte filtru k importu podmnožinu dat. V podokně na horní doprava návrháře dimenzí, přetáhněte datum do pole dimenze. V hierarchii vyberte položku Datum.kalendářní rok. operátor vyberte Nerovná; pro Výraz Filter klikněte na šipku dolů a vyberte KR 2009 a 2010 kr.

      Tím vytvoříte filtr pro datovou krychli, kterým vyloučíte hodnoty pro rok 2009.

  7. Klikněte na OK a zkontrolujte dotaz MDX vytvořený návrhářem dotazů.

  8. Zadejte popisný název datové sady. Tento název se použije jako název tabulky v datovém modelu. Pokud nepřiřadíte nový název, uloží se výsledky dotazu ve výchozím nastavení do nové tabulky s názvem Query.

  9. Klikněte na tlačítko Dokončit.

  10. Po načtení dat klikněte na tlačítko Zavřít.

Veškerá data importovaná z databáze datové krychle jsou zjednodušená. Ve vašem modelu se data zobrazí jako jedna tabulka obsahující všechny sloupce, které jste zadali v dotazu. Proto pokud definujete dotaz, který načítá míry ve víc dimenzích, importují se data tak, že se každá dimenze umístí do samostatného sloupce.

Po importu dat do datového modelu je dobré ověřit datový typ sloupců, které obsahují číselná nebo finanční data. Pokud Power Pivot zjistí ve sloupci prázdné hodnoty, změní datový typ na Text. Datový typ můžete ověřit a změnit tak, že jednotlivé sloupce vyberete a podíváte se u nich na Datový typ ve skupině Formátování na pásu karet. Pokud mají číselná nebo finanční data přiřazený nesprávný datový typ, můžete ho opravit pomocí možnosti Datový typ.

Pokud chcete použít data v kontingenční tabulce, přepněte se zpět do Excelu:

  1. Klikněte na Vložit > Tabulka > Kontingenční tabulka.

  2. Klikněte na Použít externí zdroje dat a pak klikněte na Zvolit připojení.

  3. Klikněte na Tabulky.

  4. V části Tento datový model sešitu vyberte importovanou tabulku.

Začátek stránky

Import dat z tabulkového modelu

Následující postup popisuje import dat a jako příklad používá ukázkovou tabulkovou databázi. Postup si můžete vyzkoušet s ukázkovou databázi Adventure Works Tabular Model SQL 2012, spuštěnou na serveru služby Analysis Services.

  1. Ujistěte se, že tabulková databáze obsahuje alespoň jednu míru. Pokud databáze neobsahuje míry, import se nepovede. Ukázkové řešení míry obsahuje.

  2. V okně Power Pivot klikněte na Načíst externí data > Z databáze > Ze služby Analysis Services nebo doplňku Power Pivot.

  3. V části Připojit ke službě Microsoft SQL Server Analysis Services zadejte do pole Název serveru nebo souboru název počítače, na kterém běží Analysis Services.

  4. Klikněte na šipku dolů umístěnou vpravo vedle seznamu Název databáze a vyberte ze seznamu databázi služby Analysis Services. Pokud máte přístup třeba k ukázkové databázi AW Internet Sales Tabular Model, vyberete Adventure Works Tabular Model SQL 2012.

  5. Kliknutím na tlačítko Testovat připojení ověřte, zda je server služby Analysis Services dostupný.

  6. Klikněte na Další.

  7. Na stránce Zadání dotazu v jazyce MDX otevřete tvůrce dotazů MDX kliknutím na položku Návrh.

    V tomto kroku přetáhněte do velké oblasti návrhu dotazu všechny míry, sloupce a hierarchie, které chcete importovat.

    Pokud už máte příkaz MDX, který chcete použít, vložte ho do textového pole a kliknutím na Ověřit ověřte, jestli bude příkaz fungovat. Další informace o návrháři najdete v tématu Návrhář dotazů MDX služby Analysis Services (Power Pivot).

    V tomto procesu postupujte takto (jako příklad se používá ukázkový model):

    1. V podokně Metadata rozbalte seznam Míry a pak rozbalte položku Internet Sales (Prodeje na internetu).

    2. Přetáhněte Internet Total Sales (Prodeje na Internetu – celkem) do velkého podokna návrhu.

    3. Rozbalte tabulku Product (Produkt).

    4. Přejděte na konec seznamu a přetáhněte kategorie nalevo od Internet celkové prodeje ve velké oblasti návrhu. Jedná se hierarchii, vrátí funkce všechna pole v hierarchii.

    5. Rozbalte tabulku Date (Datum).

    6. Přetáhněte kalendářní rok do levé části kategorie ve velké oblasti návrhu.

    7. Rozbalte položku Sales Territory (Území prodeje).

    8. Přetáhněte položku Sales Territory Region (Oblast území prodeje) do oblasti Filtr v horní části návrháře. Ve výrazu filtru vyberte Australia (Austrálie).

      Dotaz MDX do ukázkové tabulkové databáze

  8. Klikněte na OK a zkontrolujte dotaz MDX vytvořený návrhářem dotazů.

  9. Zadejte popisný název datové sady. Tento název se použije jako název tabulky v datovém modelu. Pokud nepřiřadíte nový název, uloží se výsledky dotazu ve výchozím nastavení do nové tabulky s názvem Query.

  10. Klikněte na tlačítko Dokončit.

  11. Po načtení dat klikněte na tlačítko Zavřít.

Po importu dat do datového modelu je dobré ověřit datový typ sloupců, které obsahují číselná nebo finanční data. Pokud Power Pivot zjistí ve sloupci prázdné hodnoty, změní datový typ na Text. Datový typ můžete ověřit a změnit tak, že jednotlivé sloupce vyberete a podíváte se u nich na Datový typ ve skupině Formátování na pásu karet. Pokud mají číselná nebo finanční data přiřazený nesprávný datový typ, můžete ho opravit pomocí možnosti Datový typ.

Pokud chcete použít data v kontingenční tabulce, přepněte se zpět do Excelu:

  1. Klikněte na Vložit > Tabulka > Kontingenční tabulka.

  2. Klikněte na Použít externí zdroje dat a pak klikněte na Zvolit připojení.

  3. Klikněte na Tabulky.

  4. V části Tento datový model sešitu vyberte importovanou tabulku.

Začátek stránky

Import dat z datového modelu sešitu v SharePointu

SharePoint může být nutné další software načtěte data. Pokud používáte SharePoint 2010, musíte mít Power Pivot for SharePoint 2010. SharePoint 2013 nebo novější naproti obsahuje předdefinované možnosti pro načítání a dotazování datový model. Pokud používáte SharePoint, požádejte správce Sharepointu povolit nebo nakonfigurovány BI úloh služby Excel Services.

  1. V okně Power Pivot klikněte na Načíst externí data > Z databáze > Ze služby Analysis Services nebo doplňku Power Pivot.

  2. V části Připojit ke službě Microsoft SQL Server Analysis Services do pole Popisný název připojení zadejte popisný název datového připojení. Popisné názvy připojení umožňují lépe si zapamatovat, jak bylo dané připojení použito.

  3. V části Název serveru nebo souboru zadejte adresu URL publikovaného souboru XLSX. Příklad: http://Contoso-srv/Sdilene_dokumenty/ContosoSales.xlsx.

    Poznámka: Jako zdroj dat nelze použít místní sešit aplikace Excel. Sešit musí být publikován na webu služby SharePoint.

  4. Kliknutím na tlačítko Testovat připojení ověřte, zda je sešit dostupný na webu služby SharePoint.

  5. Klikněte na Další.

  6. Klikněte na tlačítko Návrh.

  7. Sestavte dotaz přetažením měr, atributů dimenzí nebo hierarchií do velké oblasti návrhu. Volitelně můžete použít podokno filtru v pravé horní části a vybrat k importu podmnožinu dat.

  8. Klikněte na tlačítko OK.

  9. Klikněte na tlačítko Ověřit.

  10. Klikněte na tlačítko Dokončit.

Data doplňku Power Pivot se zkopírují do datového modelu a uloží se v komprimovaném formátu. Po dokončení importu dat se připojení k sešitu ukončí. Pokud chcete znovu sestavit dotaz pro původní data, můžete sešit aktualizovat v Excelu.

Začátek stránky

Aktualizace dat z externí databáze služby Analysis Services

Kliknutím na Data > Připojení > Aktualizovat vše v Excelu se znovu připojíte k databázi služby Analysis Services a aktualizujete data v sešitu.

Přitom se aktualizují jednotlivé buňky a přidají se řádky zanesené do externí databáze od posledního importu. Aktualizují se jenom řádky a existující sloupce; pokud do modelu chcete přidat nový sloupec, budete ho muset importovat pomocí postupu dřív popsaného v tomto článku.

Při aktualizaci se znova spustí dotaz použitý k importu dat. Pokud už zdroj dat není na stejném místě nebo pokud došlo k odebrání nebo přejmenování tabulek nebo sloupců, aktualizace se nepovede, ale budete mít pořád data, která jste naimportovali předtím. Pokud chcete zobrazit dotaz použitý k aktualizaci dat, kliknutím na Power Pivot > Spravovat otevřete okno Power Pivot. Dotaz zobrazíte kliknutím na Návrh > Vlastnosti tabulky.

Služba Analysis Services používá ke čtení dat ze svých databází uživatelský účet systému Windows. Předtím, než jste mohli importovat data, musel správce databáze udělit vašemu uživatelskému účtu systému Windows oprávnění ke čtení databáze. Stejná oprávnění se používají taky k aktualizování dat. Pokud chtějí data aktualizovat ostatní uživatelé, budou i oni potřebovat oprávnění ke čtení z databáze.

Myslete na to, jak sdílet sešit bude určovat, jestli aktualizace dat může dojít. V Office 365 se nedají aktualizovat data v sešitu, který je uložený na Office 365. Na SharePoint serveru 2013 nebo novější můžete naplánovat aktualizaci bezobslužného dat na serveru, ale tím vyžaduje této Power Pivot pro SharePoint nainstalovali a nakonfigurovali ve vašem prostředí Sharepointu. Obraťte se na správce Sharepointu, pokud chcete zjistit, zda plánované aktualizace dat je k dispozici.

Začátek stránky

Poznámka: Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×