Návrh zobrazení jen pro čtení

Důležité informace:  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

V aplikaci Microsoft Office InfoPath můžete vytvořit různá zobrazení téže šablony formuláře. Zobrazení je alternativním způsobem prezentace dat v šabloně formuláře. Při vyplňování formulářů založených na vaší šabloně formuláře mohou uživatelé zobrazení přepínat a vybrat si množství dat zobrazených ve formuláři. V šabloně formuláře zprávy o stavu například můžete vytvořit souhrnné zobrazení a podrobné zobrazení. Uživatelé si poté mohou zvolit, které zobrazení chtějí, podle typu potřebných informací.

Tento článek vysvětluje, jak navrhnout zobrazení, které uživatelé nemohou upravovat. Je zde také vysvětleno, jak lze pomocí pravidel automaticky přepnout do zobrazení formuláře určeného jen pro čtení, pokud uživatel klepne na tlačítko v zobrazení pro čtení i zápis.

Co chcete udělat?

Návrh zobrazení jen pro čtení

Vložení tlačítka pro přepnutí mezi zobrazením pro čtení i zápis a zobrazením jen pro čtení

Vložení tlačítka pro přepnutí do zobrazení jen pro čtení po odeslání formuláře uživatelem

Návrh zobrazení jen pro čtení

Zobrazení jen pro čtení jsou užitečná, pokud chcete pro uživatele sumarizovat data formuláře, ale nechcete, aby tato data mohli neúmyslně měnit. Předpokládejme například, že chcete zabránit tomu, aby uživatelé měnili data ve formuláři po jeho odeslání do webové služby. Můžete šablonu formuláře nakonfigurovat tak, aby se zobrazení dat pro čtení i zápis přepnulo do zobrazení jen pro čtení, jakmile uživatel ve formuláři klepne na tlačítko Odeslat. To uživatelům umožní zobrazit data, která odeslali, nebudou mít ovšem možnost tato data měnit.

  1. V nabídce Zobrazit vyberte příkaz Spravovat zobrazení.

  2. V části Akce klepněte na odkaz Přidat nové zobrazení.

  3. V dialogovém okně Přidat zobrazení zadejte název zobrazení a klepněte na tlačítko OK.

  4. Navrhněte zobrazení – přidejte do něj tabulky rozložení a ovládací prvky.

    Tip: Pokud chcete návrh nového zobrazení založit na existujícím zobrazení, otevřete existující zobrazení, stisknutím kombinace kláves CTRL+A vyberte všechny prvky zobrazení a potom stisknutím kombinace kláves CTRL+C zkopírujte výběr do schránky. V podokně úloh Zobrazení přepněte na nové zobrazení a potom stisknutím kombinace kláves CTRL+V vložte výběr do nového zobrazení. Nyní můžete odstranit všechny ovládací prvky nebo prvky rozložení, které v novém zobrazení nepotřebujete.

  5. V podokně úloh Zobrazení klepněte na příkaz Zobrazit vlastnosti.

  6. Klepněte na kartu Obecné.

  7. Ve skupinovém rámečku Nastavení zobrazení zaškrtněte políčko Jen pro čtení a klepněte na tlačítko OK.

  8. Chcete-li zkontrolovat, zda je zobrazení jen pro čtení, klepněte na tlačítko Náhled na panelu nástrojů Standardní.

  9. V okně Náhled se ujistěte, že do formuláře není možné zadávat data.

  10. Chcete-li se vrátit do režimu návrhu, klepněte na tlačítko Zavřít náhled na panelu nástrojů Standardní.

Začátek stránky

Vložení tlačítka pro přepnutí mezi zobrazením pro čtení i zápis a zobrazením jen pro čtení

Zobrazení jsou často navržena tak, aby pracovala s tlačítky a pravidly, pomocí kterých lze v šabloně formuláře automatizovat některé úkoly jako reakce na události a akce, které vyvolá osoba vyplňující formulář. Můžete například do šablony formuláře vložit tlačítko a poté vytvořit pravidlo, které přepne zobrazení při klepnutí na toto tlačítko. V následujícím příkladu vytvořil návrhář formuláře v dialogovém okně Pravidlo pravidlo, které přepne do souhrnného zobrazení jen pro čtení. Toto pravidlo se spustí vždy, když uživatelé klepnou na tlačítko ve formuláři.

Část dialogového okna Pravidlo

Vložení tlačítka pro přepnutí mezi zobrazeními

  1. V nabídce Zobrazit vyberte příkaz Spravovat zobrazení.

  2. V části Vyberte zobrazení klepněte na zobrazení pro čtení i zápis, do kterého chcete přidat tlačítko.

  3. Pokud není vidět podokno úloh Ovládací prvky, klikněte na Další ovládací prvky v nabídce Vložit nebo stiskněte klávesy ALT+I, C.

  4. V šabloně formuláře umístěte kurzor na místo, kam chcete vložit tlačítko.

  5. V části Vložit ovládací prvky klepněte na položku Tlačítko.

  6. V šabloně formuláře poklepejte na tlačítko, které jste právě vložili.

  7. Klepněte na kartu Obecné.

  8. V rozevíracím seznamu Akce klepněte na položku Pravidla a vlastní kód.

  9. Do pole Popisek zadejte text, který se má zobrazit na tlačítku.

  10. Klepněte na tlačítko Pravidla.

  11. V dialogovém okně Pravidla klepněte na tlačítko Přidat.

  12. Do pole Název zadejte název pravidla.

  13. Klepněte na tlačítko Přidat akci.

  14. V rozevíracím seznamu Akce klepněte na položku Přepnout zobrazení.

  15. V rozevíracím seznamu Zobrazit, klepněte na zobrazení, do kterého chcete přepnout, a poté klepněte na tlačítko OK.

  16. Klepnutím na tlačítko OK zavřete všechna otevřená dialogová okna.

  17. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

  18. V okně Náhled klepněte na tlačítko.

    Otevře se zobrazení, které jste zadali v kroku 15.

  19. Chcete-li se vrátit do režimu návrhu, klepněte na tlačítko Zavřít náhled na panelu nástrojů Standardní.

  20. Chcete-li přidat druhé tlačítko a pravidlo, aby uživatelé mohli přepnout zpět do zobrazení pro čtení i zápis, otevřete zobrazení jen pro čtení a opakujte kroky 3 až 19.

Začátek stránky

Vložení tlačítka pro přepnutí do zobrazení jen pro čtení po odeslání formuláře uživatelem

Následující postup popisuje, jak do šablony formuláře přidat tlačítko, které zobrazí odeslaná data v zobrazení jen pro čtení. Můžete to provést ve formuláři zprávy o stavu, pokud chcete, aby uživatelé mohli přepnout z výchozího zobrazení do souhrnného zobrazení dat formuláře určeného jen pro čtení.

Poznámka: Tento postup lze použít pouze v případě, že šablona formuláře obsahuje existující Datové připojení pro odeslání dat formuláře. Pokud jste ještě nenakonfigurovali datové připojení pro odesílání, je třeba to provést před dokončením tohoto postupu, jinak tyto kroky nebudou fungovat. Odkazy na další informace o datových připojeních naleznete v části Viz také.

  1. V nabídce Zobrazit vyberte příkaz Spravovat zobrazení.

  2. V části Vyberte zobrazení klepněte na zobrazení, které má obsahovat tlačítko Odeslat.

  3. Pokud není vidět podokno úloh Ovládací prvky, klikněte na Další ovládací prvky v nabídce Vložit nebo stiskněte klávesy ALT+I, C.

  4. V šabloně formuláře umístěte kurzor na místo, kam chcete vložit tlačítko.

  5. V části Vložit ovládací prvky klepněte na položku Tlačítko.

  6. V šabloně formuláře poklepejte na tlačítko, které jste právě vložili.

  7. Klepněte na kartu Obecné.

  8. V rozevíracím seznamu Akce klepněte na položku Odeslat.

  9. Chcete-li, aby byl jako popisek tlačítka zobrazen jiný text než Odeslat, zadejte požadovaný text do pole Popisek.

  10. Klepněte na tlačítko Možnosti odeslání.

  11. V dialogovém okně Možnosti odeslání ověřte, zda je zaškrtnuto políčko Povolit uživatelům odeslat tento formulář.

  12. Klepněte na přepínač Provést vlastní akci pomocí pravidel a poté klepněte na tlačítko Pravidla.

  13. V dialogovém okně Pravidla pro odesílání formulářů klepněte na tlačítko Přidat.

  14. Do pole Název zadejte název pravidla a poté klepněte na tlačítko Přidat akci.

  15. V rozevíracím seznamu Akce klepněte na položku Přepnout zobrazení.

  16. V rozevíracím seznamu Zobrazit klepněte na zobrazení jen pro čtení, do kterého chcete přepnout, a poté klepněte na tlačítko OK.

  17. Klepnutím na tlačítko OK zavřete všechna otevřená dialogová okna.

  18. Změny můžete otestovat kliknutím na Náhled na panelu nástrojů Standardní nebo stisknutím kláves CTRL+SHIFT+B.

  19. V okně Náhled klepněte na tlačítko, které slouží k odeslání formuláře.

    Mělo by se otevřít zobrazení jen pro čtení.

  20. Chcete-li se vrátit do režimu návrhu, klepněte na tlačítko Zavřít náhled na panelu nástrojů Standardní.

Začátek stránky

Poznámka: Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×