Kopírování vzorce přetažením úchytu v Excelu for Mac

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Pomocí úchytu můžete rychle zkopírovat vzorce do sousedních buněk.

Úchyt

Když se úchyt přetáhne do jiných buněk, Excel zobrazí pro každou buňku jiný výsledek.

Kopírování vzorce přetažením úchytu

Postupujte takto:

  1. Vyberte buňku obsahující vzorec, kterým chcete vyplnit sousední buňky.

  2. Přesuňte kurzor do pravého dolního rohu, aby se změnil na znaménko plus (+):

    Kurzor na úchytu

  3. Přetáhněte úchyt dolů, nahoru nebo přes buňky, které chcete vyplnit. V tomto příkladu tady obrázku přetažením úchytu vyplnit:

    Kurzor přetahující úchyt dolů

  4. Po uvolnění se vzorec automaticky vyplní do ostatních buněk:

    Hodnoty zobrazené ve vyplněných buňkách

  5. Pokud chcete změnit způsob vyplnění buněk, klikněte na tlačítko Možnosti automatického vyplnění Tlačítko Možnosti automatického vyplnění , které se zobrazí, když dokončíte přetahování, a vyberte požadovanou možnost.

Další informace o kopírování vzorců najdete v tématu Kopírování a vložení vzorce do jiné buňky nebo listu.

Tipy: 

  • Můžete také stisknout kombinaci kláves Ctrl + D, pokud chcete vzorcem Vyplnit dolů ve sloupci. Nejdřív vyberte buňku obsahující vzorec, který chcete vyplnit a potom vyberte buňky pod ním a stiskněte kombinaci kláves Ctrl + D.

  • Můžete také stisknout kombinaci kláves Ctrl + R vyplňovat vzorce v řádku napravo. Nejdřív vyberte buňku obsahující vzorec, který chcete vyplnit a potom vyberte buňky vpravo od něj a stiskněte kombinaci kláves Ctrl + R.

Pokud vyplňování nefunguje

Vyplnění někdy funguje správně a další časy, které nefunguje očekávaným. Proto je třeba zkontrolovat odkazy na buňky na první buňku.

Odkazy na buňky prostě odkazují na jiné buňky. Řekněme třeba, že první buňka obsahuje tento vzorec:


=SUMA(A1;B1)


Relativní odkazyse a1 a B1. Jednoduše to znamená, že když zadáte vzorec dolů odkazy se změní postupně z A1 a B1 A2, B2 a tak dále takto:

=SUM(A1,B1)

=SUMA(A2;B2)

=SUM(A3,B3)

Další časy, nebudete chtít odkazy do jiných buněk Chcete-li změnit. Například Řekněme, že byste chtěli první odkaz A1, pobytu pevné a B1 změnit při tažení úchytu. Chcete-li toto je případ, zadejte znak dolaru ($) v odkazu na první: =SUM($A$1,B1). Znak dolaru způsobí Excel zachovat přejdete A1 jako vyplnit ostatní buňky. Je to, co bude výsledek podobný jako:

=SUMA($A$1;B1)

=SUMA($A$1;B2)

=SUMA($A$3;B3)

Odkazy se znaky dolaru ($) se nazývají absolutní odkazy. Při vyplňování směrem dolů zůstane odkaz na A1 stejný, ale Excel změní odkaz B1 na B2 a B3.

Máte potíže se zobrazením úchytu?

Jestliže nevidíte výplně zpracovat, můžete skrýt. Chcete-li zobrazit ho:

  1. V nabídce Excel klikněte na Předvolby.

  2. Klikněte na Upravit.

  3. V části Možnosti úprav zaškrtněte políčko Povolit úchyt a přetahování buněk.

Pokud výpočet automatické sešitu nefunguje, nebude přepočet vzorců při vyplnit buňky.

Tady je postup, jak zapnout:

  1. V nabídce Excel klikněte na Předvolby.

  2. Klikněte na Výpočet.

  3. Ve skupinovém rámečku Možnosti výpočtů zajistit, že je vybraná možnost Automatická.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×