Kontrola pravopisu a gramatiky v Office

Všechny aplikace Microsoft Office umí kontrolovat pravopis a většina umí kontrolovat gramatiku. 

Pokud zjistíte, že kontrola pravopisu nebo gramatiky nefunguje, jak by měla, přečtěte si článek Kontrola pravopisu a gramatiky nefunguje podle očekávání. Pokud byste chtěli zkontrolovat pravopis nebo gramatiku v jiném jazyce, než je váš výchozí jazyk, přečtěte si článek Kontrola pravopisu a gramatiky v jiném jazyce.

Používáte Office 365? Pak by vás mohla zajímat nová výkoná funkce Editor ve Wordu. Další informace najdete v tématu Editor – váš pomocník pro psaní.

Ruční spuštění kontroly pravopisu a gramatiky

Pokud chcete spustit kontrolu pravopisu a gramatiky v souboru, stačí stisknout klávesu F7 nebo postupovat podle těchto kroků:

  1. Otevřete některou z většiny aplikací Office a klikněte na pásu karet na Revize. V Accessu nebo InfoPathu můžete tento krok přeskočit. V Projectu přejděte na kartu Project.

  2. Klikněte na Pravopis nebo Pravopis a gramatika.

    Tlačítko kontroly pravopisu a gramatiky na pásu karet Revize

  3. Při nalezení pravopisných chyb se zobrazí dialogové okno, ve kterém je uvedené první chybně napsané slovo.

  4. Až se rozhodnete, jak chybně napsané slovo vyřešit (jestli ho přeskočíte, přidáte do slovníku aplikace nebo změníte), aplikace se přesune na další chybně napsané slovo.

Další informace získáte po kliknutí na nadpis níže.

Většina aplikací Office automaticky hledá potenciální pravopisné a gramatické chyby při psaní, takže nemusíte dělat nic, aby se chyby zobrazovaly během práce. 

Poznámky: 

  • Automatická kontrola pravopisu a gramatiky není dostupná v Accessu, Excelu ani Projectu. Kontrolu pravopisu můžete spustit ručně stisknutím klávesy F7.

  • Automatická kontrola gramatiky je dostupná jenom v Outlooku, Wordu a PowerPointu 2013 (nebo novější verzi).

Office potenciální pravopisné chyby označuje červenou vlnovkou:

Pravopisná chyba označená červenou vlnovkou

Potenciální gramatické chyby jsou označené modrou vlnovkou:

Možná gramatická chyba označená modrou vlnovkou

Pokud nejsou pravopisné nebo gramatické chyby označené, je možné, že automatická kontrola je vypnutá. Jak ji zapnout najdete v části Zapnutí nebo vypnutí automatické kontroly pravopisu a gramatiky.

Když uvidíte pravopisnou nebo gramatickou chybu, s jejíž opravou chcete pomoct, klikněte pravým tlačítkem myši na podtržené slovo nebo slovní spojení a zvolte jednu z možností opravy chyby.

Pokud Office označuje slova jako špatně napsaná, ale máte je napsaná tak, jak potřebujete, vyberte Přidat do slovníku, aby Office věděl, že v budoucnu nechcete toto slovo označovat jako chybně napsané. Další informace k tomuto tématu najdete tady: Přidání nebo úprava slov ve slovníku kontroly pravopisu.

Pokud nechcete, aby Office označoval vlnovkami potenciální chyby, když pracujete, můžete automatickou kontrolu pravopisu a gramatiky vypnout:

  1. Otevřete možnosti kontroly pravopisu a gramatiky:

    • Ve OneNotu, PowerPointu, Publisheru, Visiu a Wordu: V nabídce Soubor klikněte na Možnosti a potom na Kontrola pravopisu a mluvnice.

    • V InfoPathu: Na kartě Domů klikněte na šipku vedle nebo pod položkou Pravopis a potom klikněte na Možnosti kontroly pravopisu.

    • V Outlooku: V nabídce Soubor klikněte na Možnosti, pak klikněte na Pošta a potom na Pravopis a automatické opravy.

  2. Zaškrtněte nebo zrušte zaškrtnutí políčka Kontrolovat pravopis při psaní. V aplikacích, které mají automatickou kontrolu gramatiky, můžete také zaškrtnout nebo zrušit zaškrtnutí políčka Označovat gramatické chyby při psaní.

    Zaškrtávací políčko Kontrolovat pravopis při psaní

    Poznámka: Ve Wordu můžete kontrolu pravopisu zapnout nebo vypnout pro dokument, se kterým pracujete, nebo pro všechny nové dokumenty. Vyberte možnost v seznamu Výjimky pro a pak zaškrtněte nebo zrušte zaškrtnutí políček Skrýt pravopisné chyby pouze v tomto dokumentu a Skrýt gramatické chyby pouze v tomto dokumentu.

Pokud nechcete, aby vám Office kontroloval gramatiku (buď při spuštění kontroly pravopisu nebo automaticky při psaní), můžete ji vypnout:

  1. Otevřete možnosti kontroly pravopisu a gramatiky:

    • Ve OneNotu, PowerPointu, Publisheru, Visiu a Wordu: V nabídce Soubor klikněte na Možnosti a potom na Kontrola pravopisu a mluvnice.

    • V InfoPathu: Na kartě Domů klikněte na šipku vedle nebo pod položkou Pravopis a potom klikněte na Možnosti kontroly pravopisu.

    • V Outlooku: V nabídce Soubor klikněte na Možnosti, pak klikněte na Pošta a potom na Pravopis a automatické opravy.

  2. Zrušte zaškrtnutí políček Označovat gramatické chyby při psaníS pravopisem kontrolovat i gramatiku.

    Zaškrtávací políčka Gramatika

    Poznámka: Ne každá aplikace Office má obě tyto možnosti.

Ve Wordu, Outlooku, PowerPointu 2013 (nebo novějším) můžete opakovanou kontrolu přeskočených slov a gramatiky vynutit následujícím způsobem:

  1. Otevřete dokument nebo položku, kterou chcete zkontrolovat.

  2. V nabídce Soubor klikněte na Možnosti > Kontrola pravopisu a mluvnice > Znovu zkontrolovat dokument. V Outlooku tuto možnost najdete v nabídce Soubor > Možnosti > Pošta > Pravopis a automatické opravy.

  3. Když se zobrazí zpráva upozornění týkající se obnovení kontroly pravopisu a gramatiky, klikněte na Ano.

  4. Kliknutím na OK v dialogovém okně se vraťte do dokumentu a pak znovu spusťte kontrolu pravopisu a gramatiky.

Dejte nám vědět.

Tento článek naposledy aktualizoval Ben dne 28. října 2019. Pokud vám přišel užitečný (a hlavně pokud ne), použijte následující ovládací prvky pro odeslání názoru a navrhněte nám, jak ho můžeme vylepšit.

Viz také

Kontrola čitelnosti dokumentu

Kontrola pravopisu a gramatiky nefunguje podle očekávání

Výběr možností gramatiky a stylu v Office 2013 a starších verzích

Přidávání slov do slovníku pro kontrolu pravopisu

Při kontrole pravopisu nebo gramatiky se slova v jiném jazyce nekontrolují správně

Volba možností Automatických oprav pro velká písmena, pravopis a symboly

Kontrola pravopisu před odesláním každé zprávy v Outlooku

Když píšete, aplikace Office pro Mac automaticky hledají možné pravopisné a gramatické chyby. Pokud byste s kontrolou pravopisu a gramatiky raději počkali, až budete mít dokument napsaný, můžete automatickou kontrolu pravopisu a gramatiky vypnout nebo je můžete zkontrolovat najednou.

Word

Automatická kontrola pravopisu a gramatiky při psaní

Word automaticky hledá potenciální pravopisné chyby a označuje je červenou vlnovkou.

Pravopisná chyba označená červenou vlnovkou

Word taky hledá potenciální gramatické chyby a označuje je zelenou vlnovkou.

Gramatická chyba označená zelenou vlnovkou

Tip: Pokud se vám pravopisné nebo gramatické chyby neoznačují, budete možná muset zapnout automatickou kontrolu pravopisu a gramatiky. Jak na to se dozvíte v následujícím postupu.

Když uvidíte pravopisnou nebo gramatickou chybu, podržte stisknutou klávesu Control a klikněte na dané slovo nebo slovní spojení a pak zvolte některou z možností.

Gramatická chyba a místní nabídka s možnostmi pro opravu chyby

Pokud Word nesprávně označil slovo jako pravopisnou chybu a vy si chcete dotčené slovo přidat do slovníku, aby ho Word příště rozpoznal, podívejte se na článek Přidání nebo úprava slov ve slovníku kontroly pravopisu

  1. V nabídce Word klikněte na Předvolby > Pravopis a gramatika.

  2. V dialogovém okně Pravopis a gramatika v části Kontrola pravopisu zaškrtněte políčko Kontrolovat pravopis při psaní.

  3. V části Gramatika zaškrtněte políčko Automatická kontrola gramatiky nebo zrušte jeho zaškrtnutí.

  4. Zavřete dialogové okno, aby se změny uložily.

  1. Na kartě Revize klikněte na tlačítko Pravopis a gramatika.

  2. Když Word najde potenciální chybu, otevře se dialogové okno Pravopis a gramatika. Pravopisné chyby se zobrazí jako červený text a gramatické chyby jako zelený text.

  3. Pokud chcete chybu opravit, udělejte některou z těchto věcí:

    • Zadejte do pole opravu a klikněte na Změnit.

    • V části Návrhy klikněte na slovo, které chcete použít, a potom klikněte na Změnit.

    Pokud chcete chybu přeskočit, udělejte některou z těchto věcí:

    • Když chcete přeskočit jenom tuto instanci chyby, klikněte na Přeskočit.

    • Když chcete přeskakovat všechny instance této chyby, klikněte na Přeskakovat.

    • Když se jedná o gramatickou chybu a chcete tuto instanci chyby přeskočit a přejít na další chybu, klikněte na Další věta.

    Pokud chcete, aby se některé slovo s údajně chybným pravopisem přeskakovalo ve všech dokumentech, klikněte na Přidat a přidejte si ho do slovníku. Tento postup funguje jenom u slov. Vlastní gramatika se do slovníku přidat nedá.

  4. Když chybu opravíte nebo přeskočíte, Word přejde na další. Až Word dokončí kontrolu dokumentu, zobrazí zprávu, že kontrola pravopisu a gramatiky je hotová.

  5. Kliknutím na OK se vrátíte do dokumentu.

Seznam ignorovaných slov a gramatických jevů můžete vymazat (resetovat), aby Word kontroloval pravopisné a gramatické jevy, které měl dříve přeskakovat.

Poznámka: Když seznam ignorovaných slov a gramatických jevů resetujete, vymaže se jenom pro aktuálně otevřený dokument. Pravopisných a gramatických jevů v jiných dokumentech, o kterých jste Wordu řekli, že je má přeskakovat, se to netýká.

  1. Otevřete dokument, který je třeba zkontrolovat.

  2. V nabídce Nástroje najeďte na Pravopis a gramatika a pak klikněte na Obnovit ignorovaná slova a gramatické jevy.

    Když chcete vymazat seznamy slov a gramatických jevů, které Word přeskakuje, klikněte na Resetovat přeskakovaná slova a gramatické jevy.

    Word zobrazí upozornění na operaci resetování kontroly pravopisu a gramatiky.

    Když chcete, aby Word zkontroloval pravopisné a gramatické jevy, které měl předtím přeskakovat, klikněte na Ano.
  3. Klikněte na Ano, aby operace pokračovala.

  4. Klikněte na kartu Revize a potom kliknutím na Pravopis a gramatika spusťte kontrolu pravopisu a gramatiky.

Outlook

Automatická kontrola pravopisu a gramatiky při psaní

Ve výchozím nastavení Outlook kontroluje pravopisné chyby při psaní. Outlook označuje možné pravopisné chyby přerušovaným červeným podtržením a gramatické chyby přerušovanou zelenou čarou.

Pravopisná chyby označená přerušovaným červeným podtržením

  1. Když uvidíte slovo s přerušovaným podtržením, podržte stisknutou klávesu Control, klikněte na dané slovo nebo slovní spojení a pak zvolte některou z možností.

    Pravopisná chyba s nabídkou oprav chyby

  2. V místní nabídce udělejte jednu z těchto věcí:

    • Klikněte na některý z návrhů v horní části místní nabídky.

    • Klikněte na Přeskočit a ignorujte tak jednu instanci daného slova.

    • Klikněte na Přidat do slovníku a přidejte tak toto slovo do slovníku kontroly pravopisu.

Po otevření e-mailové zprávy:

  • Pokud chcete v Outlooku zapnout automatickou kontrolu pravopisu, klikněte v Outlookové nabídce na Předvolby. V oddílu Osobní nastavení klikněte na Pravopis a gramatika. Zaškrtněte políčko u možnosti Kontrolovat pravopis při psaní.

  • Když chcete automatickou kontrolu pravopisu vypnout nebo zapnout, klikněte v nabídce Outlook na Předvolby. V oddílu Osobní nastavení klikněte na Pravopis a gramatika. Zaškrtněte políčko u možnosti Kontrolovat gramatiku při psaní.

Předvolba Kontrolovat pravopis při psaní

Všechny problémy s pravopisem a gramatikou můžete opravit zároveň, jakmile budete hotovi s psaním zprávy nebo jiné položky.

  1. V nabídce Úpravy najeďte myší na Pravopis a gramatika a pak klikněte na položku Pravopis a gramatika.

  2. Udělejte některou z těchto věcí:

    • V seznamu návrhů klikněte na slovo, které chcete použít, nebo do políčka nahoře zadejte nový pravopis a pak klikněte na Zaměnit.

    • Přeskočte toto slovo a přejděte na další chybně napsané slovo kliknutím na Ignorovat.

    • Klikněte na Přidat a přidejte dané slovo do slovníku kontroly pravopisu.

Tip: Klávesová zkratka pro přeskočení na další pravopisnou nebo gramatickou chybu je PŘÍKAZ +;.

PowerPoint

V PowerPointu můžete kontrolovat pravopis, ale ne gramatiku.

Automatická kontrola pravopisu při psaní

PowerPoint automaticky hledá potenciální pravopisné chyby a podtrhává je červenou vlnovkou:

Pravopisná chyba označená červenou vlnovkou

Tip: Pokud se vám pravopisné chyby neoznačují, budete možná muset zapnout automatickou kontrolu pravopisu. Jak na to se dozvíte v následujícím postupu.

Když uvidíte pravopisnou chybu, klikněte se stisknutou klávesou CTRL nebo pravým tlačítkem myši na dané slovo nebo slovní spojení a zvolte jednu z navržených možností.

  1. V nabídce PowerPoint klikněte na Předvolby > Pravopis.

  2. V dialogovém okně Pravopis zaškrtněte políčko Kontrolovat pravopis při psaní nebo jeho zaškrtnutí zrušte.

  1. Na kartě Revize klikněte na tlačítko Pravopis.

  2. Když PowerPoint najde možnou chybu, podokno Pravopis se otevře a zobrazí pravopisné chyby.

  3. Pokud chcete chybu opravit, udělejte některou z těchto věcí:

    • Opravte chybu přímo na snímku.

    • Klikněte na jedno z navržených slov v podokně Pravopis a pak klikněte na Změnit.

    Pokud chcete chybu přeskočit, udělejte některou z těchto věcí:

    • Když chcete přeskočit jenom tuto instanci chyby, klikněte na Přeskočit.

    • Když chcete přeskakovat všechny instance této chyby, klikněte na Přeskakovat.

    • Když chcete přeskakovat chybně napsané slovo ve všech dokumentech, klikněte na Přidat a přidejte ho tak do slovníku.

  4. Když chybu opravíte nebo přeskočíte, PowerPoint přejde na další. Až PowerPoint dokončí kontrolu dokumentu, zobrazí zprávu, že kontrola pravopisu je hotová.

  5. Klikněte na OK a vraťte se do prezentace.

Excel

V Excelu můžete kontrolovat pravopis, ale ne gramatiku.

Kontrola pravopisu v celém dokumentu

  1. Na kartě Revize klikněte na tlačítko Pravopis.

    Poznámka: Dialogové okno Pravopis se neotevře, pokud nejsou zjištěné žádné chyby pravopisu nebo gramatiky nebo pokud slovo, které se pokoušíte přidat, už ve slovníku existuje.

  2. Udělejte některou z těchto věcí.

    Akce

    Akce

    Změna slova

    V části Suggestions klikněte na slovo, které chcete použít, a potom klikněte na Change.

    Změna všech výskytů tohoto slova v tomto dokumentu

    V části Suggestions klikněte na slovo, které chcete použít, a potom klikněte na Change All.

    Přeskočení tohoto slova a přechod na další chybně napsané slovo

    Klikněte na Přeskočit.

    Přeskočení všech výskytů tohoto slova v tomto dokumentu a přechod na další chybně napsané slovo

    Klikněte na Ignore All.

Viz taky

Kontrola pravopisu a gramatiky v jiném jazyce

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×