Vzorce a funkce

Funkce KDYŽ

KDYŽ (funkce)

Jednou z nejoblíbenějších funkcí Excelu je funkce KDYŽ, která umožňuje logicky porovnávat hodnotu s očekáváním.

To znamená, že příkaz KDYŽ může mít dva výsledky. První výsledek platí, pokud je výsledkem porovnání pravda, a druhý výsledek platí v případě nepravdy.

Například vzorec =KDYŽ(C2="Ano";1;2) říká KDYŽ(C2 = Ano; vrátit hodnotu 1; jinak vrátit hodnotu 2).

Váš prohlížeč nepodporuje video. Nainstalujte si Microsoft Silverlight, Adobe Flash Player nebo Internet Explorer 9.

Funkce KDYŽ, jedna z logických funkcí, vrátí jednu hodnotu, pokud se zadaná podmínka vyhodnotí jako Pravda, a jinou hodnotu, pokud se vyhodnotí jako Nepravda.

KDYŽ(podmínka;ano;ne)

Příklady:

  • =KDYŽ(A2>B2;"Překročil se rozpočet.";"OK")

  • =KDYŽ(A2=B2;B4-A4;"")

Název argumentu

Popis

Podmínka    (povinné)

Podmínka, kterou chcete testovat

Ano    (povinné)

Hodnota, která se má vrátit, pokud se podmínka vyhodnotí jako PRAVDA

Ne    (volitelné)

Hodnota, která se má vrátit, pokud se podmínka vyhodnotí jako NEPRAVDA

Jednoduché příklady funkce KDYŽ

Buňka D2 obsahuje vzorec =KDYŽ(C2="Ano";1;2)
  • =KDYŽ(C2="Ano";1;2)

Buňka D2 v předchozím příkladu říká: KDYŽ(C2 = Ano; vrátit hodnotu 1; jinak vrátit hodnotu 2).

Buňka D2 obsahuje vzorec =KDYŽ(C2=1;"ANO";"NE")
  • =KDYŽ(C2=1;”Ano”;”Ne”)

V tomto příkladu vzorec v buňce D2 říká: KDYŽ(C2 = 1; vrátit Ano; jinak vrátit Ne)Jak je vidět, můžete funkci KDYŽ použít k vyhodnocení textu i hodnot. Můžete ji taky použít k vyhodnocení chyb. Ověřování není omezené jenom na to, jestli se něco něčemu rovná, aby se vrátil jediný výsledek. Můžete použít i matematické operátory a provádět další výpočty založené na kritériích. Pokud do sebe vnoříte víc funkcí KDYŽ, můžete provádět i vícenásobné porovnání.

Vzorec v buňce D2 je =KDYŽ(C2>B2;"Překročení rozpočtu";"V rámci rozpočtu")
  • =KDYŽ(C2>B2;"Rozpočet překročen";"V rámci rozpočtu")

V předchozím příkladu funkce KDYŽ v buňce D2 říká KDYŽ(C2 je větší než B2; vrať hodnotu "Rozpočet překročen"; jinak vrať hodnotu "V rámci rozpočtu").

Vzorec v buňce E2 je =KDYŽ(C2>B2;C2-B2;"")
  • =KDYŽ(C2>B2;C2-B2;0)

Předchozí příklad vrátí místo textového výsledku matematický výpočet. Vzorec v buňce E2 říká KDYŽ(skutečná částka je větší než plánovaná částka; odečti plánovanou částku od skutečné částky; jinak nevracej nic).

Vzorec v buňce F7 je KDYŽ(E7="Ano";F5*0,0825;0)
  • =KDYŽ(E7="Ano";F5*0,0825;0)

V tomto příkladu vzorec v buňce F7 říká: KDYŽ(E7 = "Ano"; vypočítej celkovou částku jako součin F5 * 8,25 %; jinak se žádná daň neplatí a vrať hodnotu 0).

Poznámka: Pokud používáte ve vzorcích text, musíte ho dát do uvozovek (např. "Text"). Jedinou výjimkou je použití hodnot TRUE a FALSE, kterým Excel rozumí automaticky.

Běžné problémy

Problém

Co je špatně

0 (nula) v buňce

Argument ano ani argument ne neměl žádné argumenty. Aby se vrátila správná hodnota, přidejte do obou argumentů text argumentu, nebo do argumentu přidejte hodnotu PRAVDA nebo NEPRAVDA.

Chyba #NÁZEV? v buňce

Většinou to znamená, že je špatně napsaný vzorec.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení ve fóru Excel User Voice.

Viz také

Operátory výpočtu a priorita pořadí v Excelu

Používání vnořených funkcí ve vzorcích

Použití funkce KDYŽ ke kontrole, jestli je buňka prázdná

Použití funkce KDYŽ ke kontrole, jestli je buňka prázdná

Video: Pokročilé funkce KDYŽ

Funkce IFS (Office 365, Excel 2016 a novější)

Funkce KDYŽ – jak se vyhnout nástrahám při použití vnořených vzorců

Školicí videa: Pokročilé funkce KDYŽ

Funkce COUNTIF spočítá hodnoty podle jednoho kritéria

Funkce COUNTIFS spočítá hodnoty podle více kritérií

Funkce SUMIF sečte hodnoty podle jednoho kritéria

Funkce SUMIFS sečte hodnoty podle více kritérií

Funkce A

Funkce NEBO

Funkce SVYHLEDAT

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Zjišťování chyb ve vzorcích

Logické funkce

Funkce Excelu (podle abecedy)

Funkce Excelu (podle kategorie)

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×