Jak opravit chybu #ODKAZ!

Jak opravit chybu #ODKAZ!

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

#REF! chyba zobrazuje, když vzorec odkazuje na buňku, která není platný. Nejčastěji se při buňky, které byly odkazováno vzorci získat odstranili nebo Vložit nad.

Příklad chyby #ODKAZ!, kterou způsobilo odstranění sloupce

Následující příklad používá ve sloupci E vzorec =SUMA(B2;C2;D2).

Vzorec, který používá explicitní odkazy na buňky, jako je třeba =SUMA(B2;C2;D2), může při odstranění sloupce způsobit chybu #ODKAZ!.

Pokud by bylo potřeba odstranit sloupec B, C a D může způsobit #REF! došlo k chybě. V tomto případě jsme budete odstranit sloupec C (2007 prodej), a vzorce změnil =SUM(B2,#REF!,C2). Když použijete explicitní odkazy na buňky takto (Pokud jednotlivě-každou buňku oddělená čárkou) a odstranění odkazované řádek nebo sloupec, Excel nelze ji řešit, takže se vrátí #REF! došlo k chybě. Toto je primární důvod, proč použití explicitních odkazů ve funkcích se nedoporučuje.

Příklad chyby #ODKAZ!, která byla způsobená odstraněním sloupce

Řešení

  • Pokud jste odstranili řádky nebo sloupce omylem, můžete okamžitě kliknout na tlačítko Zpět na panelu nástrojů Rychlý přístup (nebo stisknout kombinaci kláves CTRL+Z) a obnovit je.

  • Upravte vzorec tak, aby používala odkazu na oblast místo jednotlivých buněk, jako je =SUM(B2:D2). Nyní může odstranit libovolného sloupce v oblasti součet a aplikace Excel automaticky přizpůsobí vzorec. Můžete taky použít =SUM(B2:B5) součtu řádků.

Příklad funkce SVYHLEDAT s odkazy na nesprávné oblasti

V následujícím příkladu vrátí vzorec =SVYHLEDAT(A8;A2:D5;5;NEPRAVDA) chybu #ODKAZ!, protože hledá hodnotu v pátém sloupci, ale oblast, na kterou vzorec odkazuje je A:D, což jsou jen čtyři sloupce.

Příklad vzorce SVYHLEDAT s nesprávnou oblastí  Vzorec je =SVYHLEDAT(A8;A2:D5;5;NEPRAVDA).  V oblasti funkce SVYHLEDAT neexistuje pátý sloupec, takže číslo 5 způsobí chybu #ODKAZ!.

Řešení

Upravte rozsah větší nebo snížit hodnotu sloupce vyhledávání podle rozsahu odkaz. =VLOOKUP(a8,a2:E5,5,false) bude platný odkaz oblasti, jako by = VLOOKUP(A8,A2:D5,4,FALSE).

Příklad funkce INDEX se špatným odkazem na řádek nebo sloupec

V tomto příkladu vrátí vzorec =INDEX(B2:E5;5;5) chybu #ODKAZ!, protože oblast funkce INDEX jsou čtyři řádky na čtyři sloupce, ale vzorec požaduje vrátit informaci z pátého řádku a pátého sloupce.

Příklad vzorce INDEX s neplatným odkazem na oblast  Vzorec je =INDEX(B2:E5;5;5), ale oblast je pouze 4 řádky na 4 sloupce.

Řešení

Úprava odkazů řádek nebo sloupec tak, aby v prohledávané oblasti INDEX. =Index(B2:E5,4,4) vrátí platný výsledek.

Příklad funkce NEPŘÍMÝ.ODKAZ odkazující na uzavřený sešit

V následujícím příkladu se funkce NEPŘÍMÝ.ODKAZ pokouší odkázat na sešit, který je zavřený, což způsobilo chybu #ODKAZ!.

Příklad chyby #ODKAZ!, která byla způsobená NEPŘÍMÝM odkazováním na zavřený sešit

Řešení

Otevřete sešit, odkazované. Setkáte stejná chyba odkazovat skrytých sešitu pomocí funkce dynamické pole.

Problémy s OLE

Pokud jste použili odkaz technologie OLE (Object Linking and Embedding), který vrací chybu #ODKAZ!, spusťte program, na který se odkaz odvolává.

Poznámka: OLE je technologie, kterou můžete použít ke sdílení informací mezi programy.

Problémy s DDE

Pokud jste použili téma Dynamic Data (Exchange DDE), která vrací #REF! Chyba, první zkontrolujte, že jste odkazování na správné téma. Pokud jste ještě přijímá #REF! Zkontrolujte si Nastavení Centra zabezpečení pro externí obsah jako uvedené v, chyba bloku a odblokování externího obsahu v dokumentech Office.

Poznámka: Dynamic Data (Exchange DDE)je zavedený protokol pro výměnu dat mezi serveru s Windows programy společnosti Microsoft.

Problémy s makry

Pokud zadaná prostřednictvím makra funkci listu, který odkazuje na buňku nad funkci a buňku, ve které funkce je v řádku 1, vrátí funkce #REF! protože neexistují buňky nad řádek 1. Zkontrolujte funkci zobrazíte-li jako argument odkazuje na buňku nebo oblast buněk, která není platný. Může být nutné úpravy makra v jazyce Visual Basic Editor (VBE) se tato situace do účtu.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení ve fóru Excel User Voice.

Viz také

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Zjišťování chyb ve vzorcích pomocí kontroly chyb

Funkce Excelu (podle abecedy)

Funkce Excelu (podle kategorie)

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×