Office
Přihlásit se

Import dat z aplikace Excel, systému SQL Server, webů služby SharePoint a jiných externích zdrojů

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Můžete rychle importovat a zobrazení dat přímo na obrazce, pomocí Microsoft Office Visio Professional 2007. Cílem prvního kroku je k připojení ke zdroji dat a import dat do výkresu. Druhým krokem je propojení importovaných dat s obrazci.

Informace o tom, jak přidat data do obrazců bez importu dat najdete v tématu Přidání dat do obrazců.

V tomto článku

Krok 1: Import dat

Krok 2: Propojení řádků dat s obrazci ve výkresu

Krok 1: Importujte data

V prvním kroku použijte Průvodce výběrem dat k importu dat do okna Externí data.

Data, která se zobrazí v okně Externí Data je snímek zdrojových dat v čase importovat. Aktualizovat data ve výkresu, aby odpovídalo změnám ve zdrojových datech. Zdroj dat však nelze aktualizovat změnou data ve výkresu. V tématu Aktualizace importovaných dat.

  1. V nabídce Data klepněte na příkaz Propojit data s obrazci.

  2. Na první stránce Průvodce výběrem dat vyberte, který z následujících typů zdrojů dat chcete použít:

    • Sešit aplikace Microsoft Office Excel

    • Databáze aplikace Microsoft Office Access

    • Seznam služby Microsoft Windows SharePoint Services

    • Databáze Microsoft SQL Server

    • Jiný zdroj dat OLEDB nebo ODBC

    • Dříve vytvořené připojení

  3. Dokončete ostatní kroky v průvodci.

    Poznámka: Zvolíte-li na první stránce průvodce jinou možnost než sešit aplikace Excel, databázi aplikace Access nebo seznam aplikace SharePoint, můžete být dočasně přesměrováni do Průvodce datovým připojením.

    Pro většinu stránek průvodce je k dispozici odpovídající nápověda. Nápovědu otevřete stisknutím klávesy F1 nebo klepnutím na tlačítko Nápověda.

Po klepnutí na tlačítko Dokončit na poslední stránce Průvodce datovým připojením se zobrazí okno Externí Data s importovanými daty v tabulce.

Začátek stránky

2: Propojení řádků dat s obrazci ve výkresu

Existují tři způsoby propojení řádků dat s obrazci ve výkresu: řádky můžete propojit s existujícími obrazci jeden po druhém, můžete řádky propojit s obrazci automaticky nebo vytvořit obrazce z dat.

Propojení řádků s existujícími obrazci jeden po druhém

Tento přístup je nejlepší pro existující výkresy s relativně malým počtem obrazců.

  • Přetáhněte řádek z okna Externí data do obrazce ve výkresu.

    Data se zobrazí v obrazci a ikona propojení se zobrazí nalevo od řádku v okně Externí data .

    Přetažení řádku na obrazec

    Poznámky: 

    • Jeden řádek lze propojit s více obrazci, ale více řádků nelze propojit s jedním obrazcem.

    • Pokud chcete změnit nebo vylepšit vzhled obrazci a datovými, najdete v článku rozšíření dat o datové symboly.

    • Chcete-li zobrazit okno Externí data, klepněte v nabídce Zobrazení na příkaz External Data Window(Okno externích dat).

Automatické propojení řádků s existujícími obrazci

Tento přístup je nejlepší pro existující výkresy s relativně velkým počtem obrazců. Funguje pouze v případě, že obrazce již mají data v sobě, a je možné je přizpůsobit datům ve zdroji dat.

  1. Klepněte na tlačítko Automatically Link(Propojit automaticky) v nabídce Data.

  2. Postupujte podle pokynů Průvodce automatickým propojením.

    Data se zobrazí v obrazcích. Pokud chcete změnit nebo vylepšit vzhled obrazci a datovými, najdete v článku rozšíření dat o datové symboly.

Konkrétní nápověda je k dispozici u většiny stránek průvodce. Nápovědu otevřete stisknutím klávesy F1 nebo klepnutím na ikonu nápovědy.

Vytváření obrazců z dat

Tento přístup je nejlepší pro výkresy, které ještě neobsahují obrazce a vy nepotřebujete používat zvláštní obrazce.

  1. Klepněte na obrazec v okně Obrazce.

  2. Přetáhněte řádek nebo skupinu řádků z okna Externí data na prázdnou plochu výkresu.

    Pro každý řádek, který přetáhnete do výkresu, se zobrazí jeden výskyt obrazce, na který kliknete.

Začátek stránky

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×