Vzorce a funkce

Funkce KDYŽ

Funkce KDYŽ

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Funkce když je jednou z nejoblíbenějších funkcí v aplikaci Excel a umožňuje logické porovnání mezi hodnoty a co můžete očekávat.

To znamená, že příkaz KDYŽ může mít dva výsledky. První výsledek platí, pokud je výsledkem porovnání pravda, a druhý výsledek platí v případě nepravdy.

Například, že =IF(C2="Yes",1,2) Pokud (C2 = Ano a pak se vraťte 1, jinak vrácená 2).

Váš prohlížeč nepodporuje video. Nainstalujte si Microsoft Silverlight, Adobe Flash Player nebo Internet Explorer 9.

Funkce KDYŽ, jedna z logických funkcí, vrátí jednu hodnotu, pokud se zadaná podmínka vyhodnotí jako Pravda, a jinou hodnotu, pokud se vyhodnotí jako Nepravda.

KDYŽ(podmínka;ano;ne)

Příklady:

  • =KDYŽ(A2>B2;"Překročil se rozpočet.";"OK")

  • =KDYŽ(A2=B2;B4-A4;"")

Název argumentu

Popis

Podmínka    (povinné)

Podmínka, kterou chcete testovat

Ano    (povinné)

Hodnota, která se má vrátit, pokud se podmínka vyhodnotí jako PRAVDA

Ne    (volitelné)

Hodnota, která se má vrátit, pokud se podmínka vyhodnotí jako NEPRAVDA

Jednoduché příklady funkce KDYŽ

Buňka D2 obsahuje vzorec =KDYŽ(C2="Ano";1;2)
  • =KDYŽ(C2="Ano";1;2)

Buňka D2 v předchozím příkladu říká: KDYŽ(C2 = Ano; vrátit hodnotu 1; jinak vrátit hodnotu 2).

Buňka D2 obsahuje vzorec =KDYŽ(C2=1;"ANO";"NE")
  • =KDYŽ(C2=1;"Ano";"Ne")

V tomto příkladu, že vzorec v buňce D2: IF(C2 = 1, then return Yes, otherwise return No)vidět, funkce když mohou sloužit k vyhodnotit text a hodnoty. Je taky slouží k vyhodnocení chyby. Není omezena pouze kontrola Pokud jednoho sloupce je rovno druhého a vrácení výsledkem je jedna hodnota, můžete taky pomocí matematických operátorů a provést další výpočty v závislosti na kritéria. Můžete také vnořit více funkce když společně k provedení více porovnání.

Vzorec v buňce D2 je =KDYŽ(C2>B2;"Překročení rozpočtu";"V rámci rozpočtu")
  • =KDYŽ(C2>B2;"Rozpočet překročen";"V rámci rozpočtu")

V předchozím příkladu funkce KDYŽ v buňce D2 říká KDYŽ(C2 je větší než B2; vrať hodnotu "Rozpočet překročen"; jinak vrať hodnotu "V rámci rozpočtu").

Vzorec v buňce E2 je =KDYŽ(C2>B2;C2-B2;"")
  • =KDYŽ(C2>B2;C2-B2;0)

Předchozí příklad vrátí místo textového výsledku matematický výpočet. Vzorec v buňce E2 říká KDYŽ(skutečná částka je větší než plánovaná částka; odečti plánovanou částku od skutečné částky; jinak nevracej nic).

Vzorec v buňce F7 je KDYŽ(E7="Ano";F5*0,0825;0)
  • =KDYŽ(E7="Ano";F5*0,0825;0)

V tomto příkladu vzorec v buňce F7 říká: KDYŽ(E7 = "Ano"; vypočítej celkovou částku jako součin F5 * 8,25 %; jinak se žádná daň neplatí a vrať hodnotu 0).

Poznámka: Pokud používáte ve vzorcích text, musíte ho dát do uvozovek (např. "Text"). Jedinou výjimkou je použití hodnot PRAVDA a NEPRAVDA, kterým Excel rozumí automaticky.

Běžné problémy

Problém

Co je špatně

0 (nula) v buňce

Argument ano ani argument ne neměl žádné argumenty. Aby se vrátila správná hodnota, přidejte do obou argumentů text argumentu, nebo do argumentu přidejte hodnotu PRAVDA nebo NEPRAVDA.

Chyba #NÁZEV? v buňce

Většinou to znamená, že je špatně napsaný vzorec.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení ve fóru Excel User Voice.

Viz taky

Operátory a Priorita v aplikaci Excel

Použití vnořených funkcí ve vzorci

Když pomocí ke kontrole, jestli je prázdné buňky

Když pomocí ke kontrole, jestli je prázdné buňky

Video: pokročilé funkce když

IFS fungovat (Office 365, Excelu 2016 a novější)

Funkce Upřesnit IF - práce s vnořených vzorců a chybovým nástrahy

Školicí video: pokročilé funkce když

Funkce COUNTIF bude spočítání hodnot podle jednoho kritéria

Funkce COUNTIFS bude spočítání hodnot podle více kritérií

Funkce SUMIF bude součet hodnot podle jednoho kritéria

Funkce SUMIFS bude sčítání hodnot na základě více kritérií

Funkce AND

Funkce OR

Funkce SVYHLEDAT

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Použít kontrolu chyb k zjišťování chyb ve vzorcích

Logické funkce

Funkce Excelu (podle abecedy)

Funkce aplikace Excel (podle kategorie)

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×