Excelový soubor je zamknutý pro úpravy jiným uživatelem

Pokoušíte se otevřít excelový soubor a dostanete: "soubor se používá: soubor je uzamčen pro úpravy jiným uživatelem." Někdy je soubor uzamčený jiným uživatelem, a jindy je to opravdu váš "jiný uživatel". Pokud jste soubor zamkli sami, může to být proto, že soubor je otevřený na jiném zařízení nebo že předchozí instance souboru se nezavřela správně.

Zkontrolujte, jestli jste soubor zavřeli na všech svých zařízeních. Pokud se chybu nepodaří odstranit, počkejte pár minut, až server uvolní zámek souboru. (V některých případech informace o tom, že už jste soubor zavřeli, dorazí na server se zpožděním.)

Pokud to nejste vy, kdo soubor zamkl, můžete počkat, až jiný uživatel práci dokončí a soubor zavře. Můžete také zvolit, že chcete soubor zobrazit jen pro čtení. Nebo můžete druhého uživatele požádat, aby soubor zavřel, odhlásil se nebo vám udělil oprávnění k úpravám.

Pokud chcete se souborem pracovat současně s ostatními, ověřte, že všichni používají verzi Excelu, která podporuje spoluvytváření. Když soubor vytváříte společně, může ho otevřít více lidí najednou a všichni během pár sekund uvidí změny ostatních.

Verze Excelu, které podporují spoluvytváření:

  • Excel pro Office 365*

  • Excel pro Office 365 pro Mac*

  • Excel pro web

  • Excel pro Android

  • Excel pro iOS

  • Excel Mobile

* Spoluvytváření v této verzi vyžaduje, abyste měli nainstalovanou nejnovější verzi Excelu a abyste se přihlásili k Office pomocí účtu předplatného Office 365. Upozorňujeme, že pokud máte pracovní nebo školní účet, můžete mít ještě verzi Office, která nepodporuje spoluvytváření. Může to být tím, že váš správce neposkytl k instalaci nejnovější verzi.

Stačí, aby jediná osoba používala verzi Excelu, která nepodporuje spoluvytváření, a všem ostatním se zobrazí chyba uzamčení – a to i v případě, že všichni ostatní používají verzi Excelu, která spoluvytváření podporuje.

Pokud uživatelé neví, kterou verzi aplikace přesně používají, řekněte jim, ať soubor spoluvytvářejí v Excelu Online ve webovém prohlížeči.

Pokud se chcete při spoluvytváření této chybě vyhnout, dejte soubor na OneDrive, OneDrive pro firmy nebo SharePoint. Pokud je soubor uložený na jiném místě, které spoluvytváření nepodporuje, zobrazí se uživatelům chybová zpráva o tom, že je soubor uzamčený. Následující umístění nepodporují spoluvytváření:

  • Serverové cesty typu \\server\složka a smb://server/složka

  • Umístění v cloudu, například DropBox, Box a Disk Google

  • Místní složky na počítačích s Windows nebo počítačích Mac

  • Knihovny na místních webech SharePointu. Pokud máte místní web a Excel pro Office 365, zkuste místo toho použít Excel Online ke spoluvytváření.

V případě Windows: Pokud se pokoušíte spoluvytváření, zkontrolujte název souboru a zkontrolujte, jestli je ve formátu. xlsx,. xlsm nebo. xlsb. Pokud je soubor v jiném formátu, přejděte na soubor > Uložit jako > Procházet > Uložit jako typ a zvolte formát. xlsx,. xlsm nebo. xlsb.

V případě Mac: Pokud se pokoušíte spoluvytváření, zkontrolujte název souboru a zkontrolujte, jestli je ve formátu. xlsx,. xlsm nebo. xlsb. Pokud je soubor v jiném formátu, přejděte na soubor > Uložit jako... a zvolte formát. xlsx,. xlsm nebo. xlsb.

Pokud používáte Synchronizační aplikace OneDrivu pro Windows, zkontrolujte, že používáte nejnovější verzi. Také se ujistěte, že synchronizační aplikace není pozastaven.

Při spoluvytváření se může chyba zamčeného souboru objevit, pokud soubor obsahuje funkci, kterou spoluvytváření nepodporuje. Řekněte uživateli, který má soubor otevřený, ať udělá některé z následujících věcí. Jako první se pokuste vypnout funkci sdíleného sešitu. Pokud máte otevřený snímek ze SharePointu, otevřete místo toho samotný sešit. Pokud tato dvě řešení nepomůžou, zkuste některé z následujících tipů.

Windows:

  • Pokud je to možné, odeberte ze souboru šifrování heslem nebo omezený přístup. Přejděte na Soubor > Informace > Zamknout sešit a odeberte všechna nastavení hesel nebo omezeného přístupu.

  • U všech tabulek a kontingenčních tabulek v souboru vypněte nastavení Aktualizovat data při otevření souboru. Vyberte tabulku nebo kontingenční tabulku a přejděte na Nástroje tabulky – Návrh > Aktualizovat > Vlastnosti připojení. Pak zrušte zaškrtnutí políčka Aktualizovat data při otevření souboru.

  • Deaktivujte doplněk, který způsobuje uzamčení. Vyberte Soubor > Možnosti > Doplňky > Doplňky Excelu > Přejít a zrušte zaškrtnutí políčka u příslušného doplňku.

Mac:

  • Pokud je to možné, odeberte ze souboru šifrování heslem. To provedete tak, že přejdete na kartu Revize . Pokud je zvýrazněná možnost Zamknout sešit , kliknutím na něj vypněte zámek. Pokud se zobrazí výzva, zadejte heslo.

  • Pokud je to možné, odeberte omezený přístup. Přejděte na Soubor > Omezit oprávnění > Žádná omezení.

  • U všech tabulek a kontingenčních tabulek v souboru vypněte nastavení Aktualizovat data při otevření souboru. Vyberte tabulku nebo kontingenční tabulku a přejděte na kartu Tabulka > Aktualizovat > Vlastnosti připojení. Pak zrušte zaškrtnutí políčka Aktualizovat data při otevření souboru.

  • Deaktivujte doplněk, který způsobuje uzamčení. Vyberte Nástroje > Doplňky Excelu a zrušte zaškrtnutí políčka u příslušného doplňku.

Poznámka:  Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát vědět, jestli vám informace pomohly? Pokud chcete, můžete se podívat na anglickou verzi článku.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×