Další informace o funkci SUMA

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Další informace o funkci SUMA

Pokud chcete rychle sečíst oblast buněk, stačí, když vyberete oblast a podíváte se do pravého dolního rohu okna Excelu.

Snímek obrazovky s výběrem oblasti buněk a následné zobrazení stavového řádku


Toto je stavový řádek a zobrazuje informace o tom, co jste vybrali, ať už jde o jednu nebo více buněk. Když na stavový řádek kliknete pravým tlačítkem, objeví se dialog funkcí se všemi možnostmi, které můžete vybrat. Všimněte si, že uvádí taky hodnoty pro vybranou oblast (pokud máte tyto atributy zaškrtnuté). 

Průvodce Automatické shrnutí představuje nejjednodušší způsob, jak přidat na list vzorec SUMA. Vyberte prázdnou buňku přímo nad nebo pod oblastí, kterou chcete sečíst, a na kartě Domů nebo Vzorec, které najdete na pásu karet, stiskněte Automatické shrnutí > Součet. Průvodce Automatické shrnutí vybere oblast k sečtení automaticky a vytvoří za vás vzorec součtu. Když vyberete buňku vlevo nebo vpravo od oblasti, kterou chcete sečíst, automatický výběr se provede vodorovně. Tento postup nebude fungovat u nesouvislých oblastí, ale tomu se budeme více věnovat v následujícím oddílu.

Vzorec součtu můžete vytvořit automaticky pomocí průvodce Automatické shrnutí.  Vyberte oblast nad nebo pod, případně vlevo nebo vpravo od oblasti, kterou chcete sečíst, přejděte na kartu Vzorec na pásu karet a pak vyberte Automatické shrnutí a SUMA.


Dialog Automatické shrnutí umožňuje také vybrat další běžné funkce, například:

Automatické shrnutí ve svislém směru

Buňka B6 znázorňuje vzorec součtu vytvořený funkcí Automatické shrnutí: =SUMA(B2:B5).

Průvodce Automatické shrnutí vybral automaticky buňky B2:B5 jako oblast k sečtení. Stačí jenom potvrdit výběr stisknutím klávesy Enter. Pokud potřebujete přidat další buňky nebo některé odebrat, můžete stisknout a podržet klávesu Shift a současně pomocí šipek upravit výběr tak, jak potřebujete. Až budete s výběrem spokojeni, stiskněte Enter.

Průvodce funkcí IntelliSense: Plovoucí značka (číslo1;[číslo2];...) pod funkcí je průvodce funkcí IntelliSense. Když kliknete na SUMA nebo na název funkce, změní se na modrý hypertextový odkaz, kterým otevřete téma nápovědy k dané funkci. Pokud kliknete na některý prvek funkce, zvýrazní se jeho odpovídající část ve vzorci. V tomto případě by se zvýraznila jenom část B2:B5, protože v tomto vzorci je jenom jeden odkaz na číslo. Značka IntelliSense se zobrazí pro libovolnou funkci.

Automatické shrnutí ve vodorovném směru

Buňka D2 znázorňuje vzorec součtu vytvořený funkcí Automatické shrnutí: =SUMA(B2:C2).

Použití funkce SUMA pro nesouvislé oblasti.  Vzorec v buňce C8 je =SUMA(C2:C3;C5:C6). Můžete taky použít pojmenované oblasti. Vzorec by pak vypadal takto: =SUMA(týden1;týden2).

Průvodce Automatické shrnutí funguje obvykle jenom u souvislých oblastí, takže pokud máte v oblasti sčítaných buněk prázdné řádky nebo sloupce, Excel přestane sčítat, jakmile narazí na první mezeru. V takovém případě je potřeba vzorec součtu vytvořit tak, že do výběru postupně přidáte jednotlivé oblasti k sečtení. Pokud máte v tomto příkladu data v buňce B4, Excel vygeneruje vzorec =SUMA(C2:C6), protože našel souvislou oblast.

Výběr několika nesouvislých oblastí můžete rychle provést stisknutím klávesy Ctrl a levého tlačítka myši. Nejdřív zadejte část =SUMA( a pak vyberte požadované oblasti. Excel je automaticky oddělí středníkem. Po dokončení stiskněte Enter.

Tip: Funkci SUMA můžete do buňky rychle přidat stisknutím kláves ALT+=. Pak už jen stačí vybrat požadovanou oblast nebo oblasti.

Poznámka: Možná jste si všimli, že Excel zvýraznil jednotlivé oblasti různými barvami, které odpovídají i označení oblastí ve vzorci, takže oblast C2:C3 je označená jinou barvou než oblast C5:C6. Excel používá barevné označení u všech funkcí, pokud není odkazovaná oblast na jiném listu nebo v jiném sešitu. Pokud si chcete výběr zjednodušit pomocí technologie usnadnění, můžete použít Pojmenované oblasti, jako je třeba Týden1, Týden2, atd., a pak na ně odkazovat ve vzorci:

=SUMA(Týden1;Týden2)

  1. Funkci SUMA můžete samozřejmě použít i v kombinaci s jinými funkcemi. Tady je příklad výpočtu měsíčního průměru:

    Použití funkce SUMA s jinými funkcemi.  Vzorec v buňce M2 je =SUMA(A2:L2)/POČET2(A2:L2).  Poznámka: Sloupce pro květen až listopad jsou pro lepší srozumitelnost skryté.
    • =SUMA(A2:L2)/POČET2(A2:L2)

  2. Tento vzorec vypočítá podíl součtu buněk A2 až L2 a počtu neprázdných buněk v oblasti A2 až L2 (listy květen až prosinec jsou prázdné).

  1. Někdy je potřeba sečíst konkrétní buňku na více listech. I když se zdá snadné kliknout na jednotlivých listech na buňky, které chcete sečíst, a jenom doplnit +, když chcete sečíst jejich hodnoty, je toto řešení zdlouhavé a může být náchylné k chybám.

    • =list1!A1+list2!A1+list3!A1

    Mnohem jednodušší je použít v tomto případě prostorový součet:

    Prostorový součet – vzorec v buňce D2 je =SUMA(list1:list3!A2).
    • =SUMA(list1:list3!A1)

    Tento vzorec sečte buňky A1 na všech listech od listu 1 po list 3.

    To je velmi užitečné, když máte jeden list pro každý měsíc (leden až prosinec) a chcete mít jejich celkový součet na souhrnném listu.

    Prostorový součet na pojmenovaných listech.  Vzorec v buňce D2 je =SUMA(leden:prosinec!A2).
    • =SUMA(leden:prosinec!A2)

    Tento vzorec sečte buňky A2 na všech listech od ledna po prosinec.

    Poznámky: Pokud máte názvy listů s mezerami, například „prodej za leden“, musíte při odkazování na ně ve vzorci použít apostrof: Povšimněte si apostrofu před názvem prvního listu a dalšího apostrofu za názvem posledního listu.

    • =SUMA('prodej za leden:prodej za prosinec'!A2)

    Prostorový výpočet bude fungovat taky u dalších funkcí, jako je například PRŮMĚR, MIN, MAX a podobně:

    • =PRŮMĚR(list1:list3!A1)

    • =MIN(list1:list3!A1)

    • =MAX(list1:list3!A1)

S Excelem můžete snadno provádět matematické operace, ať už jednoduché, nebo v kombinaci s funkcemi Excelu (jako je třeba SUMA). Operátory, které můžete použít společně s některými souvisejícími funkcemi, jsou uvedeny v následující tabulce. Operátory můžete zadávat jak pomocí horního řádku čísel na klávesnici, tak pomocí numerické klávesnice, pokud ji máte. Například Shift+8 zadá hvězdičku (*) pro násobení.

Operátor

Operace

Příklady

+

Sčítání

=1+1

=A1+B1

=SUMA(A1:A10)+10

=SUMA(A1:A10)+B1

-

Odčítání:

=1-1

=A1-B1

=SUMA(A1:A10)-10

=SUMA(A1:A10)-B1

*

Násobení

=1*1

=A1*B1

=SUMA(A1:A10)*10

=SUMA(A1:A10)*B1

=SOUČIN(1,1) - Funkce SOUČIN

/

Dělení

=1/1

=A1/B1

=SUMA(A1:A10)/10

=SUMA(A1:A10)/B1

=QUOTIENT(1,1) - Funkce QUOTIENT

^

Umocnění

=1^1

=A1^B1

=SUMA(A1:A10)^10

=SUMA(A1:A10)^B1

=POWER(1,1) - Funkce POWER

Další informace najdete v tématu Použití Excelu jako kalkulačky.

Další příklady

  1. Řekněme, že chcete použít procentuální slevu na oblast buněk, které jste sečetli.

    Použití operátorů s funkcí SUMA.  Vzorec v buňce B16 je =SUMA(A2:A14)*−25%.  Vzorec by byl ve správném tvaru, kdyby místo hodnoty −25% obsahoval odkaz na buňku, třeba = SUMA(A2:A14)*E2.
    • =SUMA(A2:A14)*−25%

    Výsledek bude zahrnovat 25 % slevu. Hodnota 25 % ale bude ve vzorci pevně definovaná a když ji budete chtít později změnit, může být obtížné ji najít. Je mnohem lepší zadat hodnotu 25% do samostatné buňky a odkazovat na ni. Zůstane tak dobře viditelná a můžete ji snadno změnit. Příklad:

    • =SUMA(A2:A14)*E2

    Pokud nechcete násobit, ale dělit, jednoduše nahraďte symbol * symbolem /. Příklad: =SUMA(A2:A14)/E2

  2. Přičítání nebo odčítání ve funkci SUMA

    i. Ve funkci SUMA můžete pomocí symbolů + a − snadno sčítat nebo odečítat:

    • =SUMA(A1:A10)+E2

    • =SUMA(A1:A10)−E2

Viz taky

SUMA

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×