Co je to automatické ukládání?

Automatické ukládání

Pravidlo ukládat co nejčastěji je dnes již minulostí. Teď je tu funkce Automatické ukládání, která soubory automaticky ukládá každých pár sekund, abyste si s tím nemuseli dělat starosti.

Funkce Automatické ukládání je povolená, pokud je soubor uložený na OneDrivu, OneDrivu pro firmy nebo SharePointu Online. Tato funkce automaticky ukládá vaše změny do cloudu, zatímco pracujete. A v případě, že na stejném souboru pracují ostatní, zobrazí se jim vaše změny díky automatickému ukládání během několika sekund.

Poznámka: Používáte po změně původního dokumentu nebo šablony funkci Soubor > Uložit jako? Pokud ano, doporučujeme před provedením změn použít Soubor > Uložit kopii, aby vám funkce Automatické ukládání nepřepsala původní soubor vašimi změnami. Pokud Automatické ukládání soubor přepíše a uloží do něj vaše změny, přečtěte si část Nechtěl(a) jsem změny uložit. Jak je vrátím zpátky?

Ve Windows je funkce Automatické ukládání dostupná předplatitelům Office 365 v Excelu, Wordu a PowerPointu 2016. Tady jsou některé časté otázky k této funkci.

Automatické ukládání je nová funkce, kterou mají ve Windows k dispozici předplatitelé Office 365 v Excelu, Wordu a PowerPointu 2016. Ukládá soubory automaticky za vás, takže je nemusíte ukládat ručně.

Automatické ukládání ukládá změny každých pár sekund. Interval ukládání se ale může lišit v závislosti na tom, na čem pracujete.

Můžete obnovit předchozí verzi souboru. Starší verze se tak nastaví jako aktuální.

Kliknutí ukazatelem myši na soubor, Zobrazit všechny verze

V horní části okna klikněte na název souboru a potom klikněte na Zobrazit všechny verze. Zkontrolujte data a časy a najděte verzi, kterou chcete obnovit. Potom klikněte na Otevřít verzi. Otevře se druhé okno. Pokud se chcete vrátit zpátky k této verzi, klikněte na tlačítko Obnovit. Informace o historii verzí najdete v tématu Zobrazení historických verzí souborů Office.

Pokud jste vlastníky souboru, k excelovým a wordovým souborům můžete přidat nastavení „Doporučeno jen pro čtení“. Když uživatelé otevřou soubor s tímto nastavením, zobrazí se výzva s informací, že autor doporučuje soubor otevřít jen pro čtení. Pokud chcete v souboru tuto možnost nastavit, přejděte do nabídky Soubor > Uložit jako > Procházet. Pak klikněte na Nástroje > Obecné možnosti a zaškrtněte políčko Doporučeno jen pro čtení. Klikněte na OK a pak uložte soubor pod jiným názvem, nebo přepište aktuální soubor.

Soubor můžete chránit před úpravami i dalšími způsoby. Pokud je soubor uložený na OneDrivu, můžete změnit oprávnění k jeho úpravám. Pokud je soubor na uložený SharePointu, můžete nastavit konfiguraci knihovny tak, aby se požadovala rezervace souborů.

Soubor > Uložit kopii

Možnost Uložit jako není v nabídce Soubor při otevření dokumentu z OneDrivu, OneDrivu pro firmy nebo SharePointu Online. V těchto případech se místo toho v nabídce Soubor zobrazí příkaz Uložit kopii.

Používáte příkaz Uložit jako hodně? Řada lidí obvykle pracuje na souboru a pak použije příkaz Soubor > Uložit jako, aby zachovala změny v kopii a ne v originálu. Ale při zapnuté funkci Automatické ukládání se změny průběžně ukládají do originálu. Doporučujeme proto, pokud chcete použít změny v kopii a ne v originálu, použít hned na začátku možnost Soubor > Uložit kopii.

Možnost Uložit v nabídce Soubor při otevření dokumentu z OneDrivu, OneDrivu pro firmy nebo SharePointu Online nenajdete. V těchto případech je standardně zapnuté Automatické ukládání, a proto není potřeba používat možnost Soubor > Uložit. Automatické ukládání ukládá vaši práci za vás.

Pokud máte předplatné Office 365 a nainstalované nejnovější verze Excelu, Wordu a PowerPointu 2016 pro Windows, najdete Automatické ukládání v levém horním rohu. Nezapomeňte prosím, že pokud máte pracovní nebo školní účet, může správce určit verzi Office, kterou si můžete nainstalovat – a nemusí se jednat o nejnovější verzi. Další informace najdete v článku Kdy získám nejnovější funkce v Office 2016 pro Office 365.

Pokud předplatné nemáte, nic se neděje. Pořád je k dispozici funkce automatického obnovení. Automatické obnovení chrání soubory, pokud dojde k chybovému ukončení aplikace. Když po chybovém ukončení aplikace soubor znovu otevřete, zobrazí se v podokně Obnovení dokumentu verze souboru s nejnovějšími změnami. Další informace o tom, jak tuto funkci zapnout, najdete v článku Ochrana souborů pro nečekané případy.

Automatické ukládání je povolené při práci na souboru, který je uložený na OneDrivu, OneDrivu pro firmy nebo SharePointu Online. Pokud je soubor uložený v jiném umístění, je automatické ukládání zakázané. K tomu dochází, když je soubor uložený na místním webu SharePointu, souborovém serveru nebo v místní cestě, například na jednotce C:\.

Automatické ukládání může být ale zakázané i z dalších příčin. Tady je seznam běžných příčin:

  • Soubor je ve starším formátu, například .xls, .ppt nebo .doc.

  • Soubor je v místní složce OneDrivu a OneDrive je pozastavený.

  • Soubor je synchronizovaný starší verzí synchronizačního klienta OneDrivu. Další informace o aktualizaci OneDrivu najdete v článku Začínáme s novým synchronizačním klientem OneDrivu ve Windows.

  • Soubor je vložený v jiném souboru Office.

  • Prezentace je v režimu prezentace.

Pokud používáte Excel a vyzkoušeli jste výše uvedené možnosti, můžete mít soubor obsahující funkce, které automatické ukládání nepodporuje. Proveďte alespoň jednu z následujících akcí, abyste ho povolili:

  • Vypne funkci Sdílený sešit. Tato funkce představuje starší metodu sdílení. Má řadu omezení, takže ji nahradilo spoluvytváření.

  • Pokud je to možné, odeberte ze souboru šifrování heslem: Přejděte na Soubor > Informace > Zamknout sešit. Odstraňte heslo a klikněte na OK.

  • Pokud je to možné, odeberte omezený přístup: Přejděte na Soubor > Informace > Zamknout sešit > Omezit přístup a klikněte na Neomezený přístup.

  • Pokud se pokoušíte otevřít snímek sešitu ze SharePointu, neotvírejte snímek, ale soubor.

  • U všech tabulek a kontingenčních tabulek v souboru vypněte nastavení Aktualizovat data při otevření souboru. Vyberte tabulku nebo kontingenční tabulku a přejděte na Nástroje tabulky – Návrh > Aktualizovat > Vlastnosti připojení. Pak zrušte zaškrtnutí políčka Aktualizovat data při otevření souboru.

  • Deaktivujte doplněk, který vypíná automatické ukládání. Vyberte Soubor > Možnosti > Doplňky > Doplňky Excelu > Přejít a zrušte zaškrtnutí políčka u příslušného doplňku.

Můžete to udělat dvěma způsoby: Jedním ze způsobů je vybrat Soubor > Uložit kopii a uložit soubor do jiného umístění. To vám umožní pracovat s úplně samostatnou kopií souboru.

Další možnost je vypnout před provedením změn přepínač Automatické ukládání. Pokud mají být změny dočasné a nechcete je ukládat, soubor zavřete. Po zobrazení dotazu, jestli chcete soubor uložit, pak klikněte na Ne.

Pokud nechcete průběžně ukládat a nechcete, aby ostatní viděli vaše změny, můžete funkci Automatické ukládání vypnout. Až budete hotoví, kliknete na Uložit. Změny se zobrazí ostatním lidem, kteří na souboru pracují. (Můžete také Automatické ukládání znovu zapnout a změny tak uložit a sdílet.)

U souborů, které jsou v cloudu, je automatické ukládání ve výchozím nastavení vždycky Zapnuto. Pokud ale u souboru automatické ukládání vypnete, program si bude nastavení pamatovat a při každém dalším otevření daného souboru zůstane automatické ukládání vypnuto. Pokud u souboru automatické ukládání znovu zapnete, toto nastavení se u daného souboru zapamatuje.

Ne. I když vypnete automatické ukládání, automatické obnovení bude fungovat pořád. Další informace najdete v článku Ochrana souborů pro nečekané případy. Když je zapnuté automatické ukládání, je funkce automatického obnovení vypnutá, ale nemusíte mít obavy. Soubor se každých pár sekund ukládá do cloudu. Pokud tedy dojde při úpravě souboru v cloudu k chybě, stačí soubor znovu otevřít.

Ne. Můžete ho ale vypnout pro soubor a aplikace si bude toto nastavení při každém dalším otevření daného souboru pamatovat. Pokud u souboru automatické ukládání znovu zapnete, zapamatuje si aplikace toto nastavení.

Příbuzná témata

Spolupráce na excelových sešitech
Spolupráce na powerpointových prezentacích
Spolupráce na wordových dokumentech

Na Macu je funkce Automatické ukládání dostupná předplatitelům Office 365 v Excelu, Wordu a PowerPointu 2016. Tady jsou některé časté otázky k této funkci.

Automatické ukládání je nová funkce, kterou mají na Macu k dispozici předplatitelé Office 365 v Excelu, Wordu a PowerPointu 2016. Ukládá soubory automaticky za vás, takže je nemusíte ukládat ručně.

Automatické ukládání ukládá změny každých pár sekund. Interval ukládání se ale může lišit v závislosti na tom, na čem pracujete.

Můžete obnovit předchozí verzi souboru. Starší verze se tak nastaví jako aktuální. Klikněte na Soubor > Obnovit > Procházet historii verzí. V podokně Historie verzí se podívejte na data a časy a najděte verzi, kterou chcete obnovit. Potom klikněte na Otevřít verzi. Otevře se druhé okno. Pokud chcete se vrátit zpátky k této verzi, klikněte na tlačítko Obnovit.

Pokud je soubor uložený na OneDrivu, můžete změnit oprávnění pro soubor. Pokud je soubor na uložený SharePointu, můžete nastavit knihovnu tak, aby vyžadovala rezervaci souborů.

Možnost Uložit jako není v nabídce Soubor při otevření dokumentu z OneDrivu, OneDrivu pro firmy nebo SharePointu Online. V těchto případech se místo toho v nabídce Soubor zobrazí příkaz Uložit kopii.

Používáte příkaz Uložit jako hodně? Řada lidí obvykle pracuje na souboru a pak použije příkaz Soubor > Uložit jako, aby zachovala změny v kopii a ne v originálu. Ale při zapnuté funkci Automatické ukládání se změny průběžně ukládají do originálu. Doporučujeme proto, pokud chcete použít změny v kopii a ne v originálu, použít hned na začátku možnost Soubor > Uložit kopii.

Pokud máte předplatné Office 365 a nainstalované nejnovější verze Excelu, Wordu a PowerPointu 2016 pro Mac, najdete Automatické ukládání v levém horním rohu. Nezapomeňte prosím, že pokud máte pracovní nebo školní účet, může váš správce určit verzi Office, kterou si můžete nainstalovat – a nemusí se jednat o nejnovější verzi. Další informace najdete v článku Kdy získám nejnovější funkce v Office 2016 pro Office 365.

Pokud předplatné nemáte, nic se neděje. Pořád je k dispozici funkce automatického obnovení. Automatické obnovení chrání soubory, pokud dojde k chybovému ukončení aplikace. Když po chybovém ukončení aplikace soubor znovu otevřete, zobrazí se v podokně Obnovení dokumentu verze souboru s nejnovějšími změnami. Další informace o tom, jak tuto funkci zapnout, najdete v článku Automatické uložení a obnovení souborů.

Automatické ukládání je povolené při práci na souboru, který je uložený na OneDrivu, OneDrivu pro firmy nebo SharePointu Online. Pokud je soubor uložený v jiném umístění, je automatické ukládání zakázané. K tomu dochází, když je soubor uložený na místním webu SharePointu, souborovém serveru nebo v místní složce počítače.

Aby se automatické ukládání aktivovalo, je také nutné, abyste soubor otevřeli z nabídky Soubor ve Wordu, Excelu nebo PowerPointu.

Poznámka: Pokud vaše nabídka Soubor > Otevřít vypadá jako na obrázku níže, musíte kliknout na tlačítko Online umístění a vybrat soubor na OneDrivu nebo SharePointu, jinak automatické ukládání nebude funkční. Nabídka pro otevření souboru se zobrazením položek na počítači Mac

Automatické ukládání může být ale zakázané i z dalších příčin. Tady je seznam běžných příčin:

  • Soubor je ve starším formátu, například .xls, .ppt nebo .doc.

  • Soubor je v místní složce OneDrivu a OneDrive je pozastavený.

  • Soubor je vložený v jiném souboru Office.

  • Prezentace je v režimu prezentace.

Pokud používáte Excel a vyzkoušeli jste výše uvedené možnosti, můžete mít soubor obsahující funkce, které automatické ukládání nepodporuje. Proveďte alespoň jednu z následujících akcí, abyste ho povolili:

  • Vypne funkci Sdílený sešit. Tato funkce představuje starší metodu sdílení. Má řadu omezení, takže ji nahradilo spoluvytváření.

  • Pokud je to možné, odeberte ze souboru šifrování heslem: Na kartě Revize klikněte na Zamknout sešit. Odstraňte heslo a klikněte na OK.

  • Pokud je to možné, odeberte omezený přístup: Přejděte na Soubor > Omezit oprávnění > Bez omezení.

  • Pokud se pokoušíte otevřít snímek sešitu ze SharePointu, neotvírejte snímek, ale soubor.

  • U všech tabulek a kontingenčních tabulek v souboru vypněte nastavení Aktualizovat data při otevření souboru. Vyberte tabulku nebo kontingenční tabulku a přejděte na kartu Tabulka. Klikněte na Aktualizovat > Vlastnosti připojení a zrušte zaškrtnutí políčka Aktualizovat data při otevření souboru.

  • Deaktivujte doplněk, který vypíná automatické ukládání. Vyberte Soubor > Doplňky Excelu a zrušte zaškrtnutí políčka u příslušného doplňku.

Můžete to udělat dvěma způsoby: Jedním ze způsobů je vybrat Soubor > Uložit kopii a uložit soubor do jiného umístění. To vám umožní pracovat s úplně samostatnou kopií souboru.

Další možnost je vypnout před provedením změn přepínač Automatické ukládání. Pokud mají být změny dočasné a nechcete je ukládat, soubor zavřete. Po zobrazení dotazu, jestli chcete soubor uložit, pak klikněte na Ne.

Pokud nechcete průběžně ukládat a nechcete, aby ostatní viděli vaše změny, můžete funkci Automatické ukládání vypnout. Až budete hotoví, kliknete na Uložit. Změny se zobrazí ostatním lidem, kteří na souboru pracují. (Můžete také Automatické ukládání znovu zapnout a změny tak uložit a sdílet.)

U souborů, které jsou v cloudu, je automatické ukládání ve výchozím nastavení vždycky Zapnuto. Pokud ale u souboru automatické ukládání vypnete, program si bude nastavení pamatovat a při každém dalším otevření daného souboru zůstane automatické ukládání vypnuto. Pokud u souboru automatické ukládání znovu zapnete, toto nastavení se u daného souboru zapamatuje.

Ne. I když vypnete automatické ukládání, automatické obnovení bude fungovat pořád. Další informace najdete v článku Automatické uložení a obnovení souborů. Když je zapnuté automatické ukládání, je funkce automatického obnovení vypnutá, ale nemusíte mít obavy. Soubor se každých pár sekund ukládá do cloudu. Pokud tedy dojde při úpravě souboru v cloudu k chybě, stačí soubor znovu otevřít.

Ne. Můžete ho ale vypnout pro soubor a aplikace si bude toto nastavení při každém dalším otevření daného souboru pamatovat. Pokud u souboru automatické ukládání znovu zapnete, zapamatuje si aplikace toto nastavení.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×