Co je nového v Excelu 2019 pro Windows

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Pokud na Excel 2019 pro Windows upgradujete ze starší verze Excelu, budete moct dál používat funkce, na které jste zvyklí. A kromě toho i pár nových.

Excel a jeho nativní funkce neustále vylepšujeme.

CONCAT

Tato nová funkce se podobá funkci CONCATENATE, ale je lepší. Především je kratší a jde snadněji napsat. Také ale podporuje kromě odkazů na buňky i odkazy na oblasti. Přečtěte si další informace o funkci CONCAT.

IFS

Unavuje vás zadávání složitých vnořených funkcí KDYŽ? Řešením je funkce IFS. U této funkce se podmínky testují v pořadí, v jakém je zadáte. Pokud je některá podmínka splněná, vrátí se odpovídající výsledek. Můžete také zadat podmínku, která „vychytá“ případy, kdy není splněná žádná z ostatních podmínek. Přečtěte si další informace o funkci IFS.

MAXIFS

Tato funkce vrátí největší číslo z oblasti, která splňuje jednu nebo více podmínek. Přečtěte si další informace o funkci MAXIFS.

MINIFS

Tato funkce se podobá funkci MAXIFS, ale vrátí nejmenší číslo z oblasti, která splňuje jednu nebo více podmínek. Přečtěte si další informace o funkci MINIFS.

SWITCH

Tato funkce porovnává hodnotu výrazu se seznamem hodnot v jejich pořadí a jako výsledek vrací první shodnou hodnotu. Pokud se nenajde žádná shoda, vrátí funkce hodnotu zadanou jako výchozí. Přečtěte si další informace o funkci SWITCH.

TEXTJOIN

Tato funkce spojí texty z několika oblastí a jednotlivé položky od sebe oddělí oddělovačem, který jste zadali. Přečtěte si další informace o funkci TEXTJOIN.

Mapové grafy

K porovnání hodnot a zobrazení kategorií v různých geografických oblastech můžete vytvořit mapový graf. Používejte ho, když máte v datech geografické oblasti, jako země/oblasti, státy, okresy nebo PSČ. Tady se můžete podívat na krátké video o mapových grafech.

Mapový graf Excelu s údajem hodnoty

Trychtýřové grafy

Trychtýřové grafy zobrazují hodnoty z různých fází procesu. Pomocí trychtýřového grafu můžete například zobrazit počet potenciálních zákazníků v každé fázi obchodní profilace. Hodnoty se obvykle postupně zmenšují, takže pruhy připomínají trychtýř.

Trychtýřový graf znázorňující obchodní profilaci – v prvním sloupci jsou fáze, ve druhém sloupci jsou hodnoty

SVG (Scalable Vector Graphics)

Vytvářejte vizuálně působivé dokumenty, listy a prezentace – vkládejte do nich obrázky ve formátu SVG (Scalable Vector Graphics) s použitými filtry.

Snímek s příklady filtrů SVG

Převod ikon SVG na obrazce

Libovolné obrázky a ikony ve formátu SVG můžete převést na obrazce Office, abyste mohli změnit jejich barvu, velikost nebo texturu.

Váš prohlížeč nepodporuje video. Nainstalujte si Microsoft Silverlight, Adobe Flash Player nebo Internet Explorer 9.

Vkládejte 3D modely a prohlížejte ze všech úhlů

Využijte 3D ke zvýšení vizuální působivosti vašich sešitů. Snadno vložte 3D model a potom ho otáčejte v celém rozsahu 360 stupňů.

Stáhněte si šablonu a vyzkoušejte si to!

3D model s úchyty na otáčení

Funkce rukopisu jsme zavedli v Office 2016, ale neustále je vylepšujeme a rozšiřujeme.

Nové efekty rukopisu

Své myšlenky můžete stylově vyjádřit pomocí kovových per a efektů rukopisu, jako jsou duha, galaxie, láva, oceán, zlatá a stříbrná barva a další.

Rozevírací seznam pera zobrazující efekty rukopisu

Digitální tužka

Můžete psát nebo načrtnout svůj nápad pomocí nové textury tužky.

Modrá tužka

Přizpůsobitelná a přenosná sada per

Vytvořte si osobní sadu per podle svých potřeb. Office si pamatuje vaši sadu per v aplikacích Word, Excel a PowerPoint napříč všemi vašimi zařízeními s Windows.

Galerie per

Rukopisné rovnice

Vkládání matematických rovnic je teď mnohem jednodušší. Nově můžete vždycky, když budete chtít vložit do sešitu složité matematické rovnice, přejít na Vložení > Rovnice > Rukopisná rovnice. Pokud máte dotykové zařízení, můžete použít prst nebo stylus a zapsat matematické rovnice ručně a Excel je převede na text. (Pokud nemáte dotykové zařízení, můžete k zápisu použít i myš). Průběžně taky můžete mazat, vybírat a opravovat, co jste napsali.

Tlačítko Rovnice na pásu karet Excelu 2016

Zobrazuje podokno Rukopisná rovnice v PowerPointu.

Nové tlačítko Přehrání rukopisu

Používáte ve svých tabulkách rukopis? Rukopis si teď můžete přehrát nebo převinout zpět, abyste lépe pochopili jeho tok. Přehrát si ho můžou i vaši kolegové, aby tak získali podrobné pokyny. Přehrání rukopisu najdete na kartě Kreslení. Vyzkoušejte si to!

Laso na dosah ruky

Excel teď nabízí Laso Tlačítko Laso na kartě Kreslení v PowerPointu , což je nástroj pro volný výběr rukopisu. Tažením tohoto nástroje vyberete konkrétní oblast ruční kresby a pak můžete s tímto objektem podle potřeby manipulovat. Další informace najdete v článku Kreslení a psaní rukopisných poznámek v Office.

Převedení ručních kreseb na obrazce

Karta kreslení umožňuje vybrat styly rukopisu a začít psát rukopisné poznámky na zařízení s podporou dotykového ovládání. Tyto rukopisné poznámky však můžete převést na obrazce. Vyberte je a pak vyberte převést na obrazce. Tímto způsobem získáte svobodu kreslení volného tvaru díky jednotnosti a standardizaci grafických obrazců Office. Další informace o rukopisu v Office najdete v článku Kreslení a psaní rukopisných poznámek v Office.

Vybírání a změny objektů pomocí pera pro Surface

V Excelu můžete vybrat oblast perem pro Surface a nemusíte kvůli tomu ani klepnout na pásu karet na nástroj pro výběr. Jednoduše stiskněte tlačítko pera a tažením pera vytvořte výběr. Pak můžete pomocí pera tento objekt rukopisu přesunout, otočit nebo změnit jeho velikost. Další informace najdete v článku Kreslení a psaní rukopisných poznámek v Office.

Problémy s přístupností opravíte jedním kliknutím

Kontrola přístupnosti teď funguje ještě lépe díky aktualizované podpoře pro mezinárodní standardy a užitečným doporučením, která vám napoví, jak vytvářet ještě přístupnější dokumenty.

Obrazovka počítače s dokumentem nalevo a ikona přístupnosti se značkou zaškrtnutí napravo

Užitečné zvuky zlepšující přístupnost

Zapněte si zvukové pomůcky, které vás budou provázet při práci.

Částečné zobrazení nastavení Usnadnění přístupu v Excelu

Vkládání nejnovějších odkazů

Můžete snadno připojovat hypertextové odkazy na nedávno použité cloudové soubory nebo weby a pro uživatele se čtečkou obrazovky vytvářet smysluplné zobrazované názvy. Když chcete přidat odkaz na nedávno použitý soubor, zvolte na kartě Vložení možnost Odkaz a vyberte některý soubor ze zobrazeného seznamu.

Vkládání nejnovějších odkazů

Zobrazení a obnovení změn ve sdílených sešitech

Rychle si můžete zobrazit informace o tom, kdo udělal změny ve sdílených sešitech, a snadno dokážete obnovit dřívější verze. Další informace najdete v článku Zobrazení historických verzí souborů Office.

Rychlé ukládání do naposledy použitých složek

Tuto funkci naši zákazníci velmi požadovali: Přejděte na Soubor > Uložit jako > Poslední a uvidíte seznam naposledy používaných složek, do kterých můžete soubor uložit.

Přesný výběr

Už se vám někdy stalo, že jste vybrali příliš mnoho buněk nebo zahrnuli nesprávné buňky? Nově můžete zrušit výběr nadbytečných buněk a nemusíte s výběrem začínat znovu.

Váš prohlížeč nepodporuje video. Nainstalujte si Microsoft Silverlight, Adobe Flash Player nebo Internet Explorer 9.

Rychlý přístup k hornímu a dolnímu indexu

Mějte příkazy pro horní a dolní index stále po ruce, když si je přidáte na pás karet nebo na panel nástrojů Rychlý přístup.

Panel nástrojů Rychlý přístup s příkazy pro horní a dolní index

Vylepšené automatické dokončování

Automatické dokončování v Excelu už není tak vybíravé. Řekněme například, že chcete použít funkci NETWORKDAYS, ale nemůžete si vzpomenout, jak se píše. Když napíšete jenom =DAYS, nabídka automatického dokončování vrátí všechny funkce, které v názvu obsahují řetězec „DAYS“, včetně funkce NETWORKDAYS. (Dřív jste museli napsat přesně celý název funkce.)

Nové motivy

K dispozici teď jsou tři nové motivy Office: barevný, tmavě šedý a bílý. K motivům se dostanete tak, že přejdete do nabídky Soubor >Možnosti > Obecné a pak kliknete na rozevírací nabídku vedle položky Motiv Office.

Černý motiv

Motiv Office s dosud nejvyšším kontrastem je tu. Pokud chcete změnit motiv Office, přejděte do nabídky Soubor > Účet a pak klikněte na rozevírací nabídku u položky Motiv Office. Vámi vybraný motiv se použije ve všech aplikacích Office. Další informace o motivech Office najdete v tématu o změně vzhledu Office pro Windows pomocí motivů Office.

Prolomení jazykové bariéry

Microsoft Translator vám umožní překládat slova, fráze nebo věty do jiného jazyka. Najdete ho na pásu karet na kartě Revize.

Tlačítko Translator a jedno slovo v angličtině a jeho překlad do francouzštiny

Žádná upozornění při ukládání souboru CSV

Pamatujete na toto upozornění? Tento soubor může obsahovat funkce, které nejsou kompatibilní s formátem CSV. Chtěli jste to, máte to mít! Při ukládání souborů CSV se už toto upozornění nebude zobrazovat.

Podpora formátu CSV (UTF-8)

Požádali jste o to v našem uživatelském fóru pro Excel: teď můžete otevírat a ukládat soubory CSV, které používají kódování znaků UTF-8. Přejděte na soubor _GT_ Uložit jako > Procházet. Potom klikněte na nabídku Uložit jako typ a najdete novou možnost pro soubor CSV UTF-8 (oddělený čárkami). CSV UTF-8 je běžně používaný formát souboru, který podporuje více znaků, než je ve formátu ANSI. Co to znamená? Lepší podpora pro práci s daty, která nejsou anglická, a snadná přesouvání dat do jiných aplikací.

Ochrana před únikem informací (DLP – Data Loss Prevention) v Excelu

Ochrana před ztrátou dat (DLP) je funkce Enterprise, která je velmi důležitá v Outlooku. Zavádíme v Excelu ochranu před ÚNIKem informací, která umožňuje prohledávání obsahu v reálném čase na základě sady předdefinovaných zásad pro nejběžnější citlivé datové typy (třeba číslo kreditní karty, rodné číslo a číslo bankovního účtu USA). Tato možnost taky umožní synchronizaci zásad ochrany před ÚNIKem informací z Office 365 v Excelu, Wordu a PowerPointu a poskytuje organizacím jednotné zásady pro obsah uložený v Exchange, SharePointu a OneDrivu pro firmy.

O Excelu se ví, že v jeho známém autorském prostředí kontingenční tabulky je možné dělat flexibilní a efektivní analýzy. V Excelu 2010 a Excelu 2013 jsou tyto možnosti výrazně vylepšené díky zavedení doplňku Power Pivot a datového modelu, který přináší možnost snadno vytvářet složité modely přes data, posilovat je pomocí měřítek a klíčových ukazatelů výkonu a potom vysokou rychlostí vypočítávat víc než miliony řádků. Tady jsou některá vylepšení, která jsme zavedli, abyste se mohli méně věnovat správě dat a více odhalování důležitých informací.

Přizpůsobení výchozího rozložení kontingenční tabulky   

Nastavte si kontingenční tabulku podle svých představ. Zvolte, jak chcete, aby se zobrazovaly souhrny, celkové součty a rozložení sestavy, a potom to uložte jako svoje výchozí rozložení. Až příště vytvoříte kontingenční tabulku, začne s tímto rozložením.

Automatické zjišťování relací   

Vytváří relace mezi tabulkami používanými pro datový model sešitu, takže je nemusíte vytvářet sami. Excel pozná, kdy analýza vyžaduje propojení dvou nebo více tabulek, a upozorní vás na to. Stačí jedno kliknutí a vytvoří za vás relace, takže můžete hned začít využívat jejich výhod.

Vytváření, úpravy a odstraňování vlastních měr   

Teď je možné ho provádět přímo z polí kontingenční tabulky. To vám ušetří spoustu času, když pro svou analýzu potřebujete přidat další výpočty.

Automatické seskupení podle času   

Pomáhá efektivněji využívat časově vázaná pole (rok, čtvrtletí, měsíc) v kontingenční tabulce díky tomu, že je za vás automaticky zjistí a seskupí. Po seskupení stačí skupinu přetáhnout do kontingenční tabulky v jedné akci a hned začít s analýzami na různých časových úrovních díky možnostem procházení.

Tlačítka pro procházení kontingenčního grafu   

Umožňují přibližování a oddalování časových seskupení a dalších hierarchických struktur dat.

Hledání v kontingenční tabulce   

Seznam polí vám pomůže dostat se k polím, která jsou pro vás důležitá, v rámci celé datové sady.

Inteligentní přejmenování   

Inteligentní přejmenování vám dává možnost přejmenovávat tabulky a sloupce v datovém modelu sešitu. S každou změnou Excel automaticky aktualizuje jakékoliv přidružené tabulky a výpočty v sešitu, včetně všech listů a vzorců DAX.

Několik vylepšení použitelnosti   

Udělali jsme také několik vylepšení použitelnosti. Zpožděné aktualizace třeba umožňují udělat v Power Pivotu více změn bez nutnosti čekat, až se jednotlivé změny budou propagovat v sešitu. Změny se propagují jednou po zavření okna Power Pivotu.

Kontingenční tabulka s popisky zobrazující nové funkce v Excelu 2016

Vícenásobný výběr v průřezu   

Teď můžete na dotykovém zařízení vybrat v excelovém průřezu několik položek. To je rozdíl proti předchozím verzím Excelu, ve kterých se pomocí dotykového vstupu dala najednou vybrat jenom jedna položka v průřezu. Pomocí nového tlačítka umístěného v popisku průřezu můžete přejít do režimu vícenásobného výběru.

Možnosti průřezu se zvýrazněným tlačítkem vícenásobného výběru

Rychlejší kontingenční tabulky OLAP   

Pokud pracujete s připojeními k serverům OLAP, kontingenční tabulky jsou teď rychlejší. Aktualizace z června 2016 obsahuje vylepšení výkonu této výkonné funkce dotazy a mezipaměti. Tato práce by vám mohla těžit, ať už používáte kontingenční tabulky k zodpovězení jednorázových otázek, nebo vytvářet komplikované sešity s počtem kontingenčních tabulek. Nezáleží na tom, jestli jsou kontingenční tabulky propojené s tabulkovým nebo multidimenzionálním modelem, libovolnou kontingenční tabulkou propojenou se službou Microsoft SQL Server Analysis Services, poskytovateli OLAP od třetí strany nebo pomocí Power pivotu, která je v Excelu výkonná analýza a modelování dat.vám budou pravděpodobně poskytovat nová data rychleji. Když teď zakážete meziSoučty a celkové součty, kontingenční tabulky můžou být mnohem rychlejší při aktualizaci, rozbalování, sbalení a přechodu do vašich dat. Větší je kontingenční tabulka a tím větší možná vylepšení. Konkrétně jsme provedli vylepšení tří hlavních oblastí při dotazování na servery OLAP:

  • Vylepšená efektivita dotazu: Excel se teď bude dotazovat na Souhrny a Celkové součty, jenom pokud jsou potřeba k vykreslení výsledků kontingenční tabulky. To znamená, že se zkrátí doba čekání na dokončení zpracování dotazu OLAP serverem a také přenos výsledků přes síťové připojení bude trvat kratší dobu. Na kartě Návrh kontingenční tabulky jednoduše jako obvykle zakažte Souhrny a Celkové součty. Podívejte se na článek: Zobrazení nebo skrytí souhrnů a součtů v kontingenční tabulce

  • Snížený počet dotazů: Při aktualizaci dat postupuje Excel efektivněji. Dotazy se teď aktualizují, jenom pokud jste je skutečně změnili a je potřeba je aktualizovat.

  • Efektivnější mezipaměti: Schéma kontingenční tabulky se teď po načtení sdílí se všemi kontingenčními tabulkami daného připojení a snižuje tak počet dotazů.

Uložení zobrazení diagramu relací jako obrázku:   

Zobrazení diagramu datového modelu můžete uložit jako soubor obrázku s vysokým rozlišením, který se pak dá použít ke sdílení, tisku nebo analýze datového modelu. Pokud chcete vytvořit soubor obrázku, klikněte v podokně doplňku Power Pivot na Soubor a pak vyberte Uložit zobrazení jako obrázek.

Vylepšené dialogové okno Upravit relaci vytvoří relace dat rychleji a přesněji   

Uživatelé Power Pivotu můžou ručně přidat nebo upravit relaci tabulky při procházení vzorku dat (až pět řádků dat ve vybrané tabulce). Můžete vytvářet rychlejší a přesnější relace, aniž byste se museli neustále vracet k zobrazení dat pokaždé, když budete chtít vytvořit nebo upravit relaci tabulky.

Power Pivot – Vylepšený dialog Upravit relaci

Výběr tabulky s použitím navigace pomocí klávesnice   

V dialogu Upravit relaci zadejte první písmeno názvu tabulky, abyste se přesunuli na první název sloupce začínající vybraným písmenem.

Výběr sloupců pomocí navigace sloupce   

V dialogu Upravit relaci zadejte první písmeno názvu sloupce, abyste se přesunuli na první sloupec začínající vybraným písmenem. Opětovným zadáním tohoto písmene se přesunete na další sloupec začínající tímto písmenem.

Automatický návrh sloupce pro stejný název sloupce v obou tabulkách   

Jakmile vyberete první tabulku a sloupec, vybere se u druhé tabulky sloupec se stejným názvem (pokud existuje) automaticky. Tato funkce funguje oběma směry.

Opravy, které zlepšují celkové uživatelské prostředí pro modelování   

1) Datový model Power Pivotu už se při práci se skrytými sešity neztratí. 2) Starší sešit teď můžete upgradovat pomocí datového modelu na verzi Excel 2016 a novější. 3) V Power Pivotu můžete přidat počítaný sloupec, pokud neobsahuje vzorec.

Pokud máte předplatné Power BI, můžete teď do Power BI publikovat soubory, které jsou uložené místně. Abyste mohli začít, uložte nejdřív soubor do počítače. Pak klikněte na Soubor > Publikovat > Publikovat na Power BI. Po nahrání můžete kliknout na tlačítko Přejít na Power BI a zobrazit si soubor ve webovém prohlížeči.

Tato část obsahuje vylepšení funkce načtení a transformování (také známá jako Power Query).

Nové a vylepšené konektory

Excel 2019 obsahuje nové konektory. Je tu například nový konektor SAP HANA. Také jsme vylepšili řadu stávajících konektorů, abyste mohli snadno a efektivně importovat data z nejrůznějších zdrojů. Další informace o našich konektorech najdete v tématu o importu dat z externích zdrojů.

Možnosti Data > Načíst a transformovat > Načíst data

Vylepšené transformace

Celá řada funkcí pro transformaci dat v Editoru Power Query doznala v Excelu 2019 významných vylepšení. Například: Vylepšili jsme funkce rozdělení sloupců, vkládání vlastních sloupců a přidávání sloupců z příkladu. Mezi další vylepšené funkce patří operace sloučení a připojení a transformace filtrování.

Power Query – sloupce z příkladů – možnost na kartě Přidání sloupce

Obecná vylepšení

Excel 2019 obsahuje také některá Obecná vylepšení v oblasti Get & transformování v Excelu 2019. Jedním z důležitých vylepšení je nové podokno dotazy _AMP_ připojení , které umožňuje snadno spravovat dotazy a připojení. Editor Power Query také obsahuje mnoho vylepšení, včetně rozevíracích nabídek typu "vybrat jako typ", výběr data pro filtry kalendářních dat a podmíněné sloupce, schopnost změnit pořadí kroků dotazu pomocí přetažení a možnosti zachovat rozložení v Excelu při aktualizaci Obecné informace o tom, jak začít pracovat s & transformací, najdete v článku věnovaném funkci jednotné načtení _AMP_ transformace.

Další informace o aktualizacích funkce Načíst a transformovat najdete na blogu o Excelu.

Rozšiřte své dovednosti s Office

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×