Archivace dat aplikace Access

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Můžete předejít Udržujte data uspořádaná pravidelně archivací starších nebo neaktivní záznamy. Předpokládejme například, že používáte přístupu ke správě knihovna. Může být tabulka, která sleduje půjčky transakce, s polem obsahující datum byl si položky a pole obsahující datum byla vrácena. Zásady uchovávání záznamů možná je archivace půjčky transakce záznamů jeden rok po vrácení položky a destroy záznamy po dvou letech.

Můžete archivovat tabulek v databázi, konkrétních tabulek nebo pouze konkrétních záznamů – například záznamy, které nejsou starší než určitého data. Toto téma vysvětluje, jak chcete archivovat data.

V tomto článku

Základní informace

Pravidelně přesouvat záznamy do tabulky archivu

Pravidelně nahradit tabulky

Pravidelně nahraďte všechny tabulky

Základní informace

Měli byste zvážit archivace dat obsahujících data, která není budete dál používat a chcete mít data po ruce v případě potřeby. Bude pravděpodobně nutné zásadu, která provede vaše plány archiv, například zásady uchovávání informací.

Archivace často používá k ukládání dat na základě nějaké podmínky kalendářních dat, například na konci měsíce příchozí.

Způsoby, jak archivace dat

Následující tabulka uvádí způsoby archivace dat, když byste měli použít obou metod a dalších aspektech.

Metoda

Popis

Použijte, pokud...

Další informace

Pravidelně přesouvat záznamy do tabulky archivu

Pravidelně můžete spustit dotaz, který slouží k výběru data, která chcete archivovat a připojí data do tabulky archivu. Potom spustíte dotaz, který slouží k výběru stejná data (z původní tabulky) a jej odstraní.

Některé záznamy v tabulce vyhoví podmínce, které umožňují určit, zda chcete archivovat.

Příklad: Chcete-li archivovat knihovny transakce (zaškrtnutí nevýhody), pokud je zaškrtnuté políčko v datum aspoň jeden rok.

  • Možná bude potřeba řešení problémů spojených Referenční integrita, zejména pokud jsou na jedné straně Relace 1:N záznamy, které chcete archivovat.

  • Pokud potřebujete použití parametrů v dotazech, by měl udělat tak, aby zpracovat parametry. V opačném rizika ztrátou dat.

Pravidelně nahradit tabulky

Pravidelně archivu kopii určitou tabulku a nahradit kopii nové, prázdné tabulce.

Všechny záznamy v tabulce vyhoví podmínce, které umožňují určit, zda chcete archivovat.

Příklad: máte tabulku, která obsahuje denní teploty mezními hodnotami. Každý rok archivovat v tabulce a začít pracovat s nějakou prázdné.

  • Možná bude potřeba obejít referenční integritu.

Pravidelně nahraďte všechny tabulky

Začínáte s rozdělené databáze (databázi obsahující: souboru back-end databázi, která obsahuje všechny tabulky, a soubor front-end databáze, která obsahuje všechny ostatní databázové objekty). Pravidelně archivu kopii back-end databáze a potom nahraďte back-end databáze nové, prázdné.

Všechny záznamy ve většině tabulek v databázi splňují podmínku, kterou můžete určit, zda chcete archivovat.

Příklad: databáze se skládá z několika tabulek s různými typy povětrnostních data. Každý rok archivaci všechny tabulky.

  • Pokud máte všechny vyhledávací tabulky (tabulky, které používáte k ukládání hodnot pro vyhledávání, například poštovní směrovací čísla nebo oddělení), budete muset importovat data do nové back-end databázi.

  • Makro nelze použít pro tuto metodu. Databáze musí archivovat ručně.

Alternativní řešení referenční integrity

Pokud záznamy, které chcete archivovat se vztahují k záznamům v jiných tabulkách, bude pravděpodobně informace k alternativním řešením relace. Pokud záznamy, které chcete archivovat jsou záznamy "podřízené" (patří k straně "n" Relace 1:N ), je nejspíš bezpečně archivovat bez problém. Pokud jsou záznamy, které chcete archivovat "nadřazené" záznamy (patří k straně "1" Relace 1:N ), můžete archivovat jejich související "podřízené" záznamy dne:

  • Můžete zabránit v odstranění "nadřazené" záznamy. Pokud jste už přidán "nadřazené" záznamy k tabulce archivu to může způsobit problémy.

    – nebo –

  • Se stanou "vzniku osiřelých záznamů" – záznamy, které patří "nadřazenému", který neexistuje. To může způsobit potíže s integrity dat a různé funkce v databázi, která používá záznamy "řádky".

Referenční integrita kontrolujte, Uděláte to takto:

  1. Zjistěte, jaké "podřízené" záznamů patří záznamy, které chcete archivovat. Například potřeby archivaci záznamů materiálů, které můžu půjčovat v knihovně můžu nejprve určit, zda je otevřeno transakce pro tyto uživatele, zda aktiva byly rezervovaný, ale ne vrátí.

  2. Proveďte jednu z následujících akcí:

    • Pokud "podsložky" záznamy lze vždy bezpečně odstranit, ujistěte se, že vztah Vynutí referenční integritu, s kaskádové odstranění. Zajistíte tím, že budou odstraněny všechny související "podřízené" záznamy.

    • Pokud "podřízené" záznamy vždy nelze bezpečně, zvažte Archivace všech tabulek v databázi.

    • Vytvoření dotazu, který slouží k výběru "nadřazené" záznamy, které neobsahují "podřízené" záznamy. Potom, výběrového dotazu použít při vytváření dotazů archivu (viz část pravidelně přesouvat záznamy do tabulky archivu) místo použití "nadřazené" tabulky.

      Tip: Použití Průvodce dotazem pro vyhledání neshodných záznamů. Další informace naleznete v článku porovnání dvou tabulek a vyhledání záznamů bez shody.

Začátek stránky

Pravidelně přesouvat záznamy do tabulky archivu

Nejdřív zkontrolujte prázdné kopii tabulku obsahující záznamy, které chcete archivovat. Toto nové prázdné tabulce je tabulka archivu. Dále vytvořte Přidávací dotaz zkopírujte záznamy z původní tabulky do archivu tabulky. Pak vytvoříte Odstraňovací dotaz archivované odeberete z původní tabulky. Nakonec vytváření maker spouštěných obou dotazů. Když chcete archivovat záznamy, spusťte makro.

Tip: Můžete připojit makro k tlačítku ve formuláři, takže po kliknutí na tlačítko makra.

Krok 1: Vytvoření tabulky archivu

Krok 2: Vytvoření dotazu, který slouží ke kopírování dat do tabulky archivu

Krok 3: Vytvoření odstraňovacího dotazu, která odebere stejná data z původní tabulky

Krok 4: Vytvoření makra, které se spouští obou dotazů

Krok 1: Vytvoření tabulky archivu

Pokud chcete zachovat všechny archivované záznamy v jedné tabulce, se dělat jenom tento krok jednou. Archiv tabulku, kterou vytvoříte v tomto kroku bude obsahovat všechny vaše archivované záznamy.

Pokud chcete odstranit staré tabulky archiv, když vytvoříte novou, není potřeba udělat tento krok. Zkopírujte data do archivu tabulky můžete použít Vytvářecí dotaz místo přidávacího dotazu. K tomuto účelu přejděte rovnou na Krok 2.

Pokud chcete použít novou tabulku archivu pokaždé, když tuto archivaci a chcete zachovat staré tabulkách archiv, přejmenujte staré tabulky archivu než vytvoříte novou. Pokud jsou archivace na základě data, vzhledem k tomu pojmenování staré tabulkách archivu podle rozsah dat, které představují.

Poznámka: Pokud vytvoříte novou tabulku archivu každý čas a zachovat starý, je nutné před spuštěním svoje dotazy na možnost archivovat staré přejmenovat.

  1. V navigačním podokně vyberte tabulku obsahující záznamy, které chcete archivovat, stiskněte kombinaci kláves CTRL + C a stiskněte kombinaci kláves CTRL + V.

  2. V dialogovém okně Vložit tabulku jako v části Možnosti vložení vyberte Jen struktura.

  3. V poli Název tabulky odstranění slov Kopie a přidat podtržítko a slovo "archivu" název existující tabulky a klikněte na OK. Například pokud původní tabulky jmenuje transakce tabulce archivu se jmenuje Transactions_archive.

    Vložit tabulku jako

Krok 2: Vytvoření dotazu, který slouží ke kopírování dat do tabulky archivu

  1. Na kartě <ui>Vložení</ui> klikněte ve skupině <ui>Jiné</ui> na <ui>Návrh dotazu</ui>.

  2. Použijte dialogové okno Zobrazit tabulku a přidejte tabulku, která obsahuje záznamy, které chcete archivovat. Zavřete dialogové okno Zobrazit tabulku.

  3. V okně návrhu dotazu poklikejte na hvězdičku (*) v tabulce, který jste právě přidali. Název tabulky a hvězdičku se zobrazí v prvním sloupci návrhové mřížky dotazu.

    Poznámka: Hvězdička označuje, že bude dotaz obsahovat všechny sloupce z tabulky ve výsledku dotazu. Pokud používáte hvězdičky, pokud pole po přidání nebo odebrání z tabulky, se upraví i výstup dotazu.

  4. V okně návrhu dotazu poklikejte na pole, které chcete použít k určení vyžadovaného podmínky, který uchovává by splňovat předtím, než je archivovat. Například pokud transakce tabulka obsahuje pole s názvem zaškrtnuté políčko Datum a budou archivovány všechny záznamy, které toto datum je víc než jeden rok, můžete poklepáním Checked datum. Pole se zobrazí v dalšího prázdného sloupce návrhové mřížky dotazu.

    Návrhová mřížka dotazu

    Pokud chcete používání kritérií s dalších polí, opakujte tento krok.

  5. Použijte řádek kritérií Pokud chcete určit kritéria pro pole, která jste právě přidali. Například, můžete určit, že zaškrtnuté políčko datum musí být starší než 1. ledna 2008 pomocí výrazu < #1/1/2008 # v řádku kritéria.

    Pokud hodnoty kritérií změnit pokaždé, když archivujete, připomínat vašeho dotazu s výzvou k zadání vstupních hodnot. K tomuto účelu použijte parametru v řádku kritéria tak, aby dotazu požádá o zadání kritérií. Pokud chcete použít parametr, zadat pomocí výrazů, jak můžete obvykle by, ale místo zadanou hodnotu, používejte otázce stručný hranatých závorkách. Můžete třeba použít výraz < [archivace transakce dokončen před:], třeba takto:

    Výraz s parametrem

    Další informace o použití parametrů naleznete v článku Vytvoření dotazu s výzvou k zadání vstupních hodnot.

    Můžete taky pomocí řádku nebo můžete určit alternativní podmínky. Další informace o používání kritérií naleznete v článku Příklady kritérií dotazů.

    Tip: Pokud používáte k zadání kritérií pole date a chcete archivovat všechny záznamy, které nejsou starší než s aktuálním datem, zadejte < Date() v řádku kritéria pro pole datum.

  6. Proveďte jednu z následujících akcí:

    • Pokud jste již vytvořili tabulce archivovat, je třeba přidávacího dotazu k přidání zadaný záznamů do tabulky.

      1. Na kartě Návrh klikněte ve skupině Typ dotazu na položku Přidávací.

      2. V dialogovém okně Přidat do pole Název tabulky vyberte název tabulky archivovat a klikněte na tlačítko OK.

        Přidat do

        V návrhové mřížce dotazu se zobrazí řádek Přidat do.

      3. Zrušte zaškrtnutí políčka řádku Přidat do pro všechna pole, které jste použili k zadání kritérií. (Pouze na hvězdičku má hodnotu pro Přidat do.)

        Řádek Přidat do v návrhové mřížce dotazu

    • Pokud jste nevytvořili tabulce archiv, musíte vytvářecího dotazu k vytvoření tabulky archivu pomocí zadaného záznamy.

      1. Na kartě Návrh klikněte ve skupině Typ dotazu na položku Vytvářecí.

      2. V dialogovém okně Vytvořit tabulku v poli Název tabulky zadejte název tabulky archivovat a klikněte na tlačítko OK.

  7. Stisknutím CTRL+S dotaz uložte.

Krok 3: Vytvoření odstraňovacího dotazu, která odebere stejná data z původní tabulky

  1. Na kartě <ui>Vložení</ui> klikněte ve skupině <ui>Jiné</ui> na <ui>Návrh dotazu</ui>.

  2. Použijte dialogové okno Zobrazit tabulku a přidejte tabulku, která obsahuje záznamy, které chcete archivovat. Zavřete dialogové okno Zobrazit tabulku.

  3. V okně návrhu dotazu poklikejte na hvězdičku (*) v tabulce, který jste právě přidali. Název tabulky a hvězdičku se zobrazí v prvním sloupci návrhové mřížky dotazu.

  4. V okně návrhu dotazu poklikejte na stejné pole, které jste použili k zadat podmínku v přidávacího dotazu.

  5. Použijte řádek kritérií Pokud chcete určit kritéria pro pole, která jste právě přidali. Další informace o používání kritérií naleznete v článku Příklady kritérií dotazů.

    Důležité informace: Je-li přidat nebo vytvářecího dotazu použít parametr, tak by měl odstraňovací dotaz. Navíc nezapomeňte zadat stejnou hodnotu obou dotazů. Pokud chcete zadat hodnoty různých parametrů, může dojít ke ztrátě dat. Abyste předešli ztrátě dat, zvažte sběr hodnoty pomocí formuláře a po nich žádáte formuláři vstupní hodnoty dotazů. Další informace naleznete v článku Vytvoření dotazu s výzvou k zadání vstupních hodnot.

  6. Na kartě Návrh klikněte ve skupině Typ dotazu na tlačítko Odstranit.

    Řádek Odstranit v návrhové mřížce dotazu se zobrazí.

    Řádek Odstranit v návrhové mřížce dotazu

  7. Stisknutím CTRL+S dotaz uložte.

Krok 4: Vytvoření makra, které se spouští obou dotazů

  1. Na kartě <ui>Vytvořit</ui> klikněte ve skupině <ui>Jiné</ui> na položku <ui>Makro</ui>. Není-li tento příkaz k dispozici, klikněte na šipku pod tlačítkem <ui>Modul</ui> nebo pod tlačítkem <ui>Modul třídy</ui> a potom klikněte na položku <ui>Makro</ui>.

  2. V prvním řádku návrhové mřížky, ve sloupci Akce vyberte OtevřítDotaz.

    Akce makra OtevřítDotaz

  3. V dolní části mřížky v seznamu Argumentů do pole Název dotazu vyberte (připojit nebo vytvářecích) dotaz, který jste vytvořili v kroku 2 z rozevíracího seznamu.

    Argument dotazu akce makra OtevřítDotaz

  4. Ve druhém řádku návrhové mřížky, ve sloupci Akce vyberte OtevřítDotaz.

  5. V dolní části mřížky v seznamu Argumentů do pole Název dotazu vyberte odstraňovacího dotazu z rozevíracího seznamu.

    Makro by měl vypadat nějak takto:

    Makro připravené k uložení

  6. Stisknutím kombinace kláves CTRL + S uložte makro.

    Když chcete archivovat záznamy, spusťte makro.

Začátek stránky

Pravidelně nahradit tabulky

Pokud chcete vždy archivace všechna data v tabulce, nemusíte používat dotazy nebo makra. Jako alternativu můžete pravidelně nahradit tabulce prázdné kopírovat.

Důležité informace: Pokud tabulce archivujete souvisí s jinými tabulkami, můžete zkusit informace k alternativním řešením referenční integritu.

  1. V navigačním podokně vyberte tabulku, kterou chcete archivovat, stiskněte kombinaci kláves CTRL + C a stiskněte kombinaci kláves CTRL + V.

  2. V dialogovém okně Vložit tabulku jako v části Možnosti vložení zaškrtněte políčko Struktura pouze a klikněte na OK.

    Access názvy výtisku kopie původní název tabulky.

  3. V navigačním podokně klikněte pravým tlačítkem na původní tabulku a v místní nabídce, která se zobrazí klikněte na příkaz Přejmenovat.

    Pojmenujte tabulku, která označuje, co je obsahuje, například "DailyTemperatureExtremes_archive_2007".

  4. V navigačním podokně klikněte pravým tlačítkem na prázdný kopírovat a v místní nabídce, která se zobrazí klikněte na příkaz Přejmenovat.

    Zobrazit prázdné kopie původní název tabulky.

Začátek stránky

Pravidelně nahraďte všechny tabulky

Pokud používáte rozdělené databáze, můžete pravidelně nahradit všechny tabulky nahrazením prázdné kopii back-end databáze.

Nejprve připravte výtisku prázdné. Pokud se změní návrh databáze, můžete znovu použít tuto kopii pokaždé, když archivujete. Potom když budete chtít okno archiv, můžete přejmenovat existující back-end databáze označíte, že je archivu a uložte výtisku prázdné jako novou back-end databáze.

Příprava prázdné kopii back-end databáze

Importujte definice tabulky pro všechny tabulky v back-end databázi.

  1. Vytvořte novou, prázdnou databázi. Odstranění tabulky Table1.

  2. Na kartě Externí data ve skupině Import klikněte na Access.

  3. V dialogovém okně Načíst externí Data vyberte možnost importovat tabulky, dotazy, formuláře, sestavy, makra a moduly do aktuální databáze a pak klikněte na Procházet.

  4. V dialogovém okně Otevřít vyberte back-end databázi. Klikněte na Otevřít a zavřete dialogové okno Otevřít soubor a potom klikněte na OK.

  5. V dialogovém okně Import objektů klikněte na Možnosti.

  6. V části Importovat tabulky zaškrtněte políčko Pouze definici.

  7. Na kartě tabulky klikněte na tlačítko Vybrat vše, klikněte na tlačítko OK a potom na tlačítko Zavřít.

Pak přidání dat do libovolné vyhledávací tabulky ve výtisku prázdné. Pro každou vyhledávací tabulka v relaci proveďte následující kroky:

  1. Odkaz na vyhledávací tabulky v existující back-end databázi.

  2. Vytvoření přidávacího dotazu, která přidá všechny záznamy od původní výtisku.

Nahraďte prázdné kopii back-end databáze

Přejmenujte existující back-end databáze označíte, že je teď archivu.

Potom otevřete prázdný kopii a uložit pomocí původní název back-end databázi.

  1. Klikněte na Tlačítko Microsoft Office Obrázek tlačítka Office a potom přejděte na příkaz Uložit jako. Otevření nabídky Uložit jako.

  2. V části Uložit databázi v jiném formátu klikněte na Databáze aplikace Access 2007.

Začátek stránky

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×