Aktualizace dat v existujícím grafu

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Po vytvoření grafu pravděpodobně muset změnit její zdrojová data na List. Zahrnout tyto změny v grafu, aplikace Microsoft Excel nabízí různé způsoby aktualizace grafu. Graf můžete okamžitě aktualizovat nejnovějšími změněné hodnoty nebo dynamicky můžete změnit podkladového zdroje. Přidání, změna nebo odebrání dat můžete rovněž aktualizovat grafu.

Změna podkladových dat, na kterých je graf založen

Při aktualizaci zdrojových dat grafu dat v grafu a vzhled změníte. Rozsah tyto změny závisí na způsobu definujete zdroj dat grafu. V aplikaci Excel můžete automaticky aktualizovat hodnoty změněné listu do grafu nebo můžete použít způsoby, jak dynamicky změnit podkladovém zdroji dat do grafu.

Automatická aktualizace změněných dat v existujícím grafu

Hodnot v grafu jsou propojené na data listu, ze kterého je vytvořena grafu. Výpočet nastavit možnosti Automatická (v Excelu klikněte na kartu soubor > Možnosti > pásu karet aplikace Excel, tlačítko Možnosti výpočtů ), změny provedené na data listu automaticky zobrazí v grafu.

Poznámka: V Excel 2007, klikněte na tlačítko Microsoft Office Obrázek tlačítka Office > Možnosti aplikace Excel > vzorce > výpočty > Možnosti výpočtů.

  1. Otevřete list obsahující data, která jsou vynesená do grafu.

  2. Do buňky obsahující hodnotu, kterou chcete změnit, zadejte hodnotu novou.

  3. Stiskněte klávesu ENTER.

Dynamická změna podkladového zdroje dat u existujícího grafu

Pokud chcete, aby zdroj dat grafu rostl dynamicky, můžete to udělat dvěma způsoby. Buď graf můžete založit na datech v excelové tabulce nebo ho můžete založit na definovaném názvu.

Založení grafu na excelové tabulce

Pokud jste vytvořili graf založený na oblast buněk, aktualizace dat v oblasti původní se projeví v grafu. Ale zvětšit velikost oblasti přidávání řádků a sloupců a změnit data v grafu a vzhled, třeba změnit ručně původního zdroje dat v grafu změnou oblast buněk, který graf je založený na.

Pokud chcete, aby se data a vzhled grafu změnily, když se zdroj dat zvětší, můžete jako podkladový zdroj dat využít excelovou tabulku.

  1. Klikněte na graf, u kterého chcete změnit oblast buněk se zdrojovými daty.

    Zobrazí se pás karet Nástroje grafu s kartami Návrh, RozloženíFormát.

  2. Na kartě Návrh klepněte ve skupině Data na tlačítko Vybrat data.

    Vzhled pásu karet aplikace Excel

  3. Z dialogového okna Vybrat zdroj dat si poznamenejte umístění oblasti dat a potom klikněte na OK.

  4. Přejděte na toto umístění a klikněte na libovolnou buňku v této oblasti dat.

  5. Na kartě Vložit ve skupině Tabulky klepněte na tlačítko Tabulka.

    Vzhled pásu karet aplikace Excel

    Klávesová zkratka: stiskněte kombinaci kláves CTRL + L nebo CTRL + T.

Založení grafu na definovaném názvu

Další způsob, jak dynamicky měnit data a vzhled grafu, když se zdroj dat zvětší, je pomocí definovaného názvu a funkce POSUN. Tento postup je užitečný, když potřebujete řešení, které funguje i s předchozími verzemi Excelu.

Další informace najdete v tématu Použití definovaných názvů k automatické aktualizaci oblasti grafu v Excelu.

Přidání dat do existujícího grafu

Pro zahrnutí dalších zdrojových dat do existujícího grafu můžete použít jeden z několika způsobů. Můžete rychle přidat další datovou řadu. Můžete přetáhnout úchyty pro změnu velikosti oblastí tak, abyste zahrnuli data grafu, která se nachází na stejném listu. Nebo můžete další data zkopírovat do vloženého grafu nebo do samostatného Listu s grafem.

Přidání datové řady do grafu

  1. Klikněte na graf, do kterého chcete přidat další datovou řadu.

    Zobrazí se pás karet Nástroje grafu s kartami Návrh, RozloženíFormát.

  2. Na kartě Návrh klepněte ve skupině Data na tlačítko Vybrat data.

    Vzhled pásu karet aplikace Excel

  3. V dialogovém okně Vybrat zdroj dat v části Položky legendy (řady), klikněte na Přidat.

  4. V dialogovém okně Upravit řady udělejte toto:

    • V poli Název řady zadejte název, který chcete pro tuto řadu použít, nebo vyberte název listu.

    • V poli Hodnoty řad zadejte odkaz na oblast datové řady, kterou chcete přidat, nebo tuto oblast vyberte přímo na listu.

      Klikněte na tlačítko Sbalit dialog  Tlačítko Sbalit v pravé části pole Název řady nebo Hodnoty řad a potom vyberte oblast, kterou chcete použít pro tabulku na listu. Až skončíte, klikněte znovu na tlačítko Sbalit dialog, abyste si dialogové okno zobrazili zase celé.

      Pokud používáte klávesy se šipkami, abyste umístili ukazatel a mohli zadat odkaz, můžete stisknout klávesu F2, kterou se dostanete do režimu úprav. Opětovným stisknutím klávesy F2 se přepnete zpět do režimu pozice. Aktuální režim si můžete ověřit na stavovém řádku.

Přetáhněte úchyty pro změnu velikosti oblastí tak, abyste do vloženého grafu přidali data

Pokud jste vložený graf vytvořili ze sousedících buněk listu, můžete do něj přidat data tak, že přetáhnete úchyty pro změnu velikosti oblastí zdrojových dat. Graf musí být na stejném listu jako data, která jste použili pro vytvoření grafu.

  1. Data a popisky, které chcete přidat do grafu, zadejte na tento list do buněk, které sousedí se stávajícími daty.

  2. Klikněte na graf, abyste si na listu kolem zdrojových dat zobrazili úchyty pro změnu velikosti.

  3. Na listu proveďte jednu z následujících akcí:

    • Pokud chcete do grafu přidat nové kategorie a datové řady, přetáhněte modrý úchyt pro změnu velikosti tak, aby jeho obdélník obsahoval nová data a popisky.

    • Pokud chcete přidat pouze nové datové řady, přetáhněte zelený úchyt pro změnu velikosti tak, aby jeho obdélník obsahoval nová data a popisky.

    • Pokud chcete přidat nové kategorie a datové body, přetáhněte fialový úchyt pro změnu velikosti tak, aby jeho obdélník obsahoval nová data a kategorie.

Kopírování dat do grafu

Pokud jste vložený graf vytvořili z nesousedících buněk nebo pokud je graf na samostatném listu s grafem, můžete do něj další data zkopírovat.

  1. Na listu vyberte buňky s daty, které chcete do grafu přidat.

    Pokud chcete, aby se v grafu objevil popisek sloupce nebo řádku, v němž jsou nová data umístěna, zahrňte buňku obsahující popisek do výběru.

  2. Na kartě Domů klikněte ve skupině Schránka na Kopírovat Obrázek tlačítka .

    Vzhled pásu karet aplikace Excel

    Klávesová zkratka: stiskněte kombinaci kláves CTRL + C.

  3. Klikněte na list s grafem nebo na vložený graf, do kterého chcete kopírovaná data vložit.

  4. Proveďte jednu z následujících akcí:

    • Pokud chcete data do grafu vložit, klikněte na kartě Domů ve skupině Schránka na Vložit Obrázek tlačítka .

      Klávesová zkratka: stiskněte CTRL + V.

    • Pokud chcete určit, jak by zkopírovaná data měla být v grafu vynesena, klikněte na kartě Domů ve skupině Schránka na šipku u tlačítka Vložit, vyberte Vložit jinak a pak vyberte požadovanou možnost.

Změna dat v existujícím grafu

Existující graf můžete změnit úpravou jednotlivých datových řad, které se zobrazují v grafu, nebo změnou oblasti buněk, na které je graf založen. Nebo taky můžete změnit popisky vodorovné osy (kategorie).

Změna oblasti buněk, na které je graf založen

  1. Klikněte na graf, u kterého chcete změnit oblast buněk se zdrojovými daty.

    Zobrazí se pás karet Nástroje grafu s kartami Návrh, RozloženíFormát.

  2. Na kartě Návrh klepněte ve skupině Data na tlačítko Vybrat data.

    Vzhled pásu karet aplikace Excel

  3. V dialogovém okně Vybrat zdroj dat si ověřte, že v poli Oblast dat grafu máte vybraný celý odkaz.

    Klikněte na tlačítko Sbalit dialog  Tlačítko Sbalit v pravé části pole Oblast dat grafu a potom vyberte oblast, kterou chcete použít pro tabulku na listu. Až skončíte, klikněte znovu na tlačítko Sbalit dialog, abyste si dialogové okno zobrazili zase celé.

  4. Na listu vyberte buňky s daty, které chcete v grafu zobrazit.

    Pokud chcete, aby se v grafu zobrazily popisky sloupců nebo řádků, zahrňte do výběru buňky, které tyto popisky obsahují.

    Pokud používáte klávesy se šipkami, abyste umístili ukazatel a mohli zadat odkaz, můžete stisknout klávesu F2, kterou se dostanete do režimu úprav. Opětovným stisknutím klávesy F2 se přepnete zpět do režimu pozice. Aktuální režim si můžete ověřit na stavovém řádku.

Přejmenování nebo změna datové řady, která se zobrazuje v grafu

Název a hodnoty existující datové řady můžete upravit bez ovlivnění dat na listu.

  1. Klikněte na graf obsahující datovou řadu, kterou chcete změnit.

    Zobrazí se pás karet Nástroje grafu s kartami Návrh, RozloženíFormát.

  2. Na kartě Návrh klepněte ve skupině Data na tlačítko Vybrat data.

    Vzhled pásu karet aplikace Excel

  3. V dialogovém okně Vybrat zdroj dat v části Položky legendy (řady), vyberte datovou řadu, kterou chcete změnit, a potom klikněte na Upravit.

  4. Pokud chcete datovou řadu přejmenovat, zadejte do pole Název řady název, který chcete pro tuto řadu použít, nebo vyberte název listu. Zadaný název se zobrazí v legendě grafu, ale nepřidá se do listu.

  5. Pokud chcete oblast datové řady změnit, zadejte do pole Hodnoty řad odkaz na oblast datové řady, kterou chcete přidat, nebo tuto oblast vyberte na listu nebo do tohoto pole zadejte přímo hodnoty. Zadané hodnoty se do listu nepřidají.

    Když je graf XY (bodový), zobrazí se pole Hodnoty X řadHodnoty Y řad, abyste mohli změnit oblast dat i u těchto hodnot. Když je graf bublinový, zobrazí se pole Hodnoty X řadHodnoty Y řadVelikost bublin řad, abyste také mohli změnit oblast dat i u těchto hodnot.

U každého pole můžete v jeho pravé části kliknout na tlačítko Sbalit dialog Tlačítko Sbalit a potom můžete vybrat oblast, kterou chcete použít pro tabulku na listu. Až skončíte, klikněte znovu na tlačítko Sbalit dialog, abyste si dialogové okno zobrazili zase celé.

Pokud používáte klávesy se šipkami, abyste umístili ukazatel a mohli zadat odkaz, můžete stisknout klávesu F2, kterou se dostanete do režimu úprav. Opětovným stisknutím klávesy F2 se přepnete zpět do režimu pozice. Aktuální režim si můžete ověřit na stavovém řádku.

Změna pořadí datové řady

  1. Klikněte na graf obsahující datovou řadu, kterou chcete změnit.

    Zobrazí se pás karet Nástroje grafu s kartami Návrh, RozloženíFormát.

  2. Na kartě Návrh klepněte ve skupině Data na tlačítko Vybrat data.

    Vzhled pásu karet aplikace Excel

  3. V dialogovém okně Vybrat zdroj dat v části Položky legendy (řady), vyberte datovou řadu, kterou chcete přesunout na jiné místo v pořadí.

  4. Klikněte na šipku Přesunout nahoru nebo Přesunout dolů, abyste datovou řadu přesunuli.

  5. Krok 3 a 4 opakujte u všech datových řad, které chcete přesunout.

Změna popisků vodorovné osy (kategorie)

Když změníte popisky vodorovné osy (kategorie), změní se popisky všech vodorovných os. Popisky jednotlivých vodorovných os změnit nemůžete.

  1. Klikněte na graf obsahující popisky vodorovné osy, které chcete změnit.

    Zobrazí se pás karet Nástroje grafu s kartami Návrh, RozloženíFormát.

  2. Na kartě Návrh klepněte ve skupině Data na tlačítko Vybrat data.

    Vzhled pásu karet aplikace Excel

  3. V části Popisky vodorovné osy (kategorie) klikněte na Úpravy.

  4. V poli Oblast popisku osy zadejte odkaz na oblast datové řady, kterou chcete použít pro popisky vodorovné osy, nebo tuto oblast vyberte přímo na listu.

    Klikněte na tlačítko Sbalit dialog  Tlačítko Sbalit v pravé části pole Název řady nebo Hodnoty řad a potom vyberte oblast, kterou chcete použít pro tabulku na listu. Až skončíte, klikněte znovu na tlačítko Sbalit dialog, abyste si dialogové okno zobrazili zase celé.

    Pokud používáte klávesy se šipkami, abyste umístili ukazatel a mohli zadat odkaz, můžete stisknout klávesu F2, kterou se dostanete do režimu úprav. Opětovným stisknutím klávesy F2 se přepnete zpět do režimu pozice. Aktuální režim si můžete ověřit na stavovém řádku.

Odebrání dat z grafu

Pomocí možnosti výpočtů nastavit automatické data, která se odstraní z listu se automaticky odeberou z grafu. Můžete taky odebrání dat z grafu beze změny zdrojových datech na listu.

Odstranění zdrojových dat na listu

  • Na listu vyberte buňku nebo oblast buněk obsahující data, která chcete odebrat z grafu, a potom stiskněte klávesu DELETE.

    • Pokud data z vybraných buněk odeberete, vynesou se do grafu prázdné buňky. Způsob, kterým se prázdné buňky vykreslují, můžete změnit, když kliknete pravým tlačítkem na graf a potom vyberete Skryté a prázdné buňky.

    • Pokud odstraníte sloupec, odebere se z grafu celá datová řada. Pokud odstraníte řádek, může se zobrazit chybová zpráva. Když kliknete na tlačítko OK, graf může zobrazit jeden nebo více datových bodů z datové řady, kterou jste odstranili. Na tyto datové body můžete kliknout a potom stisknout klávesu DELETE.

Odebrání datové řady z grafu

  1. Klikněte na graf nebo na datovou řadu, kterou chcete odebrat, nebo následujícím způsobem vyberte graf nebo datovou řadu ze seznamu prvků grafu:

    1. Klepněte na graf.

      Zobrazí se pás karet Nástroje grafu s kartami Návrh, RozloženíFormát.

    2. Na kartě Formát ve skupině Aktuální výběr klikněte na šipku vedle pole Oblasti grafu a potom klikněte na prvek grafu, který chcete použít.

      Skupina Aktuální výběr na kartě Formát (Nástroje grafu)

  2. Proveďte některou z následujících akcí:

    1. Pokud jste vybrali graf, postupujte takto:

      1. Na kartě Návrh klikněte ve skupině Data na tlačítko Vybrat data.

        Vzhled pásu karet aplikace Excel

      2. V dialogovém okně Vybrat zdroj dat v části Položky legendy (řady), vyberte datovou řadu, kterou chcete odebrat, a potom klikněte na Odebrat.

    2. Pokud jste v grafu vybrali datové řady, stiskněte klávesu DELETE.

Word

Po vytvoření grafu můžete upravovat data v listu aplikace Excel. Změny se projeví v grafu ve Wordu.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf.

  3. Na kartě Návrh grafu klikněte na Úpravy dat v Excelu.

    Otevře se Excel a zobrazí tabulku dat pro graf.

    Tabulka dat pro graf Office

  4. Pokud chcete změnit počet řádků nebo sloupců, které jsou součástí grafu, umístěte ukazatel myši do pravého dolního rohu vybraných dat a tažením vyberte další data. V následujícím příkladu je tabulka rozšířena tak, aby zahrnovala další kategorie a datové řady.

    Selecting more data for an Office chart

  5. Pokud chcete do buňky přidat data nebo je upravit, klikněte na ní a potom proveďte změnu.

  6. Pokud chcete zobrazit výsledky změn, přepněte do Wordu.

Po vytvoření grafu můžete změnit způsob, jakým se v grafu vykreslují řádky a sloupce tabulky.  Vaše první verze grafu může například vykreslovat řádky dat z tabulky na svislé ose grafu (hodnoty) a sloupce dat na vodorovné ose (kategorie). V následujícím příkladu graf zvýrazňuje prodeje podle nástroje.

Graf znázorňující prodej podle kategorií

Ale pokud chcete, aby graf zvýrazňoval prodeje po měsících, můžete změnit způsob, jakým se graf vykreslí.

Graf znázorňující prodej podle měsíců

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf.

  3. Na kartě Návrh grafu klikněte na Přepnout řádek či sloupec.

    Přepnout řádek či sloupec je k dispozici pouze v případě grafu Excelové tabulce dat je otevřít a jenom pro určité typy grafů. Pokud Přepnout řádek či sloupec není k dispozici:

    1. Klikněte na graf.

    2. Na kartě Návrh grafu klikněte na Úpravy dat v Excelu.

Pokud chcete změnit pořadí datové řady, je třeba pracovat s grafem, který má víc než jednu datovou řadu.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. V grafu vyberte Datová řada. Například ve sloupcovém grafu, klikněte na některý sloupec a všechny sloupce, které datové řady jako vybrané.

  3. Na kartě Návrh grafu klikněte na Vybrat Data.

  4. V dialogovém okně Vybrat zdroj dat vedle položky legendy (řady), použijte nahoru nebo přesunout dolů v seznamu přesouvat nahoru nebo dolů na řadu.

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

    Poznámka: U většiny typů grafů ovlivní změny pořadí datové řady legendu a samotný graf.

  5. Klepněte na tlačítko OK.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. V grafu vyberte Datová řada. Například ve sloupcovém grafu, klikněte na některý sloupec a všechny sloupce, které datové řady jako vybrané.

  3. Na kartě Návrh grafu klikněte na Vybrat Data.

  4. V dialogovém okně Vybrat zdroj dat proveďte jeden z těchto věcí:

    Akce

    Akce

    Odebrání řady

    V části položky legendy (řady) vyberte datovou řadu, kterou chcete odebrat a potom klikněte na Odebrat (-).

    Přidání řady

    V části položky legendy (řady) klikněte na Přidat (+) a potom v listu aplikace Excel vyberte všechna data, která chcete zahrnout do grafu.

  5. Klepněte na tlačítko OK.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. V grafu vyberte Datová řada. Například ve sloupcovém grafu, klikněte na některý sloupec a všechny sloupce, které datové řady jako vybrané.

  3. Klepněte na kartu Formát.

  4. V části Chart Element Styles (Styly prvků grafu) klikněte na šipku vedle položky Fill (Vyplnit) Tlačítko Barva výplně a potom na požadovanou barvu.

Můžete přidat popisky, aby se v grafu zobrazily hodnoty datových bodů z excelového listu.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf a potom klikněte na kartu Návrh grafu.

  3. Klikněte na Přidat prvek grafu a potom klikněte na Popisky dat.

  4. Vyberte umístění, ve kterém chcete popisek dat zobrazit (například vyberte Vnější ukončit ).

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf a potom klikněte na kartu Návrh grafu.

  3. Klikněte na Prvek grafu přidat a potom klikněte na Tabulku dat.

  4. Vyberte požadované možnosti.

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

Když vytváříte graf z dat, která používají kalendářní data, a data se v grafu vykreslují na vodorovné ose, Office automaticky změní vodorovnou osu na datovou (časovou) osu. Vodorovnou osu můžete na datovou osu změnit také ručně. Datová osa zobrazuje data chronologicky v zadaných intervalech nebo po základních jednotkách, určených například počtem dní, měsíců nebo roků, a to i když data na listu Excelu nejsou seřazená postupně nebo nejsou ve stejných základních jednotkách.

Office ve výchozím nastavení určuje základní jednotky pro datovou osu podle nejmenšího rozdílu mezi libovolnými dvěma daty. Pokud máte například data pro ceny akcií, kde je nejmenší rozdíl mezi kalendářními daty sedm dnů, Office nastaví základní jednotku na dny. Pokud ale chcete vidět, jak si akcie vedou v dlouhodobém horizontu, můžete základní jednotku změnit na měsíce nebo roky.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf a potom klikněte na kartu Návrh grafu.

  3. Klikněte na Přidat prvek grafu, klikněte na tlačítko osou a potom klikněte na Další možnosti osy. Zobrazí se v podokně Formát osy.

  4. U osy, kterou chcete změnit, zkontrolujte, zda se zobrazují popisky osy.

  5. Ve skupinovém rámečku Typ osy klikněte na tlačítko Osa data.

  6. Ve skupinovém rámečku jednotky vyberte v rozevíracím seznamu Basednů, měsíců nebo roků.

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

Poznámka: Pokud tento postup a grafu nezobrazují data jako časovou osu, zkontrolujte zajišťuje popisky os jsou ve formátu data v Excelové tabulce, například 05/01/08 nebo 08 dne. Další informace o tom, jak formátování buněk jako kalendářní data, najdete v článku zobrazení dat, časů, měny, zlomky nebo procent.

PowerPoint

Po vytvoření grafu můžete upravovat data v listu aplikace Excel. Změny se projeví v grafu v PowerPointu.

  1. Klikněte na graf.

  2. Na kartě Návrh grafu klikněte na Úpravy dat v Excelu.

    Otevře se Excel a zobrazí tabulku dat pro graf.

    Tabulka dat pro graf Office

  3. Pokud chcete změnit počet řádků nebo sloupců, které jsou součástí grafu, umístěte ukazatel myši do pravého dolního rohu vybraných dat a tažením vyberte další data. V následujícím příkladu je tabulka rozšířena tak, aby zahrnovala další kategorie a datové řady.

    Selecting more data for an Office chart

  4. Pokud chcete do buňky přidat data nebo je upravit, klikněte na ní a potom proveďte změnu.

  5. Pokud se chcete podívat, jak se změny projevily, přepněte zpět do PowerPointu.

Po vytvoření grafu můžete změnit způsob, jakým se v grafu vykreslují řádky a sloupce tabulky.  Vaše první verze grafu může například vykreslovat řádky dat z tabulky na svislé ose grafu (hodnoty) a sloupce dat na vodorovné ose (kategorie). V následujícím příkladu graf zvýrazňuje prodeje podle nástroje.

Graf znázorňující prodej podle kategorií

Ale pokud chcete, aby graf zvýrazňoval prodeje po měsících, můžete změnit způsob, jakým se graf vykreslí.

Graf znázorňující prodej podle měsíců

  1. Klikněte na graf.

  2. Na kartě Návrh graf vyberte Přepnout řádek či sloupec.

    Přepnout řádek či sloupec je k dispozici pouze v případě grafu Excelové tabulce dat je otevřít a jenom pro určité typy grafů. Pokud Přepnout řádek či sloupec není k dispozici:

    1. Klikněte na graf.

    2. Na kartě Návrh grafu klikněte na Úpravy dat v Excelu.

Pokud chcete změnit pořadí datové řady, je třeba pracovat s grafem, který má víc než jednu datovou řadu.

  1. V grafu vyberte Datová řada. Například ve sloupcovém grafu, klikněte na některý sloupec a všechny sloupce, které datové řady jako vybrané.

  2. Na kartě Návrh grafu klikněte na Vybrat Data.

  3. V dialogovém okně Vybrat zdroj dat vedle položky legendy (řady), použijte nahoru nebo přesunout dolů v seznamu přesouvat nahoru nebo dolů na řadu.

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

    Poznámka: U většiny typů grafů ovlivní změny pořadí datové řady legendu a samotný graf.

  4. Klepněte na tlačítko OK.

  1. V grafu vyberte Datová řada. Například ve sloupcovém grafu, klikněte na některý sloupec a všechny sloupce, které datové řady jako vybrané.

  2. Klikněte na kartu Grafu – návrh a potom klikněte na Vybrat Data.

  3. V dialogovém okně Vybrat zdroj dat proveďte jeden z těchto věcí:

    Akce

    Akce

    Odebrání řady

    V části položky legendy (řady) vyberte datovou řadu, kterou chcete odebrat a potom klikněte na Odebrat (-).

    Přidání řady

    V části položky legendy (řady) klikněte na Přidat (+) a potom v listu aplikace Excel vyberte všechna data, která chcete zahrnout do grafu.

  4. Klepněte na tlačítko OK.

  1. V grafu vyberte Datová řada. Například ve sloupcovém grafu, klikněte na některý sloupec a všechny sloupce, které datové řady jako vybrané.

  2. Klepněte na kartu Formát.

  3. V části Chart Element Styles (Styly prvků grafu) klikněte na šipku vedle položky Fill (Vyplnit) Tlačítko Barva výplně a potom na požadovanou barvu.

Můžete přidat popisky, aby se v grafu zobrazily hodnoty datových bodů z excelového listu.

  1. Klikněte na graf a potom klikněte na kartu Návrh grafu.

  2. Klikněte na Přidat prvek grafu a potom klikněte na Popisky dat.

  3. Vyberte umístění, ve kterém chcete popisek dat zobrazit (například vyberte Vnější ukončit ).

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

  1. Klikněte na graf a potom klikněte na kartu Návrh grafu.

  2. Klikněte na Prvek grafu přidat a potom klikněte na Tabulku dat.

  3. Vyberte požadované možnosti.

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

Když vytváříte graf z dat, která používají kalendářní data, a data se v grafu vykreslují na vodorovné ose, Office automaticky změní vodorovnou osu na datovou (časovou) osu. Vodorovnou osu můžete na datovou osu změnit také ručně. Datová osa zobrazuje data chronologicky v zadaných intervalech nebo po základních jednotkách, určených například počtem dní, měsíců nebo roků, a to i když data na listu Excelu nejsou seřazená postupně nebo nejsou ve stejných základních jednotkách.

Office ve výchozím nastavení určuje základní jednotky pro datovou osu podle nejmenšího rozdílu mezi libovolnými dvěma daty. Pokud máte například data pro ceny akcií, kde je nejmenší rozdíl mezi kalendářními daty sedm dnů, Office nastaví základní jednotku na dny. Pokud ale chcete vidět, jak si akcie vedou v dlouhodobém horizontu, můžete základní jednotku změnit na měsíce nebo roky.

  1. Klikněte na graf a potom klikněte na kartu Návrh grafu.

  2. Klikněte na Přidat prvek grafu, klikněte na tlačítko osou a potom klikněte na Další možnosti osy. Zobrazí se v podokně Formát osy.

  3. U osy, kterou chcete změnit, zkontrolujte, zda se zobrazují popisky osy.

  4. Ve skupinovém rámečku Typ osy vyberte Datum osy.

  5. Ve skupinovém rámečku jednotky vyberte v rozevíracím seznamu Basednů, měsíců nebo roků.

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

Poznámka: Pokud tento postup a grafu nezobrazují data jako časovou osu, zkontrolujte zajišťuje popisky os jsou ve formátu data v Excelové tabulce, například 05/01/08 nebo 08 dne. Další informace o tom, jak formátování buněk jako kalendářní data, najdete v článku zobrazení dat, časů, měny, zlomky nebo procent.

Excel

Po vytvoření grafu můžete upravovat data v listu Excelu. Změny se projeví v grafu.

  1. Klikněte na graf.

    Excel zvýrazňuje tabulku dat, který se používá pro graf. Šedá výplň označuje řádek nebo sloupec používaný osy kategorií. Červená výplň označuje řádek nebo sloupec obsahující řady popisků dat. Modrá výplň označuje datových bodů v grafu.

    Datová pole v aplikaci Excel

    Popisek 1 Popisky datové řady

    Popisek 2 Hodnoty pro osu kategorií

    Popisek 3 Datové body znázorněné v grafu

  2. Pokud chcete změnit počet řádků nebo sloupců, které jsou součástí grafu, umístěte ukazatel myši do pravého dolního rohu vybraných dat a tažením vyberte další data. V následujícím příkladu je tabulka rozšířena tak, aby zahrnovala další kategorie a datové řady.

    Výběr dalších dat pro graf Excelu

    Tip: Pokud nechcete, aby se data zobrazila v grafu, můžete řádky a sloupce v tabulce skrýt.

  3. Pokud chcete do buňky přidat data nebo je upravit, klikněte na ní a potom proveďte změnu.

Po vytvoření grafu můžete změnit způsob, jakým se v grafu vykreslují řádky a sloupce tabulky.  Vaše první verze grafu může například vykreslovat řádky dat z tabulky na svislé ose grafu (hodnoty) a sloupce dat na vodorovné ose (kategorie). V následujícím příkladu graf zvýrazňuje prodeje podle nástroje.

Graf znázorňující prodej podle kategorií

Ale pokud chcete, aby graf zvýrazňoval prodeje po měsících, můžete změnit způsob, jakým se graf vykreslí.

Graf znázorňující prodej podle měsíců

  1. Klikněte na graf.

  2. Na kartě Návrh grafu klikněte na Přepnout řádek či sloupec.

Pokud chcete změnit pořadí datové řady, je třeba pracovat s grafem, který má víc než jednu datovou řadu.

  1. V grafu vyberte Datová řada. Například ve sloupcovém grafu, klikněte na některý sloupec a všechny sloupce, které datové řady jako vybrané.

  2. Na kartě Návrh grafu klikněte na Vybrat Data.

  3. V dialogovém okně Vybrat zdroj dat vedle položky legendy (řady), použijte nahoru nebo přesunout dolů v seznamu přesouvat nahoru nebo dolů na řadu.

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

    Poznámka: U většiny typů grafů ovlivní změny pořadí datové řady legendu a samotný graf.

  4. Klepněte na tlačítko OK.

  1. V grafu vyberte Datová řada. Například ve sloupcovém grafu, klikněte na některý sloupec a všechny sloupce, které datové řady jako vybrané.

  2. Klikněte na kartu Grafu – návrh a potom klikněte na Vybrat Data.

  3. V dialogovém okně Vybrat zdroj dat proveďte jeden z těchto věcí:

    Akce

    Akce

    Odebrání řady

    V části položky legendy (řady) vyberte datovou řadu, kterou chcete odebrat a potom klikněte na Odebrat (-).

    Přidání řady

    V části položky legendy (řady) klikněte na Přidat (+) a potom v listu aplikace Excel vyberte všechna data, která chcete zahrnout do grafu.

  4. Klepněte na tlačítko OK.

  1. V grafu vyberte Datová řada. Například ve sloupcovém grafu, klikněte na sloupec a všechny sloupce, které datové řady jako vybrané.

  2. Klepněte na kartu Formát.

  3. V části Chart Element Styles (Styly prvků grafu) klikněte na šipku vedle položky Fill (Vyplnit) Tlačítko Barva výplně a potom na požadovanou barvu.

    Tip: Různé barvy podle datového bodu v grafu, který obsahuje pouze jednu datovou řadu, klikněte na řada a potom klikněte na Formát kartu klikněte na Výplň a v závislosti na graf, zaškrtněte políčko měnit barvy tak, že čárky nebo různé barvy podle výsečí zaškrtávací políčko. V závislosti na typu grafu nemusí být některé možnosti k dispozici.

Můžete přidat popisky, aby se v grafu zobrazily hodnoty datových bodů z excelového listu.

  1. Klikněte na graf a potom klikněte na kartu Návrh grafu.

  2. Klikněte na Přidat prvek grafu a potom klikněte na Popisky dat.

  3. Vyberte umístění, ve kterém chcete popisek dat zobrazit (například vyberte Vnější ukončit ).

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

  1. Klikněte na graf a potom klikněte na kartu Návrh grafu.

  2. Klikněte na Prvek grafu přidat a potom klikněte na Tabulku dat.

  3. Vyberte požadované možnosti.

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

Když vytváříte graf z dat, která používají kalendářní data, a data se v grafu vykreslují na vodorovné ose, Office automaticky změní vodorovnou osu na datovou (časovou) osu. Vodorovnou osu můžete na datovou osu změnit také ručně. Datová osa zobrazuje data chronologicky v zadaných intervalech nebo po základních jednotkách, určených například počtem dní, měsíců nebo roků, a to i když data na listu Excelu nejsou seřazená postupně nebo nejsou ve stejných základních jednotkách.

Office ve výchozím nastavení určuje základní jednotky pro datovou osu podle nejmenšího rozdílu mezi libovolnými dvěma daty. Pokud máte například data pro ceny akcií, kde je nejmenší rozdíl mezi kalendářními daty sedm dnů, Office nastaví základní jednotku na dny. Pokud ale chcete vidět, jak si akcie vedou v dlouhodobém horizontu, můžete základní jednotku změnit na měsíce nebo roky.

  1. Klikněte na graf a potom klikněte na kartu Návrh grafu.

  2. Klikněte na Přidat prvek grafu, klikněte na tlačítko osou a potom klikněte na Další možnosti osy. Zobrazí se v podokně Formát osy.

  3. U osy, kterou chcete změnit, zkontrolujte, zda se zobrazují popisky osy.

  4. Ve skupinovém rámečku Typ osy vyberte Datum osy.

  5. Ve skupinovém rámečku jednotky vyberte v rozevíracím seznamu Basednů, měsíců nebo roků.

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

Poznámka: Pokud tento postup a grafu nezobrazují data jako časovou osu, zkontrolujte zajišťuje popisky os jsou ve formátu data v Excelové tabulce, například 05/01/08 nebo 08 dne. Další informace o tom, jak formátování buněk jako kalendářní data, najdete v článku zobrazení dat, časů, měny, zlomky nebo procent.

Word

Po vytvoření grafu můžete upravovat data v listu aplikace Excel. Změny se projeví v grafu ve Wordu.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf.

  3. Na kartě Charts (Grafy) v části Data klikněte na šipku vedle možnosti Edit (Upravit) a poté na příkaz Edit Data in Excel (Upravit data v Excelu).

    Karta Grafy, skupina Data

    Otevře se Excel a zobrazí tabulku dat pro graf.

    Tabulka dat pro graf Office

  4. Pokud chcete změnit počet řádků nebo sloupců, které jsou součástí grafu, umístěte ukazatel myši do pravého dolního rohu vybraných dat a tažením vyberte další data. V následujícím příkladu je tabulka rozšířena tak, aby zahrnovala další kategorie a datové řady.

    Selecting more data for an Office chart

  5. Pokud chcete do buňky přidat data nebo je upravit, klikněte na ní a potom proveďte změnu.

  6. Pokud chcete zobrazit výsledky změn, přepněte do Wordu.

Po vytvoření grafu můžete změnit způsob, jakým se v grafu vykreslují řádky a sloupce tabulky.  Vaše první verze grafu může například vykreslovat řádky dat z tabulky na svislé ose grafu (hodnoty) a sloupce dat na vodorovné ose (kategorie). V následujícím příkladu graf zvýrazňuje prodeje podle nástroje.

Graf znázorňující prodej podle kategorií

Ale pokud chcete, aby graf zvýrazňoval prodeje po měsících, můžete změnit způsob, jakým se graf vykreslí.

Graf znázorňující prodej podle měsíců

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf.

  3. Na kartě Charts (Grafy) klikněte v části Data na Plot series by row (Vykreslit řady podle řádků)   Řady podle řádku nebo Plot series by column (Vykreslit řady podle sloupců)   Řady podle sloupce .

    Karta Grafy, skupina Data

    Pokud přepínač vykreslování není k dispozici

    Přepínač vykreslování je k dispozici pouze pro určité typy grafů a pouze pokud je excelová tabulka dat v grafu otevřená.

    1. Klikněte na graf.

    2. Na kartě Charts (Grafy) v části Data klikněte na šipku vedle možnosti Edit (Upravit) a poté na příkaz Edit Data in Excel (Upravit data v Excelu). Karta Grafy, skupina Data

Pokud chcete změnit pořadí datové řady, je třeba pracovat s grafem, který má víc než jednu datovou řadu.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. V grafu vyberte Datová řada a potom klikněte na kartu Chart Layout (Rozložení grafu).

    Ve sloupcovém grafu například klikněte na sloupec a vyberou se všechny sloupce v dané datové řadě.

  3. V části Current Selection (Aktuální výběr) klikněte na Format Selection (Formátovat výběr).

    Karta Grafy, skupina Aktuální výběr

  4. V navigačním podokně klikněte na možnost Order (Pořadí), potom na název řady a následně na položku Move Up (Posunout nahoru) nebo Move Down (Posunout dolů).

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

    Poznámka: U většiny typů grafů ovlivní změny pořadí datové řady legendu a samotný graf.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. V grafu vyberte Datová řada a potom klikněte na kartu Charts (Grafy).

    Například ve sloupcovém grafu klikněte na sloupec a vyberou se všechny sloupce dané datové řady.

  3. V části Data klikněte na šipku vedle možnosti Edit (Upravit) a potom na Select Data in Excel (Vybrat data v Excelu).

    Karta Grafy, skupina Data

  4. V dialogovém okně Vybrat zdroj dat proveďte jeden z těchto věcí:

    Akce

    Akce

    Odebrání řady

    V části Series (Řady) vyberte datovou řadu, kterou chcete odebrat, a potom klikněte na Remove (Odebrat).

    Přidání řady

    V části Series (Řady) klikněte na Add (Přidat) a potom na listu Excelu vyberte všechna data, která chcete zahrnout do grafu.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. V grafu vyberte Datová řada a potom klikněte kartu Format (Formát).

    Ve sloupcovém grafu například klikněte na sloupec a vyberou se všechny sloupce v dané datové řadě.

  3. V části Chart Element Styles (Styly prvků grafu) klikněte na šipku vedle položky Fill (Vyplnit) Tlačítko Barva výplně a potom na požadovanou barvu.

    Tip: Pokud chcete barvu odlišit podle datových bodů v grafu, který má jen jednu datovou řadu, klikněte na řadu a potom na kartu Chart Layout (Rozložení grafu). V části Current Selection (Aktuální výběr) klikněte na Format Selection (Formátovat výběr). V navigačním podokně klikněte na Fill (Vyplnit) a potom v závislosti na grafu zaškrtněte políčko Vary color by point (Odlišit barvu podle bodu) nebo Vary color by slice (Odlišit barvu podle výseče). V závislosti na typu grafu nemusí být některé možnosti dostupné.

Můžete přidat popisky, aby se v grafu zobrazily hodnoty datových bodů z excelového listu.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf a potom na kartu Chart Layout (Rozložení grafu).

  3. V části Labels (Popisky) klikněte na Data Labels (Popisky dat) a potom v horní části seznamu klikněte na typ popisku dat, který vám vyhovuje.

    Karta Rozložení grafů, skupina Popisky

  4. V části Labels (Popisky) klikněte na Data Labels (Popisky dat) a potom v dolní části seznamu kliknutím vyberte, kde se má popisek dat zobrazit.

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf a potom na kartu Chart Layout (Rozložení grafu).

  3. V části Labels (Popisky) klikněte na Data Table (Tabulka dat) a klikněte na to, co potřebujete.

    Karta Rozložení grafů, skupina Popisky

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

Když vytváříte graf z dat, která používají kalendářní data, a data se v grafu vykreslují na vodorovné ose, Office automaticky změní vodorovnou osu na datovou (časovou) osu. Vodorovnou osu můžete na datovou osu změnit také ručně. Datová osa zobrazuje data chronologicky v zadaných intervalech nebo po základních jednotkách, určených například počtem dní, měsíců nebo roků, a to i když data na listu Excelu nejsou seřazená postupně nebo nejsou ve stejných základních jednotkách.

Office ve výchozím nastavení určuje základní jednotky pro datovou osu podle nejmenšího rozdílu mezi libovolnými dvěma daty. Pokud máte například data pro ceny akcií, kde je nejmenší rozdíl mezi kalendářními daty sedm dnů, Office nastaví základní jednotku na dny. Pokud ale chcete vidět, jak si akcie vedou v dlouhodobém horizontu, můžete základní jednotku změnit na měsíce nebo roky.

  1. V nabídce View (Zobrazení) klikněte na Print Layout (Rozložení při tisku).

  2. Klikněte na graf a potom na kartu Chart Layout (Rozložení grafu).

  3. U osy, kterou chcete změnit, zkontrolujte, zda se zobrazují popisky osy.

  4. V části Axes (Osy) klikněte na Axes (Osy), umístěte ukazatel myši na Horizontal Axis (Vodorovnou osu) a klikněte na položku Axis Options (Možnosti osy).

    Chart Layout tab, Axes group

  5. V navigačním podokně klikněte na Scale (Měřítko) a potom v části Horizontal axis type (Typ vodorovné osy) na položku Date (Datum).

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

Poznámka: Pokud tento postup a grafu nezobrazují data jako časovou osu, zkontrolujte zajišťuje popisky os jsou ve formátu data v Excelové tabulce, například 05/01/08 nebo 08 dne. Další informace o tom, jak formátování buněk jako kalendářní data, najdete v článku zobrazení dat, časů, měny, zlomky nebo procent.

PowerPoint

Po vytvoření grafu můžete upravovat data v listu aplikace Excel. Změny se projeví v grafu v PowerPointu.

  1. Klikněte na graf.

  2. Na kartě Charts (Grafy) v části Data klikněte na šipku vedle možnosti Edit (Upravit) a poté na příkaz Edit Data in Excel (Upravit data v Excelu).

    Karta Grafy, skupina Data

    Otevře se Excel a zobrazí tabulku dat pro graf.

    Tabulka dat pro graf Office

  3. Pokud chcete změnit počet řádků nebo sloupců, které jsou součástí grafu, umístěte ukazatel myši do pravého dolního rohu vybraných dat a tažením vyberte další data. V následujícím příkladu je tabulka rozšířena tak, aby zahrnovala další kategorie a datové řady.

    Selecting more data for an Office chart

  4. Pokud chcete do buňky přidat data nebo je upravit, klikněte na ní a potom proveďte změnu.

  5. Pokud se chcete podívat, jak se změny projevily, přepněte zpět do PowerPointu.

Po vytvoření grafu můžete změnit způsob, jakým se v grafu vykreslují řádky a sloupce tabulky.  Vaše první verze grafu může například vykreslovat řádky dat z tabulky na svislé ose grafu (hodnoty) a sloupce dat na vodorovné ose (kategorie). V následujícím příkladu graf zvýrazňuje prodeje podle nástroje.

Graf znázorňující prodej podle kategorií

Ale pokud chcete, aby graf zvýrazňoval prodeje po měsících, můžete změnit způsob, jakým se graf vykreslí.

Graf znázorňující prodej podle měsíců

  1. Klikněte na graf.

  2. Na kartě Charts (Grafy) klikněte v části Data na Plot series by row (Vykreslit řady podle řádků)   Řady podle řádku nebo Plot series by column (Vykreslit řady podle sloupců)   Řady podle sloupce .

    Karta Grafy, skupina Data

    Pokud přepínač vykreslování není k dispozici

    Přepínač vykreslování je k dispozici pouze pro určité typy grafů a pouze pokud je excelová tabulka dat v grafu otevřená.

    1. Klikněte na graf.

    2. Na kartě Charts (Grafy) v části Data klikněte na šipku vedle možnosti Edit (Upravit) a poté na příkaz Edit Data in Excel (Upravit data v Excelu). Karta Grafy, skupina Data

Pokud chcete změnit pořadí datové řady, je třeba pracovat s grafem, který má víc než jednu datovou řadu.

  1. V grafu vyberte Datová řada a potom klikněte na kartu Chart Layout (Rozložení grafu).

    Ve sloupcovém grafu například klikněte na sloupec a vyberou se všechny sloupce v dané datové řadě.

  2. V části Current Selection (Aktuální výběr) klikněte na Format Selection (Formátovat výběr).

    Karta Grafy, skupina Aktuální výběr

  3. V navigačním podokně klikněte na možnost Order (Pořadí), potom na název řady a následně na položku Move Up (Posunout nahoru) nebo Move Down (Posunout dolů).

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

    Poznámka: U většiny typů grafů ovlivní změny pořadí datové řady legendu a samotný graf.

  1. V grafu vyberte Datová řada a potom klikněte na kartu Charts (Grafy).

    Například ve sloupcovém grafu klikněte na sloupec a vyberou se všechny sloupce dané datové řady.

  2. V části Data klikněte na šipku vedle možnosti Edit (Upravit) a potom na Select Data in Excel (Vybrat data v Excelu).

    Karta Grafy, skupina Data

  3. V dialogovém okně Vybrat zdroj dat proveďte jeden z těchto věcí:

    Akce

    Akce

    Odebrání řady

    V části Series (Řady) vyberte datovou řadu, kterou chcete odebrat, a potom klikněte na Remove (Odebrat).

    Přidání řady

    V části Series (Řady) klikněte na Add (Přidat) a potom na listu Excelu vyberte všechna data, která chcete zahrnout do grafu.

  1. V grafu vyberte Datová řada a potom klikněte kartu Format (Formát).

    Ve sloupcovém grafu například klikněte na sloupec a vyberou se všechny sloupce v dané datové řadě.

  2. V části Chart Element Styles (Styly prvků grafu) klikněte na šipku vedle položky Fill (Vyplnit) Tlačítko Barva výplně a potom na požadovanou barvu.

    Tip: Pokud chcete barvu odlišit podle datových bodů v grafu, který má jen jednu datovou řadu, klikněte na řadu a potom na kartu Chart Layout (Rozložení grafu). V části Current Selection (Aktuální výběr) klikněte na Format Selection (Formátovat výběr). V navigačním podokně klikněte na Fill (Vyplnit) a potom v závislosti na grafu zaškrtněte políčko Vary color by point (Odlišit barvu podle bodu) nebo Vary color by slice (Odlišit barvu podle výseče). V závislosti na typu grafu nemusí být některé možnosti dostupné.

Můžete přidat popisky, aby se v grafu zobrazily hodnoty datových bodů z excelového listu.

  1. Klikněte na graf a potom na kartu Chart Layout (Rozložení grafu).

  2. V části Labels (Popisky) klikněte na Data Labels (Popisky dat) a potom v horní části seznamu klikněte na typ popisku dat, který vám vyhovuje.

    Karta Rozložení grafů, skupina Popisky

  3. V části Labels (Popisky) klikněte na Data Labels (Popisky dat) a potom v dolní části seznamu kliknutím vyberte, kde se má popisek dat zobrazit.

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

  1. Klikněte na graf a potom na kartu Chart Layout (Rozložení grafu).

  2. V části Labels (Popisky) klikněte na Data Table (Tabulka dat) a klikněte na to, co potřebujete.

    Karta Rozložení grafů, skupina Popisky

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

Když vytváříte graf z dat, která používají kalendářní data, a data se v grafu vykreslují na vodorovné ose, Office automaticky změní vodorovnou osu na datovou (časovou) osu. Vodorovnou osu můžete na datovou osu změnit také ručně. Datová osa zobrazuje data chronologicky v zadaných intervalech nebo po základních jednotkách, určených například počtem dní, měsíců nebo roků, a to i když data na listu Excelu nejsou seřazená postupně nebo nejsou ve stejných základních jednotkách.

Office ve výchozím nastavení určuje základní jednotky pro datovou osu podle nejmenšího rozdílu mezi libovolnými dvěma daty. Pokud máte například data pro ceny akcií, kde je nejmenší rozdíl mezi kalendářními daty sedm dnů, Office nastaví základní jednotku na dny. Pokud ale chcete vidět, jak si akcie vedou v dlouhodobém horizontu, můžete základní jednotku změnit na měsíce nebo roky.

  1. Klikněte na graf a potom na kartu Chart Layout (Rozložení grafu).

  2. U osy, kterou chcete změnit, zkontrolujte, zda se zobrazují popisky osy.

  3. V části Axes (Osy) klikněte na Axes (Osy), umístěte ukazatel myši na Horizontal Axis (Vodorovnou osu) a klikněte na položku Axis Options (Možnosti osy).

    Chart Layout tab, Axes group

  4. V navigačním podokně klikněte na Scale (Měřítko) a potom v části Horizontal axis type (Typ vodorovné osy) na položku Date (Datum).

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

Poznámka: Pokud tento postup a grafu nezobrazují data jako časovou osu, zkontrolujte zajišťuje popisky os jsou ve formátu data v Excelové tabulce, například 05/01/08 nebo 08 dne. Další informace o tom, jak formátování buněk jako kalendářní data, najdete v článku zobrazení dat, časů, měny, zlomky nebo procent.

Excel

Po vytvoření grafu můžete upravovat data v listu Excelu. Změny se projeví v grafu.

  1. Klikněte na graf.

    Excel zvýrazní tabulku dat, která se používá v grafu. Fialová osnova označuje řádek nebo sloupec použitý pro osu kategorií. Zelená osnova označuje řádek nebo sloupec, který obsahuje popisky datové řady. Modrá osnova označuje datové body znázorněné v grafu.

    Excelová tabulka dat pro graf

    Popisek 1 Popisky datové řady

    Popisek 2 Hodnoty pro osu kategorií

    Popisek 3 Datové body znázorněné v grafu

  2. Pokud chcete změnit počet řádků nebo sloupců, které jsou součástí grafu, umístěte ukazatel myši do pravého dolního rohu vybraných dat a tažením vyberte další data. V následujícím příkladu je tabulka rozšířena tak, aby zahrnovala další kategorie a datové řady.

    Výběr dalších dat pro graf Excelu

    Tip: Pokud nechcete, aby se data zobrazila v grafu, můžete řádky a sloupce v tabulce skrýt.

  3. Pokud chcete do buňky přidat data nebo je upravit, klikněte na ní a potom proveďte změnu.

Po vytvoření grafu můžete změnit způsob, jakým se v grafu vykreslují řádky a sloupce tabulky.  Vaše první verze grafu může například vykreslovat řádky dat z tabulky na svislé ose grafu (hodnoty) a sloupce dat na vodorovné ose (kategorie). V následujícím příkladu graf zvýrazňuje prodeje podle nástroje.

Graf znázorňující prodej podle kategorií

Ale pokud chcete, aby graf zvýrazňoval prodeje po měsících, můžete změnit způsob, jakým se graf vykreslí.

Graf znázorňující prodej podle měsíců

  1. Klikněte na graf.

  2. Na kartě Charts (Grafy) klikněte v části Data na Plot series by row (Vykreslit řady podle řádků)   Řady podle řádku nebo Plot series by column (Vykreslit řady podle sloupců)   Řady podle sloupce .

    Karta Grafy Excelu, skupina Data

Pokud chcete změnit pořadí datové řady, je třeba pracovat s grafem, který má víc než jednu datovou řadu.

  1. V grafu vyberte Datová řada a potom klikněte na kartu Chart Layout (Rozložení grafu).

    Ve sloupcovém grafu například klikněte na sloupec a vyberou se všechny sloupce v dané datové řadě.

  2. V části Current Selection (Aktuální výběr) klikněte na Format Selection (Formátovat výběr).

    Karta Grafy, skupina Aktuální výběr

  3. V navigačním podokně klikněte na možnost Order (Pořadí), potom na název řady a následně na položku Move Up (Posunout nahoru) nebo Move Down (Posunout dolů).

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

    Poznámka: U většiny typů grafů ovlivní změny pořadí datové řady legendu a samotný graf.

  1. V grafu vyberte Datová řada a potom klikněte na kartu Charts (Grafy).

    Například ve sloupcovém grafu klikněte na sloupec a vyberou se všechny sloupce dané datové řady.

  2. V části Data klikněte na Select (Vybrat).

    Karta Grafy Excelu, skupina Data

  3. V dialogovém okně Vybrat zdroj dat proveďte jeden z těchto věcí:

    Akce

    Akce

    Odebrání řady

    V části Series (Řady) vyberte datovou řadu, kterou chcete odebrat, a potom klikněte na Remove (Odebrat).

    Přidání řady

    V části Series (Řady) klikněte na Add (Přidat) a potom na listu Excelu vyberte všechna data, která chcete zahrnout do grafu.

  1. V grafu vyberte Datová řada a potom klikněte kartu Format (Formát).

    Ve sloupcovém grafu například klikněte na sloupec a vyberou se všechny sloupce v dané datové řadě.

  2. V části Chart Element Styles (Styly prvků grafu) klikněte na šipku vedle položky Fill (Vyplnit) Tlačítko Barva výplně a potom na požadovanou barvu.

    Tip: Pokud chcete barvu odlišit podle datových bodů v grafu, který má jen jednu datovou řadu, klikněte na řadu a potom na kartu Chart Layout (Rozložení grafu). V části Current Selection (Aktuální výběr) klikněte na Format Selection (Formátovat výběr). V navigačním podokně klikněte na Fill (Vyplnit) a potom v závislosti na grafu zaškrtněte políčko Vary color by point (Odlišit barvu podle bodu) nebo Vary color by slice (Odlišit barvu podle výseče). V závislosti na typu grafu nemusí být některé možnosti dostupné.

Můžete přidat popisky, aby se v grafu zobrazily hodnoty datových bodů z excelového listu.

  1. Klikněte na graf a potom na kartu Chart Layout (Rozložení grafu).

  2. V části Labels (Popisky) klikněte na Data Labels (Popisky dat) a potom v horní části seznamu klikněte na typ popisku dat, který vám vyhovuje.

    Karta Rozložení grafů, skupina Popisky

  3. V části Labels (Popisky) klikněte na Data Labels (Popisky dat) a potom v dolní části seznamu kliknutím vyberte, kde se má popisek dat zobrazit.

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

  1. Klikněte na graf a potom na kartu Chart Layout (Rozložení grafu).

  2. V části Labels (Popisky) klikněte na Data Table (Tabulka dat) a klikněte na to, co potřebujete.

    Karta Rozložení grafů, skupina Popisky

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

Když vytváříte graf z dat, která používají kalendářní data, a data se v grafu vykreslují na vodorovné ose, Office automaticky změní vodorovnou osu na datovou (časovou) osu. Vodorovnou osu můžete na datovou osu změnit také ručně. Datová osa zobrazuje data chronologicky v zadaných intervalech nebo po základních jednotkách, určených například počtem dní, měsíců nebo roků, a to i když data na listu Excelu nejsou seřazená postupně nebo nejsou ve stejných základních jednotkách.

Office ve výchozím nastavení určuje základní jednotky pro datovou osu podle nejmenšího rozdílu mezi libovolnými dvěma daty. Pokud máte například data pro ceny akcií, kde je nejmenší rozdíl mezi kalendářními daty sedm dnů, Office nastaví základní jednotku na dny. Pokud ale chcete vidět, jak si akcie vedou v dlouhodobém horizontu, můžete základní jednotku změnit na měsíce nebo roky.

  1. Klikněte na graf a potom na kartu Chart Layout (Rozložení grafu).

  2. U osy, kterou chcete změnit, zkontrolujte, zda se zobrazují popisky osy.

  3. V části Axes (Osy) klikněte na Axes (Osy), umístěte ukazatel myši na Horizontal Axis (Vodorovnou osu) a klikněte na položku Axis Options (Možnosti osy).

  4. V navigačním podokně klikněte na Scale (Měřítko) a potom v části Horizontal axis type (Typ vodorovné osy) na položku Date (Datum).

    V závislosti na typu grafu nemusí být některé možnosti dostupné.

Poznámka: Pokud tento postup a grafu nezobrazují data jako časovou osu, zkontrolujte zajišťuje popisky os jsou ve formátu data v Excelové tabulce, například 05/01/08 nebo 08 dne. Další informace o tom, jak formátování buněk jako kalendářní data, najdete v článku zobrazení dat, časů, měny, zlomky nebo procent.

Viz taky

Vytvoření grafu

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×