Zpětná analýza zdrojového kódu Microsoft Visual C++ 6.0

  1. Úpravy aplikace Visual C++

    how

    1. V aplikaci Visual C++ klepněte v nabídce Tools (Nástroje) na příkaz Customize (Vlastní).

    2. V dialogovém okně Customize klepněte na kartu Add-Ins And Macro Files (Doplňky a soubory maker).

    3. V seznamu Add-Ins And Macro Files vyberte položku Visio UML Add-In (Doplněk UML aplikace Visio).

      Zobrazí se doplněk Visio UML Add-In spolu se znakem zaškrtnutí.

    4. Klepněte na tlačítko Zavřít.

      Zobrazí se plovoucí panel nástrojů Doplněk UML aplikace Visio obsahující pět tlačítek.

    5. Chcete-li mít panel nástrojů k dispozici při každém spuštění aplikace Visual C++, ukotvěte jej pomocí myši přetažením do oblasti panelů nástrojů.

      Tip : Chcete-li vytvořit klávesové zkratky pro všechna tlačítka panelu nástrojů Doplněk UML aplikace Visio, klepněte v nabídce Nástroje na příkaz Vlastní, klepněte na kartu Klávesnice a vyberte kategorii Doplňky.

      Chcete-li dále upřesnit soubory systému, u kterých chcete provést zpětnou analýzu (MFC, ATL nebo Include), klepněte na tlačítko Visio UML Options (Možnosti UML aplikace Visio) UML Options button image .

  2. Generování souboru s informacemi o procházení

    how

    1. V aplikaci Visual C++ klepněte v nabídce Project (Projekt) na příkaz Settings (Nastavení).

    2. V dialogovém okně Project Settings (Nastavení projektu) zvolte typ požadované konfigurace sestavení, klepněte na kartu C/C++ a vyberte možnost Generate Browse Info (Generovat informace o procházení).

    3. Klepněte na kartu Browse Info (Informace o procházení) a zadejte název a umístění souboru obsahujícího informace o procházení, vyberte možnost Build Browse Info File (Sestavit soubor s informacemi o procházení) a poté klepněte na tlačítko OK.

  3. V aplikaci Visual C++ vytvořte projekt.

    Poznámka : Pokud provedete v projektu aplikace Visual C++ změny po zpětné analýze, je nutné příslušný projekt znovu vytvořit a potom provést zpětnou analýzu projektu do programu Visio, aby se mohly změny projevit.

  4. V aplikaci Visual C++ klepněte na tlačítko panelu nástrojů Reverse Engineer UML Model (Zpětná analýza modelu UML) UML Reverse Engineer button image na panelu nástrojů Visio UML Add-In (Doplněk UML aplikace Visio).

    Pokud v pracovním prostoru aplikace Visual C++ existuje více projektů, vyberte v dialogovém okně Select Project(Vybrat projekt) projekt, u kterého chcete provést zpětnou analýzu, a potom klepněte na tlačítko OK.

    Pokud je v hierarchii projektu více souborů pro procházení, vyberte v dialogovém okně Select Browse File (Vybrat soubor pro procházení) příslušný soubor pro procházení a klepněte na tlačítko OK.

    Extrakce informací o třídě ze souboru s informacemi o procházení může trvat několik sekund. Po dokončení extrakce se v Průzkumníku modelů otevře okno Diagram modelu UML aplikace Visio s prázdnou stránkou výkresu diagramu statické struktury a stromovým zobrazením a bude obsahovat ikony odrážející definice tříd ve zdrojovém kódu.

  5. V okně Diagram modelu UML aplikace Visio přetáhněte ikony ze stromového zobrazení na stránku výkresu a vytvořte diagram statické struktury, který představuje zobrazení příslušného modelu.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×