Zobrazení dat z více zdrojů v jediném zobrazení dat

Důležité informace:  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Většina organizací ukládá související data na různých místech. Například informace o produktech ukládá v souboru XML s názvem produkty.xml, ale informace o kategoriích produktů v jiném souboru XML s názvem kategorie.xml. Oba zdroje dat jsou na sebe propojeny pomocí pole s názvem CategoryID.

Aplikace Microsoft Office SharePoint Designer 2007 umožňuje snadno propojovat zdroje dat obsahující související data a potom vytvořit jediné zobrazení dat obsahující data z těchto propojených zdrojů dat. Můžete dokonce propojovat různé typy zdrojů dat, například lze propojit soubor XML s databází SQL. 

V případě, že propojíte zdroje dat, můžete vytvořit jediný zdroj dat, který se zobrazí v podokně úloh Knihovna zdrojů dat se všemi vašimi ostatními zdroji dat. Vytvoření zobrazení takovéhoto propojeného zdroje dat je podobné vytváření jakéhokoli jiného zobrazení dat. Po vytvoření zobrazení dat propojeného zdroje dat můžete filtrovat, řadit, seskupovat, formátovat data v zobrazení dat nebo s nimi provádět jakékoli jiné operace, které lze provádět i s jakýmkoli jiným zobrazením dat.

V tomto článku si ukážeme, jak vytvořit dva ukázkové soubory XML, které mají být použity jako zdroje dat, jak tyto dva zdroje dat propojit a pak také jak vytvořit jediné zobrazení dat obsahující data z obou zdrojů dat. V tomto článku používáme jako zdroj dat soubor XML, aby bylo možné snadno vytvořit zdroj dat a pracovat s ním. Následující postup lze však použít s jakýmkoli zdrojem dat, včetně databází SQL.

Důležité informace: Článek se zabývá vytvářením zobrazení dat v rámci webů SharePoint, které jsou umístěny na serverech se službou Windows SharePoint Services 3.0. Pokud však web není umístěn na serveru se službou Windows SharePoint Services 3.0, je možné, že nebudou k dispozici všechny funkce.

Další informace o zobrazení dat najdete v tématu Vytvoření zobrazení dat.

V tomto článku

Vytvoření dvou souborů XML jako ukázkové zdroje dat

Propojení zdroje dat

Vytvoření zobrazení dat

Navrhované další kroky

Vytvoření dvou souborů XML jako ukázkových zdrojů dat

Společnost Northwind Traders uchovává seznam svých produktů ve formátu XML. Udržuje také seznam kategorií. Oba seznamy jsou na sebe propojeny pomocí pole s názvem CategoryID. Propojením těchto dvou souborů XML a vytvořením jediného zobrazení dat lze snadno vytvořit seznam produktů uspořádaných podle kategorie.

Vytvoření souboru produkty.xml

Pokud jste už vytvořili products.xml pro vytváření zobrazení dat, pokračujte dál.

  1. V nabídce Soubor klepněte na příkaz Otevřít web.

  2. V dialogovém okně Otevřít web vyhledejte a vyberte web SharePoint a klepněte na tlačítko Otevřít.

  3. Pokud se zobrazí dialogové okno Připojit k s dotazem na uživatelské jméno a heslo, zadejte je a klepněte na tlačítko OK.

  4. V nabídce Soubor klepněte na příkaz Nový.

  5. V dialogovém okně Nový poklepejte na položku Textový soubor.

  6. Zkopírujte následující řádky kódu do schránky (vyberte je a stiskněte klávesovou zkratku CTRL+C).

    <?xml version="1.0" encoding="utf-8"?>
    <ProductsRoot>
    <Products>
    <ProductID>1</ProductID>
    <ProductName>Chai</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>10 boxes x 20 bags</QuantityPerUnit>
    <UnitPrice>18</UnitPrice>
    <UnitsInStock>39</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>10</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>2</ProductID>
    <ProductName>Chang</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>24 - 12 oz bottles</QuantityPerUnit>
    <UnitPrice>19</UnitPrice>
    <UnitsInStock>17</UnitsInStock>
    <UnitsOnOrder>40</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>3</ProductID>
    <ProductName>Aniseed Syrup</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>12 - 550 ml bottles</QuantityPerUnit>
    <UnitPrice>10</UnitPrice>
    <UnitsInStock>13</UnitsInStock>
    <UnitsOnOrder>70</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>4</ProductID>
    <ProductName>Chef Anton's Cajun Seasoning</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>48 - 6 oz jars</QuantityPerUnit>
    <UnitPrice>22</UnitPrice>
    <UnitsInStock>53</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>5</ProductID>
    <ProductName>Chef Anton's Gumbo Mix</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>36 boxes</QuantityPerUnit>
    <UnitPrice>21.35</UnitPrice>
    <UnitsInStock>0</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>1</Discontinued>
    </Products>
    </ProductsRoot>
  7. V aplikaci Office SharePoint Designer 2007 umístěte ukazatel myši do horní části stránky a potom stisknutím kombinace kláves CTRL+V vložte právě zkopírovaný kód na stránku.

  8. V nabídce Soubor klepněte na příkaz Uložit jako.

  9. V dialogovém Uložit jako v poli název souboru zadejte products.xml.

  10. V rozevíracím seznamu Typ souboru vyberte položku XML a pak klepněte na tlačítko Uložit.

Vytvoření souboru kategorie.xml

  1. Pokud máte otevřen server SharePoint, přejděte ke kroku 4. V opačném případě klepněte v nabídce Soubor na příkaz Otevřít web.

  2. V dialogovém okně Otevřít web vyhledejte a vyberte web SharePoint a klepněte na tlačítko Otevřít.

  3. Pokud se zobrazí dialogové okno Připojit k s dotazem na uživatelské jméno a heslo, zadejte je a klepněte na tlačítko OK.

  4. V nabídce Soubor klepněte na příkaz Nový.

  5. V dialogovém okně Nový poklepejte na položku Textový soubor.

  6. Zkopírujte následující řádky kódu do schránky (vyberte je a stiskněte klávesovou zkratku CTRL+C).

    <?xml version="1.0" encoding="utf-8"?>
    <CategoriesRoot>
    <Categories>
    <CategoryID>1</CategoryID>
    <CategoryName>Beverages</CategoryName>
    <Description>Soft drinks, coffees, teas, beer, and ale</Description>
    </Categories>
    <Categories>
    <CategoryID>2</CategoryID>
    <CategoryName>Condiments</CategoryName>
    <Description>Sweet and savory sauces, relishes, spreads, and seasonings</Description>
    </Categories>
    <Categories>
    <CategoryID>3</CategoryID>
    <CategoryName>Confections</CategoryName>
    <Description>Desserts, candies, sweetbreads</Description>
    </Categories>
    <Categories>
    <CategoryID>4</CategoryID>
    <CategoryName>Dairy Products</CategoryName>
    <Description>Cheeses</Description>
    </Categories>
    <Categories>
    <CategoryID>5</CategoryID>
    <CategoryName>Grains/Cereals</CategoryName>
    <Description>Breads, crackers, pasta, and cereal</Description>
    </Categories>
    <Categories>
    <CategoryID>6</CategoryID>
    <CategoryName>Meat/Poultry</CategoryName>
    <Description>Prepared meats</Description>
    </Categories>
    <Categories>
    <CategoryID>7</CategoryID>
    <CategoryName>Produce</CategoryName>
    <Description>Dried fruit and bean curd</Description>
    </Categories>
    <Categories>
    <CategoryID>8</CategoryID>
    <CategoryName>Seafood</CategoryName>
    <Description>Seaweed and fish</Description>
    </Categories>
    </CategoriesRoot>
  7. V aplikaci Office SharePoint Designer 2007 umístěte ukazatel myši do horní části stránky a potom stisknutím kombinace kláves CTRL+V vložte právě zkopírovaný kód na stránku.

  8. V nabídce Soubor klepněte na příkaz Uložit jako.

  9. V dialogovém Uložit jako v poli název souboru zadejte kategorie.XML.

  10. Ze seznamu Typ souboru vyberte položku XML a pak klepněte na tlačítko Uložit.

Začátek stránky

Propojení zdrojů dat

Než vytvoříte zobrazení dat zobrazující data z více zdrojů, je nutné propojit zdroje dat pomocí podokna úloh Knihovna zdrojů dat. Chcete vytvořit seznam produktů uspořádaných podle kategorie produktů, je proto potřeba vytvořit zdroj dat umožňující propojit soubor produkty.xml se souborem kategorie.xml.

  1. V nabídce Podokna úkolů klepněte na příkaz Knihovna zdrojů dat.

  2. V podokně úloh Knihovna zdrojů dat klepněte na znaménko plus (+) vedle možnosti Propojené zdroje a klepněte na možnost Vytvořit nový propojený zdroj.

  3. V dialogovém okně Vlastnosti zdroje dat klepněte na možnost Konfigurovat propojený zdroj.

  4. V Průvodci propojením zdrojů dat klepněte v části Dostupné zdroje dat na možnost kategorie.xml a klepněte na tlačítko Přidat. Potom klepněte na možnost produkty.xml a klepněte na tlačítko Přidat.

  5. Klepněte na tlačítko Další.

  6. V části Vyberte typ propojení, který nejlépe vystihuje vztah mezi vybranými zdroji klepněte na možnost Spojit obsah zdrojů dat využitím podrobností zdrojů dat k vložení zobrazení dat a spojených dílčích zobrazení.

    Máte dvě možnosti: sloučit data nebo je spojit. Pro sloučení dat se rozhodnete v případě, že máte různé zdroje dat se stejnými poli, které chcete sloučit do jediného zdroje dat. Pro volbu spojení dat se rozhodnete v případě, že máte dva rozdílné zdroje dat obsahující společné pole spojující jeden zdroj dat s jiným zdrojem dat. Vzhledem k tomu, že soubory produkty.xml a kategorie.xml jsou dva různé zdroje dat se společným polem CategoryID (ID kategorie), budete oba zdroje dat spojovat.

  7. Klepněte na tlačítko Dokončit.

  8. V dialogovém okně Vlastnosti zdroje dat klepněte na kartu Obecné.

  9. Do pole název zadejte kategorie a produkty.

  10. Klepněte na tlačítko OK.

    Část propojených zdrojů v podokně úloh Knihovna zdrojů dat zobrazující nový zdroj dat s názvem Kategorie a produkty

    V knihovně zdrojů dat se v části Propojené zdroje zobrazí nový propojený zdroj dat.

Začátek stránky

Vytvoření zobrazení dat

Po propojení zdrojů dat můžete vytvořit zobrazení dat zobrazující data z propojeného zdroje dat pomocí podokna úloh Podrobnosti zdroje dat.

Chcete vytvořit zobrazení dat seznamu produktů, které je uspořádáno podle kategorií produktů. Pro každou kategorii v souboru kategorie.xml můžete zobrazit produkty v jednotlivých kategoriích ze souboru produkty.xml.

Vzhledem k tomu, že chcete vytvořit zobrazení dat zobrazující každý produkt podle kategorie, je nejdříve potřeba vytvořit zobrazení souboru kategorie.xml.

Zobrazení dat jsou založena na technologii Microsoft ASP.NET 2.0. Chcete-li vytvořit zobrazení dat, je potřeba začít se stránkou ASP.NET (soubor ASPX). V tomto příkladě vytvoříte novou stránku ASP.NET a potom do ní vložíte zobrazení dat.

  1. V nabídce Soubor klepněte na příkaz Nový.

  2. V dialogovém okně Nový poklepejte na položku ASPX.

    Otevře se nová stránka se značkou FORM.

    Značka form technologie ASP.NET

  3. V nabídce Zobrazení dat klepněte na příkaz Vložit zobrazení dat.

    Na stránce je zobrazeno prázdné zobrazení dat a otevře se podokno úloh Knihovna zdrojů dat.

    Prázdné zobrazení dat

    Jakmile je vloženo zobrazení dat, je vše připraveno k přidání dat.

  4. V podokně úloh Knihovna zdrojů dat klepněte na znaménko plus (+) vedle možnosti Propojené zdroje, klepněte na možnost Kategorie a produkty a klepněte na možnost Zobrazit data.

    Nejdříve vytvoříte zobrazení dat souboru kategorie.xml.

  5. V podokně úloh Podrobnosti zobrazení dat klepněte ve složce Kategorie na možnost CategoryName. Stiskněte a podržte klávesu CTRL a klepněte na možnost Popis.

    Dvě pole vybraná ve složce Kategorie v podokně úloh Podrobnosti zdroje dat

  6. Klepněte na možnost Vložit vybraná pole jako a klepnutím na možnost Zobrazení více položek vložte vybraná data do zobrazení dat.

    Poznámka: Pomocí možnosti Zobrazení jedné položky lze v zobrazení dat zobrazit jediný záznam. Možnost Zobrazení více položek umožňuje zobrazit více záznamů s poli ve sloupcích a záhlaví pro každý sloupec.

    Pole vybraná v podokně úloh Podrobnosti zdroje dat se nyní zobrazí v zobrazení dat.

    Zobrazení dat obsahující záznamy ze souboru kategorie.xml

    V dalším kroku vytvoříte nový sloupec zobrazující dílčí zobrazení (zobrazení dat, které se objeví uvnitř buňky jiného zobrazení dat) dat v souboru produkty.xml.

  7. V zobrazení dat klepněte pravým tlačítkem myši na sloupec Popis, klepněte na příkaz Vložit v místní nabídce a potom klepněte na příkaz Sloupec doprava.

  8. Umístěte kurzor do buňky v novém sloupci.

  9. V podokně úloh Podrobnosti zdroje dat klepněte ve složce Produkty na možnost ProductName (Název produktu). Stiskněte a podržte klávesu CTRL a klepněte na možnosti UnitsInStock (Počet položek na skladě), UnitsOnOrder (Počet objednaných položek) a ReorderLevel (Úroveň pro doobjednání).

    Složka Produkty v podokně úloh Podrobnosti zdroje dat

  10. Klepněte na možnost Vložit vybraná pole jako a klepněte na možnost Spojené dílčí zobrazení.

    Spojené dílčí zobrazení je dílčím zobrazením zdroje dat, který je propojen na jiný zdroj dat prostřednictvím společného pole. V dalším kroku propojíme pole CategoryID v souboru kategorie.xml na pole CategoryID v souboru produkty.xml.

  11. V dialogovém okně Spojené dílčí zobrazení klepněte v části Kategorie na možnost CategoryID. V části Products (Produkty) klepněte na možnost CategoryID a potom na tlačítko OK.

    Dialogové okno Spojené dílčí zobrazení

    Pole vybraná v podokně úloh Podrobnosti zdroje dat se nyní zobrazí v novém sloupci. Vzhledem k tomu, že pole CategoryID jsou mezi oběma zdroji propojena, zobrazí se v seznamu Beverages (Nápoje) pouze produkty z řad nápojů, v seznamu Condiments (Koření) pouze koření atd.

    Zobrazení dat obsahující dílčí zobrazení seznamu produktů v rámci přidružené kategorie v seznamu

Začátek stránky

Navrhované další kroky

Zobrazení dat jsou velmi výkonná a zcela přizpůsobitelná zobrazení dynamických zdrojů dat. Po vytvoření zobrazení dat propojeného zdroje dat lze dané zobrazení dat přizpůsobit stejně jako jakékoli jiné zobrazení dat. Nyní již víte, jak vytvořit jediné zobrazení dat s daty z více zdrojů, mohly by se vám proto hodit další informace:

  • Filtrování dat v zobrazení dat    Můžete snadno filtrování dat v zobrazení dat. Další informace najdete v tématu filtrování dat v zobrazení dat.

  • Řazení a seskupení dat v zobrazení dat     Můžete rychle řazení nebo seskupení dat v zobrazení dat. Další informace najdete v tématu řazení a seskupení dat v zobrazení dat.

  • Použití podmíněného formátování pro zobrazení dat    Můžete použít konkrétní formátování, do zobrazení dat Pokud data v zobrazení dat splňují určité podmínky. Další informace najdete v tématu použití podmíněného formátování pro zobrazení dat.

  • Vytvoření sloupce vzorce v zobrazení dat    Stejně jako tabulku, můžete přidat vzorce k zobrazení dat s daty provádět výpočty a zobrazte výsledky v samostatných sloupců. Další informace najdete v tématu Vytvoření sloupce vzorce v zobrazení dat.

Začátek stránky

Poznámka: Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×